source: projects/specs/trunk/a/apr/apr-vl.spec @ 8466

Revision 8466, 13.3 KB checked in by daisuke, 10 years ago (diff)

apr: update to 1.5.3

Line 
1%define aprver 1
2
3# Arches on which the multilib apr.h hack is needed:
4%define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
5
6Name: apr
7Summary: Apache Portable Runtime library
8Summary(ja): Apache ポータブルランタイムライブラリ
9Version: 1.5.1
10Release: 1%{?_dist_release}
11
12Group: System Environment/Libraries
13License: Apache Software License
14URL: http://apr.apache.org/
15
16Source0: %{name}-%{version}.tar.bz2
17Source1: apr-wrapper.h
18Patch2: apr-0.9.7-deepbind.patch
19Patch3: apr-1.2.2-locktimeout.patch
20Patch4: apr-1.2.2-libdir.patch
21Patch5: apr-1.3.3-pkgconf.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: autoconf, libtool, python, doxygen
25BuildRequires: libuuid-devel
26Conflicts: subversion < 0.20.1-2
27Obsoletes: apache2-apr
28
29%description
30The mission of the Apache Portable Runtime (APR) is to provide a
31free library of C data structures and routines, forming a system
32portability layer to as many operating systems as possible,
33including Unices, MS Win32, BeOS and OS/2.
34
35%package devel
36Summary: APR library development kit
37Summary(ja): APR ライブラリ開発キット
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40Conflicts: subversion-devel < 0.20.1-2
41Obsoletes: apache2-apr-devel
42
43%description devel
44This package provides the support files which can be used to
45build applications using the APR library.  The mission of the
46Apache Portable Runtime (APR) is to provide a free library of
47C data structures and routines.
48
49%prep
50%setup -q
51%patch2 -p1 -b .deepbind
52%patch3 -p1 -b .locktimeout
53%patch4 -p1 -b .libdir
54%patch5 -p1 -b .pkgconf
55
56%build
57# regenerate configure script etc.
58./buildconf
59
60# Forcibly prevent detection of shm_open (which then picks up but
61# does not use -lrt).
62export ac_cv_search_shm_open=no
63
64%configure \
65        --includedir=%{_includedir}/apr-%{aprver} \
66        --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
67        --with-devrandom=/dev/urandom \
68        --disable-static \
69        CC=gcc CXX=g++
70make %{?_smp_mflags} && make dox
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make install DESTDIR=$RPM_BUILD_ROOT
75
76# Move docs to more convenient location
77rm -rf html
78mkdir -p html
79cp -pr docs/dox/html/* html/
80# mv docs/dox/html html
81
82# Trim exported dependecies
83sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
84      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
85sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/  */ /g}' \
86      $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
87
88%ifarch %{multilib_arches}
89# Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
90# packages:
91mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
92   $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
93install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
94%endif
95
96# Unpackaged files:
97rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
98rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
99
100%check
101# Fail if LFS support isn't present in a 32-bit build, since this
102# breaks ABI and the soname doesn't change: see #254241
103if grep 'define SIZEOF_VOIDP 4' include/apr.h \
104   && ! grep off64_t include/apr.h; then
105  cat config.log
106  : LFS support not present in 32-bit build
107  exit 1
108fi
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(-,root,root,-)
119%doc CHANGES LICENSE NOTICE
120%{_libdir}/libapr-%{aprver}.so.*
121
122%files devel
123%defattr(-,root,root,-)
124%doc docs/APRDesign.html docs/canonical_filenames.html
125%doc docs/incomplete_types docs/non_apr_programs
126%doc --parents html
127%{_bindir}/apr-%{aprver}-config
128#{_libdir}/libapr-%{aprver}.a
129%{_libdir}/libapr-%{aprver}.so
130%{_libdir}/pkgconfig/*.pc
131%dir %{_libdir}/apr-%{aprver}
132%dir %{_libdir}/apr-%{aprver}/build
133%{_libdir}/apr-%{aprver}/build/*
134%dir %{_includedir}/apr-%{aprver}
135%{_includedir}/apr-%{aprver}/*.h
136
137%changelog
138* Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-1
139- update to 1.5.1
140
141* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.5-1
142- new upstream release
143
144* Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
145- new upstream release
146- built with rpm-4.8.1
147- removed static libraries from devel package
148
149* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
150- rebuilt with new toolchain
151
152* Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
153- new upstream release
154
155* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
156- new upstream release with security fix (CVE-2009-2412)
157
158* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
159- new upstream release
160
161* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
162- new upstream release
163- updated Patch5
164
165* Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
166- new upstream release
167- removed Patch1 and 6
168
169* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
170- removed *.la files from devel package
171
172* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
173- new upstream release
174- added Patch2 and 6 from Fedora
175  * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
176  - add fix for use of %%pI with psprintf
177  * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
178  - use RTLD_DEEPBIND in apr_dso_open by default
179
180* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
181- new upstream release
182
183* Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
184- new upstream release
185
186* Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
187- remove Requires: gcc = %%(gcc -dumpversion)
188
189* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
190- rebuilt with new toolchain
191
192* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
193- new upstream release
194
195* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
196- initial build for Vine Linux based on FC package
197
198* Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
199- fix another multilib conflict (#192659)
200
201* Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
202- BR e2fsprogs-devel for libuuid
203
204* Mon May  8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
205- use multilib parallel-installation wrapper hack for apr.h
206
207* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
208- fix installbuilddir in apr-1-config
209
210* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
211- update to 1.2.7
212- use pkg-config in apr-1-config to make it libdir-agnostic
213
214* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
215- update to 1.2.6
216
217* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
218- bump again for double-long bug on ppc(64)
219
220* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
221- rebuilt for new gcc4.1 snapshot and glibc changes
222
223* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
224- fix namespace pollution (r354824, r355464)
225
226* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
227- fix build with recent glibc (#176911)
228
229* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
230- rebuilt again
231
232* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
233- rebuilt
234
235* Fri Dec  9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
236- rebuild for new gcc
237
238* Thu Dec  8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
239- add apr_file_seek() fixes from upstream (r326593, r326597)
240
241* Wed Dec  7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
242- apr-1-config: strip more exports (#175124)
243
244* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
245- avoid linking against -lrt
246- don't print -L${libdir} in --libs output
247- don't export -lcrypt/-luuid in .la file
248
249* Fri Dec  2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
250- update to 1.2.2
251
252* Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
253- use RTLD_DEEPBIND in apr_dso_open by default
254
255* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
256- update to 0.9.7
257
258* Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
259- rebuild for new gcc
260
261* Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
262- don't override CFLAGS at build time
263- allow setting TCP_NODELAY and TCP_CORK concurrently
264- use _exit() not exit() in child if exec*() fails (upstream #30913)
265
266* Fri Sep  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
267- add from 0.9.x branch:
268 * fix for apr_{uid,gid}_* error handling (r239592)
269 * fix for apr_file_ write flushing (r267192)
270- add backport for use of readdir64_r (r265032, r265681, r265684)
271
272* Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
273- rebuild
274
275* Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
276- fix apr_procattr_child_*_set error handling
277
278* Tue Mar  1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
279- have apr-devel depend on specific version of gcc
280- add NOTICE to docdir
281
282* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
283- update to 0.9.6
284
285* Wed Feb  2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
286- don't disable sendfile on s390 (IBM LTC, #146891)
287
288* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
289- really fix apr-config --srcdir
290
291* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
292- fix apr-config --srcdir again
293
294* Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
295- update to 0.9.5
296
297* Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
298- rebuild
299
300* Wed Sep  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
301- have -devel require apr of same V-R
302
303* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
304- backport fixes from HEAD:
305 * correct implementation of nested mutexes
306 * support for POSIX semaphores on LP64 platforms
307
308* Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
309- rebuild for another attempt at using sem_open
310
311* Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
312- move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
313
314* Thu Jul  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
315- rebuild
316
317* Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
318- rebuild now /dev/shm is mounted
319
320* Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
321- add fix for cleanup structure reuse (part of upstream #23567)
322
323* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
324- rebuilt
325
326* Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
327- add support for setuid/setgid/sticky bits (Andr辿 Malo)
328- add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
329
330* Mon Jun  7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
331- enable posixsem and process-shared pthread mutex support, but
332  ensure that sysvsem remains the default mechanism
333
334* Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
335- entirely remove 2Gb file size limit from apr_file_copy();
336  fixes "svnadmin hotcopy" on repos with >2Gb strings table
337- work around getnameinfo bugs with v4-mapped addresses
338- fix apr_time_exp_get() for dates in 2038 (Philip Martin)
339
340* Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
341- use APR_LARGEFILE in apr_file_{copy,append}
342
343* Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
344- add APR_LARGEFILE flag
345
346* Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
347- fix configure check for mmap of /dev/zero
348- just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
349
350* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
351- rebuilt
352
353* Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
354- undocument apr_dir_read() ordering constraint and fix tests
355
356* Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
357- rebuilt without -Wall -Werror
358
359* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
360- rebuilt
361
362* Tue Feb  3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
363- define apr_off_t as int/long/... to prevent it changing
364  with _FILE_OFFSET_BITS on 32-bit platforms
365
366* Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
367- add apr_temp_dir_get fixes from HEAD
368
369* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
370- ensure that libapr is linked against libpthread
371- don't link libapr against -lnsl
372
373* Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
374- -devel package no longer requires libtool
375
376* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
377- disable tests on x86_64 (#97611)
378
379* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
380- update to 0.9.4, enable tests
381- ensure that libresolv is not used
382
383* Sun Sep  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
384- use /dev/urandom (#103049)
385
386* Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
387- add back CC=gcc, CXX=g++
388
389* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
390- rebuild
391
392* Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
393- work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
394
395* Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
396- support --cc and --cpp arguments in apr-config
397
398* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
399- force libtool to use CC=gcc, CXX=g++
400
401* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
402- fix libtool location in apr_rules.mk
403
404* Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
405- use AI_ADDRCONFIG in getaddrinfo() support (#73350)
406- include a working libtool script rather than relying on
407 /usr/bin/libtool (#97695)
408
409* Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
410- don't use /usr/bin/libtool
411
412* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
413- rebuilt
414
415* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
416- add fix for psprintf memory corruption (CAN-2003-0245)
417- remove executable bit from apr_poll.h
418
419* Thu May  1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
420- link libapr against libpthread
421- make apr-devel conflict with old subversion-devel
422- fix License
423
424* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
425- run ldconfig in post/postun
426
427* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
428- patch test suite to not care if IPv6 is disabled
429
430* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
431- initial build
Note: See TracBrowser for help on using the repository browser.