source: projects/specs/trunk/a/apr-util/apr-util-vl.spec @ 8467

Revision 8467, 13.0 KB checked in by daisuke, 10 years ago (diff)

apr-util:

  • update to 1.5.1
  • build with libdb and libmysqlclient add BR: libdb-devel, libmysqlclient-devel
Line 
1%define apuver 1
2
3Summary: Apache Portable Runtime Utility library
4Summary(ja): Apache ポータブルランタイムユーティリティライブラリ
5Name: apr-util
6Version: 1.5.3
7Release: 1%{?_dist_release}
8
9License: Apache Software License 2.0
10Group: System Environment/Libraries
11URL: http://apr.apache.org/
12
13Source0: %{name}-%{version}.tar.bz2
14Patch1: apr-util-1.2.7-pkgconf.patch
15Patch2: apr-util-1.3.7-nodbmdso.patch
16Patch4: apr-util-1.4.1-private.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: autoconf, doxygen, apr-devel >= 1.2.0
20BuildRequires: libdb-devel, expat-devel, libuuid-devel
21BuildRequires: postgresql-devel
22BuildRequires: libmysqlclient-devel
23BuildRequires: zlib-devel
24BuildRequires: sqlite3-devel
25BuildRequires: unixODBC-devel
26BuildRequires: openldap-devel
27Conflicts: subversion < 0.20.1-2
28Obsoletes: apache2-apr
29
30%description
31The mission of the Apache Portable Runtime (APR) is to provide a
32free library of C data structures and routines.  This library
33contains additional utility interfaces for APR; including support
34for XML, LDAP, database interfaces, URI parsing and more.
35
36%package devel
37Summary: APR utility library development kit
38Summary(ja): APR ユーティリティライブラリ開発キット
39Group: Development/Libraries
40Requires: apr-util = %{version}-%{release}, apr-devel, pkgconfig
41Requires: openldap-devel, db4-devel, expat-devel
42Conflicts: subversion-devel < 0.20.1-2
43Obsoletes: apache2-apr-devel
44
45%description devel
46This package provides the support files which can be used to
47build applications using the APR utility library.  The mission
48of the Apache Portable Runtime (APR) is to provide a free
49library of C data structures and routines.
50
51%package pgsql
52Summary: APR utility library PostgreSQL DBD driver
53Group: System Environment/Libraries
54Requires: apr-util = %{version}-%{release}
55
56%description pgsql
57This package provides the PostgreSQL driver for the apr-util
58DBD (database abstraction) interface.
59
60%package mysql
61Summary: APR utility library MySQL DBD driver
62Group: System Environment/Libraries
63Requires: apr-util = %{version}-%{release}
64
65%description mysql
66This package provides the MySQL driver for the apr-util DBD
67(database abstraction) interface.
68
69%package sqlite
70Summary: APR utility library SQLite DBD driver
71Group: System Environment/Libraries
72Requires: apr-util = %{version}-%{release}
73
74%description sqlite
75This package provides the SQLite driver for the apr-util DBD
76(database abstraction) interface.
77
78#%package freetds
79#Group: Development/Libraries
80#Summary: APR utility library FreeTDS DBD driver
81#BuildRequires: freetds-devel
82#Requires: apr-util = %{version}-%{release}
83
84#%description freetds
85#This package provides the FreeTDS driver for the apr-util DBD
86#(database abstraction) interface.
87
88%package odbc
89Summary: APR utility library ODBC DBD driver
90Group: System Environment/Libraries
91Requires: apr-util = %{version}-%{release}
92
93%description odbc
94This package provides the ODBC driver for the apr-util DBD
95(database abstraction) interface.
96
97%package ldap
98Summary: APR utility library LDAP support
99Group: System Environment/Libraries
100Requires: apr-util = %{version}-%{release}
101
102%description ldap
103This package provides the LDAP support for the apr-util.
104
105%prep
106%setup -q
107%patch1 -p1 -b .pkgconf
108%patch2 -p1 -b .nodbmdso
109%patch4 -p1 -b .private
110
111%build
112autoheader && autoconf
113%configure --with-apr=%{_prefix} \
114        --includedir=%{_includedir}/apr-%{apuver} \
115        --with-ldap --without-gdbm \
116        --with-sqlite3 --with-pgsql --with-mysql --with-odbc \
117        --with-berkeley-db \
118        --without-sqlite2
119#        --disable-util-dso       
120make %{?_smp_mflags} && make dox
121
122%install
123rm -rf $RPM_BUILD_ROOT
124make install DESTDIR=$RPM_BUILD_ROOT
125
126mkdir -p $RPM_BUILD_ROOT/%{_datadir}/aclocal
127install -m 644 build/find_apu.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
128
129# Documentation
130rm -rf html
131mkdir -p html
132cp -pr docs/dox/html/* html
133
134# Unpackaged files; remove the static libaprutil
135rm -f $RPM_BUILD_ROOT%{_libdir}/aprutil.exp \
136      $RPM_BUILD_ROOT%{_libdir}/libapr*.a
137
138# remove *.la
139rm -f $RPM_BUILD_ROOT%{_libdir}/libapr*.la
140
141# And remove the reference to the static libaprutil from the .la
142# file.
143#sed -i '/^old_library/s,libapr.*\.a,,' \
144#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
145
146# Remove unnecessary exports from dependency_libs
147#sed -ri '/^dependency_libs/{s,-l(pq|sqlite[0-9]|rt|dl|uuid) ,,g}' \
148#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
149
150# Trim libtool DSO cruft
151rm -f $RPM_BUILD_ROOT%{_libdir}/apr-util-%{apuver}/*.*a
152
153%check
154# Run the less verbose test suites
155export MALLOC_CHECK_=2 MALLOC_PERTURB_=$(($RANDOM % 255 + 1))
156cd test
157make %{?_smp_mflags} testall
158# testall breaks with DBD DSO; ignore
159export LD_LIBRARY_PATH="`echo "../dbm/.libs:../dbd/.libs:../ldap/.libs:$LD_LIBRARY_PATH" | sed -e 's/::*$//'`"
160./testall -v -q || true
161./testall testrmm
162./testall testdbm
163
164%clean
165rm -rf $RPM_BUILD_ROOT
166
167%post -p /sbin/ldconfig
168
169%postun -p /sbin/ldconfig
170
171%files
172%defattr(-,root,root,-)
173%doc CHANGES LICENSE NOTICE
174%{_libdir}/libaprutil-%{apuver}.so.*
175%dir %{_libdir}/apr-util-%{apuver}
176
177%files devel
178%defattr(-,root,root,-)
179%{_bindir}/apu-%{apuver}-config
180#{_libdir}/libaprutil-%{apuver}.a
181%{_libdir}/libaprutil-%{apuver}.so
182%{_includedir}/apr-%{apuver}/*.h
183%{_libdir}/pkgconfig/*.pc
184%{_datadir}/aclocal/*.m4
185%doc --parents html
186
187%files pgsql
188%defattr(-,root,root,-)
189%{_libdir}/apr-util-%{apuver}/apr_dbd_pgsql*
190
191%files mysql
192%defattr(-,root,root,-)
193%{_libdir}/apr-util-%{apuver}/apr_dbd_mysql*
194
195%files sqlite
196%defattr(-,root,root,-)
197%{_libdir}/apr-util-%{apuver}/apr_dbd_sqlite*
198
199#files freetds
200#defattr(-,root,root,-)
201#{_libdir}/apr-util-%{apuver}/apr_dbd_freetds*
202
203%files odbc
204%defattr(-,root,root,-)
205%{_libdir}/apr-util-%{apuver}/apr_dbd_odbc*
206
207%files ldap
208%defattr(-,root,root,-)
209%{_libdir}/apr-util-%{apuver}/apr_ldap*
210
211%changelog
212* Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.3-1
213- update to 1.5.3
214- add BR: libdb-devel, libmysqlclient-devel
215- remove BR: db4-devel, MySQL-devel
216
217* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.12-1
218- new upstream release
219- rebuilt with MySQL-5.5.15
220
221* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 1.3.9-7
222- rebuilt with postgresql-9.0.3
223
224* Sat Apr  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-6
225- rebuilt with unixODBC-2.2.14
226
227* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.9-5
228- rebuilt with rpm-4.8.1 for pkg-config
229
230* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-4
231- rebuilt with gcc-4.4.3-3 on ppc
232
233* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-3
234- rebuilt with rpm-4.8.0-3 (on ppc)
235
236* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.9-2
237- rebuild with db4-4.8.0
238
239* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
240- new upstream release
241- dropped Patch100, 110, 120 and 130 (merged into upstream)
242- added BR: zlib-devel
243
244* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-5
245- add Patch130 for fix CVE-2009-2412 (IOF apr_rmm_malloc)
246- This patch is included in 1.3.9
247
248* Thu Jun 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-4
249- add patch100 for fix CVE-2009-0023
250- add patch110 for fix CVE-2009-1955
251- add patch120 for fix CVE-2009-1956
252- These patches are included in 1.3.7 or later
253
254* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.4-3
255- rebuilt with MySQL-5.1.34.
256
257* Thu Apr  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2
258- rebuilt with openldap-2.4.11
259
260* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-1vl5
261- new upstream release
262- split out DBD drivers and ldap support into subpackage
263
264* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
265- new upstream release
266- built with db-4.6.21
267
268* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
269- removed *.la files from devel package
270
271* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
272- new upstream release
273- added Patch3 from Fedora Core
274  * Fri Mar 23 2007 Joe Orton <jorton@redhat.com> 1.2.8-6
275  - add DBD DSO lifetime fix (r521327)
276
277* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl2
278- rebuild with expat-2.0.1
279
280* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
281- new upstream release
282
283* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
284- rebuilt with new toolchain
285
286* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
287- new upstream release
288- dropped Patch1 (merged into upstream)
289
290* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.7-0vl2
291- rebuilt with openldap-2.3.27-0vl1
292
293* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
294- initial build for Vine Linux based on FC package
295
296* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
297- update to 1.2.7
298- use pkg-config in apu-1-config to make it libdir-agnostic
299
300* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
301- update to 1.2.6
302- define LDAP_DEPRECATED in apr_ldap.h (r391985, #188073)
303
304* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.2
305- bump again for double-long bug on ppc(64)
306
307* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.1
308- rebuilt for new gcc4.1 snapshot and glibc changes
309
310* Mon Jan 30 2006 Joe Orton <jorton@redhat.com> 1.2.2-4
311- rebuild to drop reference to libexpat.la
312
313* Wed Jan 18 2006 Joe Orton <jorton@redhat.com> 1.2.2-3
314- disable sqlite2 support
315- BuildRequire e2fsprogs-devel
316- enable malloc paranoia in %%check
317
318* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-2.2
319- rebuilt again
320
321* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
322- rebuilt
323
324* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
325- trim exports from .la file/--libs output (#174924)
326
327* Fri Nov 25 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
328- update to 1.2.2
329
330* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
331- fix epoch again
332
333* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
334- update to 0.9.7
335- drop static libs (#170051)
336
337* Tue Jul 26 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
338- add FILE bucket fix for truncated files (#159191)
339- add epoch to dependencies
340
341* Fri Mar  4 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
342- rebuild
343
344* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
345- update to 0.9.6
346
347* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-3
348- restore db-4.3 detection lost in 0.9.5 upgrade
349
350* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-2
351- rebuild
352
353* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
354- update to 0.9.5
355
356* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-19
357- actually explicitly check for and detect db-4.3.
358
359* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-18
360- rebuild against db-4.3.21.
361
362* Fri Sep 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
363- add security fix for CAN-2004-0786
364
365* Sat Jun 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-16
366- have -devel require matching release of apr-util
367
368* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
369- rebuilt
370
371* Thu Apr  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
372- fix use of SHA1 passwords (#119651)
373
374* Tue Mar 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
375- remove fundamentally broken check_sbcs() from xlate code
376
377* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
378- tweak xlate fix
379
380* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
381- rebuild with xlate fixes and tests enabled
382
383* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-10.1
384- rebuilt
385
386* Tue Mar  2 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
387- rename sdbm_* symbols to apu__sdbm_*
388
389* Mon Feb 16 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
390- fix sdbm apr_dbm_exists() on s390x/ppc64
391
392* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-8
393- rebuilt
394
395* Thu Feb  5 2004 Joe Orton <jorton@redhat.com> 0.9.4-7
396- fix warnings from use of apr_optional*.h with gcc 3.4
397
398* Thu Jan 29 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
399- drop gdbm support
400
401* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
402- fix DB library detection
403
404* Sat Dec 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-4
405- rebuild against db-4.2.52.
406
407* Mon Oct 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-3
408- rebuild against db-4.2.42.
409
410* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
411- fix 'apu-config --apu-la-file' output
412
413* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
414- update to 0.9.4.
415
416* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-10
417- rebuild
418
419* Mon Jul  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
420- rebuild
421- don't run testuuid test because of #98677
422
423* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
424- rebuild
425
426* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
427- rebuilt
428
429* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
430- fix to detect crypt_r correctly (CAN-2003-0195)
431
432* Thu May 15 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
433- fix to try linking against -ldb first (#90917)
434- depend on openldap, gdbm, db4, expat appropriately.
435
436* Tue May 13 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
437- rebuild
438
439* Wed May  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
440- make devel package conflict with old subversion-devel
441- run the less crufty parts of the test suite
442
443* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
444- run ldconfig in post/postun
445
446* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
447- initial build
Note: See TracBrowser for help on using the repository browser.