source: projects/specs/trunk/a/apr-util/apr-util-vl.spec @ 12478

Revision 12478, 13.4 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

apache2-2.4.46-1

appstream-data-7-2

apr-util-1.6.1-2

apr-1.7.0-2

e2fsprogs-1.45.6-1

gnome-calculator-3.36.0-1

golang-1.15-1

tmux-3.1b-1

valgrind-3.16.1-1

Line 
1%define apuver 1
2
3Summary: Apache Portable Runtime Utility library
4Summary(ja): Apache ポータブルランタイムユーティリティライブラリ
5Name: apr-util
6Version: 1.6.1
7Release: 2%{?_dist_release}
8Group: system
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: Apache Software License 2.0
13URL: http://apr.apache.org/
14Source0: %{name}-%{version}.tar.bz2
15Patch1: apr-util-1.2.7-pkgconf.patch
16Patch4: apr-util-1.4.1-private.patch
17Patch5: apr-util-mariadb-upstream.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: autoconf, doxygen, apr-devel >= 1.2.0
21BuildRequires: libdb-devel, expat-devel, libuuid-devel
22BuildRequires: libpq-devel
23BuildRequires: libmariadb-devel
24BuildRequires: zlib-devel
25BuildRequires: sqlite3-devel
26BuildRequires: unixODBC-devel
27BuildRequires: openldap-devel
28Conflicts: subversion < 0.20.1-2
29Obsoletes: apache2-apr
30
31%description
32The mission of the Apache Portable Runtime (APR) is to provide a
33free library of C data structures and routines.  This library
34contains additional utility interfaces for APR; including support
35for XML, LDAP, database interfaces, URI parsing and more.
36
37
38%package devel
39Summary: APR utility library development kit
40Summary(ja): APR ユーティリティライブラリ開発キット
41Group: programming
42Requires: apr-util = %{version}-%{release}, apr-devel, pkgconfig
43Requires: openldap-devel, libdb-devel, expat-devel
44Conflicts: subversion-devel < 0.20.1-2
45Obsoletes: apache2-apr-devel
46
47%description devel
48This package provides the support files which can be used to
49build applications using the APR utility library.  The mission
50of the Apache Portable Runtime (APR) is to provide a free
51library of C data structures and routines.
52
53
54%package pgsql
55Summary: APR utility library PostgreSQL DBD driver
56Group: system
57Requires: apr-util = %{version}-%{release}
58
59%description pgsql
60This package provides the PostgreSQL driver for the apr-util
61DBD (database abstraction) interface.
62
63
64%package mysql
65Summary: APR utility library MySQL DBD driver
66Group: system
67Requires: apr-util = %{version}-%{release}
68
69%description mysql
70This package provides the MySQL driver for the apr-util DBD
71(database abstraction) interface.
72
73
74%package sqlite
75Summary: APR utility library SQLite DBD driver
76Group: system
77Requires: apr-util = %{version}-%{release}
78
79%description sqlite
80This package provides the SQLite driver for the apr-util DBD
81(database abstraction) interface.
82
83
84#%package freetds
85#Group: Development/Libraries
86#Summary: APR utility library FreeTDS DBD driver
87#BuildRequires: freetds-devel
88#Requires: apr-util = %{version}-%{release}
89
90#%description freetds
91#This package provides the FreeTDS driver for the apr-util DBD
92#(database abstraction) interface.
93
94%package odbc
95Summary: APR utility library ODBC DBD driver
96Group: system
97Requires: apr-util = %{version}-%{release}
98
99%description odbc
100This package provides the ODBC driver for the apr-util DBD
101(database abstraction) interface.
102
103
104%package ldap
105Summary: APR utility library LDAP support
106Group: system
107Requires: apr-util = %{version}-%{release}
108
109%description ldap
110This package provides the LDAP support for the apr-util.
111
112
113%prep
114%setup -q
115%patch1 -p1 -b .pkgconf
116%patch4 -p1 -b .private
117%patch5 -p1 -b .mariadb
118
119
120%build
121autoheader && autoconf
122%configure --with-apr=%{_prefix} \
123        --includedir=%{_includedir}/apr-%{apuver} \
124        --with-ldap=ldap_r --without-gdbm \
125        --with-sqlite3 --with-pgsql --with-mysql --with-odbc \
126        --with-dbm=db5 --with-berkeley-db \
127        --without-sqlite2
128#        --disable-util-dso       
129make %{?_smp_mflags} && make dox
130
131
132%install
133rm -rf $RPM_BUILD_ROOT
134make install DESTDIR=$RPM_BUILD_ROOT
135
136mkdir -p $RPM_BUILD_ROOT/%{_datadir}/aclocal
137install -m 644 build/find_apu.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
138
139# Documentation
140rm -rf html
141mkdir -p html
142cp -pr docs/dox/html/* html
143
144# Unpackaged files; remove the static libaprutil
145rm -f $RPM_BUILD_ROOT%{_libdir}/aprutil.exp \
146      $RPM_BUILD_ROOT%{_libdir}/libapr*.a
147
148# remove *.la
149rm -f $RPM_BUILD_ROOT%{_libdir}/libapr*.la
150
151# And remove the reference to the static libaprutil from the .la
152# file.
153#sed -i '/^old_library/s,libapr.*\.a,,' \
154#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
155
156# Remove unnecessary exports from dependency_libs
157#sed -ri '/^dependency_libs/{s,-l(pq|sqlite[0-9]|rt|dl|uuid) ,,g}' \
158#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
159
160# Trim libtool DSO cruft
161rm -f $RPM_BUILD_ROOT%{_libdir}/apr-util-%{apuver}/*.*a
162
163
164%check
165# Run the less verbose test suites
166export MALLOC_CHECK_=2 MALLOC_PERTURB_=$(($RANDOM % 255 + 1))
167cd test
168make %{?_smp_mflags} testall
169# testall breaks with DBD DSO; ignore
170export LD_LIBRARY_PATH="`echo "../dbm/.libs:../dbd/.libs:../ldap/.libs:$LD_LIBRARY_PATH" | sed -e 's/::*$//'`"
171./testall -v -q || true
172./testall testrmm
173./testall testdbm
174
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179
180%post -p /sbin/ldconfig
181%postun -p /sbin/ldconfig
182
183
184%files
185%defattr(-,root,root,-)
186%license LICENSE
187%doc CHANGES NOTICE
188%{_libdir}/libaprutil-%{apuver}.so.*
189%dir %{_libdir}/apr-util-%{apuver}
190%{_libdir}/apr-util-%{apuver}/apr_dbm_db*
191
192%files devel
193%defattr(-,root,root,-)
194%{_bindir}/apu-%{apuver}-config
195#{_libdir}/libaprutil-%{apuver}.a
196%{_libdir}/libaprutil-%{apuver}.so
197%{_includedir}/apr-%{apuver}/*.h
198%{_libdir}/pkgconfig/*.pc
199%{_datadir}/aclocal/*.m4
200
201%files pgsql
202%defattr(-,root,root,-)
203%{_libdir}/apr-util-%{apuver}/apr_dbd_pgsql*
204
205%files mysql
206%defattr(-,root,root,-)
207%{_libdir}/apr-util-%{apuver}/apr_dbd_mysql*
208
209%files sqlite
210%defattr(-,root,root,-)
211%{_libdir}/apr-util-%{apuver}/apr_dbd_sqlite*
212
213#files freetds
214#defattr(-,root,root,-)
215#{_libdir}/apr-util-%{apuver}/apr_dbd_freetds*
216
217%files odbc
218%defattr(-,root,root,-)
219%{_libdir}/apr-util-%{apuver}/apr_dbd_odbc*
220
221%files ldap
222%defattr(-,root,root,-)
223%{_libdir}/apr-util-%{apuver}/apr_ldap*
224
225
226%changelog
227* Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.1-2
228- rebuilt with current environment.
229
230* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.1-1
231- updated to 1.6.1.
232- dropped Patch2.
233- imported Patch5 from rawhide to build with libmariadb.
234- made BerkeleyDB to be dynamically linked.
235
236* Mon May 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.4-1
237- updated to 1.5.4.
238
239* Tue Jul 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.3-2
240- add BR: libpq-devel instead of postgresql-devel
241
242* Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.3-1
243- update to 1.5.3
244- add BR: libdb-devel, libmysqlclient-devel
245- remove BR: db4-devel, MySQL-devel
246
247* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.12-1
248- new upstream release
249- rebuilt with MySQL-5.5.15
250
251* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 1.3.9-7
252- rebuilt with postgresql-9.0.3
253
254* Sat Apr  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-6
255- rebuilt with unixODBC-2.2.14
256
257* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.9-5
258- rebuilt with rpm-4.8.1 for pkg-config
259
260* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-4
261- rebuilt with gcc-4.4.3-3 on ppc
262
263* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-3
264- rebuilt with rpm-4.8.0-3 (on ppc)
265
266* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.9-2
267- rebuild with db4-4.8.0
268
269* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
270- new upstream release
271- dropped Patch100, 110, 120 and 130 (merged into upstream)
272- added BR: zlib-devel
273
274* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-5
275- add Patch130 for fix CVE-2009-2412 (IOF apr_rmm_malloc)
276- This patch is included in 1.3.9
277
278* Thu Jun 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-4
279- add patch100 for fix CVE-2009-0023
280- add patch110 for fix CVE-2009-1955
281- add patch120 for fix CVE-2009-1956
282- These patches are included in 1.3.7 or later
283
284* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.4-3
285- rebuilt with MySQL-5.1.34.
286
287* Thu Apr  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2
288- rebuilt with openldap-2.4.11
289
290* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-1vl5
291- new upstream release
292- split out DBD drivers and ldap support into subpackage
293
294* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
295- new upstream release
296- built with db-4.6.21
297
298* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
299- removed *.la files from devel package
300
301* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
302- new upstream release
303- added Patch3 from Fedora Core
304  * Fri Mar 23 2007 Joe Orton <jorton@redhat.com> 1.2.8-6
305  - add DBD DSO lifetime fix (r521327)
306
307* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl2
308- rebuild with expat-2.0.1
309
310* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
311- new upstream release
312
313* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
314- rebuilt with new toolchain
315
316* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
317- new upstream release
318- dropped Patch1 (merged into upstream)
319
320* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.7-0vl2
321- rebuilt with openldap-2.3.27-0vl1
322
323* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
324- initial build for Vine Linux based on FC package
325
326* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
327- update to 1.2.7
328- use pkg-config in apu-1-config to make it libdir-agnostic
329
330* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
331- update to 1.2.6
332- define LDAP_DEPRECATED in apr_ldap.h (r391985, #188073)
333
334* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.2
335- bump again for double-long bug on ppc(64)
336
337* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.1
338- rebuilt for new gcc4.1 snapshot and glibc changes
339
340* Mon Jan 30 2006 Joe Orton <jorton@redhat.com> 1.2.2-4
341- rebuild to drop reference to libexpat.la
342
343* Wed Jan 18 2006 Joe Orton <jorton@redhat.com> 1.2.2-3
344- disable sqlite2 support
345- BuildRequire e2fsprogs-devel
346- enable malloc paranoia in %%check
347
348* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-2.2
349- rebuilt again
350
351* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
352- rebuilt
353
354* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
355- trim exports from .la file/--libs output (#174924)
356
357* Fri Nov 25 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
358- update to 1.2.2
359
360* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
361- fix epoch again
362
363* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
364- update to 0.9.7
365- drop static libs (#170051)
366
367* Tue Jul 26 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
368- add FILE bucket fix for truncated files (#159191)
369- add epoch to dependencies
370
371* Fri Mar  4 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
372- rebuild
373
374* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
375- update to 0.9.6
376
377* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-3
378- restore db-4.3 detection lost in 0.9.5 upgrade
379
380* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-2
381- rebuild
382
383* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
384- update to 0.9.5
385
386* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-19
387- actually explicitly check for and detect db-4.3.
388
389* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-18
390- rebuild against db-4.3.21.
391
392* Fri Sep 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
393- add security fix for CAN-2004-0786
394
395* Sat Jun 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-16
396- have -devel require matching release of apr-util
397
398* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
399- rebuilt
400
401* Thu Apr  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
402- fix use of SHA1 passwords (#119651)
403
404* Tue Mar 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
405- remove fundamentally broken check_sbcs() from xlate code
406
407* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
408- tweak xlate fix
409
410* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
411- rebuild with xlate fixes and tests enabled
412
413* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-10.1
414- rebuilt
415
416* Tue Mar  2 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
417- rename sdbm_* symbols to apu__sdbm_*
418
419* Mon Feb 16 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
420- fix sdbm apr_dbm_exists() on s390x/ppc64
421
422* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-8
423- rebuilt
424
425* Thu Feb  5 2004 Joe Orton <jorton@redhat.com> 0.9.4-7
426- fix warnings from use of apr_optional*.h with gcc 3.4
427
428* Thu Jan 29 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
429- drop gdbm support
430
431* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
432- fix DB library detection
433
434* Sat Dec 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-4
435- rebuild against db-4.2.52.
436
437* Mon Oct 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-3
438- rebuild against db-4.2.42.
439
440* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
441- fix 'apu-config --apu-la-file' output
442
443* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
444- update to 0.9.4.
445
446* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-10
447- rebuild
448
449* Mon Jul  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
450- rebuild
451- don't run testuuid test because of #98677
452
453* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
454- rebuild
455
456* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
457- rebuilt
458
459* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
460- fix to detect crypt_r correctly (CAN-2003-0195)
461
462* Thu May 15 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
463- fix to try linking against -ldb first (#90917)
464- depend on openldap, gdbm, db4, expat appropriately.
465
466* Tue May 13 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
467- rebuild
468
469* Wed May  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
470- make devel package conflict with old subversion-devel
471- run the less crufty parts of the test suite
472
473* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
474- run ldconfig in post/postun
475
476* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
477- initial build
Note: See TracBrowser for help on using the repository browser.