source: projects/specs/trunk/a/apr-util/apr-util-vl.spec @ 4849

Revision 4849, 12.7 KB checked in by inagaki, 13 years ago (diff)

update: apr, apr-util

Line 
1%define apuver 1
2
3Summary: Apache Portable Runtime Utility library
4Summary(ja): Apache ポータブルランタイムユーティリティライブラリ
5Name: apr-util
6Version: 1.3.12
7Release: 1%{?_dist_release}
8
9License: Apache Software License 2.0
10Group: System Environment/Libraries
11URL: http://apr.apache.org/
12
13Source0: %{name}-%{version}.tar.bz2
14Patch1: apr-util-1.2.7-pkgconf.patch
15Patch2: apr-util-1.3.7-nodbmdso.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: autoconf, doxygen, apr-devel >= 1.2.0
19BuildRequires: db4-devel, expat-devel, libuuid-devel
20BuildRequires: postgresql-devel
21BuildRequires: MySQL-devel
22BuildRequires: zlib-devel
23BuildRequires: sqlite3-devel
24BuildRequires: unixODBC-devel
25BuildRequires: openldap-devel
26Conflicts: subversion < 0.20.1-2
27Obsoletes: apache2-apr
28
29%description
30The mission of the Apache Portable Runtime (APR) is to provide a
31free library of C data structures and routines.  This library
32contains additional utility interfaces for APR; including support
33for XML, LDAP, database interfaces, URI parsing and more.
34
35%package devel
36Summary: APR utility library development kit
37Summary(ja): APR ユーティリティライブラリ開発キット
38Group: Development/Libraries
39Requires: apr-util = %{version}-%{release}, apr-devel, pkgconfig
40Requires: openldap-devel, db4-devel, expat-devel
41Conflicts: subversion-devel < 0.20.1-2
42Obsoletes: apache2-apr-devel
43
44%description devel
45This package provides the support files which can be used to
46build applications using the APR utility library.  The mission
47of the Apache Portable Runtime (APR) is to provide a free
48library of C data structures and routines.
49
50%package pgsql
51Summary: APR utility library PostgreSQL DBD driver
52Group: System Environment/Libraries
53Requires: apr-util = %{version}-%{release}
54
55%description pgsql
56This package provides the PostgreSQL driver for the apr-util
57DBD (database abstraction) interface.
58
59%package mysql
60Summary: APR utility library MySQL DBD driver
61Group: System Environment/Libraries
62Requires: apr-util = %{version}-%{release}
63
64%description mysql
65This package provides the MySQL driver for the apr-util DBD
66(database abstraction) interface.
67
68%package sqlite
69Summary: APR utility library SQLite DBD driver
70Group: System Environment/Libraries
71Requires: apr-util = %{version}-%{release}
72
73%description sqlite
74This package provides the SQLite driver for the apr-util DBD
75(database abstraction) interface.
76
77#%package freetds
78#Group: Development/Libraries
79#Summary: APR utility library FreeTDS DBD driver
80#BuildRequires: freetds-devel
81#Requires: apr-util = %{version}-%{release}
82
83#%description freetds
84#This package provides the FreeTDS driver for the apr-util DBD
85#(database abstraction) interface.
86
87%package odbc
88Summary: APR utility library ODBC DBD driver
89Group: System Environment/Libraries
90Requires: apr-util = %{version}-%{release}
91
92%description odbc
93This package provides the ODBC driver for the apr-util DBD
94(database abstraction) interface.
95
96%package ldap
97Summary: APR utility library LDAP support
98Group: System Environment/Libraries
99Requires: apr-util = %{version}-%{release}
100
101%description ldap
102This package provides the LDAP support for the apr-util.
103
104%prep
105%setup -q
106%patch1 -p1 -b .pkgconf
107%patch2 -p1 -b .nodbmdso
108
109%build
110autoheader && autoconf
111%configure --with-apr=%{_prefix} \
112        --includedir=%{_includedir}/apr-%{apuver} \
113        --with-ldap --without-gdbm \
114        --with-sqlite3 --with-pgsql --with-mysql --with-odbc \
115        --with-berkeley-db \
116        --without-sqlite2
117#        --disable-util-dso       
118make %{?_smp_mflags} && make dox
119
120%install
121rm -rf $RPM_BUILD_ROOT
122make install DESTDIR=$RPM_BUILD_ROOT
123
124mkdir -p $RPM_BUILD_ROOT/%{_datadir}/aclocal
125install -m 644 build/find_apu.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
126
127# Documentation
128rm -rf html
129mkdir -p html
130cp -pr docs/dox/html/* html
131
132# Unpackaged files; remove the static libaprutil
133rm -f $RPM_BUILD_ROOT%{_libdir}/aprutil.exp \
134      $RPM_BUILD_ROOT%{_libdir}/libapr*.a
135
136# remove *.la
137rm -f $RPM_BUILD_ROOT%{_libdir}/libapr*.la
138
139# And remove the reference to the static libaprutil from the .la
140# file.
141#sed -i '/^old_library/s,libapr.*\.a,,' \
142#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
143
144# Remove unnecessary exports from dependency_libs
145#sed -ri '/^dependency_libs/{s,-l(pq|sqlite[0-9]|rt|dl|uuid) ,,g}' \
146#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
147
148# Trim libtool DSO cruft
149rm -f $RPM_BUILD_ROOT%{_libdir}/apr-util-%{apuver}/*.*a
150
151%check
152# Run the less verbose test suites
153export MALLOC_CHECK_=2 MALLOC_PERTURB_=$(($RANDOM % 255 + 1))
154cd test
155make %{?_smp_mflags} testall
156# testall breaks with DBD DSO; ignore
157export LD_LIBRARY_PATH="`echo "../dbm/.libs:../dbd/.libs:../ldap/.libs:$LD_LIBRARY_PATH" | sed -e 's/::*$//'`"
158./testall -v -q || true
159./testall testrmm
160./testall testdbm
161
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165%post -p /sbin/ldconfig
166
167%postun -p /sbin/ldconfig
168
169%files
170%defattr(-,root,root,-)
171%doc CHANGES LICENSE NOTICE
172%{_libdir}/libaprutil-%{apuver}.so.*
173%dir %{_libdir}/apr-util-%{apuver}
174
175%files devel
176%defattr(-,root,root,-)
177%{_bindir}/apu-%{apuver}-config
178#{_libdir}/libaprutil-%{apuver}.a
179%{_libdir}/libaprutil-%{apuver}.so
180%{_includedir}/apr-%{apuver}/*.h
181%{_libdir}/pkgconfig/*.pc
182%{_datadir}/aclocal/*.m4
183%doc --parents html
184
185%files pgsql
186%defattr(-,root,root,-)
187%{_libdir}/apr-util-%{apuver}/apr_dbd_pgsql*
188
189%files mysql
190%defattr(-,root,root,-)
191%{_libdir}/apr-util-%{apuver}/apr_dbd_mysql*
192
193%files sqlite
194%defattr(-,root,root,-)
195%{_libdir}/apr-util-%{apuver}/apr_dbd_sqlite*
196
197#files freetds
198#defattr(-,root,root,-)
199#{_libdir}/apr-util-%{apuver}/apr_dbd_freetds*
200
201%files odbc
202%defattr(-,root,root,-)
203%{_libdir}/apr-util-%{apuver}/apr_dbd_odbc*
204
205%files ldap
206%defattr(-,root,root,-)
207%{_libdir}/apr-util-%{apuver}/apr_ldap*
208
209%changelog
210* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.12-1
211- new upstream release
212- rebuilt with MySQL-5.5.15
213
214* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 1.3.9-7
215- rebuilt with postgresql-9.0.3
216
217* Sat Apr  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-6
218- rebuilt with unixODBC-2.2.14
219
220* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.9-5
221- rebuilt with rpm-4.8.1 for pkg-config
222
223* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-4
224- rebuilt with gcc-4.4.3-3 on ppc
225
226* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-3
227- rebuilt with rpm-4.8.0-3 (on ppc)
228
229* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.9-2
230- rebuild with db4-4.8.0
231
232* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
233- new upstream release
234- dropped Patch100, 110, 120 and 130 (merged into upstream)
235- added BR: zlib-devel
236
237* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-5
238- add Patch130 for fix CVE-2009-2412 (IOF apr_rmm_malloc)
239- This patch is included in 1.3.9
240
241* Thu Jun 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-4
242- add patch100 for fix CVE-2009-0023
243- add patch110 for fix CVE-2009-1955
244- add patch120 for fix CVE-2009-1956
245- These patches are included in 1.3.7 or later
246
247* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.4-3
248- rebuilt with MySQL-5.1.34.
249
250* Thu Apr  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2
251- rebuilt with openldap-2.4.11
252
253* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-1vl5
254- new upstream release
255- split out DBD drivers and ldap support into subpackage
256
257* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
258- new upstream release
259- built with db-4.6.21
260
261* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
262- removed *.la files from devel package
263
264* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
265- new upstream release
266- added Patch3 from Fedora Core
267  * Fri Mar 23 2007 Joe Orton <jorton@redhat.com> 1.2.8-6
268  - add DBD DSO lifetime fix (r521327)
269
270* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl2
271- rebuild with expat-2.0.1
272
273* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
274- new upstream release
275
276* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
277- rebuilt with new toolchain
278
279* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
280- new upstream release
281- dropped Patch1 (merged into upstream)
282
283* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.7-0vl2
284- rebuilt with openldap-2.3.27-0vl1
285
286* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
287- initial build for Vine Linux based on FC package
288
289* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
290- update to 1.2.7
291- use pkg-config in apu-1-config to make it libdir-agnostic
292
293* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
294- update to 1.2.6
295- define LDAP_DEPRECATED in apr_ldap.h (r391985, #188073)
296
297* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.2
298- bump again for double-long bug on ppc(64)
299
300* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.1
301- rebuilt for new gcc4.1 snapshot and glibc changes
302
303* Mon Jan 30 2006 Joe Orton <jorton@redhat.com> 1.2.2-4
304- rebuild to drop reference to libexpat.la
305
306* Wed Jan 18 2006 Joe Orton <jorton@redhat.com> 1.2.2-3
307- disable sqlite2 support
308- BuildRequire e2fsprogs-devel
309- enable malloc paranoia in %%check
310
311* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-2.2
312- rebuilt again
313
314* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
315- rebuilt
316
317* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
318- trim exports from .la file/--libs output (#174924)
319
320* Fri Nov 25 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
321- update to 1.2.2
322
323* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
324- fix epoch again
325
326* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
327- update to 0.9.7
328- drop static libs (#170051)
329
330* Tue Jul 26 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
331- add FILE bucket fix for truncated files (#159191)
332- add epoch to dependencies
333
334* Fri Mar  4 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
335- rebuild
336
337* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
338- update to 0.9.6
339
340* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-3
341- restore db-4.3 detection lost in 0.9.5 upgrade
342
343* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-2
344- rebuild
345
346* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
347- update to 0.9.5
348
349* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-19
350- actually explicitly check for and detect db-4.3.
351
352* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-18
353- rebuild against db-4.3.21.
354
355* Fri Sep 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
356- add security fix for CAN-2004-0786
357
358* Sat Jun 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-16
359- have -devel require matching release of apr-util
360
361* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
362- rebuilt
363
364* Thu Apr  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
365- fix use of SHA1 passwords (#119651)
366
367* Tue Mar 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
368- remove fundamentally broken check_sbcs() from xlate code
369
370* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
371- tweak xlate fix
372
373* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
374- rebuild with xlate fixes and tests enabled
375
376* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-10.1
377- rebuilt
378
379* Tue Mar  2 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
380- rename sdbm_* symbols to apu__sdbm_*
381
382* Mon Feb 16 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
383- fix sdbm apr_dbm_exists() on s390x/ppc64
384
385* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-8
386- rebuilt
387
388* Thu Feb  5 2004 Joe Orton <jorton@redhat.com> 0.9.4-7
389- fix warnings from use of apr_optional*.h with gcc 3.4
390
391* Thu Jan 29 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
392- drop gdbm support
393
394* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
395- fix DB library detection
396
397* Sat Dec 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-4
398- rebuild against db-4.2.52.
399
400* Mon Oct 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-3
401- rebuild against db-4.2.42.
402
403* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
404- fix 'apu-config --apu-la-file' output
405
406* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
407- update to 0.9.4.
408
409* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-10
410- rebuild
411
412* Mon Jul  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
413- rebuild
414- don't run testuuid test because of #98677
415
416* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
417- rebuild
418
419* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
420- rebuilt
421
422* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
423- fix to detect crypt_r correctly (CAN-2003-0195)
424
425* Thu May 15 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
426- fix to try linking against -ldb first (#90917)
427- depend on openldap, gdbm, db4, expat appropriately.
428
429* Tue May 13 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
430- rebuild
431
432* Wed May  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
433- make devel package conflict with old subversion-devel
434- run the less crufty parts of the test suite
435
436* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
437- run ldconfig in post/postun
438
439* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
440- initial build
Note: See TracBrowser for help on using the repository browser.