source: projects/specs/trunk/a/apr-util/apr-util-vl.spec @ 1928

Revision 1928, 12.7 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define apuver 1
2
3Summary: Apache Portable Runtime Utility library
4Summary(ja): Apache ポータブルランタイムユーティリティライブラリ
5Name: apr-util
6Version: 1.3.9
7Release: 5%{?_dist_release}
8License: Apache Software License 2.0
9Group: System Environment/Libraries
10URL: http://apr.apache.org/
11Source0: %{name}-%{version}.tar.bz2
12Patch1: apr-util-1.2.7-pkgconf.patch
13Patch2: apr-util-1.3.7-nodbmdso.patch
14#security fix
15Patch100: apr-util-1.3.x-CVE-2009-0023.diff
16Patch110: apr-util-1.3.x-CVE-2009-1955.diff
17Patch120: apr-util-1.3.4_CVE-2009-1956.patch
18Patch130: apr-util-1.3.x-CVE-2009-2412.diff
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: autoconf, doxygen, apr-devel >= 1.2.0
22BuildRequires: db4-devel, expat-devel, libuuid-devel
23BuildRequires: postgresql-devel
24BuildRequires: MySQL-devel
25BuildRequires: zlib-devel
26BuildRequires: sqlite3-devel
27BuildRequires: unixODBC-devel
28BuildRequires: openldap-devel
29Conflicts: subversion < 0.20.1-2
30Obsoletes: apache2-apr
31
32%description
33The mission of the Apache Portable Runtime (APR) is to provide a
34free library of C data structures and routines.  This library
35contains additional utility interfaces for APR; including support
36for XML, LDAP, database interfaces, URI parsing and more.
37
38%package devel
39Summary: APR utility library development kit
40Summary(ja): APR ユーティリティライブラリ開発キット
41Group: Development/Libraries
42Requires: apr-util = %{version}-%{release}, apr-devel, pkgconfig
43Requires: openldap-devel, db4-devel, expat-devel
44Conflicts: subversion-devel < 0.20.1-2
45Obsoletes: apache2-apr-devel
46
47%description devel
48This package provides the support files which can be used to
49build applications using the APR utility library.  The mission
50of the Apache Portable Runtime (APR) is to provide a free
51library of C data structures and routines.
52
53%package pgsql
54Summary: APR utility library PostgreSQL DBD driver
55Group: System Environment/Libraries
56Requires: apr-util = %{version}-%{release}
57
58%description pgsql
59This package provides the PostgreSQL driver for the apr-util
60DBD (database abstraction) interface.
61
62%package mysql
63Summary: APR utility library MySQL DBD driver
64Group: System Environment/Libraries
65Requires: apr-util = %{version}-%{release}
66
67%description mysql
68This package provides the MySQL driver for the apr-util DBD
69(database abstraction) interface.
70
71%package sqlite
72Summary: APR utility library SQLite DBD driver
73Group: System Environment/Libraries
74Requires: apr-util = %{version}-%{release}
75
76%description sqlite
77This package provides the SQLite driver for the apr-util DBD
78(database abstraction) interface.
79
80#%package freetds
81#Group: Development/Libraries
82#Summary: APR utility library FreeTDS DBD driver
83#BuildRequires: freetds-devel
84#Requires: apr-util = %{version}-%{release}
85
86#%description freetds
87#This package provides the FreeTDS driver for the apr-util DBD
88#(database abstraction) interface.
89
90%package odbc
91Summary: APR utility library ODBC DBD driver
92Group: System Environment/Libraries
93Requires: apr-util = %{version}-%{release}
94
95%description odbc
96This package provides the ODBC driver for the apr-util DBD
97(database abstraction) interface.
98
99%package ldap
100Summary: APR utility library LDAP support
101Group: System Environment/Libraries
102Requires: apr-util = %{version}-%{release}
103
104%description ldap
105This package provides the LDAP support for the apr-util.
106
107%prep
108%setup -q
109%patch1 -p1 -b .pkgconf
110%patch2 -p1 -b .nodbmdso
111
112#patch100 -p0 -b .CVE-2009-0023
113#patch110 -p0 -b .CVE-2009-1955
114#patch120 -p0 -b .CVE-2009-1956
115#patch130 -p4 -b .CVE-2009-2412
116
117%build
118autoheader && autoconf
119%configure --with-apr=%{_prefix} \
120        --includedir=%{_includedir}/apr-%{apuver} \
121        --with-ldap --without-gdbm \
122        --with-sqlite3 --with-pgsql --with-mysql --with-odbc \
123        --with-berkeley-db \
124        --without-sqlite2
125#        --disable-util-dso       
126make %{?_smp_mflags} && make dox
127
128%install
129rm -rf $RPM_BUILD_ROOT
130make install DESTDIR=$RPM_BUILD_ROOT
131
132mkdir -p $RPM_BUILD_ROOT/%{_datadir}/aclocal
133install -m 644 build/find_apu.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
134
135# Documentation
136rm -rf html
137mkdir -p html
138cp -pr docs/dox/html/* html
139
140# Unpackaged files; remove the static libaprutil
141rm -f $RPM_BUILD_ROOT%{_libdir}/aprutil.exp \
142      $RPM_BUILD_ROOT%{_libdir}/libapr*.a
143
144# remove *.la
145rm -f $RPM_BUILD_ROOT%{_libdir}/libapr*.la
146
147# And remove the reference to the static libaprutil from the .la
148# file.
149#sed -i '/^old_library/s,libapr.*\.a,,' \
150#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
151
152# Remove unnecessary exports from dependency_libs
153#sed -ri '/^dependency_libs/{s,-l(pq|sqlite[0-9]|rt|dl|uuid) ,,g}' \
154#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
155
156# Trim libtool DSO cruft
157rm -f $RPM_BUILD_ROOT%{_libdir}/apr-util-%{apuver}/*.*a
158
159%check
160# Run the less verbose test suites
161export MALLOC_CHECK_=2 MALLOC_PERTURB_=$(($RANDOM % 255 + 1))
162cd test
163make %{?_smp_mflags} testall
164# testall breaks with DBD DSO; ignore
165export LD_LIBRARY_PATH="`echo "../dbm/.libs:../dbd/.libs:../ldap/.libs:$LD_LIBRARY_PATH" | sed -e 's/::*$//'`"
166./testall -v -q || true
167./testall testrmm
168./testall testdbm
169
170%clean
171rm -rf $RPM_BUILD_ROOT
172
173%post -p /sbin/ldconfig
174
175%postun -p /sbin/ldconfig
176
177%files
178%defattr(-,root,root,-)
179%doc CHANGES LICENSE NOTICE
180%{_libdir}/libaprutil-%{apuver}.so.*
181%dir %{_libdir}/apr-util-%{apuver}
182
183%files devel
184%defattr(-,root,root,-)
185%{_bindir}/apu-%{apuver}-config
186#{_libdir}/libaprutil-%{apuver}.a
187%{_libdir}/libaprutil-%{apuver}.so
188%{_includedir}/apr-%{apuver}/*.h
189%{_libdir}/pkgconfig/*.pc
190%{_datadir}/aclocal/*.m4
191%doc --parents html
192
193%files pgsql
194%defattr(-,root,root,-)
195%{_libdir}/apr-util-%{apuver}/apr_dbd_pgsql*
196
197%files mysql
198%defattr(-,root,root,-)
199%{_libdir}/apr-util-%{apuver}/apr_dbd_mysql*
200
201%files sqlite
202%defattr(-,root,root,-)
203%{_libdir}/apr-util-%{apuver}/apr_dbd_sqlite*
204
205#files freetds
206#defattr(-,root,root,-)
207#{_libdir}/apr-util-%{apuver}/apr_dbd_freetds*
208
209%files odbc
210%defattr(-,root,root,-)
211%{_libdir}/apr-util-%{apuver}/apr_dbd_odbc*
212
213%files ldap
214%defattr(-,root,root,-)
215%{_libdir}/apr-util-%{apuver}/apr_ldap*
216
217%changelog
218* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.9-5
219- rebuilt with rpm-4.8.1 for pkg-config
220
221* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-4
222- rebuilt with gcc-4.4.3-3 on ppc
223
224* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-3
225- rebuilt with rpm-4.8.0-3 (on ppc)
226
227* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.9-2
228- rebuild with db4-4.8.0
229
230* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
231- new upstream release
232- dropped Patch100, 110, 120 and 130 (merged into upstream)
233- added BR: zlib-devel
234
235* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-5
236- add Patch130 for fix CVE-2009-2412 (IOF apr_rmm_malloc)
237- This patch is included in 1.3.9
238
239* Thu Jun 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-4
240- add patch100 for fix CVE-2009-0023
241- add patch110 for fix CVE-2009-1955
242- add patch120 for fix CVE-2009-1956
243- These patches are included in 1.3.7 or later
244
245* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.4-3
246- rebuilt with MySQL-5.1.34.
247
248* Thu Apr  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2
249- rebuilt with openldap-2.4.11
250
251* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-1vl5
252- new upstream release
253- split out DBD drivers and ldap support into subpackage
254
255* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
256- new upstream release
257- built with db-4.6.21
258
259* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
260- removed *.la files from devel package
261
262* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
263- new upstream release
264- added Patch3 from Fedora Core
265  * Fri Mar 23 2007 Joe Orton <jorton@redhat.com> 1.2.8-6
266  - add DBD DSO lifetime fix (r521327)
267
268* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl2
269- rebuild with expat-2.0.1
270
271* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
272- new upstream release
273
274* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
275- rebuilt with new toolchain
276
277* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
278- new upstream release
279- dropped Patch1 (merged into upstream)
280
281* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.7-0vl2
282- rebuilt with openldap-2.3.27-0vl1
283
284* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
285- initial build for Vine Linux based on FC package
286
287* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
288- update to 1.2.7
289- use pkg-config in apu-1-config to make it libdir-agnostic
290
291* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
292- update to 1.2.6
293- define LDAP_DEPRECATED in apr_ldap.h (r391985, #188073)
294
295* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.2
296- bump again for double-long bug on ppc(64)
297
298* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.1
299- rebuilt for new gcc4.1 snapshot and glibc changes
300
301* Mon Jan 30 2006 Joe Orton <jorton@redhat.com> 1.2.2-4
302- rebuild to drop reference to libexpat.la
303
304* Wed Jan 18 2006 Joe Orton <jorton@redhat.com> 1.2.2-3
305- disable sqlite2 support
306- BuildRequire e2fsprogs-devel
307- enable malloc paranoia in %%check
308
309* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-2.2
310- rebuilt again
311
312* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
313- rebuilt
314
315* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
316- trim exports from .la file/--libs output (#174924)
317
318* Fri Nov 25 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
319- update to 1.2.2
320
321* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
322- fix epoch again
323
324* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
325- update to 0.9.7
326- drop static libs (#170051)
327
328* Tue Jul 26 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
329- add FILE bucket fix for truncated files (#159191)
330- add epoch to dependencies
331
332* Fri Mar  4 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
333- rebuild
334
335* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
336- update to 0.9.6
337
338* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-3
339- restore db-4.3 detection lost in 0.9.5 upgrade
340
341* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-2
342- rebuild
343
344* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
345- update to 0.9.5
346
347* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-19
348- actually explicitly check for and detect db-4.3.
349
350* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-18
351- rebuild against db-4.3.21.
352
353* Fri Sep 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
354- add security fix for CAN-2004-0786
355
356* Sat Jun 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-16
357- have -devel require matching release of apr-util
358
359* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
360- rebuilt
361
362* Thu Apr  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
363- fix use of SHA1 passwords (#119651)
364
365* Tue Mar 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
366- remove fundamentally broken check_sbcs() from xlate code
367
368* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
369- tweak xlate fix
370
371* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
372- rebuild with xlate fixes and tests enabled
373
374* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-10.1
375- rebuilt
376
377* Tue Mar  2 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
378- rename sdbm_* symbols to apu__sdbm_*
379
380* Mon Feb 16 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
381- fix sdbm apr_dbm_exists() on s390x/ppc64
382
383* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-8
384- rebuilt
385
386* Thu Feb  5 2004 Joe Orton <jorton@redhat.com> 0.9.4-7
387- fix warnings from use of apr_optional*.h with gcc 3.4
388
389* Thu Jan 29 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
390- drop gdbm support
391
392* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
393- fix DB library detection
394
395* Sat Dec 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-4
396- rebuild against db-4.2.52.
397
398* Mon Oct 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-3
399- rebuild against db-4.2.42.
400
401* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
402- fix 'apu-config --apu-la-file' output
403
404* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
405- update to 0.9.4.
406
407* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-10
408- rebuild
409
410* Mon Jul  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
411- rebuild
412- don't run testuuid test because of #98677
413
414* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
415- rebuild
416
417* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
418- rebuilt
419
420* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
421- fix to detect crypt_r correctly (CAN-2003-0195)
422
423* Thu May 15 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
424- fix to try linking against -ldb first (#90917)
425- depend on openldap, gdbm, db4, expat appropriately.
426
427* Tue May 13 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
428- rebuild
429
430* Wed May  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
431- make devel package conflict with old subversion-devel
432- run the less crufty parts of the test suite
433
434* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
435- run ldconfig in post/postun
436
437* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
438- initial build
Note: See TracBrowser for help on using the repository browser.