source: projects/specs/trunk/a/apr-util/apr-util-vl.spec @ 11917

Revision 11917, 13.4 KB checked in by tomop, 5 years ago (diff)

apr-util-1.6.1-1

Line 
1%define apuver 1
2
3Summary: Apache Portable Runtime Utility library
4Summary(ja): Apache ポータブルランタイムユーティリティライブラリ
5Name: apr-util
6Version: 1.6.1
7Release: 1%{?_dist_release}
8
9License: Apache Software License 2.0
10Group: System Environment/Libraries
11URL: http://apr.apache.org/
12
13Vendor: Project Vine
14Distribution: Vine Linux
15
16Source0: %{name}-%{version}.tar.bz2
17Patch1: apr-util-1.2.7-pkgconf.patch
18Patch4: apr-util-1.4.1-private.patch
19Patch5: apr-util-mariadb-upstream.patch
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: autoconf, doxygen, apr-devel >= 1.2.0
23BuildRequires: libdb-devel, expat-devel, libuuid-devel
24BuildRequires: libpq-devel
25BuildRequires: libmariadb-devel
26BuildRequires: zlib-devel
27BuildRequires: sqlite3-devel
28BuildRequires: unixODBC-devel
29BuildRequires: openldap-devel
30Conflicts: subversion < 0.20.1-2
31Obsoletes: apache2-apr
32
33%description
34The mission of the Apache Portable Runtime (APR) is to provide a
35free library of C data structures and routines.  This library
36contains additional utility interfaces for APR; including support
37for XML, LDAP, database interfaces, URI parsing and more.
38
39%package devel
40Summary: APR utility library development kit
41Summary(ja): APR ユーティリティライブラリ開発キット
42Group: Development/Libraries
43Requires: apr-util = %{version}-%{release}, apr-devel, pkgconfig
44Requires: openldap-devel, libdb-devel, expat-devel
45Conflicts: subversion-devel < 0.20.1-2
46Obsoletes: apache2-apr-devel
47
48%description devel
49This package provides the support files which can be used to
50build applications using the APR utility library.  The mission
51of the Apache Portable Runtime (APR) is to provide a free
52library of C data structures and routines.
53
54%package pgsql
55Summary: APR utility library PostgreSQL DBD driver
56Group: System Environment/Libraries
57Requires: apr-util = %{version}-%{release}
58
59%description pgsql
60This package provides the PostgreSQL driver for the apr-util
61DBD (database abstraction) interface.
62
63%package mysql
64Summary: APR utility library MySQL DBD driver
65Group: System Environment/Libraries
66Requires: apr-util = %{version}-%{release}
67
68%description mysql
69This package provides the MySQL driver for the apr-util DBD
70(database abstraction) interface.
71
72%package sqlite
73Summary: APR utility library SQLite DBD driver
74Group: System Environment/Libraries
75Requires: apr-util = %{version}-%{release}
76
77%description sqlite
78This package provides the SQLite driver for the apr-util DBD
79(database abstraction) interface.
80
81#%package freetds
82#Group: Development/Libraries
83#Summary: APR utility library FreeTDS DBD driver
84#BuildRequires: freetds-devel
85#Requires: apr-util = %{version}-%{release}
86
87#%description freetds
88#This package provides the FreeTDS driver for the apr-util DBD
89#(database abstraction) interface.
90
91%package odbc
92Summary: APR utility library ODBC DBD driver
93Group: System Environment/Libraries
94Requires: apr-util = %{version}-%{release}
95
96%description odbc
97This package provides the ODBC driver for the apr-util DBD
98(database abstraction) interface.
99
100%package ldap
101Summary: APR utility library LDAP support
102Group: System Environment/Libraries
103Requires: apr-util = %{version}-%{release}
104
105%description ldap
106This package provides the LDAP support for the apr-util.
107
108%prep
109%setup -q
110%patch1 -p1 -b .pkgconf
111%patch4 -p1 -b .private
112%patch5 -p1 -b .mariadb
113
114%build
115autoheader && autoconf
116%configure --with-apr=%{_prefix} \
117        --includedir=%{_includedir}/apr-%{apuver} \
118        --with-ldap=ldap_r --without-gdbm \
119        --with-sqlite3 --with-pgsql --with-mysql --with-odbc \
120        --with-dbm=db5 --with-berkeley-db \
121        --without-sqlite2
122#        --disable-util-dso       
123make %{?_smp_mflags} && make dox
124
125%install
126rm -rf $RPM_BUILD_ROOT
127make install DESTDIR=$RPM_BUILD_ROOT
128
129mkdir -p $RPM_BUILD_ROOT/%{_datadir}/aclocal
130install -m 644 build/find_apu.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
131
132# Documentation
133rm -rf html
134mkdir -p html
135cp -pr docs/dox/html/* html
136
137# Unpackaged files; remove the static libaprutil
138rm -f $RPM_BUILD_ROOT%{_libdir}/aprutil.exp \
139      $RPM_BUILD_ROOT%{_libdir}/libapr*.a
140
141# remove *.la
142rm -f $RPM_BUILD_ROOT%{_libdir}/libapr*.la
143
144# And remove the reference to the static libaprutil from the .la
145# file.
146#sed -i '/^old_library/s,libapr.*\.a,,' \
147#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
148
149# Remove unnecessary exports from dependency_libs
150#sed -ri '/^dependency_libs/{s,-l(pq|sqlite[0-9]|rt|dl|uuid) ,,g}' \
151#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
152
153# Trim libtool DSO cruft
154rm -f $RPM_BUILD_ROOT%{_libdir}/apr-util-%{apuver}/*.*a
155
156%check
157# Run the less verbose test suites
158export MALLOC_CHECK_=2 MALLOC_PERTURB_=$(($RANDOM % 255 + 1))
159cd test
160make %{?_smp_mflags} testall
161# testall breaks with DBD DSO; ignore
162export LD_LIBRARY_PATH="`echo "../dbm/.libs:../dbd/.libs:../ldap/.libs:$LD_LIBRARY_PATH" | sed -e 's/::*$//'`"
163./testall -v -q || true
164./testall testrmm
165./testall testdbm
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
170%post -p /sbin/ldconfig
171
172%postun -p /sbin/ldconfig
173
174%files
175%defattr(-,root,root,-)
176%doc CHANGES LICENSE NOTICE
177%{_libdir}/libaprutil-%{apuver}.so.*
178%dir %{_libdir}/apr-util-%{apuver}
179%{_libdir}/apr-util-%{apuver}/apr_dbm_db*
180
181%files devel
182%defattr(-,root,root,-)
183%{_bindir}/apu-%{apuver}-config
184#{_libdir}/libaprutil-%{apuver}.a
185%{_libdir}/libaprutil-%{apuver}.so
186%{_includedir}/apr-%{apuver}/*.h
187%{_libdir}/pkgconfig/*.pc
188%{_datadir}/aclocal/*.m4
189
190%files pgsql
191%defattr(-,root,root,-)
192%{_libdir}/apr-util-%{apuver}/apr_dbd_pgsql*
193
194%files mysql
195%defattr(-,root,root,-)
196%{_libdir}/apr-util-%{apuver}/apr_dbd_mysql*
197
198%files sqlite
199%defattr(-,root,root,-)
200%{_libdir}/apr-util-%{apuver}/apr_dbd_sqlite*
201
202#files freetds
203#defattr(-,root,root,-)
204#{_libdir}/apr-util-%{apuver}/apr_dbd_freetds*
205
206%files odbc
207%defattr(-,root,root,-)
208%{_libdir}/apr-util-%{apuver}/apr_dbd_odbc*
209
210%files ldap
211%defattr(-,root,root,-)
212%{_libdir}/apr-util-%{apuver}/apr_ldap*
213
214%changelog
215* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.1-1
216- updated to 1.6.1.
217- dropped Patch2.
218- imported Patch5 from rawhide to build with libmariadb.
219- made BerkeleyDB to be dynamically linked.
220
221* Mon May 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.4-1
222- updated to 1.5.4.
223
224* Tue Jul 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.3-2
225- add BR: libpq-devel instead of postgresql-devel
226
227* Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.3-1
228- update to 1.5.3
229- add BR: libdb-devel, libmysqlclient-devel
230- remove BR: db4-devel, MySQL-devel
231
232* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.12-1
233- new upstream release
234- rebuilt with MySQL-5.5.15
235
236* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 1.3.9-7
237- rebuilt with postgresql-9.0.3
238
239* Sat Apr  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-6
240- rebuilt with unixODBC-2.2.14
241
242* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.9-5
243- rebuilt with rpm-4.8.1 for pkg-config
244
245* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-4
246- rebuilt with gcc-4.4.3-3 on ppc
247
248* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-3
249- rebuilt with rpm-4.8.0-3 (on ppc)
250
251* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.9-2
252- rebuild with db4-4.8.0
253
254* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
255- new upstream release
256- dropped Patch100, 110, 120 and 130 (merged into upstream)
257- added BR: zlib-devel
258
259* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-5
260- add Patch130 for fix CVE-2009-2412 (IOF apr_rmm_malloc)
261- This patch is included in 1.3.9
262
263* Thu Jun 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-4
264- add patch100 for fix CVE-2009-0023
265- add patch110 for fix CVE-2009-1955
266- add patch120 for fix CVE-2009-1956
267- These patches are included in 1.3.7 or later
268
269* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.4-3
270- rebuilt with MySQL-5.1.34.
271
272* Thu Apr  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2
273- rebuilt with openldap-2.4.11
274
275* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-1vl5
276- new upstream release
277- split out DBD drivers and ldap support into subpackage
278
279* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
280- new upstream release
281- built with db-4.6.21
282
283* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
284- removed *.la files from devel package
285
286* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
287- new upstream release
288- added Patch3 from Fedora Core
289  * Fri Mar 23 2007 Joe Orton <jorton@redhat.com> 1.2.8-6
290  - add DBD DSO lifetime fix (r521327)
291
292* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl2
293- rebuild with expat-2.0.1
294
295* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
296- new upstream release
297
298* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
299- rebuilt with new toolchain
300
301* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
302- new upstream release
303- dropped Patch1 (merged into upstream)
304
305* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.7-0vl2
306- rebuilt with openldap-2.3.27-0vl1
307
308* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
309- initial build for Vine Linux based on FC package
310
311* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
312- update to 1.2.7
313- use pkg-config in apu-1-config to make it libdir-agnostic
314
315* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
316- update to 1.2.6
317- define LDAP_DEPRECATED in apr_ldap.h (r391985, #188073)
318
319* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.2
320- bump again for double-long bug on ppc(64)
321
322* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.1
323- rebuilt for new gcc4.1 snapshot and glibc changes
324
325* Mon Jan 30 2006 Joe Orton <jorton@redhat.com> 1.2.2-4
326- rebuild to drop reference to libexpat.la
327
328* Wed Jan 18 2006 Joe Orton <jorton@redhat.com> 1.2.2-3
329- disable sqlite2 support
330- BuildRequire e2fsprogs-devel
331- enable malloc paranoia in %%check
332
333* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-2.2
334- rebuilt again
335
336* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
337- rebuilt
338
339* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
340- trim exports from .la file/--libs output (#174924)
341
342* Fri Nov 25 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
343- update to 1.2.2
344
345* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
346- fix epoch again
347
348* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
349- update to 0.9.7
350- drop static libs (#170051)
351
352* Tue Jul 26 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
353- add FILE bucket fix for truncated files (#159191)
354- add epoch to dependencies
355
356* Fri Mar  4 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
357- rebuild
358
359* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
360- update to 0.9.6
361
362* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-3
363- restore db-4.3 detection lost in 0.9.5 upgrade
364
365* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-2
366- rebuild
367
368* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
369- update to 0.9.5
370
371* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-19
372- actually explicitly check for and detect db-4.3.
373
374* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-18
375- rebuild against db-4.3.21.
376
377* Fri Sep 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
378- add security fix for CAN-2004-0786
379
380* Sat Jun 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-16
381- have -devel require matching release of apr-util
382
383* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
384- rebuilt
385
386* Thu Apr  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
387- fix use of SHA1 passwords (#119651)
388
389* Tue Mar 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
390- remove fundamentally broken check_sbcs() from xlate code
391
392* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
393- tweak xlate fix
394
395* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
396- rebuild with xlate fixes and tests enabled
397
398* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-10.1
399- rebuilt
400
401* Tue Mar  2 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
402- rename sdbm_* symbols to apu__sdbm_*
403
404* Mon Feb 16 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
405- fix sdbm apr_dbm_exists() on s390x/ppc64
406
407* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-8
408- rebuilt
409
410* Thu Feb  5 2004 Joe Orton <jorton@redhat.com> 0.9.4-7
411- fix warnings from use of apr_optional*.h with gcc 3.4
412
413* Thu Jan 29 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
414- drop gdbm support
415
416* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
417- fix DB library detection
418
419* Sat Dec 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-4
420- rebuild against db-4.2.52.
421
422* Mon Oct 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-3
423- rebuild against db-4.2.42.
424
425* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
426- fix 'apu-config --apu-la-file' output
427
428* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
429- update to 0.9.4.
430
431* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-10
432- rebuild
433
434* Mon Jul  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
435- rebuild
436- don't run testuuid test because of #98677
437
438* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
439- rebuild
440
441* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
442- rebuilt
443
444* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
445- fix to detect crypt_r correctly (CAN-2003-0195)
446
447* Thu May 15 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
448- fix to try linking against -ldb first (#90917)
449- depend on openldap, gdbm, db4, expat appropriately.
450
451* Tue May 13 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
452- rebuild
453
454* Wed May  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
455- make devel package conflict with old subversion-devel
456- run the less crufty parts of the test suite
457
458* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
459- run ldconfig in post/postun
460
461* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
462- initial build
Note: See TracBrowser for help on using the repository browser.