source: projects/specs/trunk/a/apr-util/apr-util-vl.spec @ 8858

Revision 8858, 13.1 KB checked in by daisuke, 10 years ago (diff)

apr-util: fix BR

Line 
1%define apuver 1
2
3Summary: Apache Portable Runtime Utility library
4Summary(ja): Apache ポータブルランタイムユーティリティライブラリ
5Name: apr-util
6Version: 1.5.3
7Release: 2%{?_dist_release}
8
9License: Apache Software License 2.0
10Group: System Environment/Libraries
11URL: http://apr.apache.org/
12
13Source0: %{name}-%{version}.tar.bz2
14Patch1: apr-util-1.2.7-pkgconf.patch
15Patch2: apr-util-1.3.7-nodbmdso.patch
16Patch4: apr-util-1.4.1-private.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: autoconf, doxygen, apr-devel >= 1.2.0
20BuildRequires: libdb-devel, expat-devel, libuuid-devel
21BuildRequires: libpq-devel
22BuildRequires: libmysqlclient-devel
23BuildRequires: zlib-devel
24BuildRequires: sqlite3-devel
25BuildRequires: unixODBC-devel
26BuildRequires: openldap-devel
27Conflicts: subversion < 0.20.1-2
28Obsoletes: apache2-apr
29
30%description
31The mission of the Apache Portable Runtime (APR) is to provide a
32free library of C data structures and routines.  This library
33contains additional utility interfaces for APR; including support
34for XML, LDAP, database interfaces, URI parsing and more.
35
36%package devel
37Summary: APR utility library development kit
38Summary(ja): APR ユーティリティライブラリ開発キット
39Group: Development/Libraries
40Requires: apr-util = %{version}-%{release}, apr-devel, pkgconfig
41Requires: openldap-devel, libdb-devel, expat-devel
42Conflicts: subversion-devel < 0.20.1-2
43Obsoletes: apache2-apr-devel
44
45%description devel
46This package provides the support files which can be used to
47build applications using the APR utility library.  The mission
48of the Apache Portable Runtime (APR) is to provide a free
49library of C data structures and routines.
50
51%package pgsql
52Summary: APR utility library PostgreSQL DBD driver
53Group: System Environment/Libraries
54Requires: apr-util = %{version}-%{release}
55
56%description pgsql
57This package provides the PostgreSQL driver for the apr-util
58DBD (database abstraction) interface.
59
60%package mysql
61Summary: APR utility library MySQL DBD driver
62Group: System Environment/Libraries
63Requires: apr-util = %{version}-%{release}
64
65%description mysql
66This package provides the MySQL driver for the apr-util DBD
67(database abstraction) interface.
68
69%package sqlite
70Summary: APR utility library SQLite DBD driver
71Group: System Environment/Libraries
72Requires: apr-util = %{version}-%{release}
73
74%description sqlite
75This package provides the SQLite driver for the apr-util DBD
76(database abstraction) interface.
77
78#%package freetds
79#Group: Development/Libraries
80#Summary: APR utility library FreeTDS DBD driver
81#BuildRequires: freetds-devel
82#Requires: apr-util = %{version}-%{release}
83
84#%description freetds
85#This package provides the FreeTDS driver for the apr-util DBD
86#(database abstraction) interface.
87
88%package odbc
89Summary: APR utility library ODBC DBD driver
90Group: System Environment/Libraries
91Requires: apr-util = %{version}-%{release}
92
93%description odbc
94This package provides the ODBC driver for the apr-util DBD
95(database abstraction) interface.
96
97%package ldap
98Summary: APR utility library LDAP support
99Group: System Environment/Libraries
100Requires: apr-util = %{version}-%{release}
101
102%description ldap
103This package provides the LDAP support for the apr-util.
104
105%prep
106%setup -q
107%patch1 -p1 -b .pkgconf
108%patch2 -p1 -b .nodbmdso
109%patch4 -p1 -b .private
110
111%build
112autoheader && autoconf
113%configure --with-apr=%{_prefix} \
114        --includedir=%{_includedir}/apr-%{apuver} \
115        --with-ldap --without-gdbm \
116        --with-sqlite3 --with-pgsql --with-mysql --with-odbc \
117        --with-berkeley-db \
118        --without-sqlite2
119#        --disable-util-dso       
120make %{?_smp_mflags} && make dox
121
122%install
123rm -rf $RPM_BUILD_ROOT
124make install DESTDIR=$RPM_BUILD_ROOT
125
126mkdir -p $RPM_BUILD_ROOT/%{_datadir}/aclocal
127install -m 644 build/find_apu.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
128
129# Documentation
130rm -rf html
131mkdir -p html
132cp -pr docs/dox/html/* html
133
134# Unpackaged files; remove the static libaprutil
135rm -f $RPM_BUILD_ROOT%{_libdir}/aprutil.exp \
136      $RPM_BUILD_ROOT%{_libdir}/libapr*.a
137
138# remove *.la
139rm -f $RPM_BUILD_ROOT%{_libdir}/libapr*.la
140
141# And remove the reference to the static libaprutil from the .la
142# file.
143#sed -i '/^old_library/s,libapr.*\.a,,' \
144#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
145
146# Remove unnecessary exports from dependency_libs
147#sed -ri '/^dependency_libs/{s,-l(pq|sqlite[0-9]|rt|dl|uuid) ,,g}' \
148#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
149
150# Trim libtool DSO cruft
151rm -f $RPM_BUILD_ROOT%{_libdir}/apr-util-%{apuver}/*.*a
152
153%check
154# Run the less verbose test suites
155export MALLOC_CHECK_=2 MALLOC_PERTURB_=$(($RANDOM % 255 + 1))
156cd test
157make %{?_smp_mflags} testall
158# testall breaks with DBD DSO; ignore
159export LD_LIBRARY_PATH="`echo "../dbm/.libs:../dbd/.libs:../ldap/.libs:$LD_LIBRARY_PATH" | sed -e 's/::*$//'`"
160./testall -v -q || true
161./testall testrmm
162./testall testdbm
163
164%clean
165rm -rf $RPM_BUILD_ROOT
166
167%post -p /sbin/ldconfig
168
169%postun -p /sbin/ldconfig
170
171%files
172%defattr(-,root,root,-)
173%doc CHANGES LICENSE NOTICE
174%{_libdir}/libaprutil-%{apuver}.so.*
175%dir %{_libdir}/apr-util-%{apuver}
176
177%files devel
178%defattr(-,root,root,-)
179%{_bindir}/apu-%{apuver}-config
180#{_libdir}/libaprutil-%{apuver}.a
181%{_libdir}/libaprutil-%{apuver}.so
182%{_includedir}/apr-%{apuver}/*.h
183%{_libdir}/pkgconfig/*.pc
184%{_datadir}/aclocal/*.m4
185%doc --parents html
186
187%files pgsql
188%defattr(-,root,root,-)
189%{_libdir}/apr-util-%{apuver}/apr_dbd_pgsql*
190
191%files mysql
192%defattr(-,root,root,-)
193%{_libdir}/apr-util-%{apuver}/apr_dbd_mysql*
194
195%files sqlite
196%defattr(-,root,root,-)
197%{_libdir}/apr-util-%{apuver}/apr_dbd_sqlite*
198
199#files freetds
200#defattr(-,root,root,-)
201#{_libdir}/apr-util-%{apuver}/apr_dbd_freetds*
202
203%files odbc
204%defattr(-,root,root,-)
205%{_libdir}/apr-util-%{apuver}/apr_dbd_odbc*
206
207%files ldap
208%defattr(-,root,root,-)
209%{_libdir}/apr-util-%{apuver}/apr_ldap*
210
211%changelog
212* Tue Jul 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.3-2
213- add BR: libqp-devel instead of postgresql-devel
214
215* Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.3-1
216- update to 1.5.3
217- add BR: libdb-devel, libmysqlclient-devel
218- remove BR: db4-devel, MySQL-devel
219
220* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.12-1
221- new upstream release
222- rebuilt with MySQL-5.5.15
223
224* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 1.3.9-7
225- rebuilt with postgresql-9.0.3
226
227* Sat Apr  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-6
228- rebuilt with unixODBC-2.2.14
229
230* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.9-5
231- rebuilt with rpm-4.8.1 for pkg-config
232
233* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-4
234- rebuilt with gcc-4.4.3-3 on ppc
235
236* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-3
237- rebuilt with rpm-4.8.0-3 (on ppc)
238
239* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.9-2
240- rebuild with db4-4.8.0
241
242* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
243- new upstream release
244- dropped Patch100, 110, 120 and 130 (merged into upstream)
245- added BR: zlib-devel
246
247* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-5
248- add Patch130 for fix CVE-2009-2412 (IOF apr_rmm_malloc)
249- This patch is included in 1.3.9
250
251* Thu Jun 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-4
252- add patch100 for fix CVE-2009-0023
253- add patch110 for fix CVE-2009-1955
254- add patch120 for fix CVE-2009-1956
255- These patches are included in 1.3.7 or later
256
257* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.4-3
258- rebuilt with MySQL-5.1.34.
259
260* Thu Apr  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2
261- rebuilt with openldap-2.4.11
262
263* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-1vl5
264- new upstream release
265- split out DBD drivers and ldap support into subpackage
266
267* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
268- new upstream release
269- built with db-4.6.21
270
271* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
272- removed *.la files from devel package
273
274* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
275- new upstream release
276- added Patch3 from Fedora Core
277  * Fri Mar 23 2007 Joe Orton <jorton@redhat.com> 1.2.8-6
278  - add DBD DSO lifetime fix (r521327)
279
280* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl2
281- rebuild with expat-2.0.1
282
283* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
284- new upstream release
285
286* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
287- rebuilt with new toolchain
288
289* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
290- new upstream release
291- dropped Patch1 (merged into upstream)
292
293* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.7-0vl2
294- rebuilt with openldap-2.3.27-0vl1
295
296* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
297- initial build for Vine Linux based on FC package
298
299* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
300- update to 1.2.7
301- use pkg-config in apu-1-config to make it libdir-agnostic
302
303* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
304- update to 1.2.6
305- define LDAP_DEPRECATED in apr_ldap.h (r391985, #188073)
306
307* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.2
308- bump again for double-long bug on ppc(64)
309
310* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.1
311- rebuilt for new gcc4.1 snapshot and glibc changes
312
313* Mon Jan 30 2006 Joe Orton <jorton@redhat.com> 1.2.2-4
314- rebuild to drop reference to libexpat.la
315
316* Wed Jan 18 2006 Joe Orton <jorton@redhat.com> 1.2.2-3
317- disable sqlite2 support
318- BuildRequire e2fsprogs-devel
319- enable malloc paranoia in %%check
320
321* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-2.2
322- rebuilt again
323
324* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
325- rebuilt
326
327* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
328- trim exports from .la file/--libs output (#174924)
329
330* Fri Nov 25 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
331- update to 1.2.2
332
333* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
334- fix epoch again
335
336* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
337- update to 0.9.7
338- drop static libs (#170051)
339
340* Tue Jul 26 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
341- add FILE bucket fix for truncated files (#159191)
342- add epoch to dependencies
343
344* Fri Mar  4 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
345- rebuild
346
347* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
348- update to 0.9.6
349
350* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-3
351- restore db-4.3 detection lost in 0.9.5 upgrade
352
353* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-2
354- rebuild
355
356* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
357- update to 0.9.5
358
359* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-19
360- actually explicitly check for and detect db-4.3.
361
362* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-18
363- rebuild against db-4.3.21.
364
365* Fri Sep 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
366- add security fix for CAN-2004-0786
367
368* Sat Jun 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-16
369- have -devel require matching release of apr-util
370
371* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
372- rebuilt
373
374* Thu Apr  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
375- fix use of SHA1 passwords (#119651)
376
377* Tue Mar 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
378- remove fundamentally broken check_sbcs() from xlate code
379
380* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
381- tweak xlate fix
382
383* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
384- rebuild with xlate fixes and tests enabled
385
386* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-10.1
387- rebuilt
388
389* Tue Mar  2 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
390- rename sdbm_* symbols to apu__sdbm_*
391
392* Mon Feb 16 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
393- fix sdbm apr_dbm_exists() on s390x/ppc64
394
395* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-8
396- rebuilt
397
398* Thu Feb  5 2004 Joe Orton <jorton@redhat.com> 0.9.4-7
399- fix warnings from use of apr_optional*.h with gcc 3.4
400
401* Thu Jan 29 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
402- drop gdbm support
403
404* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
405- fix DB library detection
406
407* Sat Dec 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-4
408- rebuild against db-4.2.52.
409
410* Mon Oct 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-3
411- rebuild against db-4.2.42.
412
413* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
414- fix 'apu-config --apu-la-file' output
415
416* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
417- update to 0.9.4.
418
419* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-10
420- rebuild
421
422* Mon Jul  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
423- rebuild
424- don't run testuuid test because of #98677
425
426* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
427- rebuild
428
429* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
430- rebuilt
431
432* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
433- fix to detect crypt_r correctly (CAN-2003-0195)
434
435* Thu May 15 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
436- fix to try linking against -ldb first (#90917)
437- depend on openldap, gdbm, db4, expat appropriately.
438
439* Tue May 13 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
440- rebuild
441
442* Wed May  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
443- make devel package conflict with old subversion-devel
444- run the less crufty parts of the test suite
445
446* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
447- run ldconfig in post/postun
448
449* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
450- initial build
Note: See TracBrowser for help on using the repository browser.