source: projects/specs/trunk/a/apel/apel-vl.spec @ 3640

Revision 3640, 6.0 KB checked in by iwaim, 13 years ago (diff)

apel-10.8-2

Line 
1%define _noVersionedDependencies        1
2
3%define       origver       10.8
4%define       origname      apel       
5
6Summary:      A Portable Emacs Library
7Summary(ja):  Emacs 用の 基礎的な関数を提供するライブラリ
8Name:         %{origname}
9Version:      %{origver}
10Release:      2%{?_dist_release}
11
12Source0:      http://kanji.zinbun.kyoto-u.ac.jp/~tomo/lemi/dist/apel/apel-%{origver}.tar.gz
13Source1:      apel-install.sh
14Source2:      apel-remove.sh
15Source3:      apel-init.el
16
17Patch10:      apel-10.3-APEL-ELS.diff
18
19License:      1993-1999 Free Software Foundation, Inc., Dan Rich, Morioka Tomohiko, Kobayashi Shuhei
20Group:        Applications/Editors/Emacs
21BuildRoot:    %{_tmppath}/%{name}-%{version}-root
22BuildArch:    noarch
23
24Requires: emacsen
25Requires(post,preun): emacsen emacsen-common
26Obsoletes:    %{origname}-el
27Conflicts:    semi <= 1.14.5-0vl2
28
29Vendor:       Project Vine
30Distribution: Vine Linux
31Packager:     shaolin
32
33
34%description
35This package contains following .el files for emacsen:
36
37  APEL       %{origver}
38
39APEL stands for "A Portable Emacs Library".
40It provides basic functions and macros for emacsen.
41
42Note: in order to rebuild this SRPM package, you need emacsen
43and emacsen-common installed.
44
45
46%description -l ja
47このパッケージは GNU Emacs %{emacsver} 上で使用する
48以下の elisp を収めています.
49
50  APEL       %{origver}
51
52APEL は "A Portable Emacs Library" の略です.
53Emacs 環境のための基礎的な関数やマクロを提供します.
54
55注意:この SRPM パッケージを rebuild するには、emacsen と emacsen-common が
56インストールされている必要があります.
57
58
59%prep
60%setup -q -n %{origname}-%{origver}
61
62%patch10 -p1
63
64
65%install
66
67[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
68[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
69
70mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
71mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
72mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
73
74#
75# install el files
76#
77
78cp Makefile EMU-* APEL-* *.el %{SOURCE3} \
79   ${RPM_BUILD_ROOT}/usr/share/emacs/site-lisp/%{origname}
80
81#
82# install  script( bytecompile el and install elc , remove )   
83#
84
85%_installemacsenscript %{origname} %{SOURCE1}
86
87%_removeemacsenscript  %{origname} %{SOURCE2}
88
89
90%post
91
92#
93# bytecompile and install
94#
95
96if [ "$1" = 2 ]; then
97
98%_emacsenPackageRemove %{origname}
99
100fi
101
102%_addemacsenlist %{origname}
103
104%_emacsenPackageInstall %{origname}
105
106
107%preun
108
109if [ "$1" = 0 ]; then
110
111%_emacsenPackageRemove %{origname}
112
113%_removeemacsenlist %{origname}
114
115fi
116
117
118%triggerpostun -- apel-el
119
120%_emacsenPackageInstall %{origname}
121
122
123%clean
124[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
125
126
127%files
128%defattr(-,root,root)
129%doc ChangeLog README*
130/usr/share/emacs/site-lisp/%{origname}/
131/usr/lib/emacsen-common/packages/install/%{origname}
132/usr/lib/emacsen-common/packages/remove/%{origname}
133
134 
135%changelog
136* Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 10.8-2
137- drop defining prereq_ge macro: using Requires(post,preun) tag
138- add Requires: emacsen
139
140* Tue Jun 15 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 10.8-1
141- new upstream release
142
143* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 10.7-2
144- spec in utf8
145
146* Fri May  2 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.7-1
147- applied new versioning policy
148
149* Fri Dec  7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.7-0vl1
150- updated to 10.7
151
152* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.6-0vl3
153- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
154
155* Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.6-0vl2
156- rebuilt
157
158* Tue Jul  8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 10.6-0vl1
159- updated to new upstream version 10.6
160
161* Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.5-0vl1
162- updated to new upstream version 10.5
163
164* Mon May 19 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 10.4-0vl1
165- update.
166- Tag Changed(Copyright -> License)
167
168* Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl9
169- Obsoletes: apel-el now, instead of Conflicts:
170- added %%triggerpostun -- apel-el
171
172* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl8
173- package name changed apel-el -> apel again
174- added Source3 for forthcoming site-start mechanism
175
176* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl7
177- activate file-detect and atype (Patch10), especially for xemacs
178
179* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl6
180- fixed the target directory for emu modules to be installed
181- included missing documents again
182- cleanup the spec file
183
184* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
185- emacsenize
186
187* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
188- 1.14.3-0vl2
189- back to Requires: emacs = 20.7 -> emacs >= 20.7 (for emacs-beta)
190
191* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
192- 1.14.3-0vl1
193- updated to apel-10.3, flim-1.14.3, semi-1.14.3, emh-1.14.1
194
195* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
196- 1.13.7-8
197- added %define _noVersionedDependencies 1
198
199* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
200- 1.13.7-7
201- modified %files section to handle compressed man page(s)
202
203* Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
204- 1.13.7-6
205- apel updated to 10.2
206
207* Mon Jan 24 2000 MATSUBAYASHI 'Shaolin' Kohji
208- 1.13.7-5
209- added patch (see emacs-mime-ja: 00303) to format texinfo correctly
210
211* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji
212- 1.13.7-4
213- updated in sync with apel-10.0 / clime-1.13.6 release
214
215* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji
216- 1.13.7-3
217- change Group to Applications/Editors/EmacsLisp
218
219* Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
220- 1.13.7-2
221- added patches (see emacs-mime-ja:00183, emacs-mime-ja:00184)
222- now emh-1.10.1 and rmail-mime-1.13.0 are also included
223- documentation files are properly stored under /usr/doc directory
224
225* Wed Nov  3 1999 MATSUBAYASHI 'Shaolin' Kohji
226- 1.13.7-1
227- updated to apel-9.23 / clime-1.13.5 / semi-1.13.7 release
228- added Japanese / English info files to be installed
Note: See TracBrowser for help on using the repository browser.