source: projects/specs/trunk/a/apel/apel-vl.spec @ 8426

Revision 8426, 6.6 KB checked in by daisuke, 10 years ago (diff)

apel:

  • add patch0 for (original) git master
  • add patch1 to update to ikazuhiro's branch (2014-03-15)  https://github.com/ikazuhiro/apel/commits/master
  • add patch2 from debian package (Prevent an error of fontset-pixel-size for Emacs 23.)
  • add patch3 from debian package (use new style backquotes to use on emacs-24.3.90)
Line 
1%define _noVersionedDependencies        1
2
3%define       origver       10.8
4%define       origname      apel
5
6Summary:      A Portable Emacs Library
7Summary(ja):  Emacs 用の 基礎的な関数を提供するライブラリ
8Name:         %{origname}
9Version:      %{origver}
10Release:      3%{?_dist_release}
11
12Source0:      http://kanji.zinbun.kyoto-u.ac.jp/~tomo/lemi/dist/apel/apel-%{origver}.tar.gz
13Source1:      apel-install.sh
14Source2:      apel-remove.sh
15Source3:      apel-init.el
16
17Patch0:       apel-10.8-20120427.patch
18Patch1:       apel-10.8-ikazuhiro-branch.patch
19Patch2:       apel-10.8-prevent-fontset-error.patch
20Patch3:       apel-10.8-use-new-style-backquotes.patch
21
22License:      1993-1999 Free Software Foundation, Inc., Dan Rich, Morioka Tomohiko, Kobayashi Shuhei
23Group:        Applications/Editors/Emacs
24Url:          http://git.chise.org/elisp/apel/
25BuildRoot:    %{_tmppath}/%{name}-%{version}-root
26BuildArch:    noarch
27
28Requires: emacsen
29Requires(post,preun): emacsen emacsen-common
30Obsoletes:    %{origname}-el
31Conflicts:    semi <= 1.14.5-0vl2
32
33Vendor:       Project Vine
34Distribution: Vine Linux
35Packager:     shaolin, daisuke
36
37
38%description
39This package contains following .el files for emacsen:
40
41  APEL       %{origver}
42
43APEL stands for "A Portable Emacs Library".
44It provides basic functions and macros for emacsen.
45
46Note: in order to rebuild this SRPM package, you need emacsen
47and emacsen-common installed.
48
49
50%description -l ja
51このパッケージは GNU Emacs %{emacsver} 上で使用する
52以下の elisp を収めています.
53
54  APEL       %{origver}
55
56APEL は "A Portable Emacs Library" の略です.
57Emacs 環境のための基礎的な関数やマクロを提供します.
58
59注意:この SRPM パッケージを rebuild するには、emacsen と emacsen-common が
60インストールされている必要があります.
61
62
63%prep
64%setup -q -n %{origname}-%{origver}
65
66%patch0 -p1
67%patch1 -p1
68%patch2 -p1
69%patch3 -p1
70
71
72%install
73
74[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
75[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
76
77mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
78mkdir -p $RPM_BUILD_ROOT/%{_prefix}/lib/emacsen-common/packages/install
79mkdir -p $RPM_BUILD_ROOT/%{_prefix}/lib/emacsen-common/packages/remove
80
81#
82# install el files
83#
84
85cp Makefile EMU-* APEL-* *.el %{SOURCE3} \
86   ${RPM_BUILD_ROOT}/usr/share/emacs/site-lisp/%{origname}
87
88#
89# install  script( bytecompile el and install elc , remove )   
90#
91
92%_installemacsenscript %{origname} %{SOURCE1}
93
94%_removeemacsenscript  %{origname} %{SOURCE2}
95
96
97%post
98
99#
100# bytecompile and install
101#
102
103if [ "$1" = 2 ]; then
104
105%_emacsenPackageRemove %{origname}
106
107fi
108
109%_addemacsenlist %{origname}
110
111%_emacsenPackageInstall %{origname}
112
113
114%preun
115
116if [ "$1" = 0 ]; then
117
118%_emacsenPackageRemove %{origname}
119
120%_removeemacsenlist %{origname}
121
122fi
123
124
125%triggerpostun -- apel-el
126
127%_emacsenPackageInstall %{origname}
128
129
130%clean
131[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
132
133
134%files
135%defattr(-,root,root)
136%doc ChangeLog README*
137/usr/share/emacs/site-lisp/%{origname}/
138/usr/lib/emacsen-common/packages/install/%{origname}
139/usr/lib/emacsen-common/packages/remove/%{origname}
140
141 
142%changelog
143* Tue May 06 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 10.8-3
144- add patch0 for (original) git master
145- add patch1 to update to ikazuhiro's branch (2014-03-15)
146  https://github.com/ikazuhiro/apel/commits/master
147- add patch2 from debian package
148  (Prevent an error of fontset-pixel-size for Emacs 23.)
149- add patch3 from debian package
150  (use new style backquotes to use on emacs-24.3.90)
151
152* Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 10.8-2
153- drop defining prereq_ge macro: using Requires(post,preun) tag
154- add Requires: emacsen
155
156* Tue Jun 15 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 10.8-1
157- new upstream release
158
159* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 10.7-2
160- spec in utf8
161
162* Fri May  2 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.7-1
163- applied new versioning policy
164
165* Fri Dec  7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.7-0vl1
166- updated to 10.7
167
168* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.6-0vl3
169- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
170
171* Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.6-0vl2
172- rebuilt
173
174* Tue Jul  8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 10.6-0vl1
175- updated to new upstream version 10.6
176
177* Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.5-0vl1
178- updated to new upstream version 10.5
179
180* Mon May 19 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 10.4-0vl1
181- update.
182- Tag Changed(Copyright -> License)
183
184* Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl9
185- Obsoletes: apel-el now, instead of Conflicts:
186- added %%triggerpostun -- apel-el
187
188* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl8
189- package name changed apel-el -> apel again
190- added Source3 for forthcoming site-start mechanism
191
192* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl7
193- activate file-detect and atype (Patch10), especially for xemacs
194
195* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl6
196- fixed the target directory for emu modules to be installed
197- included missing documents again
198- cleanup the spec file
199
200* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
201- emacsenize
202
203* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
204- 1.14.3-0vl2
205- back to Requires: emacs = 20.7 -> emacs >= 20.7 (for emacs-beta)
206
207* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
208- 1.14.3-0vl1
209- updated to apel-10.3, flim-1.14.3, semi-1.14.3, emh-1.14.1
210
211* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
212- 1.13.7-8
213- added %define _noVersionedDependencies 1
214
215* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
216- 1.13.7-7
217- modified %files section to handle compressed man page(s)
218
219* Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
220- 1.13.7-6
221- apel updated to 10.2
222
223* Mon Jan 24 2000 MATSUBAYASHI 'Shaolin' Kohji
224- 1.13.7-5
225- added patch (see emacs-mime-ja: 00303) to format texinfo correctly
226
227* Fri Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji
228- 1.13.7-4
229- updated in sync with apel-10.0 / clime-1.13.6 release
230
231* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji
232- 1.13.7-3
233- change Group to Applications/Editors/EmacsLisp
234
235* Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
236- 1.13.7-2
237- added patches (see emacs-mime-ja:00183, emacs-mime-ja:00184)
238- now emh-1.10.1 and rmail-mime-1.13.0 are also included
239- documentation files are properly stored under /usr/doc directory
240
241* Wed Nov  3 1999 MATSUBAYASHI 'Shaolin' Kohji
242- 1.13.7-1
243- updated to apel-9.23 / clime-1.13.5 / semi-1.13.7 release
244- added Japanese / English info files to be installed
Note: See TracBrowser for help on using the repository browser.