source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 8063

Revision 8063, 26.0 KB checked in by Takemikaduchi, 10 years ago (diff)

merge spec file

Line 
1%define contentdir %{_datadir}/apache2
2%define docroot /var/www/apache2
3%define suexec_caller apache
4%define mmn 20051115
5%define pkgname apache2
6
7Summary: Apache HTTP Server
8Name: %{pkgname}
9Version: 2.2.25
10Release: 2%{_dist_release}
11URL: http://httpd.apache.org/
12
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: daisuke
16
17Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
18Source1: index.html.ja
19Source3: apache2.logrotate
20Source4: apache2.init
21Source5: README.confd
22Source6: vine.png
23Source10: httpd.conf
24Source11: apache-ssl.conf
25Source12: migration.html
26Source13: migration.css
27Source14: mod_ssl-Makefile.crt
28Source15: mod_ssl-Makefile.crl
29# add vine entry to config.layout
30Source100: vine-config.layout
31# man files
32Source101: apache2.8
33Source102: apache2ctl.8
34#Source103: config_vars.mk
35# build/scripts patches
36Patch1: httpd-2.1.10-apctl.patch
37Patch2: httpd-2.2.3-apxs.patch
38Patch3: httpd-2.0.45-deplibs.patch
39Patch4: httpd-2.1.10-disablemods.patch
40# features/functional changes
41Patch21: httpd-2.0.40-xfsz.patch
42# Patch22: httpd-2.1.10-pod.patch
43Patch22: httpd-2.2.23-pod.patch
44Patch23: httpd-2.0.45-export.patch
45Patch24: httpd-2.0.48-corelimit.patch
46# Bug fixes
47Patch54: httpd-2.2.0-authnoprov.patch
48Patch60: httpd-2.2.3-sslusername.patch
49
50# Security fixes
51
52
53License: Apache Software License
54Group: System Environment/Daemons
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56BuildRequires: db4-devel, expat-devel
57BuildRequires: findutils, perl, openldap-devel, zlib-devel
58BuildRequires: apr-devel, apr-util-devel
59BuildRequires: pcre-devel, sqlite3-devel
60BuildRequires: www-common
61Requires: mailcap, gawk, file, findutils, apr, apr-util
62Requires(pre): www-common
63Requires(pre): chkconfig, mktemp, fileutils
64Requires(pre): sh-utils, textutils, shadow-utils
65Requires(post): alternatives
66Provides: webserver
67Provides: httpd = %{version}
68Provides: httpd-mmn = %{mmn}
69Obsoletes: apache2-apr, apache2-apr-devel
70
71%description
72Apache is a powerful, full-featured, efficient, and freely-available
73Web server. Apache is also the most popular Web server on the
74Internet.
75
76%package devel
77Group: Development/Libraries
78Summary: Development tools for the Apache HTTP server.
79Requires: libtool, httpd = %{version}
80Requires: apr-devel, apr-util-devel
81
82%description devel
83The httpd-devel package contains the APXS binary and other files
84that you need to build Dynamic Shared Objects (DSOs) for Apache.
85
86If you are installing the Apache HTTP server and you want to be
87able to compile or develop additional modules for Apache, you need
88to install this package.
89
90%package manual
91Group: Applications/Documentation
92Summary: Documentation for the Apache HTTP server.
93
94%description manual
95The httpd-manual package contains the complete manual and
96reference guide for the Apache HTTP server. The information can
97also be found at http://httpd.apache.org/docs/.
98
99%package -n mod_ssl-apache2
100Group: System Environment/Daemons
101Summary: SSL/TLS module for the Apache HTTP server
102Epoch: 1
103BuildRequires: openssl-devel
104Requires(pre): openssl, dev, /bin/cat
105Requires: httpd, make, httpd-mmn = %{mmn}
106
107%description -n mod_ssl-apache2
108The mod_ssl module provides strong cryptography for the Apache Web
109server via the Secure Sockets Layer (SSL) and Transport Layer
110Security (TLS) protocols.
111
112%prep
113%setup -q -n httpd-%{version}
114
115%patch1 -p1 -b .apctl
116%patch2 -p1 -b .apxs
117#patch3 -p1 -b .deplibs
118%patch4 -p1 -b .disablemods
119
120%patch21 -p0 -b .xfsz
121%patch22 -p1 -b .pod
122%patch23 -p1 -b .export
123%patch24 -p1 -b .corelimit
124
125%patch54 -p1 -b .authnoprov
126%patch60 -p1 -b .sslusername
127
128# copy across the migration guide and sed it's location into apachectl
129cp $RPM_SOURCE_DIR/migration.{html,css} .
130%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
131        support/apachectl.in
132
133
134# add Vine configure's option to config.layout
135sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
136  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
137
138# regenerate configure scripts
139./buildconf
140
141%build
142# remove bundled apr, apr-util, pcre
143rm -rf srclib/{apr,apr-util,pcre}
144
145#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
146#AP_LIBS="-lssl -lcrypto"
147#export CFLAGS AP_LIBS
148CFLAGS="$RPM_OPT_FLAGS"
149SH_LDFLAGS="-Wl,-z,relro"
150export CFLAGS SH_LDFLAGS
151
152%define mpms worker prefork
153%define prefer_mpm prefork
154
155AP_CONFOPTS="\
156        --prefix=%{_sysconfdir}/apache2 \
157        --exec-prefix=%{_prefix} \
158        --bindir=%{_bindir} \
159        --sbindir=%{_sbindir} \
160        --mandir=%{_mandir} \
161        --libdir=%{_libdir} \
162        --sysconfdir=%{_sysconfdir}/apache2/conf \
163        --includedir=%{_includedir}/apache2 \
164        --libexecdir=%{_libdir}/apache2/modules \
165        --datadir=%{contentdir} \
166        --with-installbuilddir=%{_libdir}/apache2/build \
167        --enable-layout=Vine \
168        --with-program-name=apache2 \
169        --with-ldap \
170        --enable-ldap --enable-authnz-ldap \
171        --enable-mods-shared=all \
172        --enable-cache=shared \
173        --enable-cgi=shared \
174        --enable-cgid=shared \
175        --enable-rewrite=shared \
176        --enable-disk-cache=shared \
177        --enable-file-cache=shared \
178        --enable-mem-cache=shared \
179        --enable-authn-anon --enable-authn-alias \
180        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
181        --enable-suexec --with-suexec \
182        --with-suexec-caller=%{suexec_caller} \
183        --with-suexec-docroot=%{docroot} \
184        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
185        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
186        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
187        --with-pcre \
188        --enable-ssl --with-ssl \
189        --enable-deflate \
190        --enable-proxy --enable-proxy-connect \
191        --enable-proxy-http --enable-proxy-ftp"
192#all  mpm build
193for mpm in %{mpms}; do
194   mkdir mpm-$mpm;
195   cd mpm-$mpm;
196   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
197   make %{?_smp_mflags} ;
198#   mv apache2 apache2.$mpm ;
199   cd ../
200done
201
202%install
203rm -rf $RPM_BUILD_ROOT
204
205# install mpms binary
206pushd mpm-prefork
207  make DESTDIR=$RPM_BUILD_ROOT install
208  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
209popd
210
211for mpm in %{mpms}; do
212    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
213done
214
215# install conf file/directory
216mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
217install -m 644 $RPM_SOURCE_DIR/README.confd \
218   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
219install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
220   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
221
222rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
223install -m 644 $RPM_SOURCE_DIR/httpd.conf \
224   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
225
226# mod_ssl bits
227for suffix in crl crt csr key prm; do
228   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
229done
230
231# Makefiles for certificate management
232for ext in crt crl; do
233  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
234        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
235done
236ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
237
238# for holding mod_dav lock database
239mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
240
241# create a prototype session cache
242mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
243touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
244
245# move utilities to /usr/bin
246mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
247   $RPM_BUILD_ROOT%{_bindir}
248
249# Make the MMN accessible to module packages
250echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
251
252# contentdir
253# mkdir $RPM_BUILD_ROOT%{contentdir}/html
254install -m 644 $RPM_SOURCE_DIR/index.html.ja \
255        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
256rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
257
258install -m 644 $RPM_SOURCE_DIR/vine.png \
259        $RPM_BUILD_ROOT%{contentdir}/icons
260
261# docroot
262mkdir -p $RPM_BUILD_ROOT%{docroot}/html
263
264# logs
265# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
266mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
267
268ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
269
270
271# symlinks for /etc/apache2
272ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
273ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
274ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
275ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
276
277# install SYSV init stuff
278mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
279install -m755 $RPM_SOURCE_DIR/apache2.init \
280        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
281%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
282        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
283
284# install log rotation stuff
285mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
286install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
287        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
288
289mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
290
291# fix man page paths
292sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
293    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
294    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
295    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
296    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
297    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
298    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
299  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
300
301install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
302        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
303
304# change command name to avoid conflict with apache1 pacjage
305%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
306
307for i in %{cflcmd}; do \
308  echo $i
309  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
310done;
311
312mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
313
314%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
315
316(cd $RPM_BUILD_ROOT;
317for i in %{cflman}; do \
318    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
319   
320done;
321)
322
323#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
324mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
325
326
327rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
328rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
329# conflict with apache 1, so removed...
330rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
331rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
332
333# remove unpackaged files
334rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
335      $RPM_BUILD_ROOT%{_libdir}/*.la \
336      $RPM_BUILD_ROOT%{_libdir}/*.exp \
337      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
338      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
339      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
340      $RPM_BUILD_ROOT%{docroot}/html/* \
341      $RPM_BUILD_ROOT%{contentdir}/html/* \
342      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
343
344%triggerpostun -- apache < 2.0
345/sbin/chkconfig --add apache2
346
347
348%post
349# Register the httpd service
350for mpm in %{mpms}; do
351  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
352done
353/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
354/sbin/chkconfig --add apache2
355
356%preun
357if [ $1 = 0 ]; then
358        /sbin/service apache2 stop > /dev/null 2>&1
359        /sbin/chkconfig --del apache2
360        for mpm in %{mpms}; do
361          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
362        done 
363fi
364
365%postun
366if [ "$1" -ge 1 ]; then
367        /sbin/service apache2 condrestart
368fi
369/sbin/ldconfig
370
371%post -n mod_ssl-apache2
372/sbin/ldconfig ### is this needed?
373umask 077
374
375if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
376%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
377fi
378
379FQDN=`hostname`
380if [ "x${FQDN}" = "x" ]; then
381   FQDN=localhost.localdomain
382fi
383
384if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
385cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
386--
387SomeState
388SomeCity
389SomeOrganization
390SomeOrganizationalUnit
391${FQDN}
392root@${FQDN}
393EOF
394fi
395
396%clean
397rm -rf $RPM_BUILD_ROOT
398
399%files
400%defattr(-,root,root)
401
402%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
403%doc migration.html migration.css
404
405%dir %{_sysconfdir}/apache2
406%{_sysconfdir}/apache2/modules
407%{_sysconfdir}/apache2/logs
408%{_sysconfdir}/apache2/run
409%dir %{_sysconfdir}/apache2/conf
410%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
411%config(noreplace) %{_sysconfdir}/apache2/conf/magic
412
413%config %{_sysconfdir}/logrotate.d/apache2
414%config %{_sysconfdir}/rc.d/init.d/apache2
415
416%dir %{_sysconfdir}/apache2/conf.d
417%{_sysconfdir}/apache2/conf.d/README
418
419%dir %{_sysconfdir}/apache2/conf/extra
420%config %{_sysconfdir}/apache2/conf/extra/*
421
422%dir %{_sysconfdir}/apache2/conf/original
423%{_sysconfdir}/apache2/conf/original/*
424
425%{_bindir}/ab
426%{_bindir}/ht*
427%{_bindir}/logresolve
428%{_sbindir}/ht*
429%{_sbindir}/apache2.*
430%{_sbindir}/apache2ctl
431%{_sbindir}/rotatelogs2
432%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
433
434%dir %{_libdir}/apache2
435%dir %{_libdir}/apache2/modules
436# everything but mod_ssl.so:
437%{_libdir}/apache2/modules/mod_[a-r]*.so
438%{_libdir}/apache2/modules/mod_s[petu]*.so
439%{_libdir}/apache2/modules/mod_[t-z]*.so
440
441%dir %{contentdir}
442%dir %{contentdir}/cgi-bin
443%dir %{contentdir}/html
444%dir %{contentdir}/icons
445%dir %{contentdir}/error
446%dir %{contentdir}/error/include
447%{contentdir}/icons/*
448%{contentdir}/error/README
449%{contentdir}/error/noindex.html
450%config(noreplace) %{contentdir}/error/*.var
451%config(noreplace) %{contentdir}/error/include/*.html
452
453%dir %{docroot}/html
454
455%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
456
457%attr(0700,www-data,www-data) %dir %{_localstatedir}/lib/dav
458
459%{_mandir}/man1/*
460
461%{_mandir}/man8/*
462
463%files manual
464%defattr(-,root,root)
465%{contentdir}/manual
466
467%files -n mod_ssl-apache2
468%defattr(-,root,root)
469%{_libdir}/apache2/modules/mod_ssl.so
470%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
471%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
472%config %{_sysconfdir}/apache2/conf/Makefile
473%config %{_sysconfdir}/apache2/conf/ssl.*/*
474%attr(0700,www-data,root) %dir %{_localstatedir}/cache/mod_ssl
475%attr(0600,www-data,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
476%attr(0600,www-data,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
477%attr(0600,www-data,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
478
479%files devel
480%defattr(-,root,root)
481%{_includedir}/apache2
482%{_sysconfdir}/apache2/build
483%{_bindir}/apxs
484%{_mandir}/man?/apxs*
485%{_libdir}/apache2/build/*.mk
486%{_libdir}/apache2/build/*.sh
487
488%changelog
489* Wed Dec 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.25-2
490- merge VineSeed spec file
491  * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-2
492  - rebuild with pcre-8.31
493
494  * Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-1
495  - update to 2.2.23
496  - add R(pre): www-common, BR: www-common
497  - move apache contents to %{contentdir}
498
499* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
500- new upstream release with security fix (CVE-2013-1862,1896)
501- drop patch100 (is included in new release)
502
503* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
504- add patch100 for fix CVE-2013-1862 (mod_rewrite)
505
506* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
507- new upstream release with security fix (CVE-2012-3499, 4558)
508
509* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
510- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
511- update patch22 to fit new release
512- update man filename convert list
513
514* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
515- update to 2.2.22
516  - CVE-2012-0021 (mod_log_config)
517  - CVE-2012-0031
518  - CVE-2012-0053
519- remove upstreamed patches
520
521* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
522- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
523
524* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
525- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
526
527* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
528- add patch70 for fix byterange filter
529
530* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
531- add Patch100 for fix CVE-2011-3368 (mod_proxy)
532
533* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
534- new upstream release with security fix (CVE-2011-3348)
535- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
536
537* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
538- update Patch101 (Thanks to debian team)
539
540* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
541- add Patch101 for fix CVE-2011-3192 regression
542
543* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
544- new upstream release with security fix (CVE-2011-3192)
545- drop patch100 (is included in new release)
546
547* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
548- add patch100 for fix CVE-2011-3192 (Range Header DoS)
549
550* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
551- update to 2.2.19
552
553* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
554- remove old Obsoletes/Conflicts
555
556* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
557- rebuild with openssl-1.0.0c
558
559* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
560- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
561
562* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
563- add R(post): alternatives
564
565* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
566- add patch110 for fix CVE-2010-0434 from mdk 2010
567
568* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
569- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
570
571* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
572- rebuilt with rpm-4.8.0-3 (on ppc)
573
574* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
575- rebuild with db4-4.8.0
576
577* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
578- new upstream release with security fix
579  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
580- fix ssl.conf (2.2.13-1 includes wrong file)
581
582* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
583- new upstream release
584
585* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
586- new upstream release
587  (including security fix for CVE-2009-1890, CVE-2009-1191,
588   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
589
590* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
591- rebuilt with openldap-2.4.11
592
593* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
594- new upstream release
595
596* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
597- new upstream release (including security fix for CVE-2008-2939)
598
599* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
600- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
601- built with db4-4.6.21, apr 1.3.0
602
603* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
604- add Patch60 (to fix bug#31418).
605
606* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
607- rebuild with expat-2.0.1
608
609* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
610- new upstream release
611
612* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
613- added postun script from VinePlus/4.0 package
614  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
615  - add postun script to restart daemon with message
616
617* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
618- updated Patch2: httpd-2.2.3-apxs.patch
619
620* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
621- modified libdir in config.layout for lib64 architecture
622
623* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
624- rebuilt with openssl-0.9.8e
625
626* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
627- rebuilt with new toolchain and db4-4.3.x
628
629* Wed Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
630- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
631
632* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
633- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
634
635* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
636- rebuilt with openldap-2.3.27-0vl1
637
638* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
639- new upstream release including security fix (CVE-2006-3747)
640
641* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
642- new upstream release
643  - update to 2.2.2
644- remove apr/apr-devel subpackage,
645  use external apr/apr-util instead of internal one.
646
647* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
648- new upstream release
649- use apache2.prefork as default.
650
651* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
652- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
653- remove unpackaged files in %%install section
654
655* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
656- fix logrotate configuration (use apache2.pid instead of httpd.pid)
657  (BTS:10)
658- use Epoch instead of Serial
659
660* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
661- new upstream release
662- drop obsolete security patches which is merged in upstream
663
664* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
665- new upstream release
666
667* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
668- added Patch122 to 125 for secutiry fix
669  (CAN-2004-{1268,2088,2700,2728})
670- fix %install section
671
672* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
673- new upstream release
674
675* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
676- new upstream release
677
678* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
679- rebuilt with db4-4.2.52
680
681* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
682- separate apr, apr-devel packages
683- add BuildPreReq: zlib-devel
684
685* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
686- fix %%files to include instdso.sh
687  thanks to jax <jax AT morejams DOT no-ip DOT com>
688- add %%{?_smp_mflags} to make option.
689
690* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
691- new upstream version
692
693* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
694- new upstream version
695
696* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
697- new upstream version
698- update apxs patch (Patch101)
699- fix dependency:
700    - change file name to package name in Requires and {Build,}Prereq
701- add BuildPrereq: openldap-devel
702- update %%files section
703- rename httpd.8 manpage
704
705* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
706- new upstream version
707- used vine-config.layout in srclib
708
709* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
710- rebuild
711
712* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
713- change pkg name from mod_ssl to mod_ssl-apache2
714- remove "apache-manual" entry from Obsoletes:
715
716* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
717- remove "mod_dav" and "apache-devel" from Obsoletes:
718- enable MPMS(worker %mpms )
719
720* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
721- add correct config_vars.mk
722
723* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
724- apply apxs's patch ( from Debian)
725
726* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
727- add apr-config,apu-config to devel's %file
728
729* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
730- change apxs path ( /usr/sbin -> /usr/bin
731- add symlink under /etc/apache2/conf
732  (logs, run), httpd.conf -> apache2.conf
733- fixed apache2 initscript.
734
735* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
736- build Vine Linux
737- new upstream version
738- sharing with apache1
739
740* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
741- link httpd with libssl to avoid library loading/unloading weirdness
742
743* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
744- add LoadModule lines for proxy modules in httpd.conf (#73349)
745- fix permissions of conf/ssl.*/ directories; add Makefiles for
746  certificate management (#73352)
747
748* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
749- provide "httpd-mmn" to manage module ABI compatibility
750
751* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
752- fix SSL session cache (#69699)
753- revert addition of LDAP support to apr-util
754
755* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
756- set SIGXFSZ disposition to "ignored" (#69520)
757- make dummy connections to the first listener in config (#72692)
758
759* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
760- allow "apachectl configtest" on a 1.3 httpd.conf
761- add mod_deflate
762- enable LDAP support in apr-util
763- don't package everything in /var/www/error as config(noreplace)
764
765* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
766- add trigger (#68657)
767
768* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
769- update to 2.0.40
770
771* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
772- improve comment on use of UserDir in default config (#66886)
773
774* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
775- use /sbin/nologin as shell for apache user (#68371)
776- add patch from CVS to fix possible infinite loop when processing
777  internal redirects
778
779* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
780- modify init script to detect 1.3.x httpd.conf's and direct users
781  to the migration guide
782
783* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
784- patch apachectl to detect 1.3.x httpd.conf's and direct users
785  to the migration guide
786- ship the migration guide
787
788* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
789- move /etc/httpd2 back to /etc/httpd
790- add noindex.html page and poweredby logo; tweak default config
791  to load noindex.html if no default "/" page is present.
792- add patch to prevent mutex errors on graceful restart
793
794* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
795- automated rebuild
796
797* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
798- add patch to fix SSL mutex handling
799
800* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
801- improved config directory patch
802
803* Mon May 20 2002 Joe Orton <jorton@redhat.com>
804- initial build; based heavily on apache.spec and mod_ssl.spec
805- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
806
Note: See TracBrowser for help on using the repository browser.