source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 8062

Revision 8062, 25.6 KB checked in by Takemikaduchi, 10 years ago (diff)

rebuild package

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20051115
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.25
9Release: 1%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41# Patch22: httpd-2.1.10-pod.patch
42Patch22: httpd-2.2.23-pod.patch
43Patch23: httpd-2.0.45-export.patch
44Patch24: httpd-2.0.48-corelimit.patch
45# Bug fixes
46Patch54: httpd-2.2.0-authnoprov.patch
47Patch60: httpd-2.2.3-sslusername.patch
48
49# Security fixes
50
51
52License: Apache Software License
53Group: System Environment/Daemons
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55BuildRequires: db4-devel, expat-devel
56BuildRequires: findutils, perl, openldap-devel, zlib-devel
57BuildRequires: apr-devel, apr-util-devel
58BuildRequires: pcre-devel, sqlite3-devel
59Requires: mailcap, gawk, file, findutils, apr, apr-util
60Requires(pre): chkconfig, mktemp, fileutils
61Requires(pre): sh-utils, textutils, shadow-utils
62Requires(post): alternatives
63Provides: webserver
64Provides: httpd = %{version}
65Provides: httpd-mmn = %{mmn}
66Obsoletes: apache2-apr, apache2-apr-devel
67
68%description
69Apache is a powerful, full-featured, efficient, and freely-available
70Web server. Apache is also the most popular Web server on the
71Internet.
72
73%package devel
74Group: Development/Libraries
75Summary: Development tools for the Apache HTTP server.
76Requires: libtool, httpd = %{version}
77Requires: apr-devel, apr-util-devel
78
79%description devel
80The httpd-devel package contains the APXS binary and other files
81that you need to build Dynamic Shared Objects (DSOs) for Apache.
82
83If you are installing the Apache HTTP server and you want to be
84able to compile or develop additional modules for Apache, you need
85to install this package.
86
87%package manual
88Group: Applications/Documentation
89Summary: Documentation for the Apache HTTP server.
90
91%description manual
92The httpd-manual package contains the complete manual and
93reference guide for the Apache HTTP server. The information can
94also be found at http://httpd.apache.org/docs/.
95
96%package -n mod_ssl-apache2
97Group: System Environment/Daemons
98Summary: SSL/TLS module for the Apache HTTP server
99Epoch: 1
100BuildRequires: openssl-devel
101Requires(pre): openssl, dev, /bin/cat
102Requires: httpd, make, httpd-mmn = %{mmn}
103
104%description -n mod_ssl-apache2
105The mod_ssl module provides strong cryptography for the Apache Web
106server via the Secure Sockets Layer (SSL) and Transport Layer
107Security (TLS) protocols.
108
109%prep
110%setup -q -n httpd-%{version}
111
112%patch1 -p1 -b .apctl
113%patch2 -p1 -b .apxs
114#patch3 -p1 -b .deplibs
115%patch4 -p1 -b .disablemods
116
117%patch21 -p0 -b .xfsz
118%patch22 -p1 -b .pod
119%patch23 -p1 -b .export
120%patch24 -p1 -b .corelimit
121
122%patch54 -p1 -b .authnoprov
123%patch60 -p1 -b .sslusername
124
125# copy across the migration guide and sed it's location into apachectl
126cp $RPM_SOURCE_DIR/migration.{html,css} .
127%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
128        support/apachectl.in
129
130
131# add Vine configure's option to config.layout
132sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
133  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
134
135# regenerate configure scripts
136./buildconf
137
138%build
139# remove bundled apr, apr-util, pcre
140rm -rf srclib/{apr,apr-util,pcre}
141
142#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
143#AP_LIBS="-lssl -lcrypto"
144#export CFLAGS AP_LIBS
145CFLAGS="$RPM_OPT_FLAGS"
146SH_LDFLAGS="-Wl,-z,relro"
147export CFLAGS SH_LDFLAGS
148
149%define mpms worker prefork
150%define prefer_mpm prefork
151
152AP_CONFOPTS="\
153        --prefix=%{_sysconfdir}/apache2 \
154        --exec-prefix=%{_prefix} \
155        --bindir=%{_bindir} \
156        --sbindir=%{_sbindir} \
157        --mandir=%{_mandir} \
158        --libdir=%{_libdir} \
159        --sysconfdir=%{_sysconfdir}/apache2/conf \
160        --includedir=%{_includedir}/apache2 \
161        --libexecdir=%{_libdir}/apache2/modules \
162        --datadir=%{contentdir} \
163        --with-installbuilddir=%{_libdir}/apache2/build \
164        --enable-layout=Vine \
165        --with-program-name=apache2 \
166        --with-ldap \
167        --enable-ldap --enable-authnz-ldap \
168        --enable-mods-shared=all \
169        --enable-cache=shared \
170        --enable-cgi=shared \
171        --enable-cgid=shared \
172        --enable-rewrite=shared \
173        --enable-disk-cache=shared \
174        --enable-file-cache=shared \
175        --enable-mem-cache=shared \
176        --enable-authn-anon --enable-authn-alias \
177        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
178        --enable-suexec --with-suexec \
179        --with-suexec-caller=%{suexec_caller} \
180        --with-suexec-docroot=%{contentdir} \
181        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
182        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
183        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
184        --with-pcre \
185        --enable-ssl --with-ssl \
186        --enable-deflate \
187        --enable-proxy --enable-proxy-connect \
188        --enable-proxy-http --enable-proxy-ftp"
189#all  mpm build
190for mpm in %{mpms}; do
191   mkdir mpm-$mpm;
192   cd mpm-$mpm;
193   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
194   make %{?_smp_mflags} ;
195#   mv apache2 apache2.$mpm ;
196   cd ../
197done
198
199%install
200rm -rf $RPM_BUILD_ROOT
201
202# install mpms binary
203pushd mpm-prefork
204  make DESTDIR=$RPM_BUILD_ROOT install
205  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
206popd
207
208for mpm in %{mpms}; do
209    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
210done
211
212# install conf file/directory
213mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
214install -m 644 $RPM_SOURCE_DIR/README.confd \
215   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
216install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
217   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
218
219rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
220install -m 644 $RPM_SOURCE_DIR/httpd.conf \
221   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
222
223# mod_ssl bits
224for suffix in crl crt csr key prm; do
225   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
226done
227
228# Makefiles for certificate management
229for ext in crt crl; do
230  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
231        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
232done
233ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
234
235# for holding mod_dav lock database
236mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
237
238# create a prototype session cache
239mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
240touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
241
242# move utilities to /usr/bin
243mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
244   $RPM_BUILD_ROOT%{_bindir}
245
246# Make the MMN accessible to module packages
247echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
248
249# docroot
250# mkdir $RPM_BUILD_ROOT%{contentdir}/html
251install -m 644 $RPM_SOURCE_DIR/index.html.ja \
252        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
253rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
254
255install -m 644 $RPM_SOURCE_DIR/vine.png \
256        $RPM_BUILD_ROOT%{contentdir}/icons
257
258# logs
259# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
260mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
261
262ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
263
264
265# symlinks for /etc/apache2
266ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
267ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
268ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
269ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
270
271# install SYSV init stuff
272mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
273install -m755 $RPM_SOURCE_DIR/apache2.init \
274        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
275%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
276        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
277
278# install log rotation stuff
279mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
280install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
281        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
282
283mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
284
285# fix man page paths
286sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
287    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
288    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
289    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
290    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
291    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
292    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
293  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
294
295install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
296        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
297
298# change command name to avoid conflict with apache1 pacjage
299%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
300
301for i in %{cflcmd}; do \
302  echo $i
303  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
304done;
305
306mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
307
308%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
309
310(cd $RPM_BUILD_ROOT;
311for i in %{cflman}; do \
312    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
313   
314done;
315)
316
317#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
318mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
319
320
321rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
322rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
323# conflict with apache 1, so removed...
324rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
325rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
326
327# remove unpackaged files
328rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
329      $RPM_BUILD_ROOT%{_libdir}/*.la \
330      $RPM_BUILD_ROOT%{_libdir}/*.exp \
331      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
332      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
333      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
334      $RPM_BUILD_ROOT%{contentdir}/html/* \
335      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
336
337%pre
338# Add the "apache" user
339/usr/sbin/useradd -c "Apache" -u 48 \
340        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
341
342%triggerpostun -- apache < 2.0
343/sbin/chkconfig --add apache2
344
345
346%post
347# Register the httpd service
348for mpm in %{mpms}; do
349  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
350done
351/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
352/sbin/chkconfig --add apache2
353
354%preun
355if [ $1 = 0 ]; then
356        /sbin/service apache2 stop > /dev/null 2>&1
357        /sbin/chkconfig --del apache2
358        for mpm in %{mpms}; do
359          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
360        done 
361fi
362
363%postun
364if [ "$1" -ge 1 ]; then
365        /sbin/service apache2 condrestart
366fi
367/sbin/ldconfig
368
369%post -n mod_ssl-apache2
370/sbin/ldconfig ### is this needed?
371umask 077
372
373if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
374%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
375fi
376
377FQDN=`hostname`
378if [ "x${FQDN}" = "x" ]; then
379   FQDN=localhost.localdomain
380fi
381
382if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
383cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
384--
385SomeState
386SomeCity
387SomeOrganization
388SomeOrganizationalUnit
389${FQDN}
390root@${FQDN}
391EOF
392fi
393
394%clean
395rm -rf $RPM_BUILD_ROOT
396
397%files
398%defattr(-,root,root)
399
400%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
401%doc migration.html migration.css
402
403%dir %{_sysconfdir}/apache2
404%{_sysconfdir}/apache2/modules
405%{_sysconfdir}/apache2/logs
406%{_sysconfdir}/apache2/run
407%dir %{_sysconfdir}/apache2/conf
408%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
409%config(noreplace) %{_sysconfdir}/apache2/conf/magic
410
411%config %{_sysconfdir}/logrotate.d/apache2
412%config %{_sysconfdir}/rc.d/init.d/apache2
413
414%dir %{_sysconfdir}/apache2/conf.d
415%{_sysconfdir}/apache2/conf.d/README
416
417%dir %{_sysconfdir}/apache2/conf/extra
418%config %{_sysconfdir}/apache2/conf/extra/*
419
420%dir %{_sysconfdir}/apache2/conf/original
421%{_sysconfdir}/apache2/conf/original/*
422
423%{_bindir}/ab
424%{_bindir}/ht*
425%{_bindir}/logresolve
426%{_sbindir}/ht*
427%{_sbindir}/apache2.*
428%{_sbindir}/apache2ctl
429%{_sbindir}/rotatelogs2
430%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
431
432%dir %{_libdir}/apache2
433%dir %{_libdir}/apache2/modules
434# everything but mod_ssl.so:
435%{_libdir}/apache2/modules/mod_[a-r]*.so
436%{_libdir}/apache2/modules/mod_s[petu]*.so
437%{_libdir}/apache2/modules/mod_[t-z]*.so
438
439%dir %{contentdir}
440%dir %{contentdir}/cgi-bin
441%dir %{contentdir}/html
442%dir %{contentdir}/icons
443%dir %{contentdir}/error
444%dir %{contentdir}/error/include
445%{contentdir}/icons/*
446%{contentdir}/error/README
447%{contentdir}/error/noindex.html
448%config(noreplace) %{contentdir}/error/*.var
449%config(noreplace) %{contentdir}/error/include/*.html
450
451%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
452
453%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
454
455%{_mandir}/man1/*
456
457%{_mandir}/man8/*
458
459%files manual
460%defattr(-,root,root)
461%{contentdir}/manual
462
463%files -n mod_ssl-apache2
464%defattr(-,root,root)
465%{_libdir}/apache2/modules/mod_ssl.so
466%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
467%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
468%config %{_sysconfdir}/apache2/conf/Makefile
469%config %{_sysconfdir}/apache2/conf/ssl.*/*
470%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
471%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
472%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
473%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
474
475%files devel
476%defattr(-,root,root)
477%{_includedir}/apache2
478%{_sysconfdir}/apache2/build
479%{_bindir}/apxs
480%{_mandir}/man?/apxs*
481%{_libdir}/apache2/build/*.mk
482%{_libdir}/apache2/build/*.sh
483
484%changelog
485* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
486- new upstream release with security fix (CVE-2013-1862,1896)
487- drop patch100 (is included in new release)
488
489* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
490- add patch100 for fix CVE-2013-1862 (mod_rewrite)
491
492* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
493- new upstream release with security fix (CVE-2012-3499, 4558)
494
495* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
496- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
497- update patch22 to fit new release
498- update man filename convert list
499
500* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
501- update to 2.2.22
502  - CVE-2012-0021 (mod_log_config)
503  - CVE-2012-0031
504  - CVE-2012-0053
505- remove upstreamed patches
506
507* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
508- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
509
510* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
511- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
512
513* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
514- add patch70 for fix byterange filter
515
516* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
517- add Patch100 for fix CVE-2011-3368 (mod_proxy)
518
519* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
520- new upstream release with security fix (CVE-2011-3348)
521- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
522
523* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
524- update Patch101 (Thanks to debian team)
525
526* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
527- add Patch101 for fix CVE-2011-3192 regression
528
529* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
530- new upstream release with security fix (CVE-2011-3192)
531- drop patch100 (is included in new release)
532
533* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
534- add patch100 for fix CVE-2011-3192 (Range Header DoS)
535
536* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
537- update to 2.2.19
538
539* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
540- remove old Obsoletes/Conflicts
541
542* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
543- rebuild with openssl-1.0.0c
544
545* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
546- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
547
548* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
549- add R(post): alternatives
550
551* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
552- add patch110 for fix CVE-2010-0434 from mdk 2010
553
554* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
555- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
556
557* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
558- rebuilt with rpm-4.8.0-3 (on ppc)
559
560* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
561- rebuild with db4-4.8.0
562
563* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
564- new upstream release with security fix
565  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
566- fix ssl.conf (2.2.13-1 includes wrong file)
567
568* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
569- new upstream release
570
571* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
572- new upstream release
573  (including security fix for CVE-2009-1890, CVE-2009-1191,
574   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
575
576* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
577- rebuilt with openldap-2.4.11
578
579* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
580- new upstream release
581
582* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
583- new upstream release (including security fix for CVE-2008-2939)
584
585* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
586- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
587- built with db4-4.6.21, apr 1.3.0
588
589* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
590- add Patch60 (to fix bug#31418).
591
592* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
593- rebuild with expat-2.0.1
594
595* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
596- new upstream release
597
598* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
599- added postun script from VinePlus/4.0 package
600  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
601  - add postun script to restart daemon with message
602
603* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
604- updated Patch2: httpd-2.2.3-apxs.patch
605
606* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
607- modified libdir in config.layout for lib64 architecture
608
609* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
610- rebuilt with openssl-0.9.8e
611
612* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
613- rebuilt with new toolchain and db4-4.3.x
614
615* Wed Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
616- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
617
618* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
619- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
620
621* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
622- rebuilt with openldap-2.3.27-0vl1
623
624* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
625- new upstream release including security fix (CVE-2006-3747)
626
627* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
628- new upstream release
629  - update to 2.2.2
630- remove apr/apr-devel subpackage,
631  use external apr/apr-util instead of internal one.
632
633* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
634- new upstream release
635- use apache2.prefork as default.
636
637* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
638- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
639- remove unpackaged files in %%install section
640
641* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
642- fix logrotate configuration (use apache2.pid instead of httpd.pid)
643  (BTS:10)
644- use Epoch instead of Serial
645
646* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
647- new upstream release
648- drop obsolete security patches which is merged in upstream
649
650* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
651- new upstream release
652
653* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
654- added Patch122 to 125 for secutiry fix
655  (CAN-2004-{1268,2088,2700,2728})
656- fix %install section
657
658* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
659- new upstream release
660
661* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
662- new upstream release
663
664* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
665- rebuilt with db4-4.2.52
666
667* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
668- separate apr, apr-devel packages
669- add BuildPreReq: zlib-devel
670
671* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
672- fix %%files to include instdso.sh
673  thanks to jax <jax AT morejams DOT no-ip DOT com>
674- add %%{?_smp_mflags} to make option.
675
676* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
677- new upstream version
678
679* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
680- new upstream version
681
682* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
683- new upstream version
684- update apxs patch (Patch101)
685- fix dependency:
686    - change file name to package name in Requires and {Build,}Prereq
687- add BuildPrereq: openldap-devel
688- update %%files section
689- rename httpd.8 manpage
690
691* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
692- new upstream version
693- used vine-config.layout in srclib
694
695* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
696- rebuild
697
698* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
699- change pkg name from mod_ssl to mod_ssl-apache2
700- remove "apache-manual" entry from Obsoletes:
701
702* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
703- remove "mod_dav" and "apache-devel" from Obsoletes:
704- enable MPMS(worker %mpms )
705
706* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
707- add correct config_vars.mk
708
709* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
710- apply apxs's patch ( from Debian)
711
712* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
713- add apr-config,apu-config to devel's %file
714
715* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
716- change apxs path ( /usr/sbin -> /usr/bin
717- add symlink under /etc/apache2/conf
718  (logs, run), httpd.conf -> apache2.conf
719- fixed apache2 initscript.
720
721* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
722- build Vine Linux
723- new upstream version
724- sharing with apache1
725
726* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
727- link httpd with libssl to avoid library loading/unloading weirdness
728
729* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
730- add LoadModule lines for proxy modules in httpd.conf (#73349)
731- fix permissions of conf/ssl.*/ directories; add Makefiles for
732  certificate management (#73352)
733
734* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
735- provide "httpd-mmn" to manage module ABI compatibility
736
737* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
738- fix SSL session cache (#69699)
739- revert addition of LDAP support to apr-util
740
741* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
742- set SIGXFSZ disposition to "ignored" (#69520)
743- make dummy connections to the first listener in config (#72692)
744
745* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
746- allow "apachectl configtest" on a 1.3 httpd.conf
747- add mod_deflate
748- enable LDAP support in apr-util
749- don't package everything in /var/www/error as config(noreplace)
750
751* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
752- add trigger (#68657)
753
754* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
755- update to 2.0.40
756
757* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
758- improve comment on use of UserDir in default config (#66886)
759
760* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
761- use /sbin/nologin as shell for apache user (#68371)
762- add patch from CVS to fix possible infinite loop when processing
763  internal redirects
764
765* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
766- modify init script to detect 1.3.x httpd.conf's and direct users
767  to the migration guide
768
769* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
770- patch apachectl to detect 1.3.x httpd.conf's and direct users
771  to the migration guide
772- ship the migration guide
773
774* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
775- move /etc/httpd2 back to /etc/httpd
776- add noindex.html page and poweredby logo; tweak default config
777  to load noindex.html if no default "/" page is present.
778- add patch to prevent mutex errors on graceful restart
779
780* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
781- automated rebuild
782
783* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
784- add patch to fix SSL mutex handling
785
786* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
787- improved config directory patch
788
789* Mon May 20 2002 Joe Orton <jorton@redhat.com>
790- initial build; based heavily on apache.spec and mod_ssl.spec
791- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
792
Note: See TracBrowser for help on using the repository browser.