source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 6959

Revision 6959, 25.1 KB checked in by daisuke, 12 years ago (diff)

apache2

  • update to 2.2.23
  • add R(pre): www-common, BR: www-common
  • move apache contents to /usr/share/apache2
  • change default docroot to /var/www/apache2/html
Line 
1%define contentdir %{_datadir}/apache2
2%define docroot /var/www/apache2
3%define suexec_caller apache
4%define mmn 20051115
5%define pkgname apache2
6
7Summary: Apache HTTP Server
8Name: %{pkgname}
9Version: 2.2.23
10Release: 1%{_dist_release}
11URL: http://httpd.apache.org/
12
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: daisuke
16
17Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
18Source1: index.html.ja
19Source3: apache2.logrotate
20Source4: apache2.init
21Source5: README.confd
22Source6: vine.png
23Source10: httpd.conf
24Source11: apache-ssl.conf
25Source12: migration.html
26Source13: migration.css
27Source14: mod_ssl-Makefile.crt
28Source15: mod_ssl-Makefile.crl
29# add vine entry to config.layout
30Source100: vine-config.layout
31# man files
32Source101: apache2.8
33Source102: apache2ctl.8
34#Source103: config_vars.mk
35# build/scripts patches
36Patch1: httpd-2.1.10-apctl.patch
37Patch2: httpd-2.2.3-apxs.patch
38Patch3: httpd-2.0.45-deplibs.patch
39Patch4: httpd-2.1.10-disablemods.patch
40# features/functional changes
41Patch21: httpd-2.0.40-xfsz.patch
42Patch22: httpd-2.2.23-pod.patch
43Patch23: httpd-2.0.45-export.patch
44Patch24: httpd-2.0.48-corelimit.patch
45# Bug fixes
46Patch54: httpd-2.2.0-authnoprov.patch
47Patch60: httpd-2.2.3-sslusername.patch
48
49# Security fixes
50
51License: Apache Software License
52Group: System Environment/Daemons
53
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55BuildRequires: db4-devel, expat-devel
56BuildRequires: findutils, perl, openldap-devel, zlib-devel
57BuildRequires: apr-devel, apr-util-devel
58BuildRequires: pcre-devel, sqlite3-devel
59BuildRequires: www-common
60Requires: mailcap, gawk, file, findutils, apr, apr-util
61Requires(pre): www-common
62Requires(pre): chkconfig, mktemp, fileutils
63Requires(pre): sh-utils, textutils, shadow-utils
64Requires(post): alternatives
65Provides: webserver
66Provides: httpd = %{version}
67Provides: httpd-mmn = %{mmn}
68Obsoletes: apache2-apr, apache2-apr-devel
69
70%description
71Apache is a powerful, full-featured, efficient, and freely-available
72Web server. Apache is also the most popular Web server on the
73Internet.
74
75%package devel
76Group: Development/Libraries
77Summary: Development tools for the Apache HTTP server.
78Requires: libtool, httpd = %{version}
79Requires: apr-devel, apr-util-devel
80
81%description devel
82The httpd-devel package contains the APXS binary and other files
83that you need to build Dynamic Shared Objects (DSOs) for Apache.
84
85If you are installing the Apache HTTP server and you want to be
86able to compile or develop additional modules for Apache, you need
87to install this package.
88
89%package manual
90Group: Applications/Documentation
91Summary: Documentation for the Apache HTTP server.
92
93%description manual
94The httpd-manual package contains the complete manual and
95reference guide for the Apache HTTP server. The information can
96also be found at http://httpd.apache.org/docs/.
97
98%package -n mod_ssl-apache2
99Group: System Environment/Daemons
100Summary: SSL/TLS module for the Apache HTTP server
101Epoch: 1
102BuildRequires: openssl-devel
103Requires(pre): openssl, dev, /bin/cat
104Requires: httpd, make, httpd-mmn = %{mmn}
105
106%description -n mod_ssl-apache2
107The mod_ssl module provides strong cryptography for the Apache Web
108server via the Secure Sockets Layer (SSL) and Transport Layer
109Security (TLS) protocols.
110
111%prep
112%setup -q -n httpd-%{version}
113
114%patch1 -p1 -b .apctl
115%patch2 -p1 -b .apxs
116#patch3 -p1 -b .deplibs
117%patch4 -p1 -b .disablemods
118
119%patch21 -p0 -b .xfsz
120%patch22 -p1 -b .pod
121%patch23 -p1 -b .export
122%patch24 -p1 -b .corelimit
123
124%patch54 -p1 -b .authnoprov
125%patch60 -p1 -b .sslusername
126
127# copy across the migration guide and sed it's location into apachectl
128cp $RPM_SOURCE_DIR/migration.{html,css} .
129%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
130        support/apachectl.in
131
132
133# add Vine configure's option to config.layout
134sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
135  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
136
137# regenerate configure scripts
138./buildconf
139
140%build
141# remove bundled apr, apr-util, pcre
142rm -rf srclib/{apr,apr-util,pcre}
143
144#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
145#AP_LIBS="-lssl -lcrypto"
146#export CFLAGS AP_LIBS
147CFLAGS="$RPM_OPT_FLAGS"
148SH_LDFLAGS="-Wl,-z,relro"
149export CFLAGS SH_LDFLAGS
150
151%define mpms worker prefork
152%define prefer_mpm prefork
153
154AP_CONFOPTS="\
155        --prefix=%{_sysconfdir}/apache2 \
156        --exec-prefix=%{_prefix} \
157        --bindir=%{_bindir} \
158        --sbindir=%{_sbindir} \
159        --mandir=%{_mandir} \
160        --libdir=%{_libdir} \
161        --sysconfdir=%{_sysconfdir}/apache2/conf \
162        --includedir=%{_includedir}/apache2 \
163        --libexecdir=%{_libdir}/apache2/modules \
164        --datadir=%{contentdir} \
165        --with-installbuilddir=%{_libdir}/apache2/build \
166        --enable-layout=Vine \
167        --with-program-name=apache2 \
168        --with-ldap \
169        --enable-ldap --enable-authnz-ldap \
170        --enable-mods-shared=all \
171        --enable-cache=shared \
172        --enable-cgi=shared \
173        --enable-cgid=shared \
174        --enable-rewrite=shared \
175        --enable-disk-cache=shared \
176        --enable-file-cache=shared \
177        --enable-mem-cache=shared \
178        --enable-authn-anon --enable-authn-alias \
179        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
180        --enable-suexec --with-suexec \
181        --with-suexec-caller=%{suexec_caller} \
182        --with-suexec-docroot=%{docroot} \
183        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
184        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
185        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
186        --with-pcre \
187        --enable-ssl --with-ssl \
188        --enable-deflate \
189        --enable-proxy --enable-proxy-connect \
190        --enable-proxy-http --enable-proxy-ftp"
191#all  mpm build
192for mpm in %{mpms}; do
193   mkdir mpm-$mpm;
194   cd mpm-$mpm;
195   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
196   make %{?_smp_mflags} ;
197#   mv apache2 apache2.$mpm ;
198   cd ../
199done
200
201%install
202rm -rf $RPM_BUILD_ROOT
203
204# install mpms binary
205pushd mpm-prefork
206  make DESTDIR=$RPM_BUILD_ROOT install
207  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
208popd
209
210for mpm in %{mpms}; do
211    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
212done
213
214# install conf file/directory
215mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
216install -m 644 $RPM_SOURCE_DIR/README.confd \
217   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
218install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
219   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
220
221rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
222install -m 644 $RPM_SOURCE_DIR/httpd.conf \
223   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
224
225# mod_ssl bits
226for suffix in crl crt csr key prm; do
227   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
228done
229
230# Makefiles for certificate management
231for ext in crt crl; do
232  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
233        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
234done
235ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
236
237# for holding mod_dav lock database
238mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
239
240# create a prototype session cache
241mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
242touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
243
244# move utilities to /usr/bin
245mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
246   $RPM_BUILD_ROOT%{_bindir}
247
248# Make the MMN accessible to module packages
249echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
250
251# contentdir
252#mkdir $RPM_BUILD_ROOT%{contentdir}/html
253install -m 644 $RPM_SOURCE_DIR/index.html.ja \
254        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
255rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
256
257install -m 644 $RPM_SOURCE_DIR/vine.png \
258        $RPM_BUILD_ROOT%{contentdir}/icons
259
260# docroot
261mkdir -p $RPM_BUILD_ROOT%{docroot}/html
262
263# logs
264# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
265mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
266
267ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
268
269
270# symlinks for /etc/apache2
271ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
272ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
273ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
274ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
275
276# install SYSV init stuff
277mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
278install -m755 $RPM_SOURCE_DIR/apache2.init \
279        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
280%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
281        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
282
283# install log rotation stuff
284mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
285install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
286        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
287
288mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
289
290# fix man page paths
291sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
292    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
293    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
294    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
295    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
296    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
297    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
298  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
299
300install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
301        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
302
303# change command name to avoid conflict with apache1 pacjage
304%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
305
306for i in %{cflcmd}; do \
307  echo $i
308  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
309done;
310
311mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
312
313%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
314
315(cd $RPM_BUILD_ROOT;
316for i in %{cflman}; do \
317    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
318   
319done;
320)
321
322#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
323mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
324
325
326rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
327rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
328# conflict with apache 1, so removed...
329rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
330rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
331
332# remove unpackaged files
333rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
334      $RPM_BUILD_ROOT%{_libdir}/*.la \
335      $RPM_BUILD_ROOT%{_libdir}/*.exp \
336      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
337      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
338      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
339      $RPM_BUILD_ROOT%{docroot}/html/* \
340      $RPM_BUILD_ROOT%{contentdir}/html/* \
341      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
342
343%triggerpostun -- apache < 2.0
344/sbin/chkconfig --add apache2
345
346
347%post
348# Register the httpd service
349for mpm in %{mpms}; do
350  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
351done
352/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
353/sbin/chkconfig --add apache2
354
355%preun
356if [ $1 = 0 ]; then
357        /sbin/service apache2 stop > /dev/null 2>&1
358        /sbin/chkconfig --del apache2
359        for mpm in %{mpms}; do
360          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
361        done 
362fi
363
364%postun
365if [ "$1" -ge 1 ]; then
366        /sbin/service apache2 condrestart
367fi
368/sbin/ldconfig
369
370%post -n mod_ssl-apache2
371/sbin/ldconfig ### is this needed?
372umask 077
373
374if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
375%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
376fi
377
378FQDN=`hostname`
379if [ "x${FQDN}" = "x" ]; then
380   FQDN=localhost.localdomain
381fi
382
383if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
384cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
385--
386SomeState
387SomeCity
388SomeOrganization
389SomeOrganizationalUnit
390${FQDN}
391root@${FQDN}
392EOF
393fi
394
395%clean
396rm -rf $RPM_BUILD_ROOT
397
398%files
399%defattr(-,root,root)
400
401%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
402%doc migration.html migration.css
403
404%dir %{_sysconfdir}/apache2
405%{_sysconfdir}/apache2/modules
406%{_sysconfdir}/apache2/logs
407%{_sysconfdir}/apache2/run
408%dir %{_sysconfdir}/apache2/conf
409%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
410%config(noreplace) %{_sysconfdir}/apache2/conf/magic
411
412%config %{_sysconfdir}/logrotate.d/apache2
413%config %{_sysconfdir}/rc.d/init.d/apache2
414
415%dir %{_sysconfdir}/apache2/conf.d
416%{_sysconfdir}/apache2/conf.d/README
417
418%dir %{_sysconfdir}/apache2/conf/extra
419%config %{_sysconfdir}/apache2/conf/extra/*
420
421%dir %{_sysconfdir}/apache2/conf/original
422%{_sysconfdir}/apache2/conf/original/*
423
424%{_bindir}/ab
425%{_bindir}/ht*
426%{_bindir}/logresolve
427%{_sbindir}/ht*
428%{_sbindir}/apache2.*
429%{_sbindir}/apache2ctl
430%{_sbindir}/rotatelogs2
431%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
432
433%dir %{_libdir}/apache2
434%dir %{_libdir}/apache2/modules
435# everything but mod_ssl.so:
436%{_libdir}/apache2/modules/mod_[a-r]*.so
437%{_libdir}/apache2/modules/mod_s[petu]*.so
438%{_libdir}/apache2/modules/mod_[t-z]*.so
439
440%dir %{contentdir}
441%dir %{contentdir}/cgi-bin
442%dir %{contentdir}/html
443%dir %{contentdir}/icons
444%dir %{contentdir}/error
445%dir %{contentdir}/error/include
446%{contentdir}/icons/*
447%{contentdir}/error/README
448%{contentdir}/error/noindex.html
449%config(noreplace) %{contentdir}/error/*.var
450%config(noreplace) %{contentdir}/error/include/*.html
451
452%dir %{docroot}/html
453
454%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
455
456%attr(0700,www-data,www-data) %dir %{_localstatedir}/lib/dav
457
458%{_mandir}/man1/*
459
460%{_mandir}/man8/*
461
462%files manual
463%defattr(-,root,root)
464%{contentdir}/manual
465
466%files -n mod_ssl-apache2
467%defattr(-,root,root)
468%{_libdir}/apache2/modules/mod_ssl.so
469%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
470%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
471%config %{_sysconfdir}/apache2/conf/Makefile
472%config %{_sysconfdir}/apache2/conf/ssl.*/*
473%attr(0700,www-data,root) %dir %{_localstatedir}/cache/mod_ssl
474%attr(0600,www-data,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
475%attr(0600,www-data,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
476%attr(0600,www-data,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
477
478%files devel
479%defattr(-,root,root)
480%{_includedir}/apache2
481%{_sysconfdir}/apache2/build
482%{_bindir}/apxs
483%{_mandir}/man?/apxs*
484%{_libdir}/apache2/build/*.mk
485%{_libdir}/apache2/build/*.sh
486
487%changelog
488* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-1
489- update to 2.2.23
490- add R(pre): www-common, BR: www-common
491- move apache contents to %{contentdir}
492
493* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
494- update to 2.2.22
495  - CVE-2012-0021 (mod_log_config)
496  - CVE-2012-0031
497  - CVE-2012-0053
498  - remove upstreamed patches
499
500* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
501- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
502
503* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
504- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
505
506* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
507- add patch70 for fix byterange filter
508
509* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
510- add Patch100 for fix CVE-2011-3368 (mod_proxy)
511
512* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
513- new upstream release with security fix (CVE-2011-3348)
514- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
515
516* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
517- update Patch101 (Thanks to debian team)
518
519* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
520- add Patch101 for fix CVE-2011-3192 regression
521
522* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
523- new upstream release with security fix (CVE-2011-3192)
524- drop patch100 (is included in new release)
525
526* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
527- add patch100 for fix CVE-2011-3192 (Range Header DoS)
528
529* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
530- update to 2.2.19
531
532* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
533- remove old Obsoletes/Conflicts
534
535* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
536- rebuild with openssl-1.0.0c
537
538* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
539- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
540
541* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
542- add R(post): alternatives
543
544* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
545- add patch110 for fix CVE-2010-0434 from mdk 2010
546
547* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
548- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
549
550* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
551- rebuilt with rpm-4.8.0-3 (on ppc)
552
553* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
554- rebuild with db4-4.8.0
555
556* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
557- new upstream release with security fix
558  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
559- fix ssl.conf (2.2.13-1 includes wrong file)
560
561* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
562- new upstream release
563
564* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
565- new upstream release
566  (including security fix for CVE-2009-1890, CVE-2009-1191,
567   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
568
569* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
570- rebuilt with openldap-2.4.11
571
572* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
573- new upstream release
574
575* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
576- new upstream release (including security fix for CVE-2008-2939)
577
578* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
579- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
580- built with db4-4.6.21, apr 1.3.0
581
582* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
583- add Patch60 (to fix bug#31418).
584
585* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
586- rebuild with expat-2.0.1
587
588* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
589- new upstream release
590
591* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
592- added postun script from VinePlus/4.0 package
593  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
594  - add postun script to restart daemon with message
595
596* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
597- updated Patch2: httpd-2.2.3-apxs.patch
598
599* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
600- modified libdir in config.layout for lib64 architecture
601
602* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
603- rebuilt with openssl-0.9.8e
604
605* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
606- rebuilt with new toolchain and db4-4.3.x
607
608* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
609- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
610
611* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
612- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
613
614* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
615- rebuilt with openldap-2.3.27-0vl1
616
617* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
618- new upstream release including security fix (CVE-2006-3747)
619
620* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
621- new upstream release
622  - update to 2.2.2
623- remove apr/apr-devel subpackage,
624  use external apr/apr-util instead of internal one.
625
626* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
627- new upstream release
628- use apache2.prefork as default.
629
630* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
631- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
632- remove unpackaged files in %%install section
633
634* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
635- fix logrotate configuration (use apache2.pid instead of httpd.pid)
636  (BTS:10)
637- use Epoch instead of Serial
638
639* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
640- new upstream release
641- drop obsolete security patches which is merged in upstream
642
643* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
644- new upstream release
645
646* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
647- added Patch122 to 125 for secutiry fix
648  (CAN-2004-{1268,2088,2700,2728})
649- fix %install section
650
651* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
652- new upstream release
653
654* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
655- new upstream release
656
657* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
658- rebuilt with db4-4.2.52
659
660* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
661- separate apr, apr-devel packages
662- add BuildPreReq: zlib-devel
663
664* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
665- fix %%files to include instdso.sh
666  thanks to jax <jax AT morejams DOT no-ip DOT com>
667- add %%{?_smp_mflags} to make option.
668
669* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
670- new upstream version
671
672* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
673- new upstream version
674
675* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
676- new upstream version
677- update apxs patch (Patch101)
678- fix dependency:
679    - change file name to package name in Requires and {Build,}Prereq
680- add BuildPrereq: openldap-devel
681- update %%files section
682- rename httpd.8 manpage
683
684* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
685- new upstream version
686- used vine-config.layout in srclib
687
688* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
689- rebuild
690
691* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
692- change pkg name from mod_ssl to mod_ssl-apache2
693- remove "apache-manual" entry from Obsoletes:
694
695* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
696- remove "mod_dav" and "apache-devel" from Obsoletes:
697- enable MPMS(worker %mpms )
698
699* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
700- add correct config_vars.mk
701
702* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
703- apply apxs's patch ( from Debian)
704
705* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
706- add apr-config,apu-config to devel's %file
707
708* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
709- change apxs path ( /usr/sbin -> /usr/bin
710- add symlink under /etc/apache2/conf
711  (logs, run), httpd.conf -> apache2.conf
712- fixed apache2 initscript.
713
714* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
715- build Vine Linux
716- new upstream version
717- sharing with apache1
718
719* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
720- link httpd with libssl to avoid library loading/unloading weirdness
721
722* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
723- add LoadModule lines for proxy modules in httpd.conf (#73349)
724- fix permissions of conf/ssl.*/ directories; add Makefiles for
725  certificate management (#73352)
726
727* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
728- provide "httpd-mmn" to manage module ABI compatibility
729
730* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
731- fix SSL session cache (#69699)
732- revert addition of LDAP support to apr-util
733
734* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
735- set SIGXFSZ disposition to "ignored" (#69520)
736- make dummy connections to the first listener in config (#72692)
737
738* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
739- allow "apachectl configtest" on a 1.3 httpd.conf
740- add mod_deflate
741- enable LDAP support in apr-util
742- don't package everything in /var/www/error as config(noreplace)
743
744* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
745- add trigger (#68657)
746
747* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
748- update to 2.0.40
749
750* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
751- improve comment on use of UserDir in default config (#66886)
752
753* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
754- use /sbin/nologin as shell for apache user (#68371)
755- add patch from CVS to fix possible infinite loop when processing
756  internal redirects
757
758* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
759- modify init script to detect 1.3.x httpd.conf's and direct users
760  to the migration guide
761
762* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
763- patch apachectl to detect 1.3.x httpd.conf's and direct users
764  to the migration guide
765- ship the migration guide
766
767* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
768- move /etc/httpd2 back to /etc/httpd
769- add noindex.html page and poweredby logo; tweak default config
770  to load noindex.html if no default "/" page is present.
771- add patch to prevent mutex errors on graceful restart
772
773* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
774- automated rebuild
775
776* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
777- add patch to fix SSL mutex handling
778
779* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
780- improved config directory patch
781
782* Mon May 20 2002 Joe Orton <jorton@redhat.com>
783- initial build; based heavily on apache.spec and mod_ssl.spec
784- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
785
Note: See TracBrowser for help on using the repository browser.