source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 5930

Revision 5930, 24.9 KB checked in by daisuke, 12 years ago (diff)

update to 2.2.22

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20051115
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.22
9Release: 1%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41Patch22: httpd-2.1.10-pod.patch
42Patch23: httpd-2.0.45-export.patch
43Patch24: httpd-2.0.48-corelimit.patch
44# Bug fixes
45Patch54: httpd-2.2.0-authnoprov.patch
46Patch60: httpd-2.2.3-sslusername.patch
47
48# Security fixes
49
50License: Apache Software License
51Group: System Environment/Daemons
52BuildRoot: %{_tmppath}/%{name}-%{version}-root
53BuildRequires: db4-devel, expat-devel
54BuildRequires: findutils, perl, openldap-devel, zlib-devel
55BuildRequires: apr-devel, apr-util-devel
56BuildRequires: pcre-devel, sqlite3-devel
57Requires: mailcap, gawk, file, findutils, apr, apr-util
58Requires(pre): chkconfig, mktemp, fileutils
59Requires(pre): sh-utils, textutils, shadow-utils
60Requires(post): alternatives
61Provides: webserver
62Provides: httpd = %{version}
63Provides: httpd-mmn = %{mmn}
64Obsoletes: apache2-apr, apache2-apr-devel
65
66%description
67Apache is a powerful, full-featured, efficient, and freely-available
68Web server. Apache is also the most popular Web server on the
69Internet.
70
71%package devel
72Group: Development/Libraries
73Summary: Development tools for the Apache HTTP server.
74Requires: libtool, httpd = %{version}
75Requires: apr-devel, apr-util-devel
76
77%description devel
78The httpd-devel package contains the APXS binary and other files
79that you need to build Dynamic Shared Objects (DSOs) for Apache.
80
81If you are installing the Apache HTTP server and you want to be
82able to compile or develop additional modules for Apache, you need
83to install this package.
84
85%package manual
86Group: Applications/Documentation
87Summary: Documentation for the Apache HTTP server.
88
89%description manual
90The httpd-manual package contains the complete manual and
91reference guide for the Apache HTTP server. The information can
92also be found at http://httpd.apache.org/docs/.
93
94%package -n mod_ssl-apache2
95Group: System Environment/Daemons
96Summary: SSL/TLS module for the Apache HTTP server
97Epoch: 1
98BuildRequires: openssl-devel
99Requires(pre): openssl, dev, /bin/cat
100Requires: httpd, make, httpd-mmn = %{mmn}
101
102%description -n mod_ssl-apache2
103The mod_ssl module provides strong cryptography for the Apache Web
104server via the Secure Sockets Layer (SSL) and Transport Layer
105Security (TLS) protocols.
106
107%prep
108%setup -q -n httpd-%{version}
109
110%patch1 -p1 -b .apctl
111%patch2 -p1 -b .apxs
112#patch3 -p1 -b .deplibs
113%patch4 -p1 -b .disablemods
114
115%patch21 -p0 -b .xfsz
116%patch22 -p1 -b .pod
117%patch23 -p1 -b .export
118%patch24 -p1 -b .corelimit
119
120%patch54 -p1 -b .authnoprov
121%patch60 -p1 -b .sslusername
122
123# copy across the migration guide and sed it's location into apachectl
124cp $RPM_SOURCE_DIR/migration.{html,css} .
125%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
126        support/apachectl.in
127
128
129# add Vine configure's option to config.layout
130sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
131  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
132
133# regenerate configure scripts
134./buildconf
135
136%build
137# remove bundled apr, apr-util, pcre
138rm -rf srclib/{apr,apr-util,pcre}
139
140#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
141#AP_LIBS="-lssl -lcrypto"
142#export CFLAGS AP_LIBS
143CFLAGS="$RPM_OPT_FLAGS"
144SH_LDFLAGS="-Wl,-z,relro"
145export CFLAGS SH_LDFLAGS
146
147%define mpms worker prefork
148%define prefer_mpm prefork
149
150AP_CONFOPTS="\
151        --prefix=%{_sysconfdir}/apache2 \
152        --exec-prefix=%{_prefix} \
153        --bindir=%{_bindir} \
154        --sbindir=%{_sbindir} \
155        --mandir=%{_mandir} \
156        --libdir=%{_libdir} \
157        --sysconfdir=%{_sysconfdir}/apache2/conf \
158        --includedir=%{_includedir}/apache2 \
159        --libexecdir=%{_libdir}/apache2/modules \
160        --datadir=%{contentdir} \
161        --with-installbuilddir=%{_libdir}/apache2/build \
162        --enable-layout=Vine \
163        --with-program-name=apache2 \
164        --with-ldap \
165        --enable-ldap --enable-authnz-ldap \
166        --enable-mods-shared=all \
167        --enable-cache=shared \
168        --enable-cgi=shared \
169        --enable-cgid=shared \
170        --enable-rewrite=shared \
171        --enable-disk-cache=shared \
172        --enable-file-cache=shared \
173        --enable-mem-cache=shared \
174        --enable-authn-anon --enable-authn-alias \
175        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
176        --enable-suexec --with-suexec \
177        --with-suexec-caller=%{suexec_caller} \
178        --with-suexec-docroot=%{contentdir} \
179        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
180        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
181        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
182        --with-pcre \
183        --enable-ssl --with-ssl \
184        --enable-deflate \
185        --enable-proxy --enable-proxy-connect \
186        --enable-proxy-http --enable-proxy-ftp"
187#all  mpm build
188for mpm in %{mpms}; do
189   mkdir mpm-$mpm;
190   cd mpm-$mpm;
191   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
192   make %{?_smp_mflags} ;
193#   mv apache2 apache2.$mpm ;
194   cd ../
195done
196
197%install
198rm -rf $RPM_BUILD_ROOT
199
200# install mpms binary
201pushd mpm-prefork
202  make DESTDIR=$RPM_BUILD_ROOT install
203  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
204popd
205
206for mpm in %{mpms}; do
207    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
208done
209
210# install conf file/directory
211mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
212install -m 644 $RPM_SOURCE_DIR/README.confd \
213   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
214install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
215   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
216
217rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
218install -m 644 $RPM_SOURCE_DIR/httpd.conf \
219   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
220
221# mod_ssl bits
222for suffix in crl crt csr key prm; do
223   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
224done
225
226# Makefiles for certificate management
227for ext in crt crl; do
228  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
229        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
230done
231ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
232
233# for holding mod_dav lock database
234mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
235
236# create a prototype session cache
237mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
238touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
239
240# move utilities to /usr/bin
241mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
242   $RPM_BUILD_ROOT%{_bindir}
243
244# Make the MMN accessible to module packages
245echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
246
247# docroot
248# mkdir $RPM_BUILD_ROOT%{contentdir}/html
249install -m 644 $RPM_SOURCE_DIR/index.html.ja \
250        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
251rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
252
253install -m 644 $RPM_SOURCE_DIR/vine.png \
254        $RPM_BUILD_ROOT%{contentdir}/icons
255
256# logs
257# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
258mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
259
260ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
261
262
263# symlinks for /etc/apache2
264ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
265ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
266ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
267ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
268
269# install SYSV init stuff
270mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
271install -m755 $RPM_SOURCE_DIR/apache2.init \
272        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
273%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
274        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
275
276# install log rotation stuff
277mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
278install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
279        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
280
281mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
282
283# fix man page paths
284sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
285    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
286    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
287    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
288    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
289    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
290    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
291  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
292
293install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
294        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
295
296# change command name to avoid conflict with apache1 pacjage
297%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
298
299for i in %{cflcmd}; do \
300  echo $i
301  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
302done;
303
304mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
305
306%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man1/apxs.1 usr/share/man/man8/httpd.8
307
308(cd $RPM_BUILD_ROOT;
309for i in %{cflman}; do \
310    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
311   
312done;
313)
314
315#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
316mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
317
318
319rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
320rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
321# conflict with apache 1, so removed...
322rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
323rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
324
325# remove unpackaged files
326rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
327      $RPM_BUILD_ROOT%{_libdir}/*.la \
328      $RPM_BUILD_ROOT%{_libdir}/*.exp \
329      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
330      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
331      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
332      $RPM_BUILD_ROOT%{contentdir}/html/* \
333      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
334
335%pre
336# Add the "apache" user
337/usr/sbin/useradd -c "Apache" -u 48 \
338        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
339
340%triggerpostun -- apache < 2.0
341/sbin/chkconfig --add apache2
342
343
344%post
345# Register the httpd service
346for mpm in %{mpms}; do
347  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
348done
349/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
350/sbin/chkconfig --add apache2
351
352%preun
353if [ $1 = 0 ]; then
354        /sbin/service apache2 stop > /dev/null 2>&1
355        /sbin/chkconfig --del apache2
356        for mpm in %{mpms}; do
357          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
358        done 
359fi
360
361%postun
362if [ "$1" -ge 1 ]; then
363        /sbin/service apache2 condrestart
364fi
365/sbin/ldconfig
366
367%post -n mod_ssl-apache2
368/sbin/ldconfig ### is this needed?
369umask 077
370
371if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
372%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
373fi
374
375FQDN=`hostname`
376if [ "x${FQDN}" = "x" ]; then
377   FQDN=localhost.localdomain
378fi
379
380if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
381cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
382--
383SomeState
384SomeCity
385SomeOrganization
386SomeOrganizationalUnit
387${FQDN}
388root@${FQDN}
389EOF
390fi
391
392%clean
393rm -rf $RPM_BUILD_ROOT
394
395%files
396%defattr(-,root,root)
397
398%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
399%doc migration.html migration.css
400
401%dir %{_sysconfdir}/apache2
402%{_sysconfdir}/apache2/modules
403%{_sysconfdir}/apache2/logs
404%{_sysconfdir}/apache2/run
405%dir %{_sysconfdir}/apache2/conf
406%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
407%config(noreplace) %{_sysconfdir}/apache2/conf/magic
408
409%config %{_sysconfdir}/logrotate.d/apache2
410%config %{_sysconfdir}/rc.d/init.d/apache2
411
412%dir %{_sysconfdir}/apache2/conf.d
413%{_sysconfdir}/apache2/conf.d/README
414
415%dir %{_sysconfdir}/apache2/conf/extra
416%config %{_sysconfdir}/apache2/conf/extra/*
417
418%dir %{_sysconfdir}/apache2/conf/original
419%{_sysconfdir}/apache2/conf/original/*
420
421%{_bindir}/ab
422%{_bindir}/ht*
423%{_bindir}/logresolve
424%{_sbindir}/ht*
425%{_sbindir}/apache2.*
426%{_sbindir}/apache2ctl
427%{_sbindir}/rotatelogs2
428%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
429
430%dir %{_libdir}/apache2
431%dir %{_libdir}/apache2/modules
432# everything but mod_ssl.so:
433%{_libdir}/apache2/modules/mod_[a-r]*.so
434%{_libdir}/apache2/modules/mod_s[petu]*.so
435%{_libdir}/apache2/modules/mod_[t-z]*.so
436
437%dir %{contentdir}
438%dir %{contentdir}/cgi-bin
439%dir %{contentdir}/html
440%dir %{contentdir}/icons
441%dir %{contentdir}/error
442%dir %{contentdir}/error/include
443%{contentdir}/icons/*
444%{contentdir}/error/README
445%{contentdir}/error/noindex.html
446%config(noreplace) %{contentdir}/error/*.var
447%config(noreplace) %{contentdir}/error/include/*.html
448
449%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
450
451%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
452
453%{_mandir}/man1/*
454
455%{_mandir}/man8/*
456
457%files manual
458%defattr(-,root,root)
459%{contentdir}/manual
460
461%files -n mod_ssl-apache2
462%defattr(-,root,root)
463%{_libdir}/apache2/modules/mod_ssl.so
464%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
465%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
466%config %{_sysconfdir}/apache2/conf/Makefile
467%config %{_sysconfdir}/apache2/conf/ssl.*/*
468%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
469%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
470%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
471%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
472
473%files devel
474%defattr(-,root,root)
475%{_includedir}/apache2
476%{_sysconfdir}/apache2/build
477%{_bindir}/apxs
478%{_mandir}/man?/apxs*
479%{_libdir}/apache2/build/*.mk
480%{_libdir}/apache2/build/*.sh
481
482%changelog
483* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
484- update to 2.2.22
485  - CVE-2012-0021 (mod_log_config)
486  - CVE-2012-0031
487  - CVE-2012-0053
488- remove upstreamed patches
489
490* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
491- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
492
493* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
494- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
495
496* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
497- add patch70 for fix byterange filter
498
499* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
500- add Patch100 for fix CVE-2011-3368 (mod_proxy)
501
502* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
503- new upstream release with security fix (CVE-2011-3348)
504- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
505
506* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
507- update Patch101 (Thanks to debian team)
508
509* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
510- add Patch101 for fix CVE-2011-3192 regression
511
512* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
513- new upstream release with security fix (CVE-2011-3192)
514- drop patch100 (is included in new release)
515
516* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
517- add patch100 for fix CVE-2011-3192 (Range Header DoS)
518
519* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
520- update to 2.2.19
521
522* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
523- remove old Obsoletes/Conflicts
524
525* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
526- rebuild with openssl-1.0.0c
527
528* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
529- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
530
531* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
532- add R(post): alternatives
533
534* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
535- add patch110 for fix CVE-2010-0434 from mdk 2010
536
537* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
538- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
539
540* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
541- rebuilt with rpm-4.8.0-3 (on ppc)
542
543* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
544- rebuild with db4-4.8.0
545
546* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
547- new upstream release with security fix
548  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
549- fix ssl.conf (2.2.13-1 includes wrong file)
550
551* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
552- new upstream release
553
554* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
555- new upstream release
556  (including security fix for CVE-2009-1890, CVE-2009-1191,
557   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
558
559* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
560- rebuilt with openldap-2.4.11
561
562* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
563- new upstream release
564
565* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
566- new upstream release (including security fix for CVE-2008-2939)
567
568* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
569- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
570- built with db4-4.6.21, apr 1.3.0
571
572* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
573- add Patch60 (to fix bug#31418).
574
575* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
576- rebuild with expat-2.0.1
577
578* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
579- new upstream release
580
581* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
582- added postun script from VinePlus/4.0 package
583  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
584  - add postun script to restart daemon with message
585
586* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
587- updated Patch2: httpd-2.2.3-apxs.patch
588
589* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
590- modified libdir in config.layout for lib64 architecture
591
592* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
593- rebuilt with openssl-0.9.8e
594
595* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
596- rebuilt with new toolchain and db4-4.3.x
597
598* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
599- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
600
601* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
602- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
603
604* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
605- rebuilt with openldap-2.3.27-0vl1
606
607* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
608- new upstream release including security fix (CVE-2006-3747)
609
610* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
611- new upstream release
612  - update to 2.2.2
613- remove apr/apr-devel subpackage,
614  use external apr/apr-util instead of internal one.
615
616* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
617- new upstream release
618- use apache2.prefork as default.
619
620* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
621- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
622- remove unpackaged files in %%install section
623
624* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
625- fix logrotate configuration (use apache2.pid instead of httpd.pid)
626  (BTS:10)
627- use Epoch instead of Serial
628
629* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
630- new upstream release
631- drop obsolete security patches which is merged in upstream
632
633* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
634- new upstream release
635
636* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
637- added Patch122 to 125 for secutiry fix
638  (CAN-2004-{1268,2088,2700,2728})
639- fix %install section
640
641* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
642- new upstream release
643
644* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
645- new upstream release
646
647* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
648- rebuilt with db4-4.2.52
649
650* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
651- separate apr, apr-devel packages
652- add BuildPreReq: zlib-devel
653
654* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
655- fix %%files to include instdso.sh
656  thanks to jax <jax AT morejams DOT no-ip DOT com>
657- add %%{?_smp_mflags} to make option.
658
659* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
660- new upstream version
661
662* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
663- new upstream version
664
665* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
666- new upstream version
667- update apxs patch (Patch101)
668- fix dependency:
669    - change file name to package name in Requires and {Build,}Prereq
670- add BuildPrereq: openldap-devel
671- update %%files section
672- rename httpd.8 manpage
673
674* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
675- new upstream version
676- used vine-config.layout in srclib
677
678* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
679- rebuild
680
681* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
682- change pkg name from mod_ssl to mod_ssl-apache2
683- remove "apache-manual" entry from Obsoletes:
684
685* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
686- remove "mod_dav" and "apache-devel" from Obsoletes:
687- enable MPMS(worker %mpms )
688
689* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
690- add correct config_vars.mk
691
692* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
693- apply apxs's patch ( from Debian)
694
695* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
696- add apr-config,apu-config to devel's %file
697
698* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
699- change apxs path ( /usr/sbin -> /usr/bin
700- add symlink under /etc/apache2/conf
701  (logs, run), httpd.conf -> apache2.conf
702- fixed apache2 initscript.
703
704* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
705- build Vine Linux
706- new upstream version
707- sharing with apache1
708
709* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
710- link httpd with libssl to avoid library loading/unloading weirdness
711
712* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
713- add LoadModule lines for proxy modules in httpd.conf (#73349)
714- fix permissions of conf/ssl.*/ directories; add Makefiles for
715  certificate management (#73352)
716
717* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
718- provide "httpd-mmn" to manage module ABI compatibility
719
720* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
721- fix SSL session cache (#69699)
722- revert addition of LDAP support to apr-util
723
724* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
725- set SIGXFSZ disposition to "ignored" (#69520)
726- make dummy connections to the first listener in config (#72692)
727
728* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
729- allow "apachectl configtest" on a 1.3 httpd.conf
730- add mod_deflate
731- enable LDAP support in apr-util
732- don't package everything in /var/www/error as config(noreplace)
733
734* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
735- add trigger (#68657)
736
737* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
738- update to 2.0.40
739
740* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
741- improve comment on use of UserDir in default config (#66886)
742
743* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
744- use /sbin/nologin as shell for apache user (#68371)
745- add patch from CVS to fix possible infinite loop when processing
746  internal redirects
747
748* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
749- modify init script to detect 1.3.x httpd.conf's and direct users
750  to the migration guide
751
752* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
753- patch apachectl to detect 1.3.x httpd.conf's and direct users
754  to the migration guide
755- ship the migration guide
756
757* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
758- move /etc/httpd2 back to /etc/httpd
759- add noindex.html page and poweredby logo; tweak default config
760  to load noindex.html if no default "/" page is present.
761- add patch to prevent mutex errors on graceful restart
762
763* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
764- automated rebuild
765
766* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
767- add patch to fix SSL mutex handling
768
769* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
770- improved config directory patch
771
772* Mon May 20 2002 Joe Orton <jorton@redhat.com>
773- initial build; based heavily on apache.spec and mod_ssl.spec
774- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
775
Note: See TracBrowser for help on using the repository browser.