source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 10067

Revision 10067, 27.9 KB checked in by iwamoto, 8 years ago (diff)

apache2: rebuilt with openssl 1.0.2g

Line 
1%define contentdir %{_datadir}/apache2
2%define docroot /var/www/apache2
3%define suexec_caller www-data
4%define mmn 20051115
5%define mmnisa %{mmn}%{__isa_name}%{__isa_bits}
6%define pkgname apache2
7%define vstring Vine
8
9Summary: Apache HTTP Server
10Name: %{pkgname}
11Version: 2.4.18
12Release: 2%{_dist_release}
13URL: http://httpd.apache.org/
14
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager: daisuke
18
19Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
20Source2: index.html
21Source3: apache2.logrotate
22Source4: apache2.init
23Source6: poweredby-vine.png
24Source7: apache2.tmpfiles
25Source10: httpd.conf
26Source11: 00-base.conf
27Source12: 00-mpm.conf
28Source13: 00-lua.conf
29Source14: 01-cgi.conf
30Source15: 00-dav.conf
31Source16: 00-proxy.conf
32Source17: 00-ssl.conf
33Source18: 01-ldap.conf
34Source19: 00-proxyhtml.conf
35Source20: userdir.conf
36Source21: ssl.conf
37Source22: welcome.conf
38Source23: manual.conf
39Source25: 01-session.conf
40# Documentation
41Source30: README.confd
42Source31: README.confmod
43# add vine entry to config.layout
44Source100: vine-config.layout
45
46# build/scripts patches
47Patch1: httpd-2.4.1-apctl.patch
48Patch2: httpd-2.4.1-apxs.patch
49Patch3: httpd-2.4.1-deplibs.patch
50# Features/functional changes
51Patch23: httpd-2.4.4-export.patch
52Patch24: httpd-2.4.1-corelimit.patch
53Patch26: httpd-2.4.4-r1337344+.patch
54Patch27: httpd-2.4.2-icons.patch
55Patch30: httpd-2.4.4-cachehardmax.patch
56Patch31: httpd-2.4.18-sslmultiproxy.patch
57# Bug fixes
58Patch55: httpd-2.4.4-malformed-host.patch
59Patch56: httpd-2.4.4-mod_unique_id.patch
60Patch57: httpd-2.4.10-sigint.patch
61Patch58: httpd-2.4.17-debug-crash.patch
62
63# Security fixes
64
65License: Apache Software License
66Group: System Environment/Daemons
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68BuildRequires: db4-devel, expat-devel, xmlto
69BuildRequires: findutils, perl, openldap-devel, zlib-devel
70BuildRequires: apr-devel, apr-util-devel
71BuildRequires: pcre-devel, sqlite3-devel
72BuildRequires: lua-devel, libxml2-devel
73BuildRequires: www-common
74Requires: mailcap, gawk, file, findutils, apr, apr-util
75Requires(pre): www-common
76Requires(pre): chkconfig, mktemp, fileutils
77Requires(pre): sh-utils, textutils, shadow-utils
78Requires(post): alternatives
79Provides: webserver
80Provides: httpd = %{version}
81Provides: httpd-mmn = %{mmn}
82Provides: apache2-mmn = %{mmn}
83Obsoletes: apache2-apr, apache2-apr-devel
84Obsoletes: apache < 2.0, apache-devel < 2.0
85
86%description
87Apache is a powerful, full-featured, efficient, and freely-available
88Web server. Apache is also the most popular Web server on the
89Internet.
90
91%package devel
92Group: Development/Libraries
93Summary: Development tools for the Apache HTTP server.
94Requires: libtool, apache2 = %{version}
95Requires: apr-devel, apr-util-devel
96
97%description devel
98The httpd-devel package contains the APXS binary and other files
99that you need to build Dynamic Shared Objects (DSOs) for Apache.
100
101If you are installing the Apache HTTP server and you want to be
102able to compile or develop additional modules for Apache, you need
103to install this package.
104
105%package manual
106Group: Applications/Documentation
107Summary: Documentation for the Apache HTTP server.
108
109%description manual
110The httpd-manual package contains the complete manual and
111reference guide for the Apache HTTP server. The information can
112also be found at http://httpd.apache.org/docs/.
113
114%package -n mod_ssl-apache2
115Group: System Environment/Daemons
116Summary: SSL/TLS module for the Apache HTTP server
117Epoch: 1
118BuildRequires: openssl-devel
119Requires(pre): net-tools, openssl, dev, /bin/cat
120Requires: apache2, make, apache2-mmn = %{mmn}
121
122%description -n mod_ssl-apache2
123The mod_ssl module provides strong cryptography for the Apache Web
124server via the Secure Sockets Layer (SSL) and Transport Layer
125Security (TLS) protocols.
126
127%prep
128%setup -q -n httpd-%{version}
129
130%patch1 -p1 -b .apctl
131%patch2 -p1 -b .apxs
132%patch3 -p1 -b .deplibs
133
134%patch23 -p1 -b .export
135%patch24 -p1 -b .corelimit
136%patch26 -p1 -b .r1337344+
137%patch27 -p1 -b .icons
138%patch30 -p1 -b .cachehardmax
139%patch31 -p1 -b .sslmultiproxy
140
141%patch55 -p1 -b .malformedhost
142%patch56 -p1 -b .uniqueid
143
144%patch57 -p1 -b .sigint
145%patch58 -p1 -b .debug-crash
146
147# Patch in the vendor string
148sed -i '/^#define PLATFORM/s/Unix/%{vstring}/' os/unix/os.h
149
150# Prevent use of setcap in "install-suexec-caps" target.
151sed -i '/suexec/s,setcap ,echo Skipping setcap for ,' Makefile.in
152
153# add Vine configure's option to config.layout
154sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
155  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
156
157%build
158# remove bundled apr, apr-util, pcre
159rm -rf srclib/{apr,apr-util,pcre}
160
161# regenerate configure scripts
162autoheader && autoconf || exit 1
163
164CFLAGS="$RPM_OPT_FLAGS"
165SH_LDFLAGS="-Wl,-z,relro"
166export CFLAGS SH_LDFLAGS
167
168AP_CONFOPTS="\
169        --prefix=%{_sysconfdir}/apache2 \
170        --exec-prefix=%{_prefix} \
171        --bindir=%{_bindir} \
172        --sbindir=%{_sbindir} \
173        --mandir=%{_mandir} \
174        --libdir=%{_libdir} \
175        --sysconfdir=%{_sysconfdir}/apache2/conf \
176        --includedir=%{_includedir}/apache2 \
177        --libexecdir=%{_libdir}/apache2/modules \
178        --datadir=%{contentdir} \
179        --with-installbuilddir=%{_libdir}/apache2/build \
180        --enable-layout=Vine \
181        --with-program-name=apache2 \
182        --with-ldap \
183        --enable-ldap --enable-authnz-ldap \
184        --enable-mods-shared=all \
185        --enable-cache=shared \
186        --enable-cgi=shared \
187        --enable-cgid=shared \
188        --enable-rewrite=shared \
189        --enable-disk-cache=shared \
190        --enable-file-cache=shared \
191        --enable-mem-cache=shared \
192        --enable-authn-anon --enable-authn-alias \
193        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
194        --enable-suexec --with-suexec \
195        --enable-suexec-capabilities \
196        --with-suexec-caller=%{suexec_caller} \
197        --with-suexec-docroot=%{docroot} \
198        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
199        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
200        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
201        --with-pcre \
202        --enable-pie \
203        --enable-ssl --with-ssl \
204        --enable-deflate \
205        --enable-proxy --enable-proxy-connect \
206        --enable-proxy-http --enable-proxy-ftp \
207        --enable-case-filter --enable-case-filter-in \
208        --enable-mpms-shared=all"
209./configure ${AP_CONFOPTS}
210make %{?_smp_mflags}
211
212%install
213rm -rf $RPM_BUILD_ROOT
214
215make DESTDIR=$RPM_BUILD_ROOT install
216
217# create apache2ctl symlink
218ln -sf apachectl $RPM_BUILD_ROOT%{_sbindir}/apache2ctl
219
220# install conf file/directory
221mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d \
222      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d \
223      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/sites.d
224install -m 644 $RPM_SOURCE_DIR/README.confd \
225   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
226install -m 644 $RPM_SOURCE_DIR/README.confmod \
227   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/README
228
229for f in 00-base.conf 00-mpm.conf 00-lua.conf 01-cgi.conf 00-dav.conf \
230         00-proxy.conf 00-ssl.conf 01-ldap.conf 00-proxyhtml.conf \
231         01-ldap.conf 01-session.conf; do
232  install -m 644 -p $RPM_SOURCE_DIR/$f \
233                    $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/$f
234done
235
236for f in welcome.conf ssl.conf manual.conf userdir.conf; do
237  install -m 644 -p $RPM_SOURCE_DIR/$f \
238     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/$f
239done
240
241# Split-out extra config shipped as default in conf.d:
242for f in autoindex; do
243  mv docs/conf/extra/httpd-${f}.conf \
244     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/${f}.conf
245done
246         
247# Extra config trimmed:
248rm -v docs/conf/extra/httpd-{ssl,userdir}.conf
249
250rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
251install -m 644 -p $RPM_SOURCE_DIR/httpd.conf \
252   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
253ln -sf httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/apache2.conf
254
255# tmpfiles.d configuration
256mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d
257install -m 644 -p $RPM_SOURCE_DIR/apache2.tmpfiles \
258   $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/apache2.conf
259
260# Other directories
261mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav \
262         $RPM_BUILD_ROOT/run/apache2/htcacheclean
263
264# Create cache directory
265mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2 \
266         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/proxy \
267         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/ssl
268
269# Make the MMN accessible to module packages
270echo %{mmnisa} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
271mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
272cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.apache2 <<EOF
273%%_httpd_mmn %{mmnisa}
274%%_httpd_apxs %%{_bindir}/apxs
275%%_httpd_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
276%%_httpd_confdir %%{_sysconfdir}/apache2/conf.d
277%%_httpd_contentdir %{contentdir}
278%%_httpd_moddir %%{_libdir}/apache2/modules
279%%_apache2_mmn %{mmnisa}
280%%_apache2_apxs %%{_bindir}/apxs
281%%_apache2_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
282%%_apache2_confdir %%{_sysconfdir}/apache2/conf.d
283%%_apache2_contentdir %{contentdir}
284%%_apache2_moddir %%{_libdir}/apache2/modules
285EOF
286
287# Handle contentdir
288mkdir $RPM_BUILD_ROOT%{contentdir}/noindex
289install -m 644 -p $RPM_SOURCE_DIR/index.html \
290        $RPM_BUILD_ROOT%{contentdir}/noindex/index.html
291install -m 644 -p $RPM_SOURCE_DIR/poweredby-vine.png \
292        $RPM_BUILD_ROOT%{contentdir}/icons/
293rm -rf %{contentdir}/htdocs
294
295# remove manual sources
296find $RPM_BUILD_ROOT%{contentdir}/manual \( \
297    -name \*.xml -o -name \*.xml.* -o -name \*.ent -o -name \*.xsl -o -name \*.dtd \
298    \) -print0 | xargs -0 rm -f
299
300# Strip the manual down just to English and replace the typemaps with flat files:
301set +x
302for f in `find $RPM_BUILD_ROOT%{contentdir}/manual -name \*.html -type f`; do
303   if test -f ${f}.en; then
304      cp ${f}.en ${f}
305      rm ${f}.*
306   fi
307done
308set -x
309
310# Clean Document Root
311rm -v $RPM_BUILD_ROOT%{docroot}/html/*.html
312rm -v $RPM_BUILD_ROOT/var/www/cgi-bin/*
313
314# symlinks for /etc/apache2
315ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
316ln -s /run/apache2 $RPM_BUILD_ROOT/etc/apache2/run
317ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
318
319# install SYSV init stuff
320mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
321install -m755 $RPM_SOURCE_DIR/apache2.init \
322        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
323%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
324        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
325
326# Install logrotate config
327mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
328install -m 644 -p $RPM_SOURCE_DIR/apache2.logrotate \
329        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
330
331# fix man page paths
332sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
333    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
334    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
335    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
336    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
337    -e "s|/usr/local/apache2/logs/httpd.pid|/run/apache2/apache2.pid|" \
338    -e "s|/usr/local/apache2|/etc/httpd|" < docs/man/httpd.8 \
339  > $RPM_BUILD_ROOT%{_mandir}/man8/httpd.8
340
341# Make ap_config_layout.h libdir-agnostic
342sed -i '/.*DEFAULT_..._LIBEXECDIR/d;/DEFAULT_..._INSTALLBUILDDIR/d' \
343    $RPM_BUILD_ROOT%{_includedir}/apache2/ap_config_layout.h
344
345# Fix path to instdso in special.mk
346sed -i '/instdso/s,top_srcdir,top_builddir,' \
347    $RPM_BUILD_ROOT%{_libdir}/apache2/build/special.mk
348
349# Remove unpackaged files
350rm -vf \
351      $RPM_BUILD_ROOT%{_libdir}/*.exp \
352      $RPM_BUILD_ROOT/etc/apache2/conf/mime.types \
353      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
354      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
355      $RPM_BUILD_ROOT%{_bindir}/{ap?-config,dbmmanage} \
356      $RPM_BUILD_ROOT%{_sbindir}/{checkgid,envvars*} \
357      $RPM_BUILD_ROOT%{contentdir}/htdocs/* \
358      $RPM_BUILD_ROOT%{_mandir}/man1/dbmmanage.* \
359      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
360
361rm -rf $RPM_BUILD_ROOT/etc/apache2/conf/{original,extra}
362
363
364
365%triggerpostun -- apache < 2.0
366/sbin/chkconfig --add apache2
367
368
369%post
370/sbin/chkconfig --add apache2
371
372%preun
373if [ $1 = 0 ]; then
374        /sbin/service apache2 stop > /dev/null 2>&1
375        /sbin/chkconfig --del apache2
376fi
377
378%postun
379if [ "$1" -ge 1 ]; then
380        /sbin/service apache2 condrestart
381fi
382/sbin/ldconfig
383
384%define sslcert %{_sysconfdir}/pki/tls/certs/localhost.crt
385%define sslkey %{_sysconfdir}/pki/tls/private/localhost.key
386
387%post -n mod_ssl-apache2
388umask 077
389
390if [ -f %{sslkey} -o -f %{sslcert} ]; then
391  exit 0
392fi
393
394%{_bindir}/openssl genrsa \
395  -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime \
396  2048 > %{sslkey} 2> /dev/null ||:
397
398FQDN=`hostname` ||:
399if [ "x${FQDN}" = "x" ]; then
400   FQDN=localhost.localdomain
401fi
402   
403cat << EOF | %{_bindir}/openssl req -new -key %{sslkey} \
404         -x509 -sha256 -days 3650 -set_serial $RANDOM -extensions v3_req \
405         -out %{sslcert} 2>/dev/null ||:
406--
407SomeState
408SomeCity
409SomeOrganization
410SomeOrganizationalUnit
411${FQDN}
412root@${FQDN}
413EOF
414
415%clean
416rm -rf $RPM_BUILD_ROOT
417
418%files
419%defattr(-,root,root)
420
421%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
422%doc migration.html migration.css
423%doc docs/conf/extra/*.conf
424
425%dir %{_sysconfdir}/apache2
426%{_sysconfdir}/apache2/modules
427%{_sysconfdir}/apache2/logs
428%{_sysconfdir}/apache2/run
429%dir %{_sysconfdir}/apache2/conf
430%config(noreplace) %{_sysconfdir}/apache2/conf/httpd.conf
431%config(noreplace) %{_sysconfdir}/apache2/conf/apache2.conf
432%config(noreplace) %{_sysconfdir}/apache2/conf/magic
433
434%config(noreplace) %{_sysconfdir}/logrotate.d/apache2
435
436%config %{_sysconfdir}/rc.d/init.d/apache2
437
438%dir %{_sysconfdir}/apache2/conf.d
439%{_sysconfdir}/apache2/conf.d/README
440%config(noreplace) %{_sysconfdir}/apache2/conf.d/*.conf
441%exclude %{_sysconfdir}/apache2/conf.d/ssl.conf
442%exclude %{_sysconfdir}/apache2/conf.d/manual.conf
443
444%dir %{_sysconfdir}/apache2/conf.modules.d
445%{_sysconfdir}/apache2/conf.modules.d/README
446%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/*.conf
447%exclude %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
448
449%dir %{_sysconfdir}/apache2/sites.d
450
451%{_prefix}/lib/tmpfiles.d/apache2.conf
452
453%{_bindir}/ab
454%{_bindir}/ht*
455%{_bindir}/logresolve
456%{_sbindir}/ht*
457%{_sbindir}/apache2
458%{_sbindir}/apachectl
459%{_sbindir}/apache2ctl
460%{_sbindir}/rotatelogs
461%{_sbindir}/fcgistarter
462%attr(4510,root,%{suexec_caller}) %{_sbindir}/suexec
463
464%dir %{_libdir}/apache2
465%dir %{_libdir}/apache2/modules
466%{_libdir}/apache2/modules/mod_*.so
467%exclude %{_libdir}/apache2/modules/mod_ssl.so
468
469%dir %{contentdir}
470%dir %{contentdir}/icons
471%dir %{contentdir}/error
472%dir %{contentdir}/error/include
473%dir %{contentdir}/noindex
474%{contentdir}/icons/*
475%{contentdir}/error/README
476%{contentdir}/error/*.var
477%{contentdir}/error/include/*.html
478%{contentdir}/noindex/index.html
479
480%dir %{docroot}/html
481%dir /var/www/cgi-bin
482
483%attr(0710,root,www-data) %dir /run/apache2
484%attr(0700,www-data,www-data) %dir /run/apache2/htcacheclean
485
486%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
487%attr(0700,www-data,www-data) %dir %{_localstatedir}/lib/dav
488%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2
489%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/proxy
490
491%{_mandir}/man1/*
492%exclude %{_mandir}/man1/apxs*
493
494%{_mandir}/man8/*
495
496
497%files manual
498%defattr(-,root,root)
499%{contentdir}/manual
500%config(noreplace) %{_sysconfdir}/apache2/conf.d/manual.conf
501
502
503%files -n mod_ssl-apache2
504%defattr(-,root,root)
505%{_libdir}/apache2/modules/mod_ssl.so
506%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
507%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
508%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/ssl
509
510
511%files devel
512%defattr(-,root,root)
513%{_includedir}/apache2
514%{_bindir}/apxs
515%{_mandir}/man1/apxs*
516%dir %{_libdir}/apache2/build
517%{_libdir}/apache2/build/*.mk
518%{_libdir}/apache2/build/*.sh
519%{_sysconfdir}/rpm/macros.apache2
520
521
522%changelog
523* Thu Mar 10 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.18-2
524- rebuilt with openssl 1.0.2g
525
526* Thu Feb  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.18-1
527- update to 2.4.18.
528- fixed 00-base.conf.
529- updated Patch31.
530
531* Mon Dec  7 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.17-2
532- fixed configuration files.
533
534* Fri Dec  4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.17-1
535- update to 2.4.17.
536- fixed dependency.
537
538* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-2
539- modify dependency
540
541* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-1
542- update to 2.4.9
543- remove suffix '2' from {htdigest,htpasswd,rotatelogs}2
544- use /run instead of /var/run
545- remove /etc/apache2/conf/ssl* , use /etc/pki now.
546- move suexec from %%{_libdir}/apache2 to %%{_sbindir}
547- split all LoadModules to conf.modules.d/*.conf
548- split module configs to conf.d/*.conf
549- cleanup docroot, move apache specific files to %%{_datadir}/apache2
550- add BR: lua-devel, libxml2-devel
551- add /etc/apache2/sites.d for virtual host settings.
552
553* Wed Dec 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.25-2
554- merge VineSeed spec file
555  * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-2
556  - rebuild with pcre-8.31
557
558  * Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-1
559  - update to 2.2.23
560  - add R(pre): www-common, BR: www-common
561  - move apache contents to %{contentdir}
562
563* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
564- new upstream release with security fix (CVE-2013-1862,1896)
565- drop patch100 (is included in new release)
566
567* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
568- add patch100 for fix CVE-2013-1862 (mod_rewrite)
569
570* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
571- new upstream release with security fix (CVE-2012-3499, 4558)
572
573* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
574- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
575- update patch22 to fit new release
576- update man filename convert list
577
578* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
579- update to 2.2.22
580  - CVE-2012-0021 (mod_log_config)
581  - CVE-2012-0031
582  - CVE-2012-0053
583- remove upstreamed patches
584
585* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
586- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
587
588* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
589- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
590
591* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
592- add patch70 for fix byterange filter
593
594* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
595- add Patch100 for fix CVE-2011-3368 (mod_proxy)
596
597* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
598- new upstream release with security fix (CVE-2011-3348)
599- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
600
601* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
602- update Patch101 (Thanks to debian team)
603
604* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
605- add Patch101 for fix CVE-2011-3192 regression
606
607* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
608- new upstream release with security fix (CVE-2011-3192)
609- drop patch100 (is included in new release)
610
611* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
612- add patch100 for fix CVE-2011-3192 (Range Header DoS)
613
614* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
615- update to 2.2.19
616
617* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
618- remove old Obsoletes/Conflicts
619
620* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
621- rebuild with openssl-1.0.0c
622
623* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
624- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
625
626* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
627- add R(post): alternatives
628
629* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
630- add patch110 for fix CVE-2010-0434 from mdk 2010
631
632* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
633- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
634
635* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
636- rebuilt with rpm-4.8.0-3 (on ppc)
637
638* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
639- rebuild with db4-4.8.0
640
641* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
642- new upstream release with security fix
643  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
644- fix ssl.conf (2.2.13-1 includes wrong file)
645
646* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
647- new upstream release
648
649* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
650- new upstream release
651  (including security fix for CVE-2009-1890, CVE-2009-1191,
652   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
653
654* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
655- rebuilt with openldap-2.4.11
656
657* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
658- new upstream release
659
660* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
661- new upstream release (including security fix for CVE-2008-2939)
662
663* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
664- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
665- built with db4-4.6.21, apr 1.3.0
666
667* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
668- add Patch60 (to fix bug#31418).
669
670* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
671- rebuild with expat-2.0.1
672
673* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
674- new upstream release
675
676* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
677- added postun script from VinePlus/4.0 package
678  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
679  - add postun script to restart daemon with message
680
681* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
682- updated Patch2: httpd-2.2.3-apxs.patch
683
684* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
685- modified libdir in config.layout for lib64 architecture
686
687* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
688- rebuilt with openssl-0.9.8e
689
690* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
691- rebuilt with new toolchain and db4-4.3.x
692
693* Wed Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
694- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
695
696* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
697- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
698
699* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
700- rebuilt with openldap-2.3.27-0vl1
701
702* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
703- new upstream release including security fix (CVE-2006-3747)
704
705* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
706- new upstream release
707  - update to 2.2.2
708- remove apr/apr-devel subpackage,
709  use external apr/apr-util instead of internal one.
710
711* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
712- new upstream release
713- use apache2.prefork as default.
714
715* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
716- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
717- remove unpackaged files in %%install section
718
719* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
720- fix logrotate configuration (use apache2.pid instead of httpd.pid)
721  (BTS:10)
722- use Epoch instead of Serial
723
724* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
725- new upstream release
726- drop obsolete security patches which is merged in upstream
727
728* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
729- new upstream release
730
731* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
732- added Patch122 to 125 for secutiry fix
733  (CAN-2004-{1268,2088,2700,2728})
734- fix %install section
735
736* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
737- new upstream release
738
739* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
740- new upstream release
741
742* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
743- rebuilt with db4-4.2.52
744
745* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
746- separate apr, apr-devel packages
747- add BuildPreReq: zlib-devel
748
749* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
750- fix %%files to include instdso.sh
751  thanks to jax <jax AT morejams DOT no-ip DOT com>
752- add %%{?_smp_mflags} to make option.
753
754* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
755- new upstream version
756
757* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
758- new upstream version
759
760* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
761- new upstream version
762- update apxs patch (Patch101)
763- fix dependency:
764    - change file name to package name in Requires and {Build,}Prereq
765- add BuildPrereq: openldap-devel
766- update %%files section
767- rename httpd.8 manpage
768
769* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
770- new upstream version
771- used vine-config.layout in srclib
772
773* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
774- rebuild
775
776* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
777- change pkg name from mod_ssl to mod_ssl-apache2
778- remove "apache-manual" entry from Obsoletes:
779
780* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
781- remove "mod_dav" and "apache-devel" from Obsoletes:
782- enable MPMS(worker %mpms )
783
784* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
785- add correct config_vars.mk
786
787* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
788- apply apxs's patch ( from Debian)
789
790* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
791- add apr-config,apu-config to devel's %file
792
793* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
794- change apxs path ( /usr/sbin -> /usr/bin
795- add symlink under /etc/apache2/conf
796  (logs, run), httpd.conf -> apache2.conf
797- fixed apache2 initscript.
798
799* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
800- build Vine Linux
801- new upstream version
802- sharing with apache1
803
804* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
805- link httpd with libssl to avoid library loading/unloading weirdness
806
807* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
808- add LoadModule lines for proxy modules in httpd.conf (#73349)
809- fix permissions of conf/ssl.*/ directories; add Makefiles for
810  certificate management (#73352)
811
812* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
813- provide "httpd-mmn" to manage module ABI compatibility
814
815* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
816- fix SSL session cache (#69699)
817- revert addition of LDAP support to apr-util
818
819* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
820- set SIGXFSZ disposition to "ignored" (#69520)
821- make dummy connections to the first listener in config (#72692)
822
823* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
824- allow "apachectl configtest" on a 1.3 httpd.conf
825- add mod_deflate
826- enable LDAP support in apr-util
827- don't package everything in /var/www/error as config(noreplace)
828
829* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
830- add trigger (#68657)
831
832* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
833- update to 2.0.40
834
835* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
836- improve comment on use of UserDir in default config (#66886)
837
838* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
839- use /sbin/nologin as shell for apache user (#68371)
840- add patch from CVS to fix possible infinite loop when processing
841  internal redirects
842
843* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
844- modify init script to detect 1.3.x httpd.conf's and direct users
845  to the migration guide
846
847* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
848- patch apachectl to detect 1.3.x httpd.conf's and direct users
849  to the migration guide
850- ship the migration guide
851
852* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
853- move /etc/httpd2 back to /etc/httpd
854- add noindex.html page and poweredby logo; tweak default config
855  to load noindex.html if no default "/" page is present.
856- add patch to prevent mutex errors on graceful restart
857
858* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
859- automated rebuild
860
861* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
862- add patch to fix SSL mutex handling
863
864* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
865- improved config directory patch
866
867* Mon May 20 2002 Joe Orton <jorton@redhat.com>
868- initial build; based heavily on apache.spec and mod_ssl.spec
869- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
870
Note: See TracBrowser for help on using the repository browser.