source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 10349

Revision 10349, 28.1 KB checked in by tomop, 8 years ago (diff)

apache2-2.4.20-1

Line 
1%define contentdir %{_datadir}/apache2
2%define docroot /var/www/apache2
3%define suexec_caller www-data
4%define mmn 20051115
5%define mmnisa %{mmn}%{__isa_name}%{__isa_bits}
6%define pkgname apache2
7%define vstring Vine
8
9Summary: Apache HTTP Server
10Name: %{pkgname}
11Version: 2.4.20
12Release: 1%{_dist_release}
13URL: http://httpd.apache.org/
14
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager: daisuke
18
19Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
20Source2: index.html
21Source3: apache2.logrotate
22Source4: apache2.init
23Source6: poweredby-vine.png
24Source7: apache2.tmpfiles
25Source10: httpd.conf
26Source11: 00-base.conf
27Source12: 00-mpm.conf
28Source13: 00-lua.conf
29Source14: 01-cgi.conf
30Source15: 00-dav.conf
31Source16: 00-proxy.conf
32Source17: 00-ssl.conf
33Source18: 01-ldap.conf
34Source19: 00-proxyhtml.conf
35Source20: userdir.conf
36Source21: ssl.conf
37Source22: welcome.conf
38Source23: manual.conf
39Source25: 01-session.conf
40# Documentation
41Source30: README.confd
42Source31: README.confmod
43# add vine entry to config.layout
44Source100: vine-config.layout
45
46# build/scripts patches
47Patch1: httpd-2.4.1-apctl.patch
48Patch2: httpd-2.4.1-apxs.patch
49Patch3: httpd-2.4.1-deplibs.patch
50# Features/functional changes
51Patch23: httpd-2.4.4-export.patch
52Patch24: httpd-2.4.1-corelimit.patch
53Patch26: httpd-2.4.4-r1337344+.patch
54Patch27: httpd-2.4.2-icons.patch
55Patch30: httpd-2.4.4-cachehardmax.patch
56Patch31: httpd-2.4.18-sslmultiproxy.patch
57# Bug fixes
58Patch55: httpd-2.4.4-malformed-host.patch
59Patch56: httpd-2.4.4-mod_unique_id.patch
60Patch57: httpd-2.4.10-sigint.patch
61Patch58: httpd-2.4.20-debug-crash.patch
62
63# Security fixes
64
65License: Apache Software License
66Group: System Environment/Daemons
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68BuildRequires: db4-devel, expat-devel, xmlto
69BuildRequires: findutils, perl, openldap-devel, zlib-devel
70BuildRequires: apr-devel, apr-util-devel
71BuildRequires: pcre-devel, sqlite3-devel
72BuildRequires: lua-devel, libxml2-devel
73BuildRequires: www-common
74Requires: mailcap, gawk, file, findutils, apr, apr-util
75Requires(pre): www-common
76Requires(pre): chkconfig, mktemp, fileutils
77Requires(pre): sh-utils, textutils, shadow-utils
78Requires(post): alternatives
79Provides: webserver
80Provides: httpd = %{version}
81Provides: httpd-mmn = %{mmn}
82Provides: apache2-mmn = %{mmn}
83Obsoletes: apache2-apr, apache2-apr-devel
84Obsoletes: apache < 2.0, apache-devel < 2.0
85
86%description
87Apache is a powerful, full-featured, efficient, and freely-available
88Web server. Apache is also the most popular Web server on the
89Internet.
90
91%package devel
92Group: Development/Libraries
93Summary: Development tools for the Apache HTTP server.
94Requires: libtool, apache2 = %{version}
95Requires: apr-devel, apr-util-devel
96
97%description devel
98The httpd-devel package contains the APXS binary and other files
99that you need to build Dynamic Shared Objects (DSOs) for Apache.
100
101If you are installing the Apache HTTP server and you want to be
102able to compile or develop additional modules for Apache, you need
103to install this package.
104
105%package manual
106Group: Applications/Documentation
107Summary: Documentation for the Apache HTTP server.
108
109%description manual
110The httpd-manual package contains the complete manual and
111reference guide for the Apache HTTP server. The information can
112also be found at http://httpd.apache.org/docs/.
113
114%package -n mod_ssl-apache2
115Group: System Environment/Daemons
116Summary: SSL/TLS module for the Apache HTTP server
117Epoch: 1
118BuildRequires: openssl-devel
119Requires(pre): net-tools, openssl, dev, /bin/cat
120Requires: apache2, make, apache2-mmn = %{mmn}
121
122%description -n mod_ssl-apache2
123The mod_ssl module provides strong cryptography for the Apache Web
124server via the Secure Sockets Layer (SSL) and Transport Layer
125Security (TLS) protocols.
126
127%prep
128%setup -q -n httpd-%{version}
129
130%patch1 -p1 -b .apctl
131%patch2 -p1 -b .apxs
132%patch3 -p1 -b .deplibs
133
134%patch23 -p1 -b .export
135%patch24 -p1 -b .corelimit
136%patch26 -p1 -b .r1337344+
137%patch27 -p1 -b .icons
138%patch30 -p1 -b .cachehardmax
139%patch31 -p1 -b .sslmultiproxy
140
141%patch55 -p1 -b .malformedhost
142%patch56 -p1 -b .uniqueid
143
144%patch57 -p1 -b .sigint
145%patch58 -p1 -b .debug-crash
146
147# Patch in the vendor string
148sed -i '/^#define PLATFORM/s/Unix/%{vstring}/' os/unix/os.h
149
150# Prevent use of setcap in "install-suexec-caps" target.
151sed -i '/suexec/s,setcap ,echo Skipping setcap for ,' Makefile.in
152
153# add Vine configure's option to config.layout
154sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
155  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
156
157%build
158# remove bundled apr, apr-util, pcre
159rm -rf srclib/{apr,apr-util,pcre}
160
161# regenerate configure scripts
162autoheader && autoconf || exit 1
163
164CFLAGS="$RPM_OPT_FLAGS"
165SH_LDFLAGS="-Wl,-z,relro"
166export CFLAGS SH_LDFLAGS
167
168AP_CONFOPTS="\
169        --prefix=%{_sysconfdir}/apache2 \
170        --exec-prefix=%{_prefix} \
171        --bindir=%{_bindir} \
172        --sbindir=%{_sbindir} \
173        --mandir=%{_mandir} \
174        --libdir=%{_libdir} \
175        --sysconfdir=%{_sysconfdir}/apache2/conf \
176        --includedir=%{_includedir}/apache2 \
177        --libexecdir=%{_libdir}/apache2/modules \
178        --datadir=%{contentdir} \
179        --with-installbuilddir=%{_libdir}/apache2/build \
180        --enable-layout=Vine \
181        --with-program-name=apache2 \
182        --with-ldap \
183        --enable-ldap --enable-authnz-ldap \
184        --enable-mods-shared=all \
185        --enable-cache=shared \
186        --enable-cgi=shared \
187        --enable-cgid=shared \
188        --enable-rewrite=shared \
189        --enable-disk-cache=shared \
190        --enable-file-cache=shared \
191        --enable-mem-cache=shared \
192        --enable-authn-anon --enable-authn-alias \
193        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
194        --enable-suexec --with-suexec \
195        --enable-suexec-capabilities \
196        --with-suexec-caller=%{suexec_caller} \
197        --with-suexec-docroot=%{docroot} \
198        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
199        --with-suexec-bin=%{_sbindir}/suexec \
200        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
201        --with-pcre \
202        --enable-pie \
203        --enable-ssl --with-ssl \
204        --enable-deflate \
205        --enable-proxy --enable-proxy-connect \
206        --enable-proxy-http --enable-proxy-ftp \
207        --enable-case-filter --enable-case-filter-in \
208        --enable-mpms-shared=all"
209./configure ${AP_CONFOPTS}
210make %{?_smp_mflags}
211
212%install
213rm -rf $RPM_BUILD_ROOT
214
215make DESTDIR=$RPM_BUILD_ROOT install
216
217# create apache2ctl symlink
218ln -sf apachectl $RPM_BUILD_ROOT%{_sbindir}/apache2ctl
219
220# install conf file/directory
221mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d \
222      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d \
223      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/sites.d
224install -m 644 $RPM_SOURCE_DIR/README.confd \
225   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
226install -m 644 $RPM_SOURCE_DIR/README.confmod \
227   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/README
228
229for f in 00-base.conf 00-mpm.conf 00-lua.conf 01-cgi.conf 00-dav.conf \
230         00-proxy.conf 00-ssl.conf 01-ldap.conf 00-proxyhtml.conf \
231         01-ldap.conf 01-session.conf; do
232  install -m 644 -p $RPM_SOURCE_DIR/$f \
233                    $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/$f
234done
235
236for f in welcome.conf ssl.conf manual.conf userdir.conf; do
237  install -m 644 -p $RPM_SOURCE_DIR/$f \
238     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/$f
239done
240
241# Split-out extra config shipped as default in conf.d:
242for f in autoindex; do
243  mv docs/conf/extra/httpd-${f}.conf \
244     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/${f}.conf
245done
246         
247# Extra config trimmed:
248rm -v docs/conf/extra/httpd-{ssl,userdir}.conf
249
250rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
251install -m 644 -p $RPM_SOURCE_DIR/httpd.conf \
252   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
253ln -sf httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/apache2.conf
254
255# tmpfiles.d configuration
256mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d
257install -m 644 -p $RPM_SOURCE_DIR/apache2.tmpfiles \
258   $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/apache2.conf
259
260# Other directories
261mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav \
262         $RPM_BUILD_ROOT/run/apache2/htcacheclean
263
264# Create cache directory
265mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2 \
266         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/proxy \
267         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/ssl
268
269# Make the MMN accessible to module packages
270echo %{mmnisa} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
271mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
272cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.apache2 <<EOF
273%%_httpd_mmn %{mmnisa}
274%%_httpd_apxs %%{_bindir}/apxs
275%%_httpd_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
276%%_httpd_confdir %%{_sysconfdir}/apache2/conf.d
277%%_httpd_contentdir %{contentdir}
278%%_httpd_moddir %%{_libdir}/apache2/modules
279%%_apache2_mmn %{mmnisa}
280%%_apache2_apxs %%{_bindir}/apxs
281%%_apache2_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
282%%_apache2_confdir %%{_sysconfdir}/apache2/conf.d
283%%_apache2_contentdir %{contentdir}
284%%_apache2_moddir %%{_libdir}/apache2/modules
285EOF
286
287# Handle contentdir
288mkdir $RPM_BUILD_ROOT%{contentdir}/noindex
289install -m 644 -p $RPM_SOURCE_DIR/index.html \
290        $RPM_BUILD_ROOT%{contentdir}/noindex/index.html
291install -m 644 -p $RPM_SOURCE_DIR/poweredby-vine.png \
292        $RPM_BUILD_ROOT%{contentdir}/icons/
293rm -rf %{contentdir}/htdocs
294
295# remove manual sources
296find $RPM_BUILD_ROOT%{contentdir}/manual \( \
297    -name \*.xml -o -name \*.xml.* -o -name \*.ent -o -name \*.xsl -o -name \*.dtd \
298    \) -print0 | xargs -0 rm -f
299
300# Strip the manual down just to English and replace the typemaps with flat files:
301set +x
302for f in `find $RPM_BUILD_ROOT%{contentdir}/manual -name \*.html -type f`; do
303   if test -f ${f}.en; then
304      cp ${f}.en ${f}
305      rm ${f}.*
306   fi
307done
308set -x
309
310# Clean Document Root
311rm -v $RPM_BUILD_ROOT%{docroot}/html/*.html
312rm -v $RPM_BUILD_ROOT/var/www/cgi-bin/*
313
314# symlinks for /etc/apache2
315ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
316ln -s /run/apache2 $RPM_BUILD_ROOT/etc/apache2/run
317ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
318
319# install SYSV init stuff
320mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
321install -m755 $RPM_SOURCE_DIR/apache2.init \
322        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
323%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
324        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
325
326# Install logrotate config
327mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
328install -m 644 -p $RPM_SOURCE_DIR/apache2.logrotate \
329        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
330
331# fix man page paths
332sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
333    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
334    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
335    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
336    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
337    -e "s|/usr/local/apache2/logs/httpd.pid|/run/apache2/apache2.pid|" \
338    -e "s|/usr/local/apache2|/etc/httpd|" < docs/man/httpd.8 \
339  > $RPM_BUILD_ROOT%{_mandir}/man8/httpd.8
340
341# Make ap_config_layout.h libdir-agnostic
342sed -i '/.*DEFAULT_..._LIBEXECDIR/d;/DEFAULT_..._INSTALLBUILDDIR/d' \
343    $RPM_BUILD_ROOT%{_includedir}/apache2/ap_config_layout.h
344
345# Fix path to instdso in special.mk
346sed -i '/instdso/s,top_srcdir,top_builddir,' \
347    $RPM_BUILD_ROOT%{_libdir}/apache2/build/special.mk
348
349# Remove unpackaged files
350rm -vf \
351      $RPM_BUILD_ROOT%{_libdir}/*.exp \
352      $RPM_BUILD_ROOT/etc/apache2/conf/mime.types \
353      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
354      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
355      $RPM_BUILD_ROOT%{_bindir}/{ap?-config,dbmmanage} \
356      $RPM_BUILD_ROOT%{_sbindir}/{checkgid,envvars*} \
357      $RPM_BUILD_ROOT%{contentdir}/htdocs/* \
358      $RPM_BUILD_ROOT%{_mandir}/man1/dbmmanage.* \
359      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
360
361rm -rf $RPM_BUILD_ROOT/etc/apache2/conf/{original,extra}
362
363
364
365%triggerpostun -- apache < 2.0
366/sbin/chkconfig --add apache2
367
368
369%post
370/sbin/chkconfig --add apache2
371
372%preun
373if [ $1 = 0 ]; then
374        /sbin/service apache2 stop > /dev/null 2>&1
375        /sbin/chkconfig --del apache2
376fi
377
378%postun
379if [ "$1" -ge 1 ]; then
380        /sbin/service apache2 condrestart
381fi
382/sbin/ldconfig
383
384%define sslcert %{_sysconfdir}/pki/tls/certs/localhost.crt
385%define sslkey %{_sysconfdir}/pki/tls/private/localhost.key
386
387%post -n mod_ssl-apache2
388umask 077
389
390if [ -f %{sslkey} -o -f %{sslcert} ]; then
391  exit 0
392fi
393
394%{_bindir}/openssl genrsa \
395  -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime \
396  2048 > %{sslkey} 2> /dev/null ||:
397
398FQDN=`hostname` ||:
399if [ "x${FQDN}" = "x" ]; then
400   FQDN=localhost.localdomain
401fi
402   
403cat << EOF | %{_bindir}/openssl req -new -key %{sslkey} \
404         -x509 -sha256 -days 3650 -set_serial $RANDOM -extensions v3_req \
405         -out %{sslcert} 2>/dev/null ||:
406--
407SomeState
408SomeCity
409SomeOrganization
410SomeOrganizationalUnit
411${FQDN}
412root@${FQDN}
413EOF
414
415%clean
416rm -rf $RPM_BUILD_ROOT
417
418%files
419%defattr(-,root,root)
420
421%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
422%doc docs/conf/extra/*.conf
423
424%dir %{_sysconfdir}/apache2
425%{_sysconfdir}/apache2/modules
426%{_sysconfdir}/apache2/logs
427%{_sysconfdir}/apache2/run
428%dir %{_sysconfdir}/apache2/conf
429%config(noreplace) %{_sysconfdir}/apache2/conf/httpd.conf
430%config(noreplace) %{_sysconfdir}/apache2/conf/apache2.conf
431%config(noreplace) %{_sysconfdir}/apache2/conf/magic
432
433%config(noreplace) %{_sysconfdir}/logrotate.d/apache2
434
435%config %{_sysconfdir}/rc.d/init.d/apache2
436
437%dir %{_sysconfdir}/apache2/conf.d
438%{_sysconfdir}/apache2/conf.d/README
439%config(noreplace) %{_sysconfdir}/apache2/conf.d/*.conf
440%exclude %{_sysconfdir}/apache2/conf.d/ssl.conf
441%exclude %{_sysconfdir}/apache2/conf.d/manual.conf
442
443%dir %{_sysconfdir}/apache2/conf.modules.d
444%{_sysconfdir}/apache2/conf.modules.d/README
445%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/*.conf
446%exclude %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
447
448%dir %{_sysconfdir}/apache2/sites.d
449
450%{_prefix}/lib/tmpfiles.d/apache2.conf
451
452%{_bindir}/ab
453%{_bindir}/ht*
454%{_bindir}/logresolve
455%{_sbindir}/ht*
456%{_sbindir}/apache2
457%{_sbindir}/apachectl
458%{_sbindir}/apache2ctl
459%{_sbindir}/rotatelogs
460%{_sbindir}/fcgistarter
461%attr(4510,root,%{suexec_caller}) %{_sbindir}/suexec
462
463%dir %{_libdir}/apache2
464%dir %{_libdir}/apache2/modules
465%{_libdir}/apache2/modules/mod_*.so
466%exclude %{_libdir}/apache2/modules/mod_ssl.so
467
468%dir %{contentdir}
469%dir %{contentdir}/icons
470%dir %{contentdir}/error
471%dir %{contentdir}/error/include
472%dir %{contentdir}/noindex
473%{contentdir}/icons/*
474%{contentdir}/error/README
475%{contentdir}/error/*.var
476%{contentdir}/error/include/*.html
477%{contentdir}/noindex/index.html
478
479%dir %{docroot}/html
480%dir /var/www/cgi-bin
481
482%attr(0710,root,www-data) %dir /run/apache2
483%attr(0700,www-data,www-data) %dir /run/apache2/htcacheclean
484
485%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
486%attr(0700,www-data,www-data) %dir %{_localstatedir}/lib/dav
487%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2
488%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/proxy
489
490%{_mandir}/man1/*
491%exclude %{_mandir}/man1/apxs*
492
493%{_mandir}/man8/*
494
495
496%files manual
497%defattr(-,root,root)
498%{contentdir}/manual
499%config(noreplace) %{_sysconfdir}/apache2/conf.d/manual.conf
500
501
502%files -n mod_ssl-apache2
503%defattr(-,root,root)
504%{_libdir}/apache2/modules/mod_ssl.so
505%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
506%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
507%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/ssl
508
509
510%files devel
511%defattr(-,root,root)
512%{_includedir}/apache2
513%{_bindir}/apxs
514%{_mandir}/man1/apxs*
515%dir %{_libdir}/apache2/build
516%{_libdir}/apache2/build/*.mk
517%{_libdir}/apache2/build/*.sh
518%{_sysconfdir}/rpm/macros.apache2
519
520
521%changelog
522* Sun May 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.20-1
523- updated to 2.4.20.
524- updated Patch58.
525- fixed %%files.
526- fixed location of suexec (BTS#3007).
527
528* Thu Mar 10 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.18-2
529- rebuilt with openssl 1.0.2g
530
531* Thu Feb  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.18-1
532- updated to 2.4.18.
533- fixed 00-base.conf.
534- updated Patch31.
535
536* Mon Dec  7 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.17-2
537- fixed configuration files.
538
539* Fri Dec  4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.17-1
540- update to 2.4.17.
541- fixed dependency.
542
543* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-2
544- modify dependency
545
546* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-1
547- update to 2.4.9
548- remove suffix '2' from {htdigest,htpasswd,rotatelogs}2
549- use /run instead of /var/run
550- remove /etc/apache2/conf/ssl* , use /etc/pki now.
551- move suexec from %%{_libdir}/apache2 to %%{_sbindir}
552- split all LoadModules to conf.modules.d/*.conf
553- split module configs to conf.d/*.conf
554- cleanup docroot, move apache specific files to %%{_datadir}/apache2
555- add BR: lua-devel, libxml2-devel
556- add /etc/apache2/sites.d for virtual host settings.
557
558* Wed Dec 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.25-2
559- merge VineSeed spec file
560  * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-2
561  - rebuild with pcre-8.31
562
563  * Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-1
564  - update to 2.2.23
565  - add R(pre): www-common, BR: www-common
566  - move apache contents to %{contentdir}
567
568* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
569- new upstream release with security fix (CVE-2013-1862,1896)
570- drop patch100 (is included in new release)
571
572* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
573- add patch100 for fix CVE-2013-1862 (mod_rewrite)
574
575* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
576- new upstream release with security fix (CVE-2012-3499, 4558)
577
578* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
579- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
580- update patch22 to fit new release
581- update man filename convert list
582
583* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
584- update to 2.2.22
585  - CVE-2012-0021 (mod_log_config)
586  - CVE-2012-0031
587  - CVE-2012-0053
588- remove upstreamed patches
589
590* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
591- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
592
593* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
594- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
595
596* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
597- add patch70 for fix byterange filter
598
599* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
600- add Patch100 for fix CVE-2011-3368 (mod_proxy)
601
602* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
603- new upstream release with security fix (CVE-2011-3348)
604- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
605
606* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
607- update Patch101 (Thanks to debian team)
608
609* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
610- add Patch101 for fix CVE-2011-3192 regression
611
612* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
613- new upstream release with security fix (CVE-2011-3192)
614- drop patch100 (is included in new release)
615
616* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
617- add patch100 for fix CVE-2011-3192 (Range Header DoS)
618
619* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
620- update to 2.2.19
621
622* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
623- remove old Obsoletes/Conflicts
624
625* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
626- rebuild with openssl-1.0.0c
627
628* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
629- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
630
631* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
632- add R(post): alternatives
633
634* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
635- add patch110 for fix CVE-2010-0434 from mdk 2010
636
637* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
638- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
639
640* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
641- rebuilt with rpm-4.8.0-3 (on ppc)
642
643* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
644- rebuild with db4-4.8.0
645
646* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
647- new upstream release with security fix
648  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
649- fix ssl.conf (2.2.13-1 includes wrong file)
650
651* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
652- new upstream release
653
654* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
655- new upstream release
656  (including security fix for CVE-2009-1890, CVE-2009-1191,
657   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
658
659* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
660- rebuilt with openldap-2.4.11
661
662* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
663- new upstream release
664
665* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
666- new upstream release (including security fix for CVE-2008-2939)
667
668* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
669- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
670- built with db4-4.6.21, apr 1.3.0
671
672* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
673- add Patch60 (to fix bug#31418).
674
675* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
676- rebuild with expat-2.0.1
677
678* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
679- new upstream release
680
681* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
682- added postun script from VinePlus/4.0 package
683  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
684  - add postun script to restart daemon with message
685
686* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
687- updated Patch2: httpd-2.2.3-apxs.patch
688
689* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
690- modified libdir in config.layout for lib64 architecture
691
692* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
693- rebuilt with openssl-0.9.8e
694
695* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
696- rebuilt with new toolchain and db4-4.3.x
697
698* Wed Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
699- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
700
701* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
702- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
703
704* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
705- rebuilt with openldap-2.3.27-0vl1
706
707* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
708- new upstream release including security fix (CVE-2006-3747)
709
710* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
711- new upstream release
712  - update to 2.2.2
713- remove apr/apr-devel subpackage,
714  use external apr/apr-util instead of internal one.
715
716* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
717- new upstream release
718- use apache2.prefork as default.
719
720* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
721- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
722- remove unpackaged files in %%install section
723
724* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
725- fix logrotate configuration (use apache2.pid instead of httpd.pid)
726  (BTS:10)
727- use Epoch instead of Serial
728
729* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
730- new upstream release
731- drop obsolete security patches which is merged in upstream
732
733* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
734- new upstream release
735
736* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
737- added Patch122 to 125 for secutiry fix
738  (CAN-2004-{1268,2088,2700,2728})
739- fix %install section
740
741* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
742- new upstream release
743
744* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
745- new upstream release
746
747* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
748- rebuilt with db4-4.2.52
749
750* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
751- separate apr, apr-devel packages
752- add BuildPreReq: zlib-devel
753
754* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
755- fix %%files to include instdso.sh
756  thanks to jax <jax AT morejams DOT no-ip DOT com>
757- add %%{?_smp_mflags} to make option.
758
759* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
760- new upstream version
761
762* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
763- new upstream version
764
765* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
766- new upstream version
767- update apxs patch (Patch101)
768- fix dependency:
769    - change file name to package name in Requires and {Build,}Prereq
770- add BuildPrereq: openldap-devel
771- update %%files section
772- rename httpd.8 manpage
773
774* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
775- new upstream version
776- used vine-config.layout in srclib
777
778* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
779- rebuild
780
781* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
782- change pkg name from mod_ssl to mod_ssl-apache2
783- remove "apache-manual" entry from Obsoletes:
784
785* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
786- remove "mod_dav" and "apache-devel" from Obsoletes:
787- enable MPMS(worker %mpms )
788
789* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
790- add correct config_vars.mk
791
792* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
793- apply apxs's patch ( from Debian)
794
795* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
796- add apr-config,apu-config to devel's %file
797
798* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
799- change apxs path ( /usr/sbin -> /usr/bin
800- add symlink under /etc/apache2/conf
801  (logs, run), httpd.conf -> apache2.conf
802- fixed apache2 initscript.
803
804* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
805- build Vine Linux
806- new upstream version
807- sharing with apache1
808
809* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
810- link httpd with libssl to avoid library loading/unloading weirdness
811
812* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
813- add LoadModule lines for proxy modules in httpd.conf (#73349)
814- fix permissions of conf/ssl.*/ directories; add Makefiles for
815  certificate management (#73352)
816
817* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
818- provide "httpd-mmn" to manage module ABI compatibility
819
820* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
821- fix SSL session cache (#69699)
822- revert addition of LDAP support to apr-util
823
824* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
825- set SIGXFSZ disposition to "ignored" (#69520)
826- make dummy connections to the first listener in config (#72692)
827
828* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
829- allow "apachectl configtest" on a 1.3 httpd.conf
830- add mod_deflate
831- enable LDAP support in apr-util
832- don't package everything in /var/www/error as config(noreplace)
833
834* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
835- add trigger (#68657)
836
837* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
838- update to 2.0.40
839
840* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
841- improve comment on use of UserDir in default config (#66886)
842
843* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
844- use /sbin/nologin as shell for apache user (#68371)
845- add patch from CVS to fix possible infinite loop when processing
846  internal redirects
847
848* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
849- modify init script to detect 1.3.x httpd.conf's and direct users
850  to the migration guide
851
852* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
853- patch apachectl to detect 1.3.x httpd.conf's and direct users
854  to the migration guide
855- ship the migration guide
856
857* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
858- move /etc/httpd2 back to /etc/httpd
859- add noindex.html page and poweredby logo; tweak default config
860  to load noindex.html if no default "/" page is present.
861- add patch to prevent mutex errors on graceful restart
862
863* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
864- automated rebuild
865
866* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
867- add patch to fix SSL mutex handling
868
869* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
870- improved config directory patch
871
872* Mon May 20 2002 Joe Orton <jorton@redhat.com>
873- initial build; based heavily on apache.spec and mod_ssl.spec
874- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
875
Note: See TracBrowser for help on using the repository browser.