source: projects/specs/trunk/a/anthy/anthy-vl.spec @ 1045

Revision 1045, 10.6 KB checked in by kazutaka, 14 years ago (diff)

UTUMI-san patch を特許侵害の恐れの無いバージョンに更新

Line 
1%define __libtoolize :
2
3%define emacsen_pkg     1
4%{?without_emacsen: %define emacsen_pkg 0}
5
6%if %{emacsen_pkg}
7%undefine without_emacsen
8%define anthy_el        anthy-el
9%define anthy           anthy
10%define emacsen_pkgdir /usr/lib/emacsen-common/packages
11%else
12%define without_emacsen 1
13%endif
14
15%define ut_patch_date   20100517
16
17Summary: A Japanese character input system library (with dictionary).
18Summary(ja): Anthy - 日本語入力システムおよび辞書
19Name: anthy
20Version: 9100h
21Release: 8%{?_dist_release}
22URL: http://www.sourceforge.jp/projects/anthy/
23Source: %{name}-%{version}.tar.gz
24Source1: anthy-el-install.sh
25Source2: anthy-el-remove.sh
26Source3: anthy-init.el
27Source4: vine-default-anthy.el
28# large dictionary and improvement patch made by UTSUMI at
29# http://www.geocities.jp/ep3797/anthy_dict_01.html
30# also it includes some patches made by G-HAL at
31# http://www.fenix.ne.jp/~G-HAL/soft/nosettle/#anthy
32Patch100: anthy-ut-patches-%{ut_patch_date}.tar.bz2
33License: GPL, LGPL, BSD
34Group: Applications/System
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36#BuildRequires: automake16, autoconf
37
38Vendor: Project Vine
39Distribution: Vine Linux
40Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
41
42%description
43Anthy is free and secure Japanese input system.
44
45%description -l ja
46Anthy はフリーでセキュアな日本語入力システムです。
47
48%if %{emacsen_pkg}
49%package -n %{anthy_el}
50Summary: Emacs-lisp frontend for Anthy
51Summary(ja): Anthy 用 Emacs-lisp フロントエンド
52Group: Applications/Editors/Emacs
53BuildRequires: emacsen
54Requires(post,preun): emacsen, emacsen-common >= 0.1
55Requires: %{name} = %{version}-%{release}
56
57%description -n %{anthy_el}
58Emacs-lisp frontend for Anthy
59
60%description -n %{anthy_el} -l ja
61Anthy のための Emacs-lisp フロントエンド
62%endif
63
64%package devel
65Summary: Development files for libanthy
66Summary(ja): libanthy を使ったアプリケーションを開発するためのファイル
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69Requires: pkgconfig
70
71%description devel
72Devepment files for anthy libraries.
73
74%description devel -l ja
75libanthy を利用したアプリケーションを開発するために必要なヘッダやライブラリ
76が含まれています。
77
78
79%prep
80%setup -q
81
82# apply conversion improvement and large dict patch set
83%{__tar} xjf %{PATCH100}
84pushd anthy-ut-patches-%{ut_patch_date}
85./apply-patches.sh
86popd
87
88%build
89#libtoolize --copy --force
90autoreconf -f -i
91%configure --localstatedir=%{_var}
92
93#%__make %{?_smp_mflags}
94# don't use smp option
95%__make
96
97
98%install
99%__rm -rf ${RPM_BUILD_ROOT}
100%makeinstall
101%if %{emacsen_pkg}
102%__mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
103#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
104#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
105%__cp -af %{SOURCE3} %{SOURCE4} \
106    ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
107%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
108%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
109%endif
110
111%if %{emacsen_pkg}
112%{?emacsen_pkg: %_installemacsenscript %{anthy} %{SOURCE1}}
113%{?emacsen_pkg: %_removeemacsenscript  %{anthy} %{SOURCE2}}
114%else
115%__rm -rf ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
116%endif
117
118## remove unuse files
119rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
120
121
122%if %{emacsen_pkg}
123%post -n %{anthy_el}
124if [ "$1" = 2 ]; then
125  %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
126fi
127%{?emacsen_pkg: %_addemacsenlist %{anthy}}
128%{?emacsen_pkg: %_emacsenPackageInstall %{anthy}}
129
130
131%preun -n %{anthy_el}
132if [ "$1" = 0 ]; then
133  %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
134
135  %{?emacsen_pkg: %_removeemacsenlist %{anthy}}
136
137fi
138%endif
139
140
141%clean
142%__rm -rf ${RPM_BUILD_ROOT}
143
144
145%post -p /sbin/ldconfig
146
147
148%postun -p /sbin/ldconfig
149
150
151%files
152%defattr(-,root,root)
153%{_bindir}/*
154%{_sysconfdir}/*
155%{_datadir}/anthy
156%{_libdir}/libanthy*.so
157%{_libdir}/libanthy*.so.*
158%doc AUTHORS COPYING ChangeLog DIARY NEWS README doc Doxyfile README.en
159
160%if %{emacsen_pkg}
161%files -n %{anthy_el}
162%defattr(-, root, root)
163%{_datadir}/emacs/site-lisp/%{anthy}
164#%{_prefix}/lib/emacsen-common/packages/install/%{anthy}
165#%{_prefix}/lib/emacsen-common/packages/remove/%{anthy}
166%{emacsen_pkgdir}/install/%{anthy}
167%{emacsen_pkgdir}/remove/%{anthy}
168%endif
169
170%files devel
171%defattr(-,root,root)
172%{_includedir}/*
173%{_libdir}/libanthy*.a
174#%{_libdir}/libanthy*.la
175%{_libdir}/pkgconfig/*.pc
176
177%changelog
178* Wed May 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 9100h-8
179- update Patch100 (anthy-ut-patches-20100517.tar.bz2)
180- run autoreconf at %%build section
181
182* Tue Jul 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-7
183- updated vine-default-anthy.el
184  - set 1 for anthy-accept-timeout (because default timeout is too long)
185
186* Sat Jun 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-6
187- update Patch100 (anthy-ut-patches-20090604.tar.bz2)
188
189* Mon May 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-5
190- update Patch100 (anthy-ut-patches-20090507.tar.bz2)
191
192* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-4
193- updated anthy-el-install.sh
194  - *-init.el: changed from hard copy to symbolic link
195    on /etc/emacs-XX.YY/site-start.d
196- corrected byte-compiling messages of emacs flaver
197
198* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-3
199- added vine-default-anthy.el
200- updated anthy-el-install.sh, anthy-el-remove.sh for vine-default-anthy.el
201
202* Tue Apr 07 2009 Shu KONNO <owa@bg.wakwak.com> 9100h-2
203- removed %%{?_smp_mflags} at make
204
205* Sun Mar 15 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-1
206- new upstream release
207- update Patch100
208
209* Wed Jan 21 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100e-3
210- add patch100 to improve conversion logic and add large dirctionary
211- add License LGPL and BSD for added patches
212-
213
214* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 9100e-2vl5
215- added %%emacsen_pkgdir
216- removed *.la
217- spec in utf-8
218
219* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100e-1vl5
220- new upstream release
221
2221* Fri Dec 28 2007 IWAI, Masaharu <iwai@alib.jp> 9100d-0vl1
223- new upstream release
224
225* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100-0vl1
226- new upstream release
227
228* Fri Jun 15 2007 IWAI, Masaharu <iwai@alib.jp> 9011-0vl1
229- new upstream release
230
231* Tue Oct 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl3
232- use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
233
234* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7900-0vl2
235- changed anthy-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
236
237* Fri Aug 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl1
238- new upstream release
239
240* Fri Apr 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500b-0vl1
241- new upstream release
242
243* Sat Mar 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500-0vl1
244- new upstream release
245
246* Fri Dec 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl3
247- add BuildRequires: emacsen instead of emacs
248- add Requires: %%{name} to anthy-el package
249- add libanthy*.la to devel package
250- update anthy-el-install.sh
251  - add anthy-azik.el, anthy-kyuri.el
252
253* Sun Dec 18 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl2
254- add BuildRequires: emacs
255
256* Tue Dec 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl1
257- new upstream release
258
259* Mon Oct 17 2005 IWAI, Masaharu <iwai@alib.jp> 7015-0vl1
260- new upstream release
261
262* Mon Oct 10 2005 IWAI, Masaharu <iwai@alib.jp> 6829-0vl1
263- new upstream release
264
265* Sun Jul 31 2005 IWAI, Masaharu <iwai@alib.jp> 6724-0vl1
266- new upstream release
267- add documents: Doxyfile and README.en
268
269* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6700b-0vl1
270- new upstream release
271
272* Tue May 10 2005 IWAI, Masaharu <iwai@alib.jp> 6508-0vl1
273- new upstream release
274
275* Sat Apr  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6300d-0vl1
276- new upstream release
277- added %{_libdir}/pkgconfig/anthy.pc to devel package
278
279* Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5812-0vl1
280- new upstream release
281
282* Sat Oct 09 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5714-0vl1
283- new upstream release
284
285* Sun Jul 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5500-0vl1
286- new upstream release
287
288* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl3
289- move libanthy*.so to anthy main package. it is needed by some
290  anthy application.
291
292* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl2
293- split development files to anthy-devel
294
295* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl1
296- new upstream release
297
298* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5220-0vl1
299- new upstream release
300
301* Wed Mar 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5122-0vl1
302- new upstream release
303
304* Sun Feb 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5100-0vl1
305- new upstream release
306
307* Mon Feb 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5021-0vl1
308- new upstream release
309
310* Wed Feb 11 2004 IWAI, Masaharu <iwai@alib.jp> 5008-0vl1
311- new upstream release
312
313* Tue Jan 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4925-0vl1
314- new upstream release
315
316* Sun Jan 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4901-0vl1
317- new upstream release
318
319* Thu Nov 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4723-0vl1
320- new upstream release
321
322* Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4708-0vl1
323- new upstream release
324
325* Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 4524-0vl1
326- new upstream release
327
328* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 4520-0vl1
329- new upstream release
330
331* Tue Sep  9 2003 IWAI, Masaharu <iwai@alib.jp> 4507-0vl3
332- update anthy-el-install.sh (Source1): [VineSeed-Plus:01834]
333  - The files to byte-compile is made the same as the upstream.
334
335* Tue Sep  9 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4507-0vl2
336- not bytecompile leim-list.el for XEmacs
337
338* Sun Sep 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4507-0vl1
339- new upstream release
340
341* Sun Aug 31 2003 IWAI, Masaharu <iwai@alib.jp> 4431-0vl1
342- new upstream snapshot release
343- create anthy-el package for emacsen
344
345* Fri Aug 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4421-0vl1
346- new upstream snapshot release
347
348* Fri Jul 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4300-0vl1
349- initial build for Vine Linux
350
351* Thu Jul 10 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp>
352- up to 4200.
353- added description.
354
355* Fri Nov 25 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
356- 3500c-1
357- up to 3500c.
358- added some documents.
359
360* Fri Nov 22 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
361- up to 3500b.
362
363* Thu Jan  3 2002 Yusuke Tabata <yusuke@kmc.gr.jp>
364- changed my mail address and URL of web page
365
366* Thu Nov 11 2001 Takayoshi Nobuoka <taka@trans-nt.com>
367- add %{_sysconfdir}/* at %files
368
369* Wed Sep  9 2001 Takayoshi Nobuoka <taka@trans-nt.com>
370- use _bindir and so on.
371
372* Sun Aug 19 2001 Tabatee <yusuke@kmc.kyoto-u.ac.jp>
373- Initial build.
374
Note: See TracBrowser for help on using the repository browser.