source: projects/specs/trunk/a/anthy/anthy-vl.spec @ 521

Revision 521, 10.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define __libtoolize :
2
3%define emacsen_pkg     1
4%{?without_emacsen: %define emacsen_pkg 0}
5
6%if %{emacsen_pkg}
7%undefine without_emacsen
8%define anthy_el        anthy-el
9%define anthy           anthy
10%define emacsen_pkgdir /usr/lib/emacsen-common/packages
11%else
12%define without_emacsen 1
13%endif
14
15%define ut_patch_date   20090604
16
17Summary: A Japanese character input system library (with dictionary).
18Summary(ja): Anthy - 日本語入力システムおよび辞書
19Name: anthy
20Version: 9100h
21Release: 7%{?_dist_release}
22URL: http://www.sourceforge.jp/projects/anthy/
23Source: %{name}-%{version}.tar.gz
24Source1: anthy-el-install.sh
25Source2: anthy-el-remove.sh
26Source3: anthy-init.el
27Source4: vine-default-anthy.el
28# large dictionary and improvement patch made by UTSUMI at
29# http://www.geocities.jp/ep3797/anthy_dict_01.html
30# also it includes some patches made by G-HAL at
31# http://www.fenix.ne.jp/~G-HAL/soft/nosettle/#anthy
32Patch100: anthy-ut-patches-%{ut_patch_date}.tar.bz2
33License: GPL, LGPL, BSD
34Group: Applications/System
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36#BuildRequires: automake16, autoconf
37
38Vendor: Project Vine
39Distribution: Vine Linux
40Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
41
42%description
43Anthy is free and secure Japanese input system.
44
45%description -l ja
46Anthy はフリーでセキュアな日本語入力システムです。
47
48%if %{emacsen_pkg}
49%package -n %{anthy_el}
50Summary: Emacs-lisp frontend for Anthy
51Summary(ja): Anthy 用 Emacs-lisp フロントエンド
52Group: Applications/Editors/Emacs
53BuildRequires: emacsen
54Requires(post,preun): emacsen, emacsen-common >= 0.1
55Requires: %{name} = %{version}-%{release}
56
57%description -n %{anthy_el}
58Emacs-lisp frontend for Anthy
59
60%description -n %{anthy_el} -l ja
61Anthy のための Emacs-lisp フロントエンド
62%endif
63
64%package devel
65Summary: Development files for libanthy
66Summary(ja): libanthy を使ったアプリケーションを開発するためのファイル
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69Requires: pkgconfig
70
71%description devel
72Devepment files for anthy libraries.
73
74%description devel -l ja
75libanthy を利用したアプリケーションを開発するために必要なヘッダやライブラリ
76が含まれています。
77
78
79%prep
80%setup -q
81
82# apply conversion improvement and large dict patch set
83%{__tar} xjf %{PATCH100}
84pushd anthy-ut-patches-%{ut_patch_date}
85./apply-patches.sh
86popd
87
88%build
89libtoolize --copy --force
90%configure --localstatedir=%{_var}
91
92#%__make %{?_smp_mflags}
93# don't use smp option
94%__make
95
96
97%install
98%__rm -rf ${RPM_BUILD_ROOT}
99%makeinstall
100%if %{emacsen_pkg}
101%__mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
102#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
103#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
104%__cp -af %{SOURCE3} %{SOURCE4} \
105    ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
106%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
107%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
108%endif
109
110%if %{emacsen_pkg}
111%{?emacsen_pkg: %_installemacsenscript %{anthy} %{SOURCE1}}
112%{?emacsen_pkg: %_removeemacsenscript  %{anthy} %{SOURCE2}}
113%else
114%__rm -rf ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
115%endif
116
117## remove unuse files
118rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
119
120
121%if %{emacsen_pkg}
122%post -n %{anthy_el}
123if [ "$1" = 2 ]; then
124  %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
125fi
126%{?emacsen_pkg: %_addemacsenlist %{anthy}}
127%{?emacsen_pkg: %_emacsenPackageInstall %{anthy}}
128
129
130%preun -n %{anthy_el}
131if [ "$1" = 0 ]; then
132  %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
133
134  %{?emacsen_pkg: %_removeemacsenlist %{anthy}}
135
136fi
137%endif
138
139
140%clean
141%__rm -rf ${RPM_BUILD_ROOT}
142
143
144%post -p /sbin/ldconfig
145
146
147%postun -p /sbin/ldconfig
148
149
150%files
151%defattr(-,root,root)
152%{_bindir}/*
153%{_sysconfdir}/*
154%{_datadir}/anthy
155%{_libdir}/libanthy*.so
156%{_libdir}/libanthy*.so.*
157%doc AUTHORS COPYING ChangeLog DIARY NEWS README doc Doxyfile README.en
158
159%if %{emacsen_pkg}
160%files -n %{anthy_el}
161%defattr(-, root, root)
162%{_datadir}/emacs/site-lisp/%{anthy}
163#%{_prefix}/lib/emacsen-common/packages/install/%{anthy}
164#%{_prefix}/lib/emacsen-common/packages/remove/%{anthy}
165%{emacsen_pkgdir}/install/%{anthy}
166%{emacsen_pkgdir}/remove/%{anthy}
167%endif
168
169%files devel
170%defattr(-,root,root)
171%{_includedir}/*
172%{_libdir}/libanthy*.a
173#%{_libdir}/libanthy*.la
174%{_libdir}/pkgconfig/*.pc
175
176%changelog
177* Tue Jul 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-7
178- updated vine-default-anthy.el
179  - set 1 for anthy-accept-timeout (because default timeout is too long)
180
181* Sat Jun 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-6
182- update Patch100 (anthy-ut-patches-20090604.tar.bz2)
183
184* Mon May 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-5
185- update Patch100 (anthy-ut-patches-20090507.tar.bz2)
186
187* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-4
188- updated anthy-el-install.sh
189  - *-init.el: changed from hard copy to symbolic link
190    on /etc/emacs-XX.YY/site-start.d
191- corrected byte-compiling messages of emacs flaver
192
193* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-3
194- added vine-default-anthy.el
195- updated anthy-el-install.sh, anthy-el-remove.sh for vine-default-anthy.el
196
197* Tue Apr 07 2009 Shu KONNO <owa@bg.wakwak.com> 9100h-2
198- removed %%{?_smp_mflags} at make
199
200* Sun Mar 15 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-1
201- new upstream release
202- update Patch100
203
204* Wed Jan 21 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100e-3
205- add patch100 to improve conversion logic and add large dirctionary
206- add License LGPL and BSD for added patches
207-
208
209* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 9100e-2vl5
210- added %%emacsen_pkgdir
211- removed *.la
212- spec in utf-8
213
214* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100e-1vl5
215- new upstream release
216
2171* Fri Dec 28 2007 IWAI, Masaharu <iwai@alib.jp> 9100d-0vl1
218- new upstream release
219
220* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100-0vl1
221- new upstream release
222
223* Fri Jun 15 2007 IWAI, Masaharu <iwai@alib.jp> 9011-0vl1
224- new upstream release
225
226* Tue Oct 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl3
227- use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
228
229* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7900-0vl2
230- changed anthy-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
231
232* Fri Aug 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl1
233- new upstream release
234
235* Fri Apr 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500b-0vl1
236- new upstream release
237
238* Sat Mar 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500-0vl1
239- new upstream release
240
241* Fri Dec 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl3
242- add BuildRequires: emacsen instead of emacs
243- add Requires: %%{name} to anthy-el package
244- add libanthy*.la to devel package
245- update anthy-el-install.sh
246  - add anthy-azik.el, anthy-kyuri.el
247
248* Sun Dec 18 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl2
249- add BuildRequires: emacs
250
251* Tue Dec 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl1
252- new upstream release
253
254* Mon Oct 17 2005 IWAI, Masaharu <iwai@alib.jp> 7015-0vl1
255- new upstream release
256
257* Mon Oct 10 2005 IWAI, Masaharu <iwai@alib.jp> 6829-0vl1
258- new upstream release
259
260* Sun Jul 31 2005 IWAI, Masaharu <iwai@alib.jp> 6724-0vl1
261- new upstream release
262- add documents: Doxyfile and README.en
263
264* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6700b-0vl1
265- new upstream release
266
267* Tue May 10 2005 IWAI, Masaharu <iwai@alib.jp> 6508-0vl1
268- new upstream release
269
270* Sat Apr  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6300d-0vl1
271- new upstream release
272- added %{_libdir}/pkgconfig/anthy.pc to devel package
273
274* Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5812-0vl1
275- new upstream release
276
277* Sat Oct 09 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5714-0vl1
278- new upstream release
279
280* Sun Jul 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5500-0vl1
281- new upstream release
282
283* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl3
284- move libanthy*.so to anthy main package. it is needed by some
285  anthy application.
286
287* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl2
288- split development files to anthy-devel
289
290* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl1
291- new upstream release
292
293* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5220-0vl1
294- new upstream release
295
296* Wed Mar 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5122-0vl1
297- new upstream release
298
299* Sun Feb 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5100-0vl1
300- new upstream release
301
302* Mon Feb 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5021-0vl1
303- new upstream release
304
305* Wed Feb 11 2004 IWAI, Masaharu <iwai@alib.jp> 5008-0vl1
306- new upstream release
307
308* Tue Jan 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4925-0vl1
309- new upstream release
310
311* Sun Jan 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4901-0vl1
312- new upstream release
313
314* Thu Nov 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4723-0vl1
315- new upstream release
316
317* Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4708-0vl1
318- new upstream release
319
320* Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 4524-0vl1
321- new upstream release
322
323* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 4520-0vl1
324- new upstream release
325
326* Tue Sep  9 2003 IWAI, Masaharu <iwai@alib.jp> 4507-0vl3
327- update anthy-el-install.sh (Source1): [VineSeed-Plus:01834]
328  - The files to byte-compile is made the same as the upstream.
329
330* Tue Sep  9 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4507-0vl2
331- not bytecompile leim-list.el for XEmacs
332
333* Sun Sep 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4507-0vl1
334- new upstream release
335
336* Sun Aug 31 2003 IWAI, Masaharu <iwai@alib.jp> 4431-0vl1
337- new upstream snapshot release
338- create anthy-el package for emacsen
339
340* Fri Aug 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4421-0vl1
341- new upstream snapshot release
342
343* Fri Jul 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4300-0vl1
344- initial build for Vine Linux
345
346* Thu Jul 10 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp>
347- up to 4200.
348- added description.
349
350* Fri Nov 25 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
351- 3500c-1
352- up to 3500c.
353- added some documents.
354
355* Fri Nov 22 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
356- up to 3500b.
357
358* Thu Jan  3 2002 Yusuke Tabata <yusuke@kmc.gr.jp>
359- changed my mail address and URL of web page
360
361* Thu Nov 11 2001 Takayoshi Nobuoka <taka@trans-nt.com>
362- add %{_sysconfdir}/* at %files
363
364* Wed Sep  9 2001 Takayoshi Nobuoka <taka@trans-nt.com>
365- use _bindir and so on.
366
367* Sun Aug 19 2001 Tabatee <yusuke@kmc.kyoto-u.ac.jp>
368- Initial build.
Note: See TracBrowser for help on using the repository browser.