source: projects/specs/trunk/a/alacarte/alacarte-vl.spec @ 521

Revision 521, 7.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           alacarte
4Version:        0.12.4
5Release:        2%{?_dist_release}
6Summary:        Menu editor for the GNOME desktop
7Summary(ja):    GNOME デスクトップ用メニューエディタ
8
9Group:          Applications/System
10License:        LGPLv2+
11URL:            http://www.gnome.org
12Source0:        http://download.gnome.org/sources/alacarte/0.12/%{name}-%{version}.tar.bz2
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15
16BuildRequires:  python, python-devel, gettext
17BuildRequires:  pygtk2-devel
18BuildRequires:  pkgconfig
19BuildRequires:  gnome-menus-devel >= 2.27.92
20BuildRequires:  intltool
21BuildRequires:  desktop-file-utils
22Requires:       pygtk2, gnome-python
23Requires:       gnome-menus >= 2.27.92
24
25Patch0:         undo-delete.patch
26
27%description
28Alacarte is a graphical menu editor that lets you edit, add, and delete
29menu entries. It follows the freedesktop.org menu specification and
30should work with any desktop environment that uses this specification.
31
32%prep
33%setup -q
34%patch0 -p1 -b .undo-delete
35
36%build
37%configure
38make
39
40%install
41rm -rf $RPM_BUILD_ROOT
42make install DESTDIR=$RPM_BUILD_ROOT
43
44# desktop-file-install can't manipulate NotShowIn
45sed -i -e 's/NotShowIn=KDE;/OnlyShowIn=GNOME;/' \
46  $RPM_BUILD_ROOT%{_datadir}/applications/alacarte.desktop
47desktop-file-validate \
48  $RPM_BUILD_ROOT%{_datadir}/applications/alacarte.desktop
49
50
51%find_lang %{name}
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%post
57touch --no-create %{_datadir}/icons/hicolor
58if [ -x /usr/bin/gtk-update-icon-cache ]; then
59  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
60fi
61
62%postun
63touch --no-create %{_datadir}/icons/hicolor
64if [ -x /usr/bin/gtk-update-icon-cache ]; then
65  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
66fi
67
68%files -f %{name}.lang
69%defattr(-,root,root,-)
70%doc README AUTHORS COPYING
71%{python_sitelib}/Alacarte
72%{_bindir}/alacarte
73%{_datadir}/applications/alacarte.desktop
74%{_datadir}/alacarte
75%{_datadir}/icons/hicolor/16x16/apps/alacarte.png
76%{_datadir}/icons/hicolor/22x22/apps/alacarte.png
77%{_datadir}/icons/hicolor/24x24/apps/alacarte.png
78%{_datadir}/icons/hicolor/32x32/apps/alacarte.png
79%{_datadir}/icons/hicolor/48x48/apps/alacarte.png
80%{_datadir}/icons/hicolor/256x256/apps/alacarte.png
81
82%changelog
83* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.12.4-2
84- initial build for Vine Linux
85
86* Mon Sep 21 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.4-1
87- Update to 0.12.4
88
89* Sat Sep 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.3-2
90- Bump the gnome-menus requires
91
92* Tue Sep  8 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.3-1
93- Update to 0.12.3
94
95* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.1-2
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
97
98* Sat May 16 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.1-1
99- Update to 0.12.1
100
101* Tue Mar 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.10-1
102- Update to 0.11.10
103
104* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.9-3
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
106
107* Mon Feb 23 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.9-2
108- Only show in GNOME (#486887)
109
110* Tue Feb 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.9-1
111- Update to 0.11.9
112
113* Tue Feb  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.8-1
114- Update to 0.11.8
115
116* Tue Jan 20 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.7-1
117- Update to 0.11.7
118
119* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.11.6-6
120- Rebuild for Python 2.6
121
122* Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-5
123- Tweak %%summary and %%description
124
125* Fri Oct 17 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-4
126- Make undoing of deletion work
127
128* Mon Sep 22 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-3
129- Update to 0.11.6
130
131* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.5-1
132- Update to 0.11.5
133
134* Thu Feb 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.4-1
135- Update to 0.11.4
136
137* Sun Dec 02 2007 Todd Zullinger <tmz@pobox.com> - 0.11.3-5
138- put the python scripts in sitelib, not sitearch
139- remove autoconf, automake, and intltool BRs
140- don't run autoconf/automake in %%build
141- BR perl(XML::Parser)
142- remove smeg Obsoletes and Provides
143- minor rpmlint cleanups
144
145* Sat Aug 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.3-4
146- Fix the build with intltool 0.36
147- Update the license field
148
149* Fri Mar 23 2007 Ray Strode <rstrode@redhat.com> - 0.11.3-3
150- change url to gnome.org (bug 233237)
151
152* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.3-2
153- Update to 0.11.3
154
155* Mon Feb 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.2-1.svn20070212
156- Bring back editing of the System menu
157
158* Fri Jan 26 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.1.1-2
159- Fix the Provides: line
160
161* Thu Jan 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.1.1-1
162- Update to 0.11.1.1
163
164* Wed Dec 20 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.2-2
165- Update to 0.10.2
166
167* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.1-4
168- try again
169
170* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 0.10.1-2
171- build against python 2.5
172
173* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.1-1
174- Update to 0.10.1
175* Mon Sep  4 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.0-1.fc6
176- Update to 0.10.0
177
178* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-7.fc6
179- Fix more build requires
180
181* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-3.fc6
182- Add BR for pkgconfig
183
184* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-1.fc6
185- Update to 0.9.90
186
187* Thu Aug 17 2006 Ray Strode <rstrode@redhat.com> - 0.8-8
188- initial build for Fedora Core
189
190* Wed Feb 15 2006 John Mahowald <jpmahowald@gmail.com> - 0.8-7
191- Rebuild for Fedora Extras 5
192
193* Fri Feb 3 2006  John Mahowald <jpmahowald@gmail.com> - 0.8-3
194- Fix stray reference to smeg
195- Use python sitearch macro from template
196
197* Sat Oct 29 2005  John Mahowald <jpmahowald@gmail.com> - 0.8-2
198- Rebuild
199
200* Thu Oct 27 2005  John Mahowald <jpmahowald@gmail.com> - 0.8-1
201- rename to alacarte
202- Update to 0.8
203
204* Thu Oct 20 2005  John Mahowald <jpmahowald@gmail.com> - 0.7.5-4
205- remove requires gnome-menus
206
207* Tue Aug 30 2005 John Mahowald <jpmahowald@gmail.com> - 0.7.5-3
208- Move to /usr/share
209
210* Tue Jun 28 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.5-2
211- Desktop-file-utils for kde desktop entry as well as default one.
212
213* Wed Jun 08 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.5-1
214- Rebuilt for 0.7.5
215
216* Sun Jun 06 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.4-1
217- Rebuilt for 0.7.4
218
219* Wed Jun 01 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.1-1
220- Rebuilt for 0.7.1
221- Smeg now use the stock gnome menu icon, removed pixmaps from %%files
222
223* Wed Jun 01 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7-2
224- Added missing dependency gnome-python2-gconf
225
226* Tue May 31 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7-1
227- Rebuilt for 0.7
228
229* Mon May 30 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.6.2-2
230- Added desktop-file-utils to Buildrequires
231- Addded desktop-file-utils %%post and %%postun
232
233* Sat May 29 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.6.2-1
234- Rebuilt for 0.6.2
235
236* Mon May 23 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.5-1
237- Initial build
Note: See TracBrowser for help on using the repository browser.