source: projects/specs/trunk/a/alacarte/alacarte-vl.spec @ 805

Revision 805, 7.5 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           alacarte
4Version:        0.13.1
5Release:        1%{?_dist_release}
6Summary:        Menu editor for the GNOME desktop
7Summary(ja):    GNOME デスクトップ用メニューエディタ
8
9Group:          Applications/System
10License:        LGPLv2+
11URL:            http://www.gnome.org
12Source0:        http://download.gnome.org/sources/alacarte/0.12/%{name}-%{version}.tar.bz2
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15
16BuildRequires:  python, python-devel, gettext
17BuildRequires:  pygtk2-devel
18BuildRequires:  pkgconfig
19BuildRequires:  gnome-menus-devel >= 2.27.92
20BuildRequires:  intltool
21BuildRequires:  desktop-file-utils
22Requires:       pygtk2, gnome-python
23Requires:       gnome-menus >= 2.27.92
24
25Patch0:         undo-delete.patch
26
27%description
28Alacarte is a graphical menu editor that lets you edit, add, and delete
29menu entries. It follows the freedesktop.org menu specification and
30should work with any desktop environment that uses this specification.
31
32%prep
33%setup -q
34%patch0 -p1 -b .undo-delete
35
36%build
37%configure
38make
39
40%install
41rm -rf $RPM_BUILD_ROOT
42make install DESTDIR=$RPM_BUILD_ROOT
43
44# desktop-file-install can't manipulate NotShowIn
45sed -i -e 's/NotShowIn=KDE;/OnlyShowIn=GNOME;/' \
46  $RPM_BUILD_ROOT%{_datadir}/applications/alacarte.desktop
47desktop-file-validate \
48  $RPM_BUILD_ROOT%{_datadir}/applications/alacarte.desktop
49
50
51%find_lang %{name}
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%post
57touch --no-create %{_datadir}/icons/hicolor
58if [ -x /usr/bin/gtk-update-icon-cache ]; then
59  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
60fi
61
62%postun
63touch --no-create %{_datadir}/icons/hicolor
64if [ -x /usr/bin/gtk-update-icon-cache ]; then
65  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
66fi
67
68%files -f %{name}.lang
69%defattr(-,root,root,-)
70%doc README AUTHORS COPYING
71%{python_sitelib}/Alacarte
72%{_bindir}/alacarte
73%{_datadir}/applications/alacarte.desktop
74%{_datadir}/alacarte
75%{_datadir}/icons/hicolor/16x16/apps/alacarte.png
76%{_datadir}/icons/hicolor/22x22/apps/alacarte.png
77%{_datadir}/icons/hicolor/24x24/apps/alacarte.png
78%{_datadir}/icons/hicolor/32x32/apps/alacarte.png
79%{_datadir}/icons/hicolor/48x48/apps/alacarte.png
80%{_datadir}/icons/hicolor/256x256/apps/alacarte.png
81
82%changelog
83* Sat Apr 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.13.1-1
84- new upstream release
85
86* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.12.4-2
87- initial build for Vine Linux
88
89* Mon Sep 21 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.4-1
90- Update to 0.12.4
91
92* Sat Sep 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.3-2
93- Bump the gnome-menus requires
94
95* Tue Sep  8 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.3-1
96- Update to 0.12.3
97
98* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.1-2
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
100
101* Sat May 16 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.1-1
102- Update to 0.12.1
103
104* Tue Mar 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.10-1
105- Update to 0.11.10
106
107* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.9-3
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
109
110* Mon Feb 23 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.9-2
111- Only show in GNOME (#486887)
112
113* Tue Feb 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.9-1
114- Update to 0.11.9
115
116* Tue Feb  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.8-1
117- Update to 0.11.8
118
119* Tue Jan 20 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.7-1
120- Update to 0.11.7
121
122* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.11.6-6
123- Rebuild for Python 2.6
124
125* Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-5
126- Tweak %%summary and %%description
127
128* Fri Oct 17 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-4
129- Make undoing of deletion work
130
131* Mon Sep 22 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-3
132- Update to 0.11.6
133
134* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.5-1
135- Update to 0.11.5
136
137* Thu Feb 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.4-1
138- Update to 0.11.4
139
140* Sun Dec 02 2007 Todd Zullinger <tmz@pobox.com> - 0.11.3-5
141- put the python scripts in sitelib, not sitearch
142- remove autoconf, automake, and intltool BRs
143- don't run autoconf/automake in %%build
144- BR perl(XML::Parser)
145- remove smeg Obsoletes and Provides
146- minor rpmlint cleanups
147
148* Sat Aug 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.3-4
149- Fix the build with intltool 0.36
150- Update the license field
151
152* Fri Mar 23 2007 Ray Strode <rstrode@redhat.com> - 0.11.3-3
153- change url to gnome.org (bug 233237)
154
155* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.3-2
156- Update to 0.11.3
157
158* Mon Feb 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.2-1.svn20070212
159- Bring back editing of the System menu
160
161* Fri Jan 26 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.1.1-2
162- Fix the Provides: line
163
164* Thu Jan 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.1.1-1
165- Update to 0.11.1.1
166
167* Wed Dec 20 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.2-2
168- Update to 0.10.2
169
170* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.1-4
171- try again
172
173* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 0.10.1-2
174- build against python 2.5
175
176* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.1-1
177- Update to 0.10.1
178* Mon Sep  4 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.0-1.fc6
179- Update to 0.10.0
180
181* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-7.fc6
182- Fix more build requires
183
184* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-3.fc6
185- Add BR for pkgconfig
186
187* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-1.fc6
188- Update to 0.9.90
189
190* Thu Aug 17 2006 Ray Strode <rstrode@redhat.com> - 0.8-8
191- initial build for Fedora Core
192
193* Wed Feb 15 2006 John Mahowald <jpmahowald@gmail.com> - 0.8-7
194- Rebuild for Fedora Extras 5
195
196* Fri Feb 3 2006  John Mahowald <jpmahowald@gmail.com> - 0.8-3
197- Fix stray reference to smeg
198- Use python sitearch macro from template
199
200* Sat Oct 29 2005  John Mahowald <jpmahowald@gmail.com> - 0.8-2
201- Rebuild
202
203* Thu Oct 27 2005  John Mahowald <jpmahowald@gmail.com> - 0.8-1
204- rename to alacarte
205- Update to 0.8
206
207* Thu Oct 20 2005  John Mahowald <jpmahowald@gmail.com> - 0.7.5-4
208- remove requires gnome-menus
209
210* Tue Aug 30 2005 John Mahowald <jpmahowald@gmail.com> - 0.7.5-3
211- Move to /usr/share
212
213* Tue Jun 28 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.5-2
214- Desktop-file-utils for kde desktop entry as well as default one.
215
216* Wed Jun 08 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.5-1
217- Rebuilt for 0.7.5
218
219* Sun Jun 06 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.4-1
220- Rebuilt for 0.7.4
221
222* Wed Jun 01 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.1-1
223- Rebuilt for 0.7.1
224- Smeg now use the stock gnome menu icon, removed pixmaps from %%files
225
226* Wed Jun 01 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7-2
227- Added missing dependency gnome-python2-gconf
228
229* Tue May 31 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7-1
230- Rebuilt for 0.7
231
232* Mon May 30 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.6.2-2
233- Added desktop-file-utils to Buildrequires
234- Addded desktop-file-utils %%post and %%postun
235
236* Sat May 29 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.6.2-1
237- Rebuilt for 0.6.2
238
239* Mon May 23 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.5-1
240- Initial build
Note: See TracBrowser for help on using the repository browser.