source: projects/specs/trunk/a/acpid/acpid-vl.spec @ 576

Revision 576, 6.7 KB checked in by daisuke, 14 years ago (diff)

update to 2.0.2, new upstream

Line 
1Summary: ACPI Event Daemon
2Summary(ja): ACPI イベントデーモン
3Name: acpid
4Version: 2.0.2
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Daemons
8URL: http://tedfelix.com/linux/acpid-netlink.html
9
10Source: http://tedfelix.com/linux/acpid-%{version}.tar.gz
11Source1: acpid.init
12Source2: acpid.video.conf
13Source3: acpid.power.conf
14Source4: acpid.power.sh
15
16Patch1: acpid-2.0.2-makefile.patch
17Patch2: acpid-2.0.2-no_umask.patch
18Patch3: acpid-2.0.2-headers.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21Requires(post): chkconfig
22Requires(preun): chkconfig, initscripts
23
24ExclusiveArch: x86_64 %{ix86}
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: daisuke
29
30%description
31acpid is a daemon that dispatches ACPI events to user-space programs.
32  (bug reports to sunthockin@users.sourceforge.net)
33
34%description -l ja
35acpidはACPIイベントをユーザスペースのプログラムへ素早く伝えるデーモンです。
36(バグレポートはsunthockin@users.sourceforge.netに送ってください)
37
38
39%prep
40%setup -q
41%patch1 -p1 -b .makefile
42%patch2 -p1 -b .no_umask
43%patch3 -p1 -b .headers
44
45%build
46make %{?_smp_mflags}
47
48
49%install
50rm -rf %{buildroot}
51mkdir -p %{buildroot}
52make install DESTDIR=%{buildroot}
53
54mkdir -p %{buildroot}%{_sysconfdir}/acpi/events
55mkdir -p %{buildroot}%{_sysconfdir}/acpi/actions
56chmod 755 %{buildroot}%{_sysconfdir}/acpi/events
57install -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/acpi/events/video.conf
58install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/acpi/events/power.conf
59install -m 755 %{SOURCE4} %{buildroot}%{_sysconfdir}/acpi/actions/power.sh
60
61install -D -m 755 %{SOURCE1} %{buildroot}%{_sysconfdir}/rc.d/init.d/acpid
62
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67
68%post
69# only run on install, not upgrade
70if [ "$1" = "1" ]; then
71        /sbin/chkconfig --add acpid
72fi
73if [ -e /var/log/acpid ]; then
74    touch /var/log/acpid
75fi
76
77
78%postun
79if [ "$1" -ge "1" ]; then
80        /sbin/service acpid condrestart >/dev/null 2>&1
81fi
82
83
84%preun
85# only run if this is the last instance to be removed
86if [ "$1" = "0" ]; then
87        /sbin/service acpid stop > /dev/null 2>&1
88        /sbin/chkconfig --del acpid
89        rm -f /var/run/acpid.socket
90fi
91
92
93%files
94%defattr(-,root,root)
95%doc COPYING Changelog README TODO samples
96%dir %{_sysconfdir}/acpi
97%dir %{_sysconfdir}/acpi/events
98%dir %{_sysconfdir}/acpi/actions
99%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/acpi/events/video.conf
100%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/acpi/events/power.conf
101%config(noreplace) %attr(0755,root,root) %{_sysconfdir}/acpi/actions/power.sh
102%{_bindir}/acpi_listen
103%{_sbindir}/acpid
104%attr(0755,root,root) %{_sysconfdir}/rc.d/init.d/acpid
105%{_mandir}/man8/acpid.8*
106%{_mandir}/man8/acpi_listen.8*
107
108
109%changelog
110* Tue Mar 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-1
111- new upstream release
112
113* Sat May  9 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.10-1
114- new upstream release: fixes CVE-2009-0798 (too many open files DoS)
115- fix power.sh (Source4) to work with ConsoleKit >= 0.3.0
116  (ck-list-sessions now returns 'unix-user' instead of 'uid')
117  without this fix, pressing power key will always goes to shutdown
118  even if gnome-power-manager is active and running
119- add ExclusiveArch: x86_64 %%{ix86}
120
121* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-4
122- add patch10 to ignore .rpmnew file
123- add power button handling script and config
124- import some patches from fedora
125  - add rpm's optflags to makefile
126  - Fixed leak of a file descriptor
127  - Fixed dumping useless info to log
128
129* Mon Aug 11 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.6-3
130- spec in UTF-8
131- adjust start/stop priority not to conflict with HAL
132
133* Sun Apr 06 2008 Kazutaka HARADA <Kazutaka@dc4.so-net.ne.jp> 1.0.6-2
134- rebuild
135- apply new versioning policy
136
137* Sun Jul 1 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.6-1vl2
138- remove %%{_sysconfdir}/logrotate.d/acpid from files
139  (from this version, syslog is used for logging)
140- remove Source2 (from this version, syslog is used for logging)
141
142* Sun Jul 1 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.6-1vl1
143- upstream release
144- update Source0 URL
145- drop Patch0 (merged into upstream source)
146- drop Patch1 (solved in another way on upstream source)
147
148* Sat May 26 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.4-1vl3
149- add Patch1 to rebuild with new toolchain
150
151* Sat Nov 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1vl2
152- update acpid.init
153  - check if ACPI interface is available or not. (<BTS:216>)
154
155* Thu Oct 21 2004 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.4-1vl1
156- upstream release
157- move sample.conf to %doc
158- add some new sample scripts to %doc
159- MEMO: file acpid-bindir.patch will be unnecessary in next upstream release,
160  since the patch is accepted in upstream CVS
161
162* Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-1vl4
163- changed Group:
164- added %clean section
165
166* Wed Jul 21 2004 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.3-1vl3
167- changed redhat/acpid.init tarball into text file
168- added Source2: logrotate support
169
170* Thu Jun 24 2004 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.3-1vl2
171- upstream release
172- extract redhat/acpid.init from acpid-1.0.2.tar.gz tarball
173- patch Makefile to mkdir %BINDIR before install
174- added Japanese Summary
175- remove /var/run/acpid.socket at preun
176- delete previously commented scripts
177
178* Sun Dec 21 2003 KAZUKI SHIMURA <rito@pos.to> 1.0.2-1vl3
179- removed name/version/release macros
180- added vendor/distribution tag
181- added %%doc (merged with 1.0.2-1vl2 in VinePlus/2.5)
182- removed needless chmod/attr
183- stop service before uninstall
184
185* Fri Nov 14 2003 Satoshi MACHINO <machino@vinelinux.org> 1.0.2-1vl2
186- rebuilt for Vine Seed
187- added japanese description
188- changed from Copylight to License
189
190* Sun Nov 2 2003  KANEKO Seiji <giraffe@m2.pbc.ne.jp>
191  - 1.0.2-1vl1
192  - Removed prefix definition
193  - Remove /var/log/acpid from package file
194
195* Thu Aug 21 2003  KANEKO Seiji <giraffe@m2.pbc.ne.jp>
196  - 1.0.2-1vl0.1
197  - Spec file modified for Vine Linux 2.6r1
198
199* Tue May 13 2003  Tim Hockin <thockin@sun.com>
200  - Fixed a dumb bug with %e expansion for commands
201  - Add COPYING file
202  - Add TODO file
203
204* Fri Mar 15 2002  Tim Hockin <thockin@sun.com>
205  - Updated RPM spec with patch from sun for chkconfig on/off
206  - Add Changelog, make 'make rpm' use it.
207  - 1.0.1
208
209* Wed Mar 13 2002  Tim Hockin <thockin@sun.com>
210  - Fixed logging bug - not appending to log (O_APPEND needed)
211  - Fix 'make install' to not need root access
212  - Fix RPM spec to not need root
213
214* Thu Sep 6 2001 Tim Hockin <thockin@sun.com>
215  - 1.0.0
216
217* Thu Aug 16 2001  Tim Hockin <thockin@sun.com>
218  - Added commandline options to actions
219
220* Wed Aug 15 2001  Tim Hockin <thockin@sun.com>
221  - Added UNIX domain socket support
222  - Changed /etc/acpid.d to /etc/acpid/events
223
224* Mon Aug 13 2001  Tim Hockin <thockin@sun.com>
225  - added changelog
226  - 0.99.1-1
227
Note: See TracBrowser for help on using the repository browser.