source: projects/specs/trunk/a/acpid/acpid-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: ACPI Event Daemon
2Summary(ja): ACPI イベントデーモン
3Name: acpid
4Version: 1.0.10
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Daemons
8URL: http://acpid.sourceforge.net/
9
10Source0: http://downloads.sourceforge.net/acpid/%{name}-%{version}.tar.gz
11Source1: acpid.init
12Source2: acpid.video.conf
13Source3: acpid.power.conf
14Source4: acpid.power.sh
15
16Patch1: acpid-1.0.10-makefile.patch
17
18Patch10: acpid-1.0.6-ignore-rpmnew.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21Requires(post): chkconfig
22Requires(preun): chkconfig, initscripts
23
24ExclusiveArch: x86_64 %{ix86}
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29
30%description
31acpid is a daemon that dispatches ACPI events to user-space programs.
32  (bug reports to sunthockin@users.sourceforge.net)
33
34%description -l ja
35acpidはACPIイベントをユーザスペースのプログラムへ素早く伝えるデーモンです。
36(バグレポートはsunthockin@users.sourceforge.netに送ってください)
37
38
39%prep
40%setup -q
41%patch1 -p1 -b .makefile
42%patch10 -p1 -b .ignore-rpmnew
43
44
45%build
46make %{?_smp_mflags}
47
48
49%install
50rm -rf %{buildroot}
51mkdir -p %{buildroot}
52make install INSTPREFIX=%{buildroot}
53
54mkdir -p %{buildroot}%{_sysconfdir}/acpi/events
55mkdir -p %{buildroot}%{_sysconfdir}/acpi/actions
56chmod 755 %{buildroot}%{_sysconfdir}/acpi/events
57install -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/acpi/events/video.conf
58install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/acpi/events/power.conf
59install -m 755 %{SOURCE4} %{buildroot}%{_sysconfdir}/acpi/actions/power.sh
60
61install -D -m 755 %{SOURCE1} %{buildroot}%{_sysconfdir}/rc.d/init.d/acpid
62
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67
68%post
69# only run on install, not upgrade
70if [ "$1" = "1" ]; then
71        /sbin/chkconfig --add acpid
72fi
73if [ -e /var/log/acpid ]; then
74    touch /var/log/acpid
75fi
76
77
78%postun
79if [ "$1" -ge "1" ]; then
80        /sbin/service acpid condrestart >/dev/null 2>&1
81fi
82
83
84%preun
85# only run if this is the last instance to be removed
86if [ "$1" = "0" ]; then
87        /sbin/service acpid stop > /dev/null 2>&1
88        /sbin/chkconfig --del acpid
89        rm -f /var/run/acpid.socket
90fi
91
92
93%files
94%defattr(-,root,root)
95%doc COPYING Changelog README TODO samples
96%dir %{_sysconfdir}/acpi
97%dir %{_sysconfdir}/acpi/events
98%dir %{_sysconfdir}/acpi/actions
99%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/acpi/events/video.conf
100%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/acpi/events/power.conf
101%config(noreplace) %attr(0755,root,root) %{_sysconfdir}/acpi/actions/power.sh
102%{_bindir}/acpi_listen
103%{_sbindir}/acpid
104%attr(0755,root,root) %{_sysconfdir}/rc.d/init.d/acpid
105%{_mandir}/man8/acpid.8*
106%{_mandir}/man8/acpi_listen.8*
107
108
109%changelog
110* Sat May  9 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.10-1
111- new upstream release: fixes CVE-2009-0798 (too many open files DoS)
112- fix power.sh (Source4) to work with ConsoleKit >= 0.3.0
113  (ck-list-sessions now returns 'unix-user' instead of 'uid')
114  without this fix, pressing power key will always goes to shutdown
115  even if gnome-power-manager is active and running
116- add ExclusiveArch: x86_64 %%{ix86}
117
118* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-4
119- add patch10 to ignore .rpmnew file
120- add power button handling script and config
121- import some patches from fedora
122  - add rpm's optflags to makefile
123  - Fixed leak of a file descriptor
124  - Fixed dumping useless info to log
125
126* Mon Aug 11 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.6-3
127- spec in UTF-8
128- adjust start/stop priority not to conflict with HAL
129
130* Sun Apr 06 2008 Kazutaka HARADA <Kazutaka@dc4.so-net.ne.jp> 1.0.6-2
131- rebuild
132- apply new versioning policy
133
134* Sun Jul 1 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.6-1vl2
135- remove %%{_sysconfdir}/logrotate.d/acpid from files
136  (from this version, syslog is used for logging)
137- remove Source2 (from this version, syslog is used for logging)
138
139* Sun Jul 1 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.6-1vl1
140- upstream release
141- update Source0 URL
142- drop Patch0 (merged into upstream source)
143- drop Patch1 (solved in another way on upstream source)
144
145* Sat May 26 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.4-1vl3
146- add Patch1 to rebuild with new toolchain
147
148* Sat Nov 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1vl2
149- update acpid.init
150  - check if ACPI interface is available or not. (<BTS:216>)
151
152* Thu Oct 21 2004 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.4-1vl1
153- upstream release
154- move sample.conf to %doc
155- add some new sample scripts to %doc
156- MEMO: file acpid-bindir.patch will be unnecessary in next upstream release,
157  since the patch is accepted in upstream CVS
158
159* Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-1vl4
160- changed Group:
161- added %clean section
162
163* Wed Jul 21 2004 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.3-1vl3
164- changed redhat/acpid.init tarball into text file
165- added Source2: logrotate support
166
167* Thu Jun 24 2004 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.3-1vl2
168- upstream release
169- extract redhat/acpid.init from acpid-1.0.2.tar.gz tarball
170- patch Makefile to mkdir %BINDIR before install
171- added Japanese Summary
172- remove /var/run/acpid.socket at preun
173- delete previously commented scripts
174
175* Sun Dec 21 2003 KAZUKI SHIMURA <rito@pos.to> 1.0.2-1vl3
176- removed name/version/release macros
177- added vendor/distribution tag
178- added %%doc (merged with 1.0.2-1vl2 in VinePlus/2.5)
179- removed needless chmod/attr
180- stop service before uninstall
181
182* Fri Nov 14 2003 Satoshi MACHINO <machino@vinelinux.org> 1.0.2-1vl2
183- rebuilt for Vine Seed
184- added japanese description
185- changed from Copylight to License
186
187* Sun Nov 2 2003  KANEKO Seiji <giraffe@m2.pbc.ne.jp>
188  - 1.0.2-1vl1
189  - Removed prefix definition
190  - Remove /var/log/acpid from package file
191
192* Thu Aug 21 2003  KANEKO Seiji <giraffe@m2.pbc.ne.jp>
193  - 1.0.2-1vl0.1
194  - Spec file modified for Vine Linux 2.6r1
195
196* Tue May 13 2003  Tim Hockin <thockin@sun.com>
197  - Fixed a dumb bug with %e expansion for commands
198  - Add COPYING file
199  - Add TODO file
200
201* Fri Mar 15 2002  Tim Hockin <thockin@sun.com>
202  - Updated RPM spec with patch from sun for chkconfig on/off
203  - Add Changelog, make 'make rpm' use it.
204  - 1.0.1
205
206* Wed Mar 13 2002  Tim Hockin <thockin@sun.com>
207  - Fixed logging bug - not appending to log (O_APPEND needed)
208  - Fix 'make install' to not need root access
209  - Fix RPM spec to not need root
210
211* Thu Sep 6 2001 Tim Hockin <thockin@sun.com>
212  - 1.0.0
213
214* Thu Aug 16 2001  Tim Hockin <thockin@sun.com>
215  - Added commandline options to actions
216
217* Wed Aug 15 2001  Tim Hockin <thockin@sun.com>
218  - Added UNIX domain socket support
219  - Changed /etc/acpid.d to /etc/acpid/events
220
221* Mon Aug 13 2001  Tim Hockin <thockin@sun.com>
222  - added changelog
223  - 0.99.1-1
224
Note: See TracBrowser for help on using the repository browser.