source: projects/specs/trunk/a/acl/acl-vl.spec @ 9517

Revision 9517, 10.6 KB checked in by tomop, 9 years ago (diff)

acl-2.2.52-2, libldb-1.1.20-2, libtevent-0.9.24-2, libtalloc-2.1.2-1, samba-4.2.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: acl
4Summary: Access control list utilities
5Version: 2.2.52
6Release: 2%{?_dist_release}
7
8Group: System Environment/Base
9License: GPLv2+
10URL: http://oss.sgi.com/projects/xfs/
11
12Source: http://download.savannah.gnu.org/releases-noredirect/acl/acl-%{version}.src.tar.gz
13
14# fix a typo in setfacl(1) man page (#675451)
15Patch1: 0001-acl-2.2.49-bz675451.patch
16
17# prepare the test-suite for SELinux and arbitrary umask
18Patch3: 0003-acl-2.2.52-tests.patch
19
20# Install the libraries to the appropriate directory
21Patch4: 0004-acl-2.2.52-libdir.patch
22
23# fix SIGSEGV of getfacl -e on overly long group name
24Patch5: 0005-acl-2.2.52-getfacl-segv.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: gawk
28BuildRequires: gettext
29BuildRequires: libattr-devel >= 2.4.1
30BuildRequires: libtool
31Requires: libacl = %{version}-%{release}
32
33%description
34This package contains the getfacl and setfacl utilities needed for
35manipulating access control lists.
36
37%package -n libacl
38Summary: Dynamic library for access control list support
39License: LGPLv2+
40Group: System Environment/Libraries
41Requires(post): /sbin/ldconfig
42Requires(postun): /sbin/ldconfig
43
44%description -n libacl
45This package contains the libacl.so dynamic library which contains
46the POSIX 1003.1e draft standard 17 functions for manipulating access
47control lists.
48
49%package -n libacl-devel
50Summary: Access control list static libraries and headers.
51License: LGPLv2+
52Group: Development/Libraries
53Requires: libacl = %{version}-%{release}
54Requires: libattr-devel
55
56%description -n libacl-devel
57This package contains static libraries and header files needed to develop
58programs which make use of the access control list programming interface
59defined in POSIX 1003.1e draft standard 17.
60
61%if %build_compat32
62
63%package -n compat32-libacl
64Summary: Dynamic library for access control list support
65License: LGPLv2+
66Group: System Environment/Libraries
67Requires(post): /sbin/ldconfig
68Requires(postun): /sbin/ldconfig
69
70%description -n compat32-libacl
71This package contains the libacl.so dynamic library which contains
72the POSIX 1003.1e draft standard 17 functions for manipulating access
73control lists.
74
75%endif
76
77%prep
78%setup -q
79%patch1 -p1
80%patch3 -p1
81%patch4 -p1
82%patch5 -p1
83
84%build
85touch .census
86# acl abuses libexecdir
87%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
88make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
89
90%install
91rm -rf %{buildroot}
92make install DESTDIR=%{buildroot}
93make install-dev DESTDIR=%{buildroot}
94make install-lib DESTDIR=%{buildroot}
95
96mv -f %{buildroot}%{_datadir}/doc/acl ./doc-nover
97
98# get rid of libacl.a and libacl.la
99rm -f %{buildroot}/%{_lib}/libacl.a
100rm -f %{buildroot}/%{_lib}/libacl.la
101rm -f %{buildroot}%{_libdir}/libacl.a
102rm -f %{buildroot}%{_libdir}/libacl.la
103
104# fix links to shared libs and permissions
105rm -f %{buildroot}%{_libdir}/libacl.so
106mkdir -p %{buildroot}%{_libdir}
107ln -sf ../../%{_lib}/libacl.so %{buildroot}%{_libdir}/libacl.so
108chmod 0755 %{buildroot}/%{_lib}/libacl.so.*.*.*
109
110%find_lang %{name}
111
112%check
113if ./setfacl/setfacl -m u:`id -u`:rwx .; then
114    make tests || exit $?
115    if test 0 = `id -u`; then
116        make root-tests || exit $?
117    fi
118else
119    echo '*** ACLs are probably not supported by the file system,' \
120         'the test-suite will NOT run ***'
121fi
122
123%clean
124rm -rf %{buildroot}
125
126%post -n libacl
127/sbin/ldconfig
128
129%postun -n libacl
130/sbin/ldconfig
131
132%if %build_compat32
133
134%post -n compat32-libacl
135/sbin/ldconfig
136
137%postun -n compat32-libacl
138/sbin/ldconfig
139
140%endif
141
142%files -f %{name}.lang
143%defattr(-,root,root)
144%doc doc-nover/*
145%{_bindir}/chacl
146%{_bindir}/getfacl
147%{_bindir}/setfacl
148%{_mandir}/man1/chacl.1*
149%{_mandir}/man1/getfacl.1*
150%{_mandir}/man1/setfacl.1*
151%{_mandir}/man5/acl.5*
152
153%files -n libacl-devel
154%defattr(-,root,root)
155/%{_lib}/libacl.so
156%{_includedir}/acl
157%{_includedir}/sys/acl.h
158%{_libdir}/libacl.*
159%{_mandir}/man3/acl_*
160
161%files -n libacl
162%defattr(-,root,root)
163/%{_lib}/libacl.so.*
164
165%if %build_compat32
166
167%files -n compat32-libacl
168%defattr(-,root,root,-)
169/%{_lib}/libacl.so.*
170
171%endif
172
173%changelog
174* Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-2
175- added compat32 package.
176
177* Fri Jul  4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-1
178- new upstream release.
179- replaced patches to the newest rawhide's.
180
181* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.49-1
182- updated to 2.2.49
183- added Patch2-7 from Fedora
184  * Wed Apr 06 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-11
185  - add function acl_extended_file_nofollow() (#692982)
186  * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-10
187  - fix typos in setfacl(1) man page (#675451)
188  * Thu Jul 08 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-8
189  - remove dependency of libacl-devel on nfs-utils-lib and openldap
190  * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-7
191  - let acl depend on the same version of libacl (#595674)
192  * Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
193  - prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
194
195* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
196- initial build for Vine Linux
197
198* Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
199- new upstream version
200
201* Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
202- Fixed segfault when using only "--" as parameter
203- Resolves: #430458
204
205* Wed Nov  7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
206- Fixed setfacl exitcodes
207- Resolves: #368451
208
209* Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
210- New version
211- dropped walk patch
212
213* Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
214- Rewriten path_max patch to support long UTF8 names
215- Resolves #287701, #183181
216
217* Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
218- Removed NFS4 ACL patch since it was rejected by upstream.
219
220* Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
221- disable nfs patch; linking libacl against libs in /usr will lead to breakage
222
223* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
224- Build Require gawk
225
226* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
227- Rebuild for selinux ppc32 issue.
228
229* Mon Aug 27 2007 Steve Dickson <steved@redhat.com>  2.2.39-5
230- Added NFS v4 ACL support
231
232* Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
233- Updated man page for getfacl
234
235* Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
236- Added support fort short params to getfacl
237- Resolves: #204087
238
239* Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
240- new improved walk patch with fixed getfacl exit code (rhbz#232884)
241
242* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
243- fix buildroot
244- remove trailing dot from summary
245- -devel requires same version of libacl
246- escape macro in changelog
247- make .so symlink relative
248
249* Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
250- Apply patch to make order consistent.
251
252* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
253- rebuild
254
255* Wed Jul  5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
256- new version 2.2.39
257- fixed usage of long UTF-8 filenames (#183181)
258  Thanks to Andrey for the initial patch.
259
260* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
261- rebuild for -devel deps
262
263* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
264- bump again for double-long bug on ppc(64)
265
266* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
267- rebuilt for new gcc4.1 snapshot and glibc changes
268
269* Fri Feb  3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
270- new version 2.2.34
271
272* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
273- rebuilt
274
275* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
276- fixed permissions of libacl
277
278* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
279- spec file cleanup
280- mark po files as lang specific
281
282* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
283- 2.2.32
284
285* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
286- update to 2.2.31
287
288* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
289- get rid of *.la files
290- remove duplicate doc files
291
292* Wed Feb  9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
293- Rebuild
294
295* Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
296- make the libs executable so that we find their dependencies (#132696)
297
298* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
299- libacl-devel Requires: libattr-devel for libattr.la
300
301* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
302- Requires libtool >= 1.5 for building
303
304* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
305- Make libacl.so.* executable.
306
307* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
308- Update to latest upstream version.
309
310* Sun Aug  8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
311- Close bug #125300 (Steve Grubb: build requires libtool,gettext)
312
313* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
314- rebuilt
315
316* Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
317- Add missing %%defattr
318
319* Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
320- Add /usr/include/acl to files manifest
321- Fix location of doc files, add main doc dir to files manifest
322
323* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
324- rebuilt
325
326* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
327- rebuilt
328
329* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
330- Fix libtool invocation
331
332* Tue Jun  3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
333- Update to acl-2.2.7
334
335* Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
336- include patch from Jay Berkenbilt to print better error messages
337
338* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
339- udpate/rebuild
340
341* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
342- set execute bits on library so that requires are generated.
343
344* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
345- Correct patch in previous fix so that shared libraries go in /lib*
346  instead of /usr/lib*
347
348* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
349- Fix multilibbing
350
351* Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
352- Added fix to install libs in correct directory on 64bit machine
353
354* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
355- Made the package only own the one directory that is unique to it:
356  /usr/include/acl
357
358* Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
359- Initial Red Hat package
360  Made as few changes as possible relative to upstream packaging to
361  make it easier to maintain long-term.  This means that some of
362  the techniques used here are definitely not standard Red Hat
363  techniques.  If you are looking for an example package to fit
364  into Red Hat Linux transparently, this would not be the one to
365  pick.
366- acl-devel -> libacl-devel
Note: See TracBrowser for help on using the repository browser.