source: projects/specs/trunk/a/acl/acl-vl.spec @ 8735

Revision 8735, 9.8 KB checked in by tomop, 10 years ago (diff)

filesystem tools.

Line 
1Name: acl
2Summary: Access control list utilities
3Version: 2.2.52
4Release: 1%{?_dist_release}
5
6Group: System Environment/Base
7License: GPLv2+
8URL: http://oss.sgi.com/projects/xfs/
9
10Source: http://download.savannah.gnu.org/releases-noredirect/acl/acl-%{version}.src.tar.gz
11
12# fix a typo in setfacl(1) man page (#675451)
13Patch1: 0001-acl-2.2.49-bz675451.patch
14
15# prepare the test-suite for SELinux and arbitrary umask
16Patch3: 0003-acl-2.2.52-tests.patch
17
18# Install the libraries to the appropriate directory
19Patch4: 0004-acl-2.2.52-libdir.patch
20
21# fix SIGSEGV of getfacl -e on overly long group name
22Patch5: 0005-acl-2.2.52-getfacl-segv.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: gawk
26BuildRequires: gettext
27BuildRequires: libattr-devel >= 2.4.1
28BuildRequires: libtool
29Requires: libacl = %{version}-%{release}
30
31%description
32This package contains the getfacl and setfacl utilities needed for
33manipulating access control lists.
34
35%package -n libacl
36Summary: Dynamic library for access control list support
37License: LGPLv2+
38Group: System Environment/Libraries
39Requires(post): /sbin/ldconfig
40Requires(postun): /sbin/ldconfig
41
42%description -n libacl
43This package contains the libacl.so dynamic library which contains
44the POSIX 1003.1e draft standard 17 functions for manipulating access
45control lists.
46
47%package -n libacl-devel
48Summary: Access control list static libraries and headers.
49License: LGPLv2+
50Group: Development/Libraries
51Requires: libacl = %{version}-%{release}
52Requires: libattr-devel
53
54%description -n libacl-devel
55This package contains static libraries and header files needed to develop
56programs which make use of the access control list programming interface
57defined in POSIX 1003.1e draft standard 17.
58
59%prep
60%setup -q
61%patch1 -p1
62%patch3 -p1
63%patch4 -p1
64%patch5 -p1
65
66%build
67touch .census
68# acl abuses libexecdir
69%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
70make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
71
72%install
73rm -rf %{buildroot}
74make install DESTDIR=%{buildroot}
75make install-dev DESTDIR=%{buildroot}
76make install-lib DESTDIR=%{buildroot}
77
78mv -f %{buildroot}%{_datadir}/doc/acl ./doc-nover
79
80# get rid of libacl.a and libacl.la
81rm -f %{buildroot}/%{_lib}/libacl.a
82rm -f %{buildroot}/%{_lib}/libacl.la
83rm -f %{buildroot}%{_libdir}/libacl.a
84rm -f %{buildroot}%{_libdir}/libacl.la
85
86# fix links to shared libs and permissions
87rm -f %{buildroot}%{_libdir}/libacl.so
88mkdir -p %{buildroot}%{_libdir}
89ln -sf ../../%{_lib}/libacl.so %{buildroot}%{_libdir}/libacl.so
90chmod 0755 %{buildroot}/%{_lib}/libacl.so.*.*.*
91
92%find_lang %{name}
93
94%check
95if ./setfacl/setfacl -m u:`id -u`:rwx .; then
96    make tests || exit $?
97    if test 0 = `id -u`; then
98        make root-tests || exit $?
99    fi
100else
101    echo '*** ACLs are probably not supported by the file system,' \
102         'the test-suite will NOT run ***'
103fi
104
105%clean
106rm -rf %{buildroot}
107
108%post -n libacl
109/sbin/ldconfig
110
111%postun -n libacl
112/sbin/ldconfig
113
114%files -f %{name}.lang
115%defattr(-,root,root)
116%doc doc-nover/*
117%{_bindir}/chacl
118%{_bindir}/getfacl
119%{_bindir}/setfacl
120%{_mandir}/man1/chacl.1*
121%{_mandir}/man1/getfacl.1*
122%{_mandir}/man1/setfacl.1*
123%{_mandir}/man5/acl.5*
124
125%files -n libacl-devel
126%defattr(-,root,root)
127/%{_lib}/libacl.so
128%{_includedir}/acl
129%{_includedir}/sys/acl.h
130%{_libdir}/libacl.*
131%{_mandir}/man3/acl_*
132
133%files -n libacl
134%defattr(-,root,root)
135/%{_lib}/libacl.so.*
136
137%changelog
138* Fri Jul  4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-1
139- new upstream release.
140- replaced patches to the newest rawhide's.
141
142* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.49-1
143- updated to 2.2.49
144- added Patch2-7 from Fedora
145  * Wed Apr 06 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-11
146  - add function acl_extended_file_nofollow() (#692982)
147  * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-10
148  - fix typos in setfacl(1) man page (#675451)
149  * Thu Jul 08 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-8
150  - remove dependency of libacl-devel on nfs-utils-lib and openldap
151  * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-7
152  - let acl depend on the same version of libacl (#595674)
153  * Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
154  - prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
155
156* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
157- initial build for Vine Linux
158
159* Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
160- new upstream version
161
162* Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
163- Fixed segfault when using only "--" as parameter
164- Resolves: #430458
165
166* Wed Nov  7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
167- Fixed setfacl exitcodes
168- Resolves: #368451
169
170* Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
171- New version
172- dropped walk patch
173
174* Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
175- Rewriten path_max patch to support long UTF8 names
176- Resolves #287701, #183181
177
178* Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
179- Removed NFS4 ACL patch since it was rejected by upstream.
180
181* Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
182- disable nfs patch; linking libacl against libs in /usr will lead to breakage
183
184* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
185- Build Require gawk
186
187* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
188- Rebuild for selinux ppc32 issue.
189
190* Mon Aug 27 2007 Steve Dickson <steved@redhat.com>  2.2.39-5
191- Added NFS v4 ACL support
192
193* Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
194- Updated man page for getfacl
195
196* Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
197- Added support fort short params to getfacl
198- Resolves: #204087
199
200* Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
201- new improved walk patch with fixed getfacl exit code (rhbz#232884)
202
203* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
204- fix buildroot
205- remove trailing dot from summary
206- -devel requires same version of libacl
207- escape macro in changelog
208- make .so symlink relative
209
210* Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
211- Apply patch to make order consistent.
212
213* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
214- rebuild
215
216* Wed Jul  5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
217- new version 2.2.39
218- fixed usage of long UTF-8 filenames (#183181)
219  Thanks to Andrey for the initial patch.
220
221* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
222- rebuild for -devel deps
223
224* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
225- bump again for double-long bug on ppc(64)
226
227* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
228- rebuilt for new gcc4.1 snapshot and glibc changes
229
230* Fri Feb  3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
231- new version 2.2.34
232
233* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
234- rebuilt
235
236* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
237- fixed permissions of libacl
238
239* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
240- spec file cleanup
241- mark po files as lang specific
242
243* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
244- 2.2.32
245
246* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
247- update to 2.2.31
248
249* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
250- get rid of *.la files
251- remove duplicate doc files
252
253* Wed Feb  9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
254- Rebuild
255
256* Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
257- make the libs executable so that we find their dependencies (#132696)
258
259* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
260- libacl-devel Requires: libattr-devel for libattr.la
261
262* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
263- Requires libtool >= 1.5 for building
264
265* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
266- Make libacl.so.* executable.
267
268* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
269- Update to latest upstream version.
270
271* Sun Aug  8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
272- Close bug #125300 (Steve Grubb: build requires libtool,gettext)
273
274* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
275- rebuilt
276
277* Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
278- Add missing %%defattr
279
280* Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
281- Add /usr/include/acl to files manifest
282- Fix location of doc files, add main doc dir to files manifest
283
284* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
285- rebuilt
286
287* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
288- rebuilt
289
290* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
291- Fix libtool invocation
292
293* Tue Jun  3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
294- Update to acl-2.2.7
295
296* Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
297- include patch from Jay Berkenbilt to print better error messages
298
299* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
300- udpate/rebuild
301
302* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
303- set execute bits on library so that requires are generated.
304
305* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
306- Correct patch in previous fix so that shared libraries go in /lib*
307  instead of /usr/lib*
308
309* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
310- Fix multilibbing
311
312* Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
313- Added fix to install libs in correct directory on 64bit machine
314
315* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
316- Made the package only own the one directory that is unique to it:
317  /usr/include/acl
318
319* Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
320- Initial Red Hat package
321  Made as few changes as possible relative to upstream packaging to
322  make it easier to maintain long-term.  This means that some of
323  the techniques used here are definitely not standard Red Hat
324  techniques.  If you are looking for an example package to fit
325  into Red Hat Linux transparently, this would not be the one to
326  pick.
327- acl-devel -> libacl-devel
Note: See TracBrowser for help on using the repository browser.