source: projects/specs/trunk/a/accerciser/accerciser-vl.spec @ 7938

Revision 7938, 4.0 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%{!?python3_sitelib: %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3
4%define pkg_version 3.8.2
5%define pkg_release 2%{?_dist_release}
6
7Summary:        An interactive Python accessibility explorer for the GNOME desktop.
8Summary(ja):    GNOME デスクトップ用 Python アクセシビリティエクスプローラ
9Name:           accerciser
10Version:        %{pkg_version}
11Release:        %{pkg_release}
12Source0:        http://ftp.gnome.org/pub/GNOME/sources/accerciser/3.8/%{name}-%{version}.tar.xz
13License:        BSD
14Group:          Desktop/Accessibility
15URL:            http://live.gnome.org/Accerciser
16
17Requires:       python3 >= 3.2
18Requires:       python3-pygobject >= 2.90.3
19Requires:       python3-pyatspi >= 2.5.2
20Requires:       at-spi2-core
21
22Requires(post): desktop-file-utils
23Requires(postun):       desktop-file-utils
24
25BuildRequires:  python3-devel >= 3.2
26BuildRequires:  python3-pygobject-devel
27BuildRequires:  gtk3-devel
28BuildRequires:  at-spi2-core-devel
29BuildRequires:  python3-pyatspi
30BuildRequires:  glib2-devel >= 2.26.0
31BuildRequires:  docbook-dtds
32BuildRequires:  yelp-tools
33BuildRequires:  autoconf
34BuildRequires:  gnome-common
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37
38Vendor: Project Vine
39Distribution: Vine Linux
40Packager: Takemikaduchi
41
42
43%description
44Accerciser is an interactive Python accessibility explorer for the GNOME
45desktop. It uses AT-SPI to inspect and control widgets, allowing you to check
46if an application is providing correct information to assistive technologies
47and automated test frameworks. Accerciser has a simple plugin framework which
48you can use to create custom views of accessibility information.
49
50
51%prep
52%setup -q
53
54
55%build
56%configure  --disable-static
57%{__make} %{?_smp_mflags}
58
59%install
60%{__rm} -rf ${RPM_BUILD_ROOT}
61%{__make} install DESTDIR=${RPM_BUILD_ROOT}
62
63%find_lang %{name} --with-gnome --all-name
64
65%clean
66%{__rm} -rf ${RPM_BUILD_ROOT}
67
68
69%post
70gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
71update-desktop-database & > /dev/null || :
72
73%postun
74if [ $1 -eq 0 ]; then
75  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
76  update-desktop-database & > /dev/null || :
77  glib-compile-schemas %{_datadir}/glib-2.0/schemas
78fi
79
80%posttrans
81glib-compile-schemas %{_datadir}/glib-2.0/schemas
82
83
84%files -f %{name}.lang
85%defattr(-,root,root)
86%doc AUTHORS COPYING ChangeLog NEWS README
87%{_bindir}/accerciser
88%{python3_sitelib}/accerciser
89%{_datadir}/applications/accerciser.desktop
90%{_datadir}/accerciser/*
91%{_datadir}/glib-2.0/schemas/*.xml
92%{_datadir}/icons/hicolor/*/apps/*
93%{_datadir}/icons/HighContrast/*/apps/*
94%{_mandir}/man1/accerciser.1.gz
95
96
97%changelog
98* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-2
99- change BuildRequires: python3-pygobject-devel instead of pygobject3
100- change BuildRequires: python3-pyatspi instead of pyatspi
101
102* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
103- new upstream release
104
105* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
106- new upstream release
107- add BuildRequires: autoconf, gnome-common
108
109* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
110- new upstream release
111
112* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
113- new upstream release
114- change BuildRequires: yelp-tools instead of gome-doc-utils
115
116* Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
117- new upstream release
118- remove BuildRequires: GConf2-devel
119
120* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
121- new upstream release
122
123* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
124- new upstream release
125
126* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
127- new upstream release
128- add BuildRequires: gtk3-devel, pygobject3-devel
129- change BuildRequires: at-spi2-core-devel instead of at-spi-devel
130
131* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
132- new upstream release
133
134* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
135- new upstream release
136
137* Mon May 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
138- new upstream release
139
140* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
141- initial build for Vine Linux
142
Note: See TracBrowser for help on using the repository browser.