source: projects/specs/trunk/a/accerciser/accerciser-vl.spec @ 10405

Revision 10405, 4.6 KB checked in by Takemikaduchi, 8 years ago (diff)

gcc-5.4.0 & python3-3.5.2

Line 
1%{!?python3_sitelib: %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3
4%define pkg_version 3.14.0
5%define pkg_release 4%{?_dist_release}
6
7Summary:        An interactive Python accessibility explorer for the GNOME desktop.
8Summary(ja):    GNOME デスクトップ用 Python アクセシビリティエクスプローラ
9Name:           accerciser
10Version:        %{pkg_version}
11Release:        %{pkg_release}
12Source0:        http://ftp.gnome.org/pub/GNOME/sources/accerciser/3.14/%{name}-%{version}.tar.xz
13License:        BSD
14Group:          User Interface/Desktops
15URL:            http://live.gnome.org/Accerciser
16
17Requires:       python3 >= 3.2
18Requires:       python3-pygobject >= 2.90.3
19Requires:       python3-pyatspi >= 2.5.2
20Requires:       at-spi2-core
21
22Requires(post): desktop-file-utils
23Requires(postun):       desktop-file-utils
24
25BuildRequires:  python3-devel >= 3.2
26BuildRequires:  python3-pygobject
27BuildRequires:  pygobject3-devel
28BuildRequires:  gtk3-devel
29BuildRequires:  at-spi2-core-devel
30BuildRequires:  python3-pyatspi
31BuildRequires:  glib2-devel >= 2.26.0
32BuildRequires:  docbook-dtds
33BuildRequires:  yelp-tools
34BuildRequires:  autoconf
35BuildRequires:  gnome-common
36
37BuildRoot:      %{_tmppath}/%{name}-%{version}-root
38
39Vendor: Project Vine
40Distribution: Vine Linux
41Packager: Takemikaduchi
42
43
44%description
45Accerciser is an interactive Python accessibility explorer for the GNOME
46desktop. It uses AT-SPI to inspect and control widgets, allowing you to check
47if an application is providing correct information to assistive technologies
48and automated test frameworks. Accerciser has a simple plugin framework which
49you can use to create custom views of accessibility information.
50
51
52%prep
53%setup -q
54
55
56%build
57%configure
58%{__make} %{?_smp_mflags}
59
60%install
61%{__rm} -rf ${RPM_BUILD_ROOT}
62%{__make} install DESTDIR=${RPM_BUILD_ROOT}
63
64%find_lang %{name} --with-gnome --all-name
65
66%clean
67%{__rm} -rf ${RPM_BUILD_ROOT}
68
69
70%post
71gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
72update-desktop-database & > /dev/null || :
73
74%postun
75if [ $1 -eq 0 ]; then
76  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
77  update-desktop-database & > /dev/null || :
78  glib-compile-schemas %{_datadir}/glib-2.0/schemas
79fi
80
81%posttrans
82glib-compile-schemas %{_datadir}/glib-2.0/schemas
83
84
85%files -f %{name}.lang
86%defattr(-,root,root)
87%doc AUTHORS COPYING ChangeLog NEWS README
88%{_bindir}/accerciser
89%{python3_sitelib}/accerciser
90%{_datadir}/applications/accerciser.desktop
91%{_datadir}/accerciser/*
92%{_datadir}/glib-2.0/schemas/*.xml
93%{_datadir}/icons/hicolor/*/apps/*
94%{_datadir}/icons/HighContrast/*/apps/*
95%{_mandir}/man1/accerciser.1.gz
96
97
98%changelog
99* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-4
100- rebuild with python3-3.5.2
101
102* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-3
103- rebuild with python3-3.4.2
104
105* Mon Jan  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.0-2
106- moved to User Interface/Desktops Group
107
108* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
109- new upstream release
110
111* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
112- new upstream release
113- remove BuildRequires: python3-pygobject-devel
114- add BuildRequires: python3-pygobject, pygobject3-devel
115
116* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-2
117- change BuildRequires: python3-pygobject-devel instead of pygobject3
118- change BuildRequires: python3-pyatspi instead of pyatspi
119
120* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
121- new upstream release
122
123* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
124- new upstream release
125- add BuildRequires: autoconf, gnome-common
126
127* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
128- new upstream release
129
130* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
131- new upstream release
132- change BuildRequires: yelp-tools instead of gome-doc-utils
133
134* Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
135- new upstream release
136- remove BuildRequires: GConf2-devel
137
138* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
139- new upstream release
140
141* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
142- new upstream release
143
144* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
145- new upstream release
146- add BuildRequires: gtk3-devel, pygobject3-devel
147- change BuildRequires: at-spi2-core-devel instead of at-spi-devel
148
149* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
150- new upstream release
151
152* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
153- new upstream release
154
155* Mon May 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
156- new upstream release
157
158* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
159- initial build for Vine Linux
160
Note: See TracBrowser for help on using the repository browser.