source: projects/specs/trunk/a/abiword/abiword-vl.spec @ 9110

Revision 9110, 26.8 KB checked in by Takemikaduchi, 9 years ago (diff)

abiword: new upstream release
others: rebuild

Line 
1%define desktop_file_utils_version 0.16
2%define abiver 3.0
3
4Summary: The AbiWord word processor
5Summary(ja): AbiWord ワードプロセッサ
6Name: abiword
7Version: 3.0.0
8Release: 1%{?_dist_release}
9Epoch: 1
10Group: Applications/Productivity
11License: GPLv2+
12Source0: http://abisource.com/downloads/abiword/%{version}/source/abiword-%{version}.tar.gz
13Source3: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
14Source11: abiword.mime
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Vendor: Project Vine
19Distribution: Vine Linux
20#Packager:
21
22# for abiword
23BuildRequires: flex
24BuildRequires: bison
25BuildRequires: gcc-c++
26BuildRequires: gtk2-devel
27BuildRequires: libpng-devel
28BuildRequires: libxml2-devel
29BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
30BuildRequires: fribidi-devel
31BuildRequires: enchant-devel
32BuildRequires: libgnomeprint-devel
33BuildRequires: libgnomeprintui-devel
34BuildRequires: wv-devel
35BuildRequires: gucharmap-devel
36BuildRequires: libSM-devel
37
38# some plugin build deps
39BuildRequires: readline-devel
40BuildRequires: bzip2-devel
41BuildRequires: poppler-devel >= 0.14.2
42BuildRequires: libwpd-devel >= 0.8.0
43BuildRequires: librsvg2-devel
44BuildRequires: libgsf-devel >= 1.12.1
45BuildRequires: libboost-devel >= 1.33.1
46
47# gnome build deps
48BuildRequires: libbonobo-devel
49BuildRequires: libbonoboui-devel
50BuildRequires: libgnomeui-devel
51
52
53Requires(pre): desktop-file-utils >= %{desktop_file_utils_version}
54Obsoletes: abiword-fonts abiword-plugins
55
56URL: http://www.abisource.com/
57
58Patch0: abiword-2.6.0-windowshelppaths.patch
59Patch1: abiword-2.6.4-desktop.patch
60Patch2: abiword-2.6.0-boolean.patch
61Patch3: abiword-2.8.6-no-undefined.patch
62
63
64%description
65AbiWord is a cross-platform Open Source word processor. The goal is to make
66AbiWord full-featured, and remain lean.
67
68%description -l ja
69AbiWord はクロスプラットフォームのオープンソースなワードプロセッサーです。
70多機能で機敏に動くことを目標としています。
71
72%package -n libabiword
73Summary: Library for developing applications based on AbiWord's core
74Summary(ja): AbiWord コアで稼動するアプリケーションを開発するためのライブラリ
75Group: System Environment/Libraries
76
77%description -n libabiword
78Library for developing applications based on AbiWord's core.
79
80%description -n libabiword -l ja
81AbiWord コアで稼動するアプリケーションを開発するためのライブラリです。
82
83%package -n libabiword-devel
84Summary: Files for developing with libabiword
85Summary(ja): libabiword を用いた開発に必要なファイル群
86Group: Development/Libraries
87Requires: libabiword = %{epoch}:%{version}-%{release}
88
89%description -n libabiword-devel
90Includes and definitions for developing with libabiword.
91
92%description -n libabiword-devel -l ja
93libabiword で開発するためのインクルードファイル及び定義ファイルです。
94
95%prep
96%setup -q
97## %patch1 -p1 -b .desktop
98%patch2 -p1 -b .boolean
99
100# setup abiword extras
101## %setup -q -T -b 2 -n abiword-extras-%{version}
102
103# setup abiword documentation
104%setup -q -T -b 3 -n abiword-docs-%{version}
105%patch0 -p1 -b .windowshelppaths
106
107%build
108# build libabiword and abiword
109cd $RPM_BUILD_DIR/abiword-%{version}
110%configure  -enable-static=no
111make %{?_smp_mflags}
112
113# build abiword-plugins
114## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
115## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
116## CXXFLAGS="-L$RPM_BUILD_DIR/%{name}-%{version}/src/wp/main/unix/" %configure --disable-gda --enable-libabiword --with-abiword=$RPM_BUILD_DIR/%{name}-%{version}
117## # Remove libtool predep_objects and postdep_objects wonkiness so that
118## # building without -nostdlib doesn't include them twice.  Because we
119## # already link with g++, weird stuff happens if you don't let the
120## # compiler handle this.
121## sed 's/^predep_objects=.*/predep_objects=\"\"/' < libtool > libtool.foo
122## sed 's/^postdep_objects=.*/postdep_objects=\"\"/' < libtool.foo > libtool.foobar
123## sed 's/-shared -nostdlib/-shared/' < libtool.foobar > libtool
124## make %{?_smp_mflags}
125
126# build abiword-extras
127## cd $RPM_BUILD_DIR/abiword-extras-%{version}
128## # abiword-extras looks at the abiword-%{version}.pc pkg-config file to get its location info
129## # however, that file is not installed yet, so just point to it in the abiword source tree
130## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
131## %configure
132## make
133
134# build the documentation
135cd $RPM_BUILD_DIR/abiword-docs-%{version}
136ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/wp/main/unix/abiword ./make-html.sh
137
138%install
139rm -rf $RPM_BUILD_ROOT
140
141# install abiword
142cd $RPM_BUILD_DIR/abiword-%{version}
143make install DESTDIR=$RPM_BUILD_ROOT
144# overwrite the static binary with the dynamic one
145## mv -f $RPM_BUILD_DIR/abiword-%{version}/src/wp/main/unix/abiword-dynamic $RPM_BUILD_ROOT%{_bindir}/abiword
146
147# Fix script permission
148#chmod +x $RPM_BUILD_ROOT%{_datadir}/%{name}-%{abiver}/scripts/abw2html.pl
149
150# install abiword-plugins
151## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
152## make install DESTDIR=$RPM_BUILD_ROOT
153
154# install the extras
155## cd $RPM_BUILD_DIR/abiword-extras-%{version}
156## make install DESTDIR=$RPM_BUILD_ROOT
157
158# install the documentation
159cd $RPM_BUILD_DIR/abiword-docs-%{version}
160mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help
161cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/
162# some of the help dirs have bad perms (#109261)
163find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/ -type d -exec chmod -c o+rx {} \;
164
165# finish up
166## mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
167## cp $RPM_BUILD_DIR/abiword-extras-%{version}/icons/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
168
169cd $RPM_BUILD_DIR/abiword-%{version}
170mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
171desktop-file-install \
172  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
173  --add-category X-Red-Hat-Extra --remove-category X-Red-Hat-Base \
174  --add-category Applications --add-category Office \
175  ./abiword.desktop
176# remove the original one (which has X-Red-Hat-Base)  (#107023)
177#rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/abiword.desktop
178
179mkdir -p $RPM_BUILD_ROOT%{_datadir}/mime-info
180install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info
181
182# nuke .la files
183rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{abiver}/plugins/*.la
184rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
185# nuke .a files
186rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
187# nuke custom dictionary files
188rm -f $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/dictionary/ispell_dictionary_list.xml
189
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post
195update-desktop-database -q %{_datadir}/applications
196
197%postun
198update-desktop-database -q %{_datadir}/applications
199
200%files
201%defattr(-,root,root)
202%{_bindir}/abiword
203%{_datadir}/applications/*
204%{_datadir}/mime-info/*
205%{_datadir}/icons/*/*/*/abiword.png
206%{_mandir}/man1/abiword.1.gz
207
208%files -n libabiword
209%doc $RPM_BUILD_DIR/%{name}-%{version}/docs $RPM_BUILD_DIR/%{name}-%{version}/COPYING $RPM_BUILD_DIR/%{name}-%{version}/COPYRIGHT.TXT $RPM_BUILD_DIR/%{name}-%{version}/README.TXT
210%{_libdir}/abiword-%{abiver}
211%{_libdir}/libabiword-%{abiver}.so
212%{_datadir}/abiword-%{abiver}
213
214%files -n libabiword-devel
215%{_includedir}/abiword-%{abiver}
216%{_libdir}/pkgconfig/*.pc
217
218%changelog
219* Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:3.0.0-1
220- update to 3.0.0
221- remove Patch3 (abiword-2.8.6-no-undefined.patch)
222
223* Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-4
224- add Patch3 (abiword-2.8.6-no-undefined.patch)
225- add BuildRequires: flex, bison
226
227* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-3
228- rebuild with poppler-0.14.2
229
230* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-2
231- rebuild with rpm-4.8.1 for pkg-config file
232
233* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-1
234- new upstream release
235- drop Source1, Source2
236- drop Patch1, Patch3
237- fix %setup, %build, %install and %files
238
239* Wed Jul 29 2009 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1:2.6.8-2
240- add Japanese Summary and description
241- add BuildRequires: libSM-devel
242
243* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.8-1
244- new upstream release
245
246* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.4-1vl5
247- new upstream release
248- built with enchant
249- split libabiword, libabiword-devel subpackage
250
251* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-2vl5
252- built with gucharmap-2.24.0
253
254* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-1vl5
255- applied new versioning policy, spec in utf-8
256
257* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl2
258- rebuilt with new toolchain
259
260* Thu Dec 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl1
261- new upstream release
262- rebuilt with wv-1.2.4
263
264* Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl2
265- fixed .desktop file
266
267* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl1
268- updated to 2.4.5
269
270* Thu Apr 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.4-2vl1
271- rebuilt for Vine and merged old spec files
272  * Thu Sep 26 2002 Masaki Shinomiya <shino@pos.to>
273  - 1.0.3-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
274  - source update, plugins-1.0.3, many plugins enabled in -0vl2
275  - disabled perl
276  - abiword-mkhash.sh for spell check
277  * Mon Jun 24 2002 Masaki Shinomiya <shino@pos.to>
278  - 1.0.2-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
279  - source update
280  - touch fonts.dir, abiword-wrapper.patch
281  - no longer segmentation fault on Vine 2.5 (see [vine-users:051609]-)
282  * Wed May 22 2002 Masaki Shinomiya <shino@pos.to>
283  - 1.0.1-0vl1 for VinePlus/2.1 and (-0vl2) for VineSeedPlus
284  - 0vl1 omits plugins because Vine 2.1.x fails to compile
285  - 0vl1 also disables gnome and perl support
286  - Japanese fonts are now usable on VineSeed/Vine 2.5
287  - by using mkjafontsdir.sh made by me
288  - source upstream to 1.0.1, plugins(merged in the main package)
289  - doc, mime-info
290  * Sat Mar 30 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.4-0vl2
291  - new upstream version
292  - fix symbolic link ([VineSeed-Plus:00941])
293  * Sun Mar 18 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.3-0vl2
294  - new upstream version
295  * Sun Feb 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.2-0vl0
296  - new upstream version.
297  - disable plugin all and comment out plugin part in build/make section,
298    because 0.99.2's source tar boll doesn't have abiword-plugins directory.
299  * Fri Feb 15 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
300  - 0.99.1-0vl3 (0.99.1-0vl2 for VinePlus-2.1)
301  - fix files owner/group ([VineSeed-Plus:00819])
302  * Sat Jan 28 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
303  - 0.99.1-0vl0.1
304  - change release number for VinePlus 2.1
305  * Sat Jan 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
306  - 0.99.1-0vl1
307  - add japanese fonts.dir
308     (see http://www.gnome.gr.jp/ml/gnome-users/200101/msg00034.html)
309    0vl0.1 release for VinePlus-2.1 succeed to input/display japanese,
310    but this release fail to input/display japanese.
311    please someone fix this problem.
312
313* Thu Apr 13 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-2.fc6
314- Fix documentation generation
315- Fix charting support
316
317* Tue Apr 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-1.fc6
318- New upstream version
319- Remove the macro patch and update the desktop patch
320
321* Wed Mar 29 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-8.fc6
322- Rebuild
323
324* Wed Mar 08 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-7.fc5
325- Disable the collaboration plugin; it is not working in 2.4.x
326
327* Thu Feb 16 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-6.fc5
328- Rebuild for Fedora Extras 5
329
330* Sun Feb 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-5.fc5
331- bug 171926
332
333* Sat Jan 21 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-4.fc5
334- Disable the PDF plugin for now, as poppler doesn't ship the xpdf
335  headers anymore
336
337* Sat Jan 14 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-3.fc5
338- Remove redundant requires - bug 177305
339
340* Thu Jan 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-2.fc5
341- Bump release, forgot to add desktop patch
342
343* Mon Jan 02 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-1.fc5
344- Update to 2.4.2
345- Add BuildRequires readline-devel for the AbiCommand plugin
346- Add BuildRequires bzip2-devel and poppler-devel for plugins
347- Update desktop patch
348- Patch to fix plugin marcros
349
350* Wed Nov 09 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-4.fc5
351- Fix bug 171928
352
353* Sun Oct 23 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-3.fc5
354- Fix bug 161832: "Abiword is not loading certain modules"
355- Add libgsf dependecy, which was needed all along
356- Disable the collaboration plugin, it is not for general use at all
357
358* Tue Oct 11 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-2
359- Use %%{?dist} in the release name
360
361* Sun Oct 9 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-1
362- Update to 2.4.1
363
364* Mon Oct 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.0-1
365- Require mathml-fonts
366- Don't rerun autogen.sh, no need anymore
367- Update gtkmathview dependency to 0.7.5
368- Update to 2.4.0
369
370* Mon Sep 26 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-2
371- Fix gtkmathview BuildRequires
372
373* Thu Sep 22 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-1
374- Update to 2.3.99
375
376* Sat Sep 10 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.6-1
377- Update to 2.3.6
378- Drop the pango patch
379
380* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-3
381- Rebuild
382
383* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-2
384- Enable the abimathview plugin
385
386* Sun Aug 21 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-1
387- Update to 2.3.5
388
389* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-4
390- Update the pango patch to disable more pango code
391
392* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-3
393- Fix the build after applying the pango disabling patch by
394  rerunning autogen.sh
395
396* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-2
397- Disable the experimental pango renderer
398
399* Wed Aug 17 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-1
400- Update to 2.3.4
401- Add link-grammar dependency
402
403* Thu Jul 28 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.9-1
404- Update to 2.2.9
405- Drop the mailmerge patch again
406
407* Mon Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-2
408- Fix build with mailmerge patch
409
410* Mon Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-1
411- Update to 2.2.8
412
413* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1:2.2.7-2
414- rebuild on all arches
415
416* Mon Apr 4 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.7-1
417- Because we love brown paper bag releases
418
419* Sun Apr 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.6-1
420- Drop the gcc4, wvread, virtdestr and pt64 patches
421- Update the desktop patch
422
423* Tue Mar 15 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-3
424- Fix 64bit build
425- Add virtual destructors to classes with virtual functions
426
427* Mon Mar 14 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-2
428- Remove the --disable-magick plugin switch
429- disable GDA support until the plugin is ported to gnomedb 1.2.x
430- Change the download location from SF to http://www.abisource.com/
431- patch libole2
432- fix read as a macro in new glibc
433
434* Wed Mar  2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.5-1
435- bump to latest stable
436- drop integrated dashboard patch again
437- some gcc4 fixes
438
439* Wed Feb 23 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-2
440- rh#149447# dashboard spam revisited
441
442* Tue Feb 22 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-1
443- bump to latest stable version
444- drop integrated nautilus depend patch
445- drop integrated libwpd depend patch
446
447* Fri Feb 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-4
448- upgrade to libwpd-0.8 and incoroprate necessary changeover patches
449
450* Mon Feb 7 2005 Matthias Clasen <mclasen@redhat.com> - 1:2.2.3-3
451- rebuild
452
453* Wed Feb 2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-2
454- remove unneccessary nautilus dependency
455
456* Mon Jan 17 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-1
457- bump to new version
458- drop integrated silenceabidash patch
459
460* Fri Jan 14 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-4
461- RH#145085# annoying cluepacket message on stdout/stderr
462
463* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 1:2.2.2-3
464- Rebuilt for new readline.
465
466* Tue Jan 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-2
467- RH#143368# use enchant as spellchecker
468
469* Mon Dec 13 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-1
470- bump to new version
471
472* Mon Dec 6 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.1-1
473- bump to new version
474- geometry patch upstreamed
475- security patch upstreamed
476- removeoledecod patch upstreamed
477- regenerate desktop patch
478
479* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-2
480- #abi7961# remove tempnam usages
481
482* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-1
483- bump to latest major stable version
484- #rh140321# sanity check geometry
485
486* Tue Nov  9 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.0.14-1
487- bump to latest stable version
488
489* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.12-4
490- rebuild for python 2.4
491
492* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 1:2.0.12-3
493- Change to PreReq instead of Requires(post), up to 0.9
494
495* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-2
496- Better Requires desktop-file-utils
497
498* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-1
499- update to new abiword, + change norwegian wordprocessor translation
500
501* Tue Sep 14 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-3
502- #132389# Add more abiword supported mime types to abiword.desktop
503
504* Mon Sep 6 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-2
505- merge abiword.keys into abiword.desktop
506
507* Fri Aug 27 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-1
508- 2.0.11
509
510* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-2
511- use libgnomedb
512
513* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-1
514- 2.0.10
515- use aiksaurus
516
517* Mon Aug 2 2004 Matthias Clasen <mclasen@redhat.com> 1:2.0.9-4
518- rebuilt
519
520* Thu Jul 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-3
521- #126012# some desktop translations
522
523* Wed Jul 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-2
524- #128004# fix irritating windows looking filenames for generated pngs
525
526* Fri Jul 16 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-1
527- 2.0.9, new version with security fix
528
529* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
530- rebuilt
531
532* Thu May 20 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
533- 2.0.7, new version + gcc34 fixes
534
535* Wed Apr 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
536- 2.0.6, 64bit changes made upstream
537
538* Sat Mar 13 2004 Jeremy Katz <> 1:2.0.5-1
539- 2.0.5
540
541* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
542- rebuilt
543
544* Thu Feb 19 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-3
545- rebuild for newer libots and libwpd
546- fix verify as non-root (#109261)
547- add wpd files to abiword.keys (#114907)
548
549* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
550- rebuilt
551
552* Thu Jan 29 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-1
553- 2.0.3 (fixes build against gtk+ 2.3 and lets us rebuild to fix libcroco dep)
554
555* Wed Dec 17 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.2-2
556- rebuild for new libwpd
557
558* Sun Nov 30 2003 Jeremy Katz <katzj@redhat.com>
559- and librsvg2-devel (#111222)
560
561* Fri Nov 28 2003 Jeremy Katz <katzj@redhat.com>
562- buildrequire libgnomeui-devel (#111164)
563
564* Tue Oct 28 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.1-1
565- 2.0.1
566- really remove duplicate desktop file
567
568* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-6
569- make the docs with the just built abiword so that we don't have to
570  have abiword installed to build the docs (#107279)
571
572* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-5
573- fix linkage to glib 1.2 in hancom plugin (#106033)
574
575* Sun Oct 19 2003 Florian La Roche <Florian.LaRoche@redhat.de>
576- add %%clean specfile target
577
578* Tue Oct 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-4
579- remove duplicate desktop file (#107023)
580
581* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-3
582- include the help
583- show the clipart (#104577)
584
585* Mon Sep 15 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-2
586- rebuild with newer libwpd and libots to get those plugins
587
588* Sun Sep 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-1
589- 2.0.0
590
591* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.6-1
592- 1.99.6
593
594* Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.5-1
595- 1.99.5
596
597* Tue Aug  5 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.3-1
598- 1.99.3
599- put icon in the right place (#101646)
600- fix some 64bit casting issues
601- disable ots plugin for now, doesn't seem to build with ots 0.4.0 :/
602- disable -pedantic -ansi so that it will build
603
604* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-2
605- ugly hack to deal with libtool silliness on x86_64
606
607* Fri Jul 11 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-1
608- 1.99.2
609- add buildrequires to make sure the ots and wp plugins get built
610- no longer needs libgal2, remove buildrequires
611
612* Mon Jun 16 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.1-1
613- 1.99.1
614
615* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
616- rebuilt
617
618* Mon May 26 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-3
619- rebuild for new libgal2
620
621* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-2
622- tweak plugins build
623
624* Mon May 12 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-0.2
625- 1.9.1
626- drop old patches, switch to using autoconf based build system instead
627  of diving makefiles
628- build with gnome support
629- build with plugins
630- add patch to build on AMD64
631
632* Mon Apr 28 2003 Tim Powers <timp@redhat.com> 1:1.0.5-2
633- rebuild to fix broken libpspell dep
634
635* Mon Mar 24 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.5-1
636- 1.0.5
637
638* Mon Feb 10 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-2
639- fix for abiword starting off the screen (#82425)
640
641* Thu Jan 23 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-1
642- 1.0.4
643
644* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
645- rebuilt
646
647* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-2
648- make it build on x86_64
649
650* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-1
651- 1.0.3 (#80560)
652- set umask before running mkfontdir in %%post
653- patch AbiWord script to convert utf8 locales into non-utf8 variants (#72633)
654
655* Mon Dec 02 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-7
656- Fix doc lines
657- Fix multilib
658
659* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-6
660- rebuilt with gcc-3.2 (we hope)
661
662* Sat Aug 10 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-5
663- fix help index symlink (#71219)
664
665* Thu Aug  1 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-4
666- add abiword binary symlink for upstream compatibility (#70267)
667
668* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.0.2-3
669- rebuild using gcc-3.2-0.1
670
671* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-2
672- use included desktop file (#64447)
673- use desktop-file-install
674
675* Wed Jun 26 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-1
676- 1.0.2
677- disable perl module build since we weren't including it anyway
678
679* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.1-1
680- 1.0.1
681
682* Sun Apr 14 2002 Jeremy Katz <katzj@redhat.com> 0.99.5-1
683- zh_CN and zh_TW fonts.dir were flipped
684- update to 0.99.5 as it fixes some major bugs
685- define ABI_BUILD_VERSION so the about screen gives us a version
686
687* Mon Apr  8 2002 Bennhard Rosenkraenzer <bero@redhat.com> 0.99.4-2
688- 1st try at fixing up CJK (#61590)
689- #if 0'ify font warning dialog (#62909, #64556)
690
691* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.4-1
692- Update to 0.99.4, fixes #61153
693- Fix #61344
694- Nuke the warning about being unable to add anything to font path,
695  that's not how xfs works.
696
697* Thu Feb 28 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.2-1
698- 0.99.2
699- remove blank lines in fonts.dir
700
701* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.1-1
702- 0.99.1
703
704* Wed Jan 30 2002 Alex Larsson <alexl@redhat.com> 0.9.5-3
705- Added patch to use libpng10
706- Added patch to fix perl build problems.
707
708* Fri Nov 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.5-1
709- 0.9.5
710
711* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.4.1-1
712- Update to 0.9.4.1 (RFE #54806)
713- Add URL (RFE #54590)
714
715* Thu Jul 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-7
716- Fix uninstall (#49350)
717
718* Sat Jul  7 2001 Tim Powers <timp@redhat.com>
719- rebuilt so that dirs aren't sgid root
720
721* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-5
722- Add build requirements (#45157)
723
724* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-4
725- Remove CVS admin files from documentation (#44916)
726
727* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
728- add s390x patch from <oliver.paukstadt@millenux.com>
729
730* Sat Jun 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
731- add s390 patch from Helge Deller
732
733* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-1
734- Update to 0.7.14
735
736* Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
737- Handle MIME type stuff (Bug #27530)
738- Add BuildPrereqs for some of the less common stuff AbiWord uses
739  (gal-devel, gnome-print-devel, libunicode-devel)
740
741* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
742- 0.7.13
743
744* Mon Jan 15 2001 Than Ngo <than@redhat.com>
745- fixed broken code for building
746
747* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
748- 0.7.12
749- copy fonts.dir to fonts.scale so mkfontdir doesn't blow it away
750
751* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
752- Rebuild to get rid of 0777 dirs
753
754* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
755- 0.7.11
756
757* Sun Aug 20 2000 Preston Brown <pbrown@redhat.com>
758- fix path to chkfontpath, it was wrong.
759
760* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
761- Up Epoch and release
762
763* Mon Aug  7 2000 Jakub Jelinek <jakub@redhat.com>
764- Don't ship AbiWord_s if we have AbiWord_d
765- Register AbiWord's fontpath with xfs
766
767* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
768- Rebuild with new libpng. This fixes Bug #13707 - gotta love it when they
769  change the ABI without increasing the soname!
770- fix tooltip (Bug #14711)
771- move binaries from /usr/share to /usr/lib
772
773* Wed Jul 12 2000 Jakub Jelinek <jakub@redhat.com>
774- Fix build on ia64.
775
776* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
777- automatic rebuild
778
779* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
780- Rebuild with new gcc.
781
782* Sun Jun 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
783- Fix build on ia64
784
785* Sat Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
786- 0.7.10
787- update download location
788
789* Fri Jun  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
790- initial build for main CD
791- clean up specfile
792- fix build with gcc 2.96 and glibc 2.2
793- exclude ia64 for now
794
795* Wed May  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
796- 0.7.9
797
798* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
799- 0.7.8
800- move the desktop file to /etc/X11/applnk so it can be used in both
801  GNOME and KDE
802- fix up handling of RPM_OPT_FLAGS
803
804* Thu Jan 20 2000 Tim Powers <timp@redhat.com>
805- bzipped source to conserve space.
806
807* Sun Jan  9 2000 Matt Wilson <msw@redhat.com>
808- enable GNOME, remove perl hack to do RPM_OPT_FLAGS
809- added libpng requirement.  0.7.7 requires 1.0.5 libpng ABI
810
811* Tue Jan  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
812- 0.7.7
813- handle RPM_OPT_FLAGS
814
815* Mon Nov 15 1999 Tim Powers <timp@redhat.com>
816- first build for inclusion into Powertools.
817- some things in this spec file are from the abisuite-0.7.5-1mdk package
Note: See TracBrowser for help on using the repository browser.