source: projects/specs/trunk/a/abiword/abiword-vl.spec @ 9192

Revision 9192, 26.8 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define desktop_file_utils_version 0.16
2%define abiver 3.0
3
4Summary: The AbiWord word processor
5Summary(ja): AbiWord ワードプロセッサ
6Name: abiword
7Version: 3.0.1
8Release: 1%{?_dist_release}
9Epoch: 1
10Group: Applications/Productivity
11License: GPLv2+
12Source0: http://abisource.com/downloads/abiword/%{version}/source/abiword-%{version}.tar.gz
13Source3: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
14Source11: abiword.mime
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Vendor: Project Vine
19Distribution: Vine Linux
20#Packager:
21
22# for abiword
23BuildRequires: flex
24BuildRequires: bison
25BuildRequires: gcc-c++
26BuildRequires: gtk2-devel
27BuildRequires: libpng-devel
28BuildRequires: libxml2-devel
29BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
30BuildRequires: fribidi-devel
31BuildRequires: enchant-devel
32BuildRequires: libgnomeprint-devel
33BuildRequires: libgnomeprintui-devel
34BuildRequires: wv-devel
35BuildRequires: gucharmap-devel
36BuildRequires: libSM-devel
37
38# some plugin build deps
39BuildRequires: readline-devel
40BuildRequires: bzip2-devel
41BuildRequires: poppler-devel >= 0.14.2
42BuildRequires: libwpd-devel >= 0.8.0
43BuildRequires: librsvg2-devel
44BuildRequires: libgsf-devel >= 1.12.1
45BuildRequires: libboost-devel >= 1.33.1
46
47# gnome build deps
48BuildRequires: libbonobo-devel
49BuildRequires: libbonoboui-devel
50BuildRequires: libgnomeui-devel
51
52
53Requires(pre): desktop-file-utils >= %{desktop_file_utils_version}
54Obsoletes: abiword-fonts abiword-plugins
55
56URL: http://www.abisource.com/
57
58Patch0: abiword-2.6.0-windowshelppaths.patch
59Patch1: abiword-2.6.4-desktop.patch
60Patch2: abiword-2.6.0-boolean.patch
61Patch3: abiword-2.8.6-no-undefined.patch
62
63
64%description
65AbiWord is a cross-platform Open Source word processor. The goal is to make
66AbiWord full-featured, and remain lean.
67
68%description -l ja
69AbiWord はクロスプラットフォームのオープンソースなワードプロセッサーです。
70多機能で機敏に動くことを目標としています。
71
72%package -n libabiword
73Summary: Library for developing applications based on AbiWord's core
74Summary(ja): AbiWord コアで稼動するアプリケーションを開発するためのライブラリ
75Group: System Environment/Libraries
76
77%description -n libabiword
78Library for developing applications based on AbiWord's core.
79
80%description -n libabiword -l ja
81AbiWord コアで稼動するアプリケーションを開発するためのライブラリです。
82
83%package -n libabiword-devel
84Summary: Files for developing with libabiword
85Summary(ja): libabiword を用いた開発に必要なファイル群
86Group: Development/Libraries
87Requires: libabiword = %{epoch}:%{version}-%{release}
88
89%description -n libabiword-devel
90Includes and definitions for developing with libabiword.
91
92%description -n libabiword-devel -l ja
93libabiword で開発するためのインクルードファイル及び定義ファイルです。
94
95%prep
96%setup -q
97## %patch1 -p1 -b .desktop
98%patch2 -p1 -b .boolean
99
100# setup abiword extras
101## %setup -q -T -b 2 -n abiword-extras-%{version}
102
103# setup abiword documentation
104%setup -q -T -b 3 -n abiword-docs-%{version}
105%patch0 -p1 -b .windowshelppaths
106
107%build
108# build libabiword and abiword
109cd $RPM_BUILD_DIR/abiword-%{version}
110%configure  -enable-static=no
111make %{?_smp_mflags}
112
113# build abiword-plugins
114## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
115## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
116## CXXFLAGS="-L$RPM_BUILD_DIR/%{name}-%{version}/src/wp/main/unix/" %configure --disable-gda --enable-libabiword --with-abiword=$RPM_BUILD_DIR/%{name}-%{version}
117## # Remove libtool predep_objects and postdep_objects wonkiness so that
118## # building without -nostdlib doesn't include them twice.  Because we
119## # already link with g++, weird stuff happens if you don't let the
120## # compiler handle this.
121## sed 's/^predep_objects=.*/predep_objects=\"\"/' < libtool > libtool.foo
122## sed 's/^postdep_objects=.*/postdep_objects=\"\"/' < libtool.foo > libtool.foobar
123## sed 's/-shared -nostdlib/-shared/' < libtool.foobar > libtool
124## make %{?_smp_mflags}
125
126# build abiword-extras
127## cd $RPM_BUILD_DIR/abiword-extras-%{version}
128## # abiword-extras looks at the abiword-%{version}.pc pkg-config file to get its location info
129## # however, that file is not installed yet, so just point to it in the abiword source tree
130## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
131## %configure
132## make
133
134# build the documentation
135cd $RPM_BUILD_DIR/abiword-docs-%{version}
136ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/wp/main/unix/abiword ./make-html.sh
137
138%install
139rm -rf $RPM_BUILD_ROOT
140
141# install abiword
142cd $RPM_BUILD_DIR/abiword-%{version}
143make install DESTDIR=$RPM_BUILD_ROOT
144# overwrite the static binary with the dynamic one
145## mv -f $RPM_BUILD_DIR/abiword-%{version}/src/wp/main/unix/abiword-dynamic $RPM_BUILD_ROOT%{_bindir}/abiword
146
147# Fix script permission
148#chmod +x $RPM_BUILD_ROOT%{_datadir}/%{name}-%{abiver}/scripts/abw2html.pl
149
150# install abiword-plugins
151## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
152## make install DESTDIR=$RPM_BUILD_ROOT
153
154# install the extras
155## cd $RPM_BUILD_DIR/abiword-extras-%{version}
156## make install DESTDIR=$RPM_BUILD_ROOT
157
158# install the documentation
159cd $RPM_BUILD_DIR/abiword-docs-%{version}
160mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help
161cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/
162# some of the help dirs have bad perms (#109261)
163find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/ -type d -exec chmod -c o+rx {} \;
164
165# finish up
166## mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
167## cp $RPM_BUILD_DIR/abiword-extras-%{version}/icons/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
168
169cd $RPM_BUILD_DIR/abiword-%{version}
170mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
171desktop-file-install \
172  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
173  --add-category X-Red-Hat-Extra --remove-category X-Red-Hat-Base \
174  --add-category Applications --add-category Office \
175  ./abiword.desktop
176# remove the original one (which has X-Red-Hat-Base)  (#107023)
177#rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/abiword.desktop
178
179mkdir -p $RPM_BUILD_ROOT%{_datadir}/mime-info
180install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info
181
182# nuke .la files
183rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{abiver}/plugins/*.la
184rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
185# nuke .a files
186rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
187# nuke custom dictionary files
188rm -f $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/dictionary/ispell_dictionary_list.xml
189
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post
195update-desktop-database -q %{_datadir}/applications
196
197%postun
198update-desktop-database -q %{_datadir}/applications
199
200%files
201%defattr(-,root,root)
202%{_bindir}/abiword
203%{_datadir}/applications/*
204%{_datadir}/mime-info/*
205%{_datadir}/icons/*/*/*/abiword.*
206%{_mandir}/man1/abiword.1.gz
207
208%files -n libabiword
209%doc $RPM_BUILD_DIR/%{name}-%{version}/docs $RPM_BUILD_DIR/%{name}-%{version}/COPYING $RPM_BUILD_DIR/%{name}-%{version}/COPYRIGHT.TXT $RPM_BUILD_DIR/%{name}-%{version}/README.TXT
210%{_libdir}/abiword-%{abiver}
211%{_libdir}/libabiword-%{abiver}.so
212%{_datadir}/abiword-%{abiver}
213
214%files -n libabiword-devel
215%{_includedir}/abiword-%{abiver}
216%{_libdir}/pkgconfig/*.pc
217
218%changelog
219* Thu Dec 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:3.0.1-1
220- new upstream release
221
222* Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:3.0.0-1
223- update to 3.0.0
224- remove Patch3 (abiword-2.8.6-no-undefined.patch)
225
226* Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-4
227- add Patch3 (abiword-2.8.6-no-undefined.patch)
228- add BuildRequires: flex, bison
229
230* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-3
231- rebuild with poppler-0.14.2
232
233* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-2
234- rebuild with rpm-4.8.1 for pkg-config file
235
236* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-1
237- new upstream release
238- drop Source1, Source2
239- drop Patch1, Patch3
240- fix %setup, %build, %install and %files
241
242* Wed Jul 29 2009 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1:2.6.8-2
243- add Japanese Summary and description
244- add BuildRequires: libSM-devel
245
246* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.8-1
247- new upstream release
248
249* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.4-1vl5
250- new upstream release
251- built with enchant
252- split libabiword, libabiword-devel subpackage
253
254* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-2vl5
255- built with gucharmap-2.24.0
256
257* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-1vl5
258- applied new versioning policy, spec in utf-8
259
260* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl2
261- rebuilt with new toolchain
262
263* Thu Dec 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl1
264- new upstream release
265- rebuilt with wv-1.2.4
266
267* Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl2
268- fixed .desktop file
269
270* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl1
271- updated to 2.4.5
272
273* Thu Apr 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.4-2vl1
274- rebuilt for Vine and merged old spec files
275  * Thu Sep 26 2002 Masaki Shinomiya <shino@pos.to>
276  - 1.0.3-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
277  - source update, plugins-1.0.3, many plugins enabled in -0vl2
278  - disabled perl
279  - abiword-mkhash.sh for spell check
280  * Mon Jun 24 2002 Masaki Shinomiya <shino@pos.to>
281  - 1.0.2-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
282  - source update
283  - touch fonts.dir, abiword-wrapper.patch
284  - no longer segmentation fault on Vine 2.5 (see [vine-users:051609]-)
285  * Wed May 22 2002 Masaki Shinomiya <shino@pos.to>
286  - 1.0.1-0vl1 for VinePlus/2.1 and (-0vl2) for VineSeedPlus
287  - 0vl1 omits plugins because Vine 2.1.x fails to compile
288  - 0vl1 also disables gnome and perl support
289  - Japanese fonts are now usable on VineSeed/Vine 2.5
290  - by using mkjafontsdir.sh made by me
291  - source upstream to 1.0.1, plugins(merged in the main package)
292  - doc, mime-info
293  * Sat Mar 30 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.4-0vl2
294  - new upstream version
295  - fix symbolic link ([VineSeed-Plus:00941])
296  * Sun Mar 18 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.3-0vl2
297  - new upstream version
298  * Sun Feb 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.2-0vl0
299  - new upstream version.
300  - disable plugin all and comment out plugin part in build/make section,
301    because 0.99.2's source tar boll doesn't have abiword-plugins directory.
302  * Fri Feb 15 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
303  - 0.99.1-0vl3 (0.99.1-0vl2 for VinePlus-2.1)
304  - fix files owner/group ([VineSeed-Plus:00819])
305  * Sat Jan 28 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
306  - 0.99.1-0vl0.1
307  - change release number for VinePlus 2.1
308  * Sat Jan 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
309  - 0.99.1-0vl1
310  - add japanese fonts.dir
311     (see http://www.gnome.gr.jp/ml/gnome-users/200101/msg00034.html)
312    0vl0.1 release for VinePlus-2.1 succeed to input/display japanese,
313    but this release fail to input/display japanese.
314    please someone fix this problem.
315
316* Thu Apr 13 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-2.fc6
317- Fix documentation generation
318- Fix charting support
319
320* Tue Apr 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-1.fc6
321- New upstream version
322- Remove the macro patch and update the desktop patch
323
324* Wed Mar 29 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-8.fc6
325- Rebuild
326
327* Wed Mar 08 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-7.fc5
328- Disable the collaboration plugin; it is not working in 2.4.x
329
330* Thu Feb 16 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-6.fc5
331- Rebuild for Fedora Extras 5
332
333* Sun Feb 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-5.fc5
334- bug 171926
335
336* Sat Jan 21 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-4.fc5
337- Disable the PDF plugin for now, as poppler doesn't ship the xpdf
338  headers anymore
339
340* Sat Jan 14 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-3.fc5
341- Remove redundant requires - bug 177305
342
343* Thu Jan 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-2.fc5
344- Bump release, forgot to add desktop patch
345
346* Mon Jan 02 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-1.fc5
347- Update to 2.4.2
348- Add BuildRequires readline-devel for the AbiCommand plugin
349- Add BuildRequires bzip2-devel and poppler-devel for plugins
350- Update desktop patch
351- Patch to fix plugin marcros
352
353* Wed Nov 09 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-4.fc5
354- Fix bug 171928
355
356* Sun Oct 23 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-3.fc5
357- Fix bug 161832: "Abiword is not loading certain modules"
358- Add libgsf dependecy, which was needed all along
359- Disable the collaboration plugin, it is not for general use at all
360
361* Tue Oct 11 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-2
362- Use %%{?dist} in the release name
363
364* Sun Oct 9 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-1
365- Update to 2.4.1
366
367* Mon Oct 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.0-1
368- Require mathml-fonts
369- Don't rerun autogen.sh, no need anymore
370- Update gtkmathview dependency to 0.7.5
371- Update to 2.4.0
372
373* Mon Sep 26 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-2
374- Fix gtkmathview BuildRequires
375
376* Thu Sep 22 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-1
377- Update to 2.3.99
378
379* Sat Sep 10 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.6-1
380- Update to 2.3.6
381- Drop the pango patch
382
383* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-3
384- Rebuild
385
386* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-2
387- Enable the abimathview plugin
388
389* Sun Aug 21 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-1
390- Update to 2.3.5
391
392* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-4
393- Update the pango patch to disable more pango code
394
395* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-3
396- Fix the build after applying the pango disabling patch by
397  rerunning autogen.sh
398
399* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-2
400- Disable the experimental pango renderer
401
402* Wed Aug 17 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-1
403- Update to 2.3.4
404- Add link-grammar dependency
405
406* Thu Jul 28 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.9-1
407- Update to 2.2.9
408- Drop the mailmerge patch again
409
410* Mon Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-2
411- Fix build with mailmerge patch
412
413* Mon Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-1
414- Update to 2.2.8
415
416* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1:2.2.7-2
417- rebuild on all arches
418
419* Mon Apr 4 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.7-1
420- Because we love brown paper bag releases
421
422* Sun Apr 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.6-1
423- Drop the gcc4, wvread, virtdestr and pt64 patches
424- Update the desktop patch
425
426* Tue Mar 15 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-3
427- Fix 64bit build
428- Add virtual destructors to classes with virtual functions
429
430* Mon Mar 14 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-2
431- Remove the --disable-magick plugin switch
432- disable GDA support until the plugin is ported to gnomedb 1.2.x
433- Change the download location from SF to http://www.abisource.com/
434- patch libole2
435- fix read as a macro in new glibc
436
437* Wed Mar  2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.5-1
438- bump to latest stable
439- drop integrated dashboard patch again
440- some gcc4 fixes
441
442* Wed Feb 23 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-2
443- rh#149447# dashboard spam revisited
444
445* Tue Feb 22 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-1
446- bump to latest stable version
447- drop integrated nautilus depend patch
448- drop integrated libwpd depend patch
449
450* Fri Feb 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-4
451- upgrade to libwpd-0.8 and incoroprate necessary changeover patches
452
453* Mon Feb 7 2005 Matthias Clasen <mclasen@redhat.com> - 1:2.2.3-3
454- rebuild
455
456* Wed Feb 2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-2
457- remove unneccessary nautilus dependency
458
459* Mon Jan 17 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-1
460- bump to new version
461- drop integrated silenceabidash patch
462
463* Fri Jan 14 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-4
464- RH#145085# annoying cluepacket message on stdout/stderr
465
466* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 1:2.2.2-3
467- Rebuilt for new readline.
468
469* Tue Jan 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-2
470- RH#143368# use enchant as spellchecker
471
472* Mon Dec 13 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-1
473- bump to new version
474
475* Mon Dec 6 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.1-1
476- bump to new version
477- geometry patch upstreamed
478- security patch upstreamed
479- removeoledecod patch upstreamed
480- regenerate desktop patch
481
482* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-2
483- #abi7961# remove tempnam usages
484
485* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-1
486- bump to latest major stable version
487- #rh140321# sanity check geometry
488
489* Tue Nov  9 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.0.14-1
490- bump to latest stable version
491
492* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.12-4
493- rebuild for python 2.4
494
495* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 1:2.0.12-3
496- Change to PreReq instead of Requires(post), up to 0.9
497
498* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-2
499- Better Requires desktop-file-utils
500
501* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-1
502- update to new abiword, + change norwegian wordprocessor translation
503
504* Tue Sep 14 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-3
505- #132389# Add more abiword supported mime types to abiword.desktop
506
507* Mon Sep 6 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-2
508- merge abiword.keys into abiword.desktop
509
510* Fri Aug 27 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-1
511- 2.0.11
512
513* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-2
514- use libgnomedb
515
516* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-1
517- 2.0.10
518- use aiksaurus
519
520* Mon Aug 2 2004 Matthias Clasen <mclasen@redhat.com> 1:2.0.9-4
521- rebuilt
522
523* Thu Jul 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-3
524- #126012# some desktop translations
525
526* Wed Jul 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-2
527- #128004# fix irritating windows looking filenames for generated pngs
528
529* Fri Jul 16 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-1
530- 2.0.9, new version with security fix
531
532* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
533- rebuilt
534
535* Thu May 20 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
536- 2.0.7, new version + gcc34 fixes
537
538* Wed Apr 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
539- 2.0.6, 64bit changes made upstream
540
541* Sat Mar 13 2004 Jeremy Katz <> 1:2.0.5-1
542- 2.0.5
543
544* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
545- rebuilt
546
547* Thu Feb 19 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-3
548- rebuild for newer libots and libwpd
549- fix verify as non-root (#109261)
550- add wpd files to abiword.keys (#114907)
551
552* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
553- rebuilt
554
555* Thu Jan 29 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-1
556- 2.0.3 (fixes build against gtk+ 2.3 and lets us rebuild to fix libcroco dep)
557
558* Wed Dec 17 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.2-2
559- rebuild for new libwpd
560
561* Sun Nov 30 2003 Jeremy Katz <katzj@redhat.com>
562- and librsvg2-devel (#111222)
563
564* Fri Nov 28 2003 Jeremy Katz <katzj@redhat.com>
565- buildrequire libgnomeui-devel (#111164)
566
567* Tue Oct 28 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.1-1
568- 2.0.1
569- really remove duplicate desktop file
570
571* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-6
572- make the docs with the just built abiword so that we don't have to
573  have abiword installed to build the docs (#107279)
574
575* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-5
576- fix linkage to glib 1.2 in hancom plugin (#106033)
577
578* Sun Oct 19 2003 Florian La Roche <Florian.LaRoche@redhat.de>
579- add %%clean specfile target
580
581* Tue Oct 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-4
582- remove duplicate desktop file (#107023)
583
584* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-3
585- include the help
586- show the clipart (#104577)
587
588* Mon Sep 15 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-2
589- rebuild with newer libwpd and libots to get those plugins
590
591* Sun Sep 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-1
592- 2.0.0
593
594* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.6-1
595- 1.99.6
596
597* Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.5-1
598- 1.99.5
599
600* Tue Aug  5 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.3-1
601- 1.99.3
602- put icon in the right place (#101646)
603- fix some 64bit casting issues
604- disable ots plugin for now, doesn't seem to build with ots 0.4.0 :/
605- disable -pedantic -ansi so that it will build
606
607* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-2
608- ugly hack to deal with libtool silliness on x86_64
609
610* Fri Jul 11 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-1
611- 1.99.2
612- add buildrequires to make sure the ots and wp plugins get built
613- no longer needs libgal2, remove buildrequires
614
615* Mon Jun 16 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.1-1
616- 1.99.1
617
618* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
619- rebuilt
620
621* Mon May 26 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-3
622- rebuild for new libgal2
623
624* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-2
625- tweak plugins build
626
627* Mon May 12 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-0.2
628- 1.9.1
629- drop old patches, switch to using autoconf based build system instead
630  of diving makefiles
631- build with gnome support
632- build with plugins
633- add patch to build on AMD64
634
635* Mon Apr 28 2003 Tim Powers <timp@redhat.com> 1:1.0.5-2
636- rebuild to fix broken libpspell dep
637
638* Mon Mar 24 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.5-1
639- 1.0.5
640
641* Mon Feb 10 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-2
642- fix for abiword starting off the screen (#82425)
643
644* Thu Jan 23 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-1
645- 1.0.4
646
647* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
648- rebuilt
649
650* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-2
651- make it build on x86_64
652
653* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-1
654- 1.0.3 (#80560)
655- set umask before running mkfontdir in %%post
656- patch AbiWord script to convert utf8 locales into non-utf8 variants (#72633)
657
658* Mon Dec 02 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-7
659- Fix doc lines
660- Fix multilib
661
662* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-6
663- rebuilt with gcc-3.2 (we hope)
664
665* Sat Aug 10 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-5
666- fix help index symlink (#71219)
667
668* Thu Aug  1 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-4
669- add abiword binary symlink for upstream compatibility (#70267)
670
671* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.0.2-3
672- rebuild using gcc-3.2-0.1
673
674* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-2
675- use included desktop file (#64447)
676- use desktop-file-install
677
678* Wed Jun 26 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-1
679- 1.0.2
680- disable perl module build since we weren't including it anyway
681
682* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.1-1
683- 1.0.1
684
685* Sun Apr 14 2002 Jeremy Katz <katzj@redhat.com> 0.99.5-1
686- zh_CN and zh_TW fonts.dir were flipped
687- update to 0.99.5 as it fixes some major bugs
688- define ABI_BUILD_VERSION so the about screen gives us a version
689
690* Mon Apr  8 2002 Bennhard Rosenkraenzer <bero@redhat.com> 0.99.4-2
691- 1st try at fixing up CJK (#61590)
692- #if 0'ify font warning dialog (#62909, #64556)
693
694* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.4-1
695- Update to 0.99.4, fixes #61153
696- Fix #61344
697- Nuke the warning about being unable to add anything to font path,
698  that's not how xfs works.
699
700* Thu Feb 28 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.2-1
701- 0.99.2
702- remove blank lines in fonts.dir
703
704* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.1-1
705- 0.99.1
706
707* Wed Jan 30 2002 Alex Larsson <alexl@redhat.com> 0.9.5-3
708- Added patch to use libpng10
709- Added patch to fix perl build problems.
710
711* Fri Nov 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.5-1
712- 0.9.5
713
714* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.4.1-1
715- Update to 0.9.4.1 (RFE #54806)
716- Add URL (RFE #54590)
717
718* Thu Jul 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-7
719- Fix uninstall (#49350)
720
721* Sat Jul  7 2001 Tim Powers <timp@redhat.com>
722- rebuilt so that dirs aren't sgid root
723
724* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-5
725- Add build requirements (#45157)
726
727* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-4
728- Remove CVS admin files from documentation (#44916)
729
730* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
731- add s390x patch from <oliver.paukstadt@millenux.com>
732
733* Sat Jun 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
734- add s390 patch from Helge Deller
735
736* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-1
737- Update to 0.7.14
738
739* Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
740- Handle MIME type stuff (Bug #27530)
741- Add BuildPrereqs for some of the less common stuff AbiWord uses
742  (gal-devel, gnome-print-devel, libunicode-devel)
743
744* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
745- 0.7.13
746
747* Mon Jan 15 2001 Than Ngo <than@redhat.com>
748- fixed broken code for building
749
750* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
751- 0.7.12
752- copy fonts.dir to fonts.scale so mkfontdir doesn't blow it away
753
754* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
755- Rebuild to get rid of 0777 dirs
756
757* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
758- 0.7.11
759
760* Sun Aug 20 2000 Preston Brown <pbrown@redhat.com>
761- fix path to chkfontpath, it was wrong.
762
763* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
764- Up Epoch and release
765
766* Mon Aug  7 2000 Jakub Jelinek <jakub@redhat.com>
767- Don't ship AbiWord_s if we have AbiWord_d
768- Register AbiWord's fontpath with xfs
769
770* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
771- Rebuild with new libpng. This fixes Bug #13707 - gotta love it when they
772  change the ABI without increasing the soname!
773- fix tooltip (Bug #14711)
774- move binaries from /usr/share to /usr/lib
775
776* Wed Jul 12 2000 Jakub Jelinek <jakub@redhat.com>
777- Fix build on ia64.
778
779* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
780- automatic rebuild
781
782* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
783- Rebuild with new gcc.
784
785* Sun Jun 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
786- Fix build on ia64
787
788* Sat Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
789- 0.7.10
790- update download location
791
792* Fri Jun  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
793- initial build for main CD
794- clean up specfile
795- fix build with gcc 2.96 and glibc 2.2
796- exclude ia64 for now
797
798* Wed May  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
799- 0.7.9
800
801* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
802- 0.7.8
803- move the desktop file to /etc/X11/applnk so it can be used in both
804  GNOME and KDE
805- fix up handling of RPM_OPT_FLAGS
806
807* Thu Jan 20 2000 Tim Powers <timp@redhat.com>
808- bzipped source to conserve space.
809
810* Sun Jan  9 2000 Matt Wilson <msw@redhat.com>
811- enable GNOME, remove perl hack to do RPM_OPT_FLAGS
812- added libpng requirement.  0.7.7 requires 1.0.5 libpng ABI
813
814* Tue Jan  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
815- 0.7.7
816- handle RPM_OPT_FLAGS
817
818* Mon Nov 15 1999 Tim Powers <timp@redhat.com>
819- first build for inclusion into Powertools.
820- some things in this spec file are from the abisuite-0.7.5-1mdk package
Note: See TracBrowser for help on using the repository browser.