source: projects/specs/trunk/a/abiword/abiword-vl.spec @ 1401

Revision 1401, 26.7 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1%define desktop_file_utils_version 0.16
2%define abiver 2.8
3
4Summary: The AbiWord word processor
5Summary(ja): AbiWord ワードプロセッサ
6Name: abiword
7Version: 2.8.6
8Release: 1%{?_dist_release}
9Epoch: 1
10Group: Applications/Productivity
11License: GPLv2+
12Source0: http://abisource.com/downloads/abiword/%{version}/source/abiword-%{version}.tar.gz
13## Source1: http://abisource.com/downloads/abiword/%{version}/source/abiword-plugins-%{version}.tar.gz
14## Source2: http://abisource.com/downloads/abiword/%{version}/source/abiword-extras-%{version}.tar.gz
15Source3: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
16Source11: abiword.mime
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22#Packager:
23
24# for abiword
25BuildRequires: gcc-c++
26BuildRequires: gtk2-devel
27BuildRequires: libpng-devel
28BuildRequires: libxml2-devel
29BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
30BuildRequires: fribidi-devel
31BuildRequires: enchant-devel
32BuildRequires: libgnomeprint-devel
33BuildRequires: libgnomeprintui-devel
34BuildRequires: wv-devel
35BuildRequires: gucharmap-devel
36BuildRequires: libSM-devel
37
38# some plugin build deps
39BuildRequires: readline-devel
40BuildRequires: bzip2-devel
41BuildRequires: poppler-devel >= 0.4.0
42#BuildRequires: ots-devel >= 0.4.2
43BuildRequires: libwpd-devel >= 0.8.0
44BuildRequires: librsvg2-devel
45#BuildRequires: aiksaurus-gtk-devel >= 1.2.1
46#BuildRequires: link-grammar-devel >= 4.2.1
47#BuildRequires: gtkmathview-devel >= 0.7.5
48BuildRequires: libgsf-devel >= 1.12.1
49BuildRequires: libboost-devel >= 1.33.1
50
51# gnome build deps
52BuildRequires: libbonobo-devel
53BuildRequires: libbonoboui-devel
54BuildRequires: libgnomeui-devel
55
56Requires(pre): desktop-file-utils >= %{desktop_file_utils_version}
57Obsoletes: abiword-fonts abiword-plugins
58
59URL: http://www.abisource.com/
60
61Patch0: abiword-2.6.0-windowshelppaths.patch
62Patch1: abiword-2.6.4-desktop.patch
63Patch2: abiword-2.6.0-boolean.patch
64Patch3: abiword-plugins-2.6.0-boolean.patch
65
66%description
67AbiWord is a cross-platform Open Source word processor. The goal is to make
68AbiWord full-featured, and remain lean.
69
70%description -l ja
71AbiWord はクロスプラットフォームのオープンソースなワードプロセッサーです。
72多機能で機敏に動くことを目標としています。
73
74%package -n libabiword
75Summary: Library for developing applications based on AbiWord's core
76Summary(ja): AbiWord コアで稼動するアプリケーションを開発するためのライブラリ
77Group: System Environment/Libraries
78
79%description -n libabiword
80Library for developing applications based on AbiWord's core.
81
82%description -n libabiword -l ja
83AbiWord コアで稼動するアプリケーションを開発するためのライブラリです。
84
85%package -n libabiword-devel
86Summary: Files for developing with libabiword
87Summary(ja): libabiword を用いた開発に必要なファイル群
88Group: Development/Libraries
89Requires: libabiword = %{epoch}:%{version}-%{release}
90
91%description -n libabiword-devel
92Includes and definitions for developing with libabiword.
93
94%description -n libabiword-devel -l ja
95libabiword で開発するためのインクルードファイル及び定義ファイルです。
96
97%prep
98%setup -q
99## %patch1 -p1 -b .desktop
100%patch2 -p1 -b .boolean
101
102# setup abiword-plugins
103## %setup -q -T -b 1 -n abiword-plugins-%{version}
104## %patch3 -p1 -b .boolean
105
106# setup abiword extras
107## %setup -q -T -b 2 -n abiword-extras-%{version}
108
109# setup abiword documentation
110%setup -q -T -b 3 -n abiword-docs-%{version}
111%patch0 -p1 -b .windowshelppaths
112
113%build
114# build libabiword and abiword
115cd $RPM_BUILD_DIR/abiword-%{version}
116%configure --enable-libabiword -enable-static=no
117make %{?_smp_mflags}
118
119# build abiword-plugins
120## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
121## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
122## CXXFLAGS="-L$RPM_BUILD_DIR/%{name}-%{version}/src/wp/main/unix/" %configure --disable-gda --enable-libabiword --with-abiword=$RPM_BUILD_DIR/%{name}-%{version}
123## # Remove libtool predep_objects and postdep_objects wonkiness so that
124## # building without -nostdlib doesn't include them twice.  Because we
125## # already link with g++, weird stuff happens if you don't let the
126## # compiler handle this.
127## sed 's/^predep_objects=.*/predep_objects=\"\"/' < libtool > libtool.foo
128## sed 's/^postdep_objects=.*/postdep_objects=\"\"/' < libtool.foo > libtool.foobar
129## sed 's/-shared -nostdlib/-shared/' < libtool.foobar > libtool
130## make %{?_smp_mflags}
131
132# build abiword-extras
133## cd $RPM_BUILD_DIR/abiword-extras-%{version}
134## # abiword-extras looks at the abiword-%{version}.pc pkg-config file to get its location info
135## # however, that file is not installed yet, so just point to it in the abiword source tree
136## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
137## %configure
138## make
139
140# build the documentation
141cd $RPM_BUILD_DIR/abiword-docs-%{version}
142ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/wp/main/unix/abiword ./make-html.sh
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147# install abiword
148cd $RPM_BUILD_DIR/abiword-%{version}
149make install DESTDIR=$RPM_BUILD_ROOT
150# overwrite the static binary with the dynamic one
151## mv -f $RPM_BUILD_DIR/abiword-%{version}/src/wp/main/unix/abiword-dynamic $RPM_BUILD_ROOT%{_bindir}/abiword
152
153# Fix script permission
154#chmod +x $RPM_BUILD_ROOT%{_datadir}/%{name}-%{abiver}/scripts/abw2html.pl
155
156# install abiword-plugins
157## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
158## make install DESTDIR=$RPM_BUILD_ROOT
159
160# install the extras
161## cd $RPM_BUILD_DIR/abiword-extras-%{version}
162## make install DESTDIR=$RPM_BUILD_ROOT
163
164# install the documentation
165cd $RPM_BUILD_DIR/abiword-docs-%{version}
166mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help
167cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/
168# some of the help dirs have bad perms (#109261)
169find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/ -type d -exec chmod -c o+rx {} \;
170
171# finish up
172## mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
173## cp $RPM_BUILD_DIR/abiword-extras-%{version}/icons/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
174
175cd $RPM_BUILD_DIR/abiword-%{version}
176mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
177desktop-file-install \
178  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
179  --add-category X-Red-Hat-Extra --remove-category X-Red-Hat-Base \
180  --add-category Applications --add-category Office \
181  ./abiword.desktop
182# remove the original one (which has X-Red-Hat-Base)  (#107023)
183#rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/abiword.desktop
184
185mkdir -p $RPM_BUILD_ROOT%{_datadir}/mime-info
186install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info
187
188# nuke .la files
189rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{abiver}/plugins/*.la
190rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
191# nuke .a files
192rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
193# nuke custom dictionary files
194rm -f $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/dictionary/ispell_dictionary_list.xml
195
196
197%clean
198rm -rf $RPM_BUILD_ROOT
199
200%post
201update-desktop-database %{_datadir}/applications
202
203%postun
204update-desktop-database %{_datadir}/applications
205
206%files
207%defattr(-,root,root)
208%{_bindir}/abiword
209%{_datadir}/applications/*
210%{_datadir}/mime-info/*
211## %{_datadir}/pixmaps/*png
212%{_datadir}/icons/*png
213%{_mandir}/man1/abiword.1.gz
214
215%files -n libabiword
216%doc $RPM_BUILD_DIR/%{name}-%{version}/docs $RPM_BUILD_DIR/%{name}-%{version}/COPYING $RPM_BUILD_DIR/%{name}-%{version}/COPYRIGHT.TXT $RPM_BUILD_DIR/%{name}-%{version}/README.TXT
217%{_libdir}/abiword-%{abiver}
218%{_libdir}/libabiword-%{abiver}.so
219%{_datadir}/abiword-%{abiver}
220
221%files -n libabiword-devel
222%{_includedir}/abiword-%{abiver}
223%{_libdir}/pkgconfig/*.pc
224
225%changelog
226* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-1
227- new upstream release
228- drop Source1, Source2
229- drop Patch1, Patch3
230- fix %setup, %build, %install and %files
231
232* Thu Jul 29 2009 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1:2.6.8-2
233- add Japanese Summary and description
234- add BuildRequires: libSM-devel
235
236* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.8-1
237- new upstream release
238
239* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.4-1vl5
240- new upstream release
241- built with enchant
242- split libabiword, libabiword-devel subpackage
243
244* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-2vl5
245- built with gucharmap-2.24.0
246
247* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-1vl5
248- applied new versioning policy, spec in utf-8
249
250* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl2
251- rebuilt with new toolchain
252
253* Thu Dec 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl1
254- new upstream release
255- rebuilt with wv-1.2.4
256
257* Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl2
258- fixed .desktop file
259
260* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl1
261- updated to 2.4.5
262
263* Tue Apr 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.4-2vl1
264- rebuilt for Vine and merged old spec files
265  * Thu Sep 26 2002 Masaki Shinomiya <shino@pos.to>
266  - 1.0.3-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
267  - source update, plugins-1.0.3, many plugins enabled in -0vl2
268  - disabled perl
269  - abiword-mkhash.sh for spell check
270  * Mon Jun 24 2002 Masaki Shinomiya <shino@pos.to>
271  - 1.0.2-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
272  - source update
273  - touch fonts.dir, abiword-wrapper.patch
274  - no longer segmentation fault on Vine 2.5 (see [vine-users:051609]-)
275  * Wed May 22 2002 Masaki Shinomiya <shino@pos.to>
276  - 1.0.1-0vl1 for VinePlus/2.1 and (-0vl2) for VineSeedPlus
277  - 0vl1 omits plugins because Vine 2.1.x fails to compile
278  - 0vl1 also disables gnome and perl support
279  - Japanese fonts are now usable on VineSeed/Vine 2.5
280  - by using mkjafontsdir.sh made by me
281  - source upstream to 1.0.1, plugins(merged in the main package)
282  - doc, mime-info
283  * Sat Mar 30 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.4-0vl2
284  - new upstream version
285  - fix symbolic link ([VineSeed-Plus:00941])
286  * Sun Mar 18 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.3-0vl2
287  - new upstream version
288  * Sun Feb 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.2-0vl0
289  - new upstream version.
290  - disable plugin all and comment out plugin part in build/make section,
291    because 0.99.2's source tar boll doesn't have abiword-plugins directory.
292  * Fri Feb 15 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
293  - 0.99.1-0vl3 (0.99.1-0vl2 for VinePlus-2.1)
294  - fix files owner/group ([VineSeed-Plus:00819])
295  * Sat Jan 28 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
296  - 0.99.1-0vl0.1
297  - change release number for VinePlus 2.1
298  * Sat Jan 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
299  - 0.99.1-0vl1
300  - add japanese fonts.dir
301     (see http://www.gnome.gr.jp/ml/gnome-users/200101/msg00034.html)
302    0vl0.1 release for VinePlus-2.1 succeed to input/display japanese,
303    but this release fail to input/display japanese.
304    please someone fix this problem.
305
306* Tue Apr 13 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-2.fc6
307- Fix documentation generation
308- Fix charting support
309
310* Tue Apr 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-1.fc6
311- New upstream version
312- Remove the macro patch and update the desktop patch
313
314* Wed Mar 29 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-8.fc6
315- Rebuild
316
317* Wed Mar 08 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-7.fc5
318- Disable the collaboration plugin; it is not working in 2.4.x
319
320* Thu Feb 16 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-6.fc5
321- Rebuild for Fedora Extras 5
322
323* Sun Feb 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-5.fc5
324- bug 171926
325
326* Sat Jan 21 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-4.fc5
327- Disable the PDF plugin for now, as poppler doesn't ship the xpdf
328  headers anymore
329
330* Sat Jan 14 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-3.fc5
331- Remove redundant requires - bug 177305
332
333* Thu Jan 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-2.fc5
334- Bump release, forgot to add desktop patch
335
336* Mon Jan 02 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-1.fc5
337- Update to 2.4.2
338- Add BuildRequires readline-devel for the AbiCommand plugin
339- Add BuildRequires bzip2-devel and poppler-devel for plugins
340- Update desktop patch
341- Patch to fix plugin marcros
342
343* Wed Nov 09 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-4.fc5
344- Fix bug 171928
345
346* Sun Oct 23 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-3.fc5
347- Fix bug 161832: "Abiword is not loading certain modules"
348- Add libgsf dependecy, which was needed all along
349- Disable the collaboration plugin, it is not for general use at all
350
351* Tue Oct 11 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-2
352- Use %%{?dist} in the release name
353
354* Sun Oct 9 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-1
355- Update to 2.4.1
356
357* Mon Oct 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.0-1
358- Require mathml-fonts
359- Don't rerun autogen.sh, no need anymore
360- Update gtkmathview dependency to 0.7.5
361- Update to 2.4.0
362
363* Mon Sep 26 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-2
364- Fix gtkmathview BuildRequires
365
366* Thu Sep 22 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-1
367- Update to 2.3.99
368
369* Sat Sep 10 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.6-1
370- Update to 2.3.6
371- Drop the pango patch
372
373* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-3
374- Rebuild
375
376* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-2
377- Enable the abimathview plugin
378
379* Sun Aug 21 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-1
380- Update to 2.3.5
381
382* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-4
383- Update the pango patch to disable more pango code
384
385* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-3
386- Fix the build after applying the pango disabling patch by
387  rerunning autogen.sh
388
389* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-2
390- Disable the experimental pango renderer
391
392* Thu Aug 17 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-1
393- Update to 2.3.4
394- Add link-grammar dependency
395
396* Thu Jul 28 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.9-1
397- Update to 2.2.9
398- Drop the mailmerge patch again
399
400* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-2
401- Fix build with mailmerge patch
402
403* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-1
404- Update to 2.2.8
405
406* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1:2.2.7-2
407- rebuild on all arches
408
409* Mon Apr 4 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.7-1
410- Because we love brown paper bag releases
411
412* Sun Apr 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.6-1
413- Drop the gcc4, wvread, virtdestr and pt64 patches
414- Update the desktop patch
415
416* Fri Mar 15 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-3
417- Fix 64bit build
418- Add virtual destructors to classes with virtual functions
419
420* Fri Mar 14 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-2
421- Remove the --disable-magick plugin switch
422- disable GDA support until the plugin is ported to gnomedb 1.2.x
423- Change the download location from SF to http://www.abisource.com/
424- patch libole2
425- fix read as a macro in new glibc
426
427* Fri Mar  2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.5-1
428- bump to latest stable
429- drop integrated dashboard patch again
430- some gcc4 fixes
431
432* Wed Feb 23 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-2
433- rh#149447# dashboard spam revisited
434
435* Tue Feb 22 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-1
436- bump to latest stable version
437- drop integrated nautilus depend patch
438- drop integrated libwpd depend patch
439
440* Fri Feb 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-4
441- upgrade to libwpd-0.8 and incoroprate necessary changeover patches
442
443* Mon Feb 7 2005 Matthias Clasen <mclasen@redhat.com> - 1:2.2.3-3
444- rebuild
445
446* Mon Feb 2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-2
447- remove unneccessary nautilus dependency
448
449* Mon Jan 17 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-1
450- bump to new version
451- drop integrated silenceabidash patch
452
453* Fri Jan 14 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-4
454- RH#145085# annoying cluepacket message on stdout/stderr
455
456* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 1:2.2.2-3
457- Rebuilt for new readline.
458
459* Tue Jan 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-2
460- RH#143368# use enchant as spellchecker
461
462* Mon Dec 13 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-1
463- bump to new version
464
465* Mon Dec 6 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.1-1
466- bump to new version
467- geometry patch upstreamed
468- security patch upstreamed
469- removeoledecod patch upstreamed
470- regenerate desktop patch
471
472* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-2
473- #abi7961# remove tempnam usages
474
475* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-1
476- bump to latest major stable version
477- #rh140321# sanity check geometry
478
479* Tue Nov  9 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.0.14-1
480- bump to latest stable version
481
482* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.12-4
483- rebuild for python 2.4
484
485* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 1:2.0.12-3
486- Change to PreReq instead of Requires(post), up to 0.9
487
488* Thu Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-2
489- Better Requires desktop-file-utils
490
491* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-1
492- update to new abiword, + change norwegian wordprocessor translation
493
494* Tue Sep 14 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-3
495- #132389# Add more abiword supported mime types to abiword.desktop
496
497* Mon Sep 6 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-2
498- merge abiword.keys into abiword.desktop
499
500* Fri Aug 27 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-1
501- 2.0.11
502
503* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-2
504- use libgnomedb
505
506* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-1
507- 2.0.10
508- use aiksaurus
509
510* Tue Aug 2 2004 Matthias Clasen <mclasen@redhat.com> 1:2.0.9-4
511- rebuilt
512
513* Thu Jul 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-3
514- #126012# some desktop translations
515
516* Wed Jul 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-2
517- #128004# fix irritating windows looking filenames for generated pngs
518
519* Fri Jul 16 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-1
520- 2.0.9, new version with security fix
521
522* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
523- rebuilt
524
525* Thu May 20 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
526- 2.0.7, new version + gcc34 fixes
527
528* Wed Apr 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
529- 2.0.6, 64bit changes made upstream
530
531* Sat Mar 13 2004 Jeremy Katz <> 1:2.0.5-1
532- 2.0.5
533
534* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
535- rebuilt
536
537* Thu Feb 19 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-3
538- rebuild for newer libots and libwpd
539- fix verify as non-root (#109261)
540- add wpd files to abiword.keys (#114907)
541
542* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
543- rebuilt
544
545* Thu Jan 29 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-1
546- 2.0.3 (fixes build against gtk+ 2.3 and lets us rebuild to fix libcroco dep)
547
548* Wed Dec 17 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.2-2
549- rebuild for new libwpd
550
551* Sun Nov 30 2003 Jeremy Katz <katzj@redhat.com>
552- and librsvg2-devel (#111222)
553
554* Fri Nov 28 2003 Jeremy Katz <katzj@redhat.com>
555- buildrequire libgnomeui-devel (#111164)
556
557* Tue Oct 28 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.1-1
558- 2.0.1
559- really remove duplicate desktop file
560
561* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-6
562- make the docs with the just built abiword so that we don't have to
563  have abiword installed to build the docs (#107279)
564
565* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-5
566- fix linkage to glib 1.2 in hancom plugin (#106033)
567
568* Sun Oct 19 2003 Florian La Roche <Florian.LaRoche@redhat.de>
569- add %%clean specfile target
570
571* Tue Oct 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-4
572- remove duplicate desktop file (#107023)
573
574* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-3
575- include the help
576- show the clipart (#104577)
577
578* Mon Sep 15 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-2
579- rebuild with newer libwpd and libots to get those plugins
580
581* Sun Sep 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-1
582- 2.0.0
583
584* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.6-1
585- 1.99.6
586
587* Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.5-1
588- 1.99.5
589
590* Tue Aug  5 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.3-1
591- 1.99.3
592- put icon in the right place (#101646)
593- fix some 64bit casting issues
594- disable ots plugin for now, doesn't seem to build with ots 0.4.0 :/
595- disable -pedantic -ansi so that it will build
596
597* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-2
598- ugly hack to deal with libtool silliness on x86_64
599
600* Fri Jul 11 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-1
601- 1.99.2
602- add buildrequires to make sure the ots and wp plugins get built
603- no longer needs libgal2, remove buildrequires
604
605* Mon Jun 16 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.1-1
606- 1.99.1
607
608* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
609- rebuilt
610
611* Mon May 26 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-3
612- rebuild for new libgal2
613
614* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-2
615- tweak plugins build
616
617* Mon May 12 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-0.2
618- 1.9.1
619- drop old patches, switch to using autoconf based build system instead
620  of diving makefiles
621- build with gnome support
622- build with plugins
623- add patch to build on AMD64
624
625* Mon Apr 28 2003 Tim Powers <timp@redhat.com> 1:1.0.5-2
626- rebuild to fix broken libpspell dep
627
628* Mon Mar 24 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.5-1
629- 1.0.5
630
631* Mon Feb 10 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-2
632- fix for abiword starting off the screen (#82425)
633
634* Thu Jan 23 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-1
635- 1.0.4
636
637* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
638- rebuilt
639
640* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-2
641- make it build on x86_64
642
643* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-1
644- 1.0.3 (#80560)
645- set umask before running mkfontdir in %%post
646- patch AbiWord script to convert utf8 locales into non-utf8 variants (#72633)
647
648* Mon Dec 02 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-7
649- Fix doc lines
650- Fix multilib
651
652* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-6
653- rebuilt with gcc-3.2 (we hope)
654
655* Sat Aug 10 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-5
656- fix help index symlink (#71219)
657
658* Thu Aug  1 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-4
659- add abiword binary symlink for upstream compatibility (#70267)
660
661* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.0.2-3
662- rebuild using gcc-3.2-0.1
663
664* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-2
665- use included desktop file (#64447)
666- use desktop-file-install
667
668* Wed Jun 26 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-1
669- 1.0.2
670- disable perl module build since we weren't including it anyway
671
672* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.1-1
673- 1.0.1
674
675* Sun Apr 14 2002 Jeremy Katz <katzj@redhat.com> 0.99.5-1
676- zh_CN and zh_TW fonts.dir were flipped
677- update to 0.99.5 as it fixes some major bugs
678- define ABI_BUILD_VERSION so the about screen gives us a version
679
680* Mon Apr  8 2002 Bennhard Rosenkraenzer <bero@redhat.com> 0.99.4-2
681- 1st try at fixing up CJK (#61590)
682- #if 0'ify font warning dialog (#62909, #64556)
683
684* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.4-1
685- Update to 0.99.4, fixes #61153
686- Fix #61344
687- Nuke the warning about being unable to add anything to font path,
688  that's not how xfs works.
689
690* Thu Feb 28 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.2-1
691- 0.99.2
692- remove blank lines in fonts.dir
693
694* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.1-1
695- 0.99.1
696
697* Wed Jan 30 2002 Alex Larsson <alexl@redhat.com> 0.9.5-3
698- Added patch to use libpng10
699- Added patch to fix perl build problems.
700
701* Fri Nov 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.5-1
702- 0.9.5
703
704* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.4.1-1
705- Update to 0.9.4.1 (RFE #54806)
706- Add URL (RFE #54590)
707
708* Thu Jul 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-7
709- Fix uninstall (#49350)
710
711* Sat Jul  7 2001 Tim Powers <timp@redhat.com>
712- rebuilt so that dirs aren't sgid root
713
714* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-5
715- Add build requirements (#45157)
716
717* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-4
718- Remove CVS admin files from documentation (#44916)
719
720* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
721- add s390x patch from <oliver.paukstadt@millenux.com>
722
723* Sat Jun 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
724- add s390 patch from Helge Deller
725
726* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-1
727- Update to 0.7.14
728
729* Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
730- Handle MIME type stuff (Bug #27530)
731- Add BuildPrereqs for some of the less common stuff AbiWord uses
732  (gal-devel, gnome-print-devel, libunicode-devel)
733
734* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
735- 0.7.13
736
737* Mon Jan 15 2001 Than Ngo <than@redhat.com>
738- fixed broken code for building
739
740* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
741- 0.7.12
742- copy fonts.dir to fonts.scale so mkfontdir doesn't blow it away
743
744* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
745- Rebuild to get rid of 0777 dirs
746
747* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
748- 0.7.11
749
750* Sun Aug 20 2000 Preston Brown <pbrown@redhat.com>
751- fix path to chkfontpath, it was wrong.
752
753* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
754- Up Epoch and release
755
756* Mon Aug  7 2000 Jakub Jelinek <jakub@redhat.com>
757- Don't ship AbiWord_s if we have AbiWord_d
758- Register AbiWord's fontpath with xfs
759
760* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
761- Rebuild with new libpng. This fixes Bug #13707 - gotta love it when they
762  change the ABI without increasing the soname!
763- fix tooltip (Bug #14711)
764- move binaries from /usr/share to /usr/lib
765
766* Wed Jul 12 2000 Jakub Jelinek <jakub@redhat.com>
767- Fix build on ia64.
768
769* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
770- automatic rebuild
771
772* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
773- Rebuild with new gcc.
774
775* Sat Jun 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
776- Fix build on ia64
777
778* Fri Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
779- 0.7.10
780- update download location
781
782* Fri Jun  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
783- initial build for main CD
784- clean up specfile
785- fix build with gcc 2.96 and glibc 2.2
786- exclude ia64 for now
787
788* Wed May  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
789- 0.7.9
790
791* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
792- 0.7.8
793- move the desktop file to /etc/X11/applnk so it can be used in both
794  GNOME and KDE
795- fix up handling of RPM_OPT_FLAGS
796
797* Thu Jan 20 2000 Tim Powers <timp@redhat.com>
798- bzipped source to conserve space.
799
800* Sun Jan  9 2000 Matt Wilson <msw@redhat.com>
801- enable GNOME, remove perl hack to do RPM_OPT_FLAGS
802- added libpng requirement.  0.7.7 requires 1.0.5 libpng ABI
803
804* Tue Jan  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
805- 0.7.7
806- handle RPM_OPT_FLAGS
807
808* Mon Nov 15 1999 Tim Powers <timp@redhat.com>
809- first build for inclusion into Powertools.
810- some things in this spec file are from the abisuite-0.7.5-1mdk package
Note: See TracBrowser for help on using the repository browser.