source: projects/specs/trunk/a/abiword/abiword-vl.spec @ 1897

Revision 1897, 26.8 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define desktop_file_utils_version 0.16
2%define abiver 2.8
3
4Summary: The AbiWord word processor
5Summary(ja): AbiWord ワードプロセッサ
6Name: abiword
7Version: 2.8.6
8Release: 2%{?_dist_release}
9Epoch: 1
10Group: Applications/Productivity
11License: GPLv2+
12Source0: http://abisource.com/downloads/abiword/%{version}/source/abiword-%{version}.tar.gz
13## Source1: http://abisource.com/downloads/abiword/%{version}/source/abiword-plugins-%{version}.tar.gz
14## Source2: http://abisource.com/downloads/abiword/%{version}/source/abiword-extras-%{version}.tar.gz
15Source3: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
16Source11: abiword.mime
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22#Packager:
23
24# for abiword
25BuildRequires: gcc-c++
26BuildRequires: gtk2-devel
27BuildRequires: libpng-devel
28BuildRequires: libxml2-devel
29BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
30BuildRequires: fribidi-devel
31BuildRequires: enchant-devel
32BuildRequires: libgnomeprint-devel
33BuildRequires: libgnomeprintui-devel
34BuildRequires: wv-devel
35BuildRequires: gucharmap-devel
36BuildRequires: libSM-devel
37
38# some plugin build deps
39BuildRequires: readline-devel
40BuildRequires: bzip2-devel
41BuildRequires: poppler-devel >= 0.4.0
42#BuildRequires: ots-devel >= 0.4.2
43BuildRequires: libwpd-devel >= 0.8.0
44BuildRequires: librsvg2-devel
45#BuildRequires: aiksaurus-gtk-devel >= 1.2.1
46#BuildRequires: link-grammar-devel >= 4.2.1
47#BuildRequires: gtkmathview-devel >= 0.7.5
48BuildRequires: libgsf-devel >= 1.12.1
49BuildRequires: libboost-devel >= 1.33.1
50
51# gnome build deps
52BuildRequires: libbonobo-devel
53BuildRequires: libbonoboui-devel
54BuildRequires: libgnomeui-devel
55
56Requires(pre): desktop-file-utils >= %{desktop_file_utils_version}
57Obsoletes: abiword-fonts abiword-plugins
58
59URL: http://www.abisource.com/
60
61Patch0: abiword-2.6.0-windowshelppaths.patch
62Patch1: abiword-2.6.4-desktop.patch
63Patch2: abiword-2.6.0-boolean.patch
64Patch3: abiword-plugins-2.6.0-boolean.patch
65
66%description
67AbiWord is a cross-platform Open Source word processor. The goal is to make
68AbiWord full-featured, and remain lean.
69
70%description -l ja
71AbiWord はクロスプラットフォームのオープンソースなワードプロセッサーです。
72多機能で機敏に動くことを目標としています。
73
74%package -n libabiword
75Summary: Library for developing applications based on AbiWord's core
76Summary(ja): AbiWord コアで稼動するアプリケーションを開発するためのライブラリ
77Group: System Environment/Libraries
78
79%description -n libabiword
80Library for developing applications based on AbiWord's core.
81
82%description -n libabiword -l ja
83AbiWord コアで稼動するアプリケーションを開発するためのライブラリです。
84
85%package -n libabiword-devel
86Summary: Files for developing with libabiword
87Summary(ja): libabiword を用いた開発に必要なファイル群
88Group: Development/Libraries
89Requires: libabiword = %{epoch}:%{version}-%{release}
90
91%description -n libabiword-devel
92Includes and definitions for developing with libabiword.
93
94%description -n libabiword-devel -l ja
95libabiword で開発するためのインクルードファイル及び定義ファイルです。
96
97%prep
98%setup -q
99## %patch1 -p1 -b .desktop
100%patch2 -p1 -b .boolean
101
102# setup abiword-plugins
103## %setup -q -T -b 1 -n abiword-plugins-%{version}
104## %patch3 -p1 -b .boolean
105
106# setup abiword extras
107## %setup -q -T -b 2 -n abiword-extras-%{version}
108
109# setup abiword documentation
110%setup -q -T -b 3 -n abiword-docs-%{version}
111%patch0 -p1 -b .windowshelppaths
112
113%build
114# build libabiword and abiword
115cd $RPM_BUILD_DIR/abiword-%{version}
116%configure --enable-libabiword -enable-static=no
117make %{?_smp_mflags}
118
119# build abiword-plugins
120## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
121## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
122## CXXFLAGS="-L$RPM_BUILD_DIR/%{name}-%{version}/src/wp/main/unix/" %configure --disable-gda --enable-libabiword --with-abiword=$RPM_BUILD_DIR/%{name}-%{version}
123## # Remove libtool predep_objects and postdep_objects wonkiness so that
124## # building without -nostdlib doesn't include them twice.  Because we
125## # already link with g++, weird stuff happens if you don't let the
126## # compiler handle this.
127## sed 's/^predep_objects=.*/predep_objects=\"\"/' < libtool > libtool.foo
128## sed 's/^postdep_objects=.*/postdep_objects=\"\"/' < libtool.foo > libtool.foobar
129## sed 's/-shared -nostdlib/-shared/' < libtool.foobar > libtool
130## make %{?_smp_mflags}
131
132# build abiword-extras
133## cd $RPM_BUILD_DIR/abiword-extras-%{version}
134## # abiword-extras looks at the abiword-%{version}.pc pkg-config file to get its location info
135## # however, that file is not installed yet, so just point to it in the abiword source tree
136## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
137## %configure
138## make
139
140# build the documentation
141cd $RPM_BUILD_DIR/abiword-docs-%{version}
142ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/wp/main/unix/abiword ./make-html.sh
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147# install abiword
148cd $RPM_BUILD_DIR/abiword-%{version}
149make install DESTDIR=$RPM_BUILD_ROOT
150# overwrite the static binary with the dynamic one
151## mv -f $RPM_BUILD_DIR/abiword-%{version}/src/wp/main/unix/abiword-dynamic $RPM_BUILD_ROOT%{_bindir}/abiword
152
153# Fix script permission
154#chmod +x $RPM_BUILD_ROOT%{_datadir}/%{name}-%{abiver}/scripts/abw2html.pl
155
156# install abiword-plugins
157## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
158## make install DESTDIR=$RPM_BUILD_ROOT
159
160# install the extras
161## cd $RPM_BUILD_DIR/abiword-extras-%{version}
162## make install DESTDIR=$RPM_BUILD_ROOT
163
164# install the documentation
165cd $RPM_BUILD_DIR/abiword-docs-%{version}
166mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help
167cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/
168# some of the help dirs have bad perms (#109261)
169find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/ -type d -exec chmod -c o+rx {} \;
170
171# finish up
172## mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
173## cp $RPM_BUILD_DIR/abiword-extras-%{version}/icons/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
174
175cd $RPM_BUILD_DIR/abiword-%{version}
176mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
177desktop-file-install \
178  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
179  --add-category X-Red-Hat-Extra --remove-category X-Red-Hat-Base \
180  --add-category Applications --add-category Office \
181  ./abiword.desktop
182# remove the original one (which has X-Red-Hat-Base)  (#107023)
183#rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/abiword.desktop
184
185mkdir -p $RPM_BUILD_ROOT%{_datadir}/mime-info
186install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info
187
188# nuke .la files
189rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{abiver}/plugins/*.la
190rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
191# nuke .a files
192rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
193# nuke custom dictionary files
194rm -f $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/dictionary/ispell_dictionary_list.xml
195
196
197%clean
198rm -rf $RPM_BUILD_ROOT
199
200%post
201update-desktop-database %{_datadir}/applications
202
203%postun
204update-desktop-database %{_datadir}/applications
205
206%files
207%defattr(-,root,root)
208%{_bindir}/abiword
209%{_datadir}/applications/*
210%{_datadir}/mime-info/*
211## %{_datadir}/pixmaps/*png
212%{_datadir}/icons/*png
213%{_mandir}/man1/abiword.1.gz
214
215%files -n libabiword
216%doc $RPM_BUILD_DIR/%{name}-%{version}/docs $RPM_BUILD_DIR/%{name}-%{version}/COPYING $RPM_BUILD_DIR/%{name}-%{version}/COPYRIGHT.TXT $RPM_BUILD_DIR/%{name}-%{version}/README.TXT
217%{_libdir}/abiword-%{abiver}
218%{_libdir}/libabiword-%{abiver}.so
219%{_datadir}/abiword-%{abiver}
220
221%files -n libabiword-devel
222%{_includedir}/abiword-%{abiver}
223%{_libdir}/pkgconfig/*.pc
224
225%changelog
226* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-2
227- rebuild with rpm-4.8.1 for pkg-config file
228
229* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-1
230- new upstream release
231- drop Source1, Source2
232- drop Patch1, Patch3
233- fix %setup, %build, %install and %files
234
235* Thu Jul 29 2009 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1:2.6.8-2
236- add Japanese Summary and description
237- add BuildRequires: libSM-devel
238
239* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.8-1
240- new upstream release
241
242* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.4-1vl5
243- new upstream release
244- built with enchant
245- split libabiword, libabiword-devel subpackage
246
247* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-2vl5
248- built with gucharmap-2.24.0
249
250* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-1vl5
251- applied new versioning policy, spec in utf-8
252
253* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl2
254- rebuilt with new toolchain
255
256* Thu Dec 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl1
257- new upstream release
258- rebuilt with wv-1.2.4
259
260* Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl2
261- fixed .desktop file
262
263* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl1
264- updated to 2.4.5
265
266* Tue Apr 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.4-2vl1
267- rebuilt for Vine and merged old spec files
268  * Thu Sep 26 2002 Masaki Shinomiya <shino@pos.to>
269  - 1.0.3-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
270  - source update, plugins-1.0.3, many plugins enabled in -0vl2
271  - disabled perl
272  - abiword-mkhash.sh for spell check
273  * Mon Jun 24 2002 Masaki Shinomiya <shino@pos.to>
274  - 1.0.2-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
275  - source update
276  - touch fonts.dir, abiword-wrapper.patch
277  - no longer segmentation fault on Vine 2.5 (see [vine-users:051609]-)
278  * Wed May 22 2002 Masaki Shinomiya <shino@pos.to>
279  - 1.0.1-0vl1 for VinePlus/2.1 and (-0vl2) for VineSeedPlus
280  - 0vl1 omits plugins because Vine 2.1.x fails to compile
281  - 0vl1 also disables gnome and perl support
282  - Japanese fonts are now usable on VineSeed/Vine 2.5
283  - by using mkjafontsdir.sh made by me
284  - source upstream to 1.0.1, plugins(merged in the main package)
285  - doc, mime-info
286  * Sat Mar 30 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.4-0vl2
287  - new upstream version
288  - fix symbolic link ([VineSeed-Plus:00941])
289  * Sun Mar 18 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.3-0vl2
290  - new upstream version
291  * Sun Feb 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.2-0vl0
292  - new upstream version.
293  - disable plugin all and comment out plugin part in build/make section,
294    because 0.99.2's source tar boll doesn't have abiword-plugins directory.
295  * Fri Feb 15 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
296  - 0.99.1-0vl3 (0.99.1-0vl2 for VinePlus-2.1)
297  - fix files owner/group ([VineSeed-Plus:00819])
298  * Sat Jan 28 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
299  - 0.99.1-0vl0.1
300  - change release number for VinePlus 2.1
301  * Sat Jan 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
302  - 0.99.1-0vl1
303  - add japanese fonts.dir
304     (see http://www.gnome.gr.jp/ml/gnome-users/200101/msg00034.html)
305    0vl0.1 release for VinePlus-2.1 succeed to input/display japanese,
306    but this release fail to input/display japanese.
307    please someone fix this problem.
308
309* Tue Apr 13 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-2.fc6
310- Fix documentation generation
311- Fix charting support
312
313* Tue Apr 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-1.fc6
314- New upstream version
315- Remove the macro patch and update the desktop patch
316
317* Wed Mar 29 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-8.fc6
318- Rebuild
319
320* Wed Mar 08 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-7.fc5
321- Disable the collaboration plugin; it is not working in 2.4.x
322
323* Thu Feb 16 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-6.fc5
324- Rebuild for Fedora Extras 5
325
326* Sun Feb 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-5.fc5
327- bug 171926
328
329* Sat Jan 21 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-4.fc5
330- Disable the PDF plugin for now, as poppler doesn't ship the xpdf
331  headers anymore
332
333* Sat Jan 14 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-3.fc5
334- Remove redundant requires - bug 177305
335
336* Thu Jan 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-2.fc5
337- Bump release, forgot to add desktop patch
338
339* Mon Jan 02 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-1.fc5
340- Update to 2.4.2
341- Add BuildRequires readline-devel for the AbiCommand plugin
342- Add BuildRequires bzip2-devel and poppler-devel for plugins
343- Update desktop patch
344- Patch to fix plugin marcros
345
346* Wed Nov 09 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-4.fc5
347- Fix bug 171928
348
349* Sun Oct 23 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-3.fc5
350- Fix bug 161832: "Abiword is not loading certain modules"
351- Add libgsf dependecy, which was needed all along
352- Disable the collaboration plugin, it is not for general use at all
353
354* Tue Oct 11 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-2
355- Use %%{?dist} in the release name
356
357* Sun Oct 9 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-1
358- Update to 2.4.1
359
360* Mon Oct 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.0-1
361- Require mathml-fonts
362- Don't rerun autogen.sh, no need anymore
363- Update gtkmathview dependency to 0.7.5
364- Update to 2.4.0
365
366* Mon Sep 26 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-2
367- Fix gtkmathview BuildRequires
368
369* Thu Sep 22 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-1
370- Update to 2.3.99
371
372* Sat Sep 10 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.6-1
373- Update to 2.3.6
374- Drop the pango patch
375
376* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-3
377- Rebuild
378
379* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-2
380- Enable the abimathview plugin
381
382* Sun Aug 21 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-1
383- Update to 2.3.5
384
385* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-4
386- Update the pango patch to disable more pango code
387
388* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-3
389- Fix the build after applying the pango disabling patch by
390  rerunning autogen.sh
391
392* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-2
393- Disable the experimental pango renderer
394
395* Thu Aug 17 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-1
396- Update to 2.3.4
397- Add link-grammar dependency
398
399* Thu Jul 28 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.9-1
400- Update to 2.2.9
401- Drop the mailmerge patch again
402
403* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-2
404- Fix build with mailmerge patch
405
406* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-1
407- Update to 2.2.8
408
409* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1:2.2.7-2
410- rebuild on all arches
411
412* Mon Apr 4 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.7-1
413- Because we love brown paper bag releases
414
415* Sun Apr 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.6-1
416- Drop the gcc4, wvread, virtdestr and pt64 patches
417- Update the desktop patch
418
419* Fri Mar 15 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-3
420- Fix 64bit build
421- Add virtual destructors to classes with virtual functions
422
423* Fri Mar 14 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-2
424- Remove the --disable-magick plugin switch
425- disable GDA support until the plugin is ported to gnomedb 1.2.x
426- Change the download location from SF to http://www.abisource.com/
427- patch libole2
428- fix read as a macro in new glibc
429
430* Fri Mar  2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.5-1
431- bump to latest stable
432- drop integrated dashboard patch again
433- some gcc4 fixes
434
435* Wed Feb 23 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-2
436- rh#149447# dashboard spam revisited
437
438* Tue Feb 22 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-1
439- bump to latest stable version
440- drop integrated nautilus depend patch
441- drop integrated libwpd depend patch
442
443* Fri Feb 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-4
444- upgrade to libwpd-0.8 and incoroprate necessary changeover patches
445
446* Mon Feb 7 2005 Matthias Clasen <mclasen@redhat.com> - 1:2.2.3-3
447- rebuild
448
449* Mon Feb 2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-2
450- remove unneccessary nautilus dependency
451
452* Mon Jan 17 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-1
453- bump to new version
454- drop integrated silenceabidash patch
455
456* Fri Jan 14 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-4
457- RH#145085# annoying cluepacket message on stdout/stderr
458
459* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 1:2.2.2-3
460- Rebuilt for new readline.
461
462* Tue Jan 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-2
463- RH#143368# use enchant as spellchecker
464
465* Mon Dec 13 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-1
466- bump to new version
467
468* Mon Dec 6 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.1-1
469- bump to new version
470- geometry patch upstreamed
471- security patch upstreamed
472- removeoledecod patch upstreamed
473- regenerate desktop patch
474
475* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-2
476- #abi7961# remove tempnam usages
477
478* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-1
479- bump to latest major stable version
480- #rh140321# sanity check geometry
481
482* Tue Nov  9 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.0.14-1
483- bump to latest stable version
484
485* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.12-4
486- rebuild for python 2.4
487
488* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 1:2.0.12-3
489- Change to PreReq instead of Requires(post), up to 0.9
490
491* Thu Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-2
492- Better Requires desktop-file-utils
493
494* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-1
495- update to new abiword, + change norwegian wordprocessor translation
496
497* Tue Sep 14 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-3
498- #132389# Add more abiword supported mime types to abiword.desktop
499
500* Mon Sep 6 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-2
501- merge abiword.keys into abiword.desktop
502
503* Fri Aug 27 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-1
504- 2.0.11
505
506* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-2
507- use libgnomedb
508
509* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-1
510- 2.0.10
511- use aiksaurus
512
513* Tue Aug 2 2004 Matthias Clasen <mclasen@redhat.com> 1:2.0.9-4
514- rebuilt
515
516* Thu Jul 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-3
517- #126012# some desktop translations
518
519* Wed Jul 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-2
520- #128004# fix irritating windows looking filenames for generated pngs
521
522* Fri Jul 16 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-1
523- 2.0.9, new version with security fix
524
525* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
526- rebuilt
527
528* Thu May 20 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
529- 2.0.7, new version + gcc34 fixes
530
531* Wed Apr 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
532- 2.0.6, 64bit changes made upstream
533
534* Sat Mar 13 2004 Jeremy Katz <> 1:2.0.5-1
535- 2.0.5
536
537* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
538- rebuilt
539
540* Thu Feb 19 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-3
541- rebuild for newer libots and libwpd
542- fix verify as non-root (#109261)
543- add wpd files to abiword.keys (#114907)
544
545* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
546- rebuilt
547
548* Thu Jan 29 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-1
549- 2.0.3 (fixes build against gtk+ 2.3 and lets us rebuild to fix libcroco dep)
550
551* Wed Dec 17 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.2-2
552- rebuild for new libwpd
553
554* Sun Nov 30 2003 Jeremy Katz <katzj@redhat.com>
555- and librsvg2-devel (#111222)
556
557* Fri Nov 28 2003 Jeremy Katz <katzj@redhat.com>
558- buildrequire libgnomeui-devel (#111164)
559
560* Tue Oct 28 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.1-1
561- 2.0.1
562- really remove duplicate desktop file
563
564* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-6
565- make the docs with the just built abiword so that we don't have to
566  have abiword installed to build the docs (#107279)
567
568* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-5
569- fix linkage to glib 1.2 in hancom plugin (#106033)
570
571* Sun Oct 19 2003 Florian La Roche <Florian.LaRoche@redhat.de>
572- add %%clean specfile target
573
574* Tue Oct 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-4
575- remove duplicate desktop file (#107023)
576
577* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-3
578- include the help
579- show the clipart (#104577)
580
581* Mon Sep 15 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-2
582- rebuild with newer libwpd and libots to get those plugins
583
584* Sun Sep 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-1
585- 2.0.0
586
587* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.6-1
588- 1.99.6
589
590* Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.5-1
591- 1.99.5
592
593* Tue Aug  5 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.3-1
594- 1.99.3
595- put icon in the right place (#101646)
596- fix some 64bit casting issues
597- disable ots plugin for now, doesn't seem to build with ots 0.4.0 :/
598- disable -pedantic -ansi so that it will build
599
600* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-2
601- ugly hack to deal with libtool silliness on x86_64
602
603* Fri Jul 11 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-1
604- 1.99.2
605- add buildrequires to make sure the ots and wp plugins get built
606- no longer needs libgal2, remove buildrequires
607
608* Mon Jun 16 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.1-1
609- 1.99.1
610
611* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
612- rebuilt
613
614* Mon May 26 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-3
615- rebuild for new libgal2
616
617* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-2
618- tweak plugins build
619
620* Mon May 12 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-0.2
621- 1.9.1
622- drop old patches, switch to using autoconf based build system instead
623  of diving makefiles
624- build with gnome support
625- build with plugins
626- add patch to build on AMD64
627
628* Mon Apr 28 2003 Tim Powers <timp@redhat.com> 1:1.0.5-2
629- rebuild to fix broken libpspell dep
630
631* Mon Mar 24 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.5-1
632- 1.0.5
633
634* Mon Feb 10 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-2
635- fix for abiword starting off the screen (#82425)
636
637* Thu Jan 23 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-1
638- 1.0.4
639
640* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
641- rebuilt
642
643* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-2
644- make it build on x86_64
645
646* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-1
647- 1.0.3 (#80560)
648- set umask before running mkfontdir in %%post
649- patch AbiWord script to convert utf8 locales into non-utf8 variants (#72633)
650
651* Mon Dec 02 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-7
652- Fix doc lines
653- Fix multilib
654
655* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-6
656- rebuilt with gcc-3.2 (we hope)
657
658* Sat Aug 10 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-5
659- fix help index symlink (#71219)
660
661* Thu Aug  1 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-4
662- add abiword binary symlink for upstream compatibility (#70267)
663
664* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.0.2-3
665- rebuild using gcc-3.2-0.1
666
667* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-2
668- use included desktop file (#64447)
669- use desktop-file-install
670
671* Wed Jun 26 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-1
672- 1.0.2
673- disable perl module build since we weren't including it anyway
674
675* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.1-1
676- 1.0.1
677
678* Sun Apr 14 2002 Jeremy Katz <katzj@redhat.com> 0.99.5-1
679- zh_CN and zh_TW fonts.dir were flipped
680- update to 0.99.5 as it fixes some major bugs
681- define ABI_BUILD_VERSION so the about screen gives us a version
682
683* Mon Apr  8 2002 Bennhard Rosenkraenzer <bero@redhat.com> 0.99.4-2
684- 1st try at fixing up CJK (#61590)
685- #if 0'ify font warning dialog (#62909, #64556)
686
687* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.4-1
688- Update to 0.99.4, fixes #61153
689- Fix #61344
690- Nuke the warning about being unable to add anything to font path,
691  that's not how xfs works.
692
693* Thu Feb 28 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.2-1
694- 0.99.2
695- remove blank lines in fonts.dir
696
697* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.1-1
698- 0.99.1
699
700* Wed Jan 30 2002 Alex Larsson <alexl@redhat.com> 0.9.5-3
701- Added patch to use libpng10
702- Added patch to fix perl build problems.
703
704* Fri Nov 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.5-1
705- 0.9.5
706
707* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.4.1-1
708- Update to 0.9.4.1 (RFE #54806)
709- Add URL (RFE #54590)
710
711* Thu Jul 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-7
712- Fix uninstall (#49350)
713
714* Sat Jul  7 2001 Tim Powers <timp@redhat.com>
715- rebuilt so that dirs aren't sgid root
716
717* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-5
718- Add build requirements (#45157)
719
720* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-4
721- Remove CVS admin files from documentation (#44916)
722
723* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
724- add s390x patch from <oliver.paukstadt@millenux.com>
725
726* Sat Jun 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
727- add s390 patch from Helge Deller
728
729* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-1
730- Update to 0.7.14
731
732* Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
733- Handle MIME type stuff (Bug #27530)
734- Add BuildPrereqs for some of the less common stuff AbiWord uses
735  (gal-devel, gnome-print-devel, libunicode-devel)
736
737* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
738- 0.7.13
739
740* Mon Jan 15 2001 Than Ngo <than@redhat.com>
741- fixed broken code for building
742
743* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
744- 0.7.12
745- copy fonts.dir to fonts.scale so mkfontdir doesn't blow it away
746
747* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
748- Rebuild to get rid of 0777 dirs
749
750* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
751- 0.7.11
752
753* Sun Aug 20 2000 Preston Brown <pbrown@redhat.com>
754- fix path to chkfontpath, it was wrong.
755
756* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
757- Up Epoch and release
758
759* Mon Aug  7 2000 Jakub Jelinek <jakub@redhat.com>
760- Don't ship AbiWord_s if we have AbiWord_d
761- Register AbiWord's fontpath with xfs
762
763* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
764- Rebuild with new libpng. This fixes Bug #13707 - gotta love it when they
765  change the ABI without increasing the soname!
766- fix tooltip (Bug #14711)
767- move binaries from /usr/share to /usr/lib
768
769* Wed Jul 12 2000 Jakub Jelinek <jakub@redhat.com>
770- Fix build on ia64.
771
772* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
773- automatic rebuild
774
775* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
776- Rebuild with new gcc.
777
778* Sat Jun 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
779- Fix build on ia64
780
781* Fri Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
782- 0.7.10
783- update download location
784
785* Fri Jun  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
786- initial build for main CD
787- clean up specfile
788- fix build with gcc 2.96 and glibc 2.2
789- exclude ia64 for now
790
791* Wed May  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
792- 0.7.9
793
794* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
795- 0.7.8
796- move the desktop file to /etc/X11/applnk so it can be used in both
797  GNOME and KDE
798- fix up handling of RPM_OPT_FLAGS
799
800* Thu Jan 20 2000 Tim Powers <timp@redhat.com>
801- bzipped source to conserve space.
802
803* Sun Jan  9 2000 Matt Wilson <msw@redhat.com>
804- enable GNOME, remove perl hack to do RPM_OPT_FLAGS
805- added libpng requirement.  0.7.7 requires 1.0.5 libpng ABI
806
807* Tue Jan  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
808- 0.7.7
809- handle RPM_OPT_FLAGS
810
811* Mon Nov 15 1999 Tim Powers <timp@redhat.com>
812- first build for inclusion into Powertools.
813- some things in this spec file are from the abisuite-0.7.5-1mdk package
Note: See TracBrowser for help on using the repository browser.