source: projects/specs/trunk/V/VirtualBox/VirtualBox-vl.spec @ 859

Revision 859, 31.1 KB checked in by daisuke, 14 years ago (diff)

VirtualBox?: update to 3.1.6

Line 
1%define version 3.1.6
2%define release 1%{?_dist_release}
3
4%define kname   vboxdrv
5%define oname   VirtualBox
6%define srcname %{oname}-%{version}-OSE
7%define distname        %{oname}-%{version}_OSE
8%define dirname vbox-ose
9%define pkgver  %{version}
10
11%define vboxlibdir      %{_libdir}/%{name}
12%define vboxdatadir     %{_datadir}/%{name}
13
14%define build_additions 1
15
16%ifarch %{ix86}
17%define vbox_platform linux.x86
18%endif
19%ifarch x86_64
20%define vbox_platform linux.amd64
21%endif
22
23# nuke vbox-specific dependencies
24%define _provides_exceptions ^VBox
25%define _requires_exceptions ^VBox
26
27Summary:        A general-purpose full virtualizer for x86 hardware
28Summary(ja):    汎用の x86 ハードウエア完全仮想化ソフトウエア
29Name:           VirtualBox
30Version:        %{version}
31Release:        %{release}
32License:        GPL
33Group:          Development/Tools
34Url:            http://www.virtualbox.org/
35
36Source0:        http://download.virtualbox.org/virtualbox/%ver/%{srcname}.tar.bz2
37Source2:        virtualbox.init
38Source4:        60-vboxadd.perms
39Source10:       VirtualBox.png
40Patch2:         VirtualBox-1.5.6_OSE-kernelrelease.patch
41Patch4:         VirtualBox-1.6.0_OSE-futex.patch
42Patch5:         virtualbox-fix-vboxadd-req.patch
43# (fc) 1.6.0-2mdv fix initscript name in VBox.sh script
44Patch6:         VirtualBox-1.6.0_OSE-initscriptname.patch
45# (fc) 2.0.2-2mdv disable version check at startup
46Patch8:         VirtualBox-disableversioncheck.patch
47# (hk) fix build kernel-headers-2.6.29*
48Patch10:        VirtualBox-kernel-headers-2.6.29.patch
49# (fc) 2.2.0-1mdv add Wine Direct3D guest additions option (Debian)
50Patch11:        15-wined3d-guest-addition.patch
51# (fc) 2.2.0-1mdv disable update notification (Debian)
52Patch12:        16-no-update.patch
53
54# vine
55Patch100:       VirtualBox-2.2.2-buildfix.patch
56
57BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
58ExclusiveArch:  %{ix86} x86_64
59Requires:       dkms-%{name} = %{version}-%{release}
60BuildRequires:  dev86, iasl
61BuildRequires:  zlib-devel
62BuildRequires:  libXcursor-devel
63BuildRequires:  libXmu-devel
64BuildRequires:  SDL-devel
65BuildRequires:  qt4-devel
66BuildRequires:  libIDL-devel
67BuildRequires:  e2fsprogs-devel
68BuildRequires:  libxslt-devel
69BuildRequires:  xerces-c-devel, xalan-c-devel
70BuildRequires:  hal-devel
71BuildRequires:  libXt-devel
72BuildRequires:  libstdc++34-devel
73BuildRequires:  python-devel
74BuildRequires:  libcap-devel
75BuildRequires:  pulseaudio-libs-devel
76BuildRequires:  kernel-devel
77BuildRequires:  mesa-libGL-devel
78BuildRequires:  mesa-libGLU-devel
79BuildRequires:  gsoap-devel
80BuildRequires:  curl-devel
81BuildRequires:  alsa-lib-devel
82BuildRequires:  dkms
83BuildRequires:  kBuild >= 0.1.5p2
84BuildRequires:  yasm
85BuildRequires:  qt4-designer
86%ifarch x86_64
87BuildRequires:  compat32-glibc-devel
88%endif
89
90%description
91VirtualBox Open Source Edition (OSE) is a general-purpose full
92virtualizer for x86 hardware.
93
94%description -l ja
95VirtualBox Open Source Edition (OSE) は汎用の x86 ハードウエア
96完全仮想化ソフトウエアです。
97
98%package -n     dkms-%{name}
99Summary:        VirtualBox OSE kernel module
100Summary(ja):    VirtualBox OSE カーネルモジュール
101Group:          System Environment/Kernel
102Requires(post):   dkms
103Requires(preun):  dkms
104
105%description -n dkms-%{name}
106Kernel support for VirtualBox OSE.
107
108%description -l ja -n dkms-%{name}
109VirtualBox OSE のカーネルサポートパッケージです。
110
111%if %{build_additions}
112%package        guest-additions
113Summary:        Additions for VirtualBox OSE guest systems
114Summary(ja):    VirtualBox OSE ゲストシステム用の追加モジュール
115Group:          System Environment/Kernel
116Requires:       dkms-vboxadd = %{version}-%{release}
117Requires:       dkms-vboxvfs = %{version}-%{release}
118Requires:       dkms-vboxvideo = %{version}-%{release}
119Requires:       xorg-x11-drv-vboxmouse
120Requires:       xorg-x11-drv-vboxvideo
121Requires:       xorg-x11-server-utils
122
123%description    guest-additions
124This packages contains additions for VirtualBox OSE guest systems.
125It allows to share files with the host system, copy/paste between
126guest and host, and sync time with host.
127
128%description -l ja guest-additions
129このパッケージには VirtualBox OSE ゲストシステムのための追加モジュール
130が含まれています。これを利用することでホストシステムとファイルを共有し
131たり、ゲスト/ホスト間でカット&ペーストを行ったり、ホストと時刻同期をし
132たりすることができます。
133
134%package -n     dkms-vboxadd
135Summary:        Kernel module for VirtualBox OSE additions
136Summary(ja):    VirtualBox OSE additions のカーネルモジュール
137Group:          System Environment/Kernel
138Requires(post):   dkms
139Requires(preun):  dkms
140Provides:       dkms-vboxvfs = %{version}-%{release}
141Obsoletes:      dkms-vboxvfs < %{version}-%{release}
142Provides:       dkms-vboxvideo = %{version}-%{release}
143Obsoletes:      dkms-vboxvideo < %{version}-%{release}
144
145%description -n dkms-vboxadd
146Kernel module for VirtualBox OSE additions.
147
148%description -l ja -n dkms-vboxadd
149VirtualBox OSE 追加モジュールのためのカーネルモジュールです。
150
151%package -n     xorg-x11-drv-vboxmouse
152Summary:        X.org X11 input driver for VirtualBox mouse
153Summary:        X.org X11 VirtualBox マウス入力ドライバ
154Group:          User Interface/X Hardware Support
155Requires:       %{name}-guest-additions
156
157%description -n xorg-x11-drv-vboxmouse
158The X.org driver for mouse in VirtualBox guests
159
160%description -l ja -n xorg-x11-drv-vboxmouse
161VirtualBox のゲストシステム用の X.org マウスドライバです。
162
163%package -n     xorg-x11-drv-vboxvideo
164Summary:        X.org X11 video driver for VirtualBox guests
165Summary(ja):    X.org X11 VirtualBox ビデオドライバ
166Group:          User Interface/X Hardware Support
167Requires:       %{name}-guest-additions
168
169%description -n xorg-x11-drv-vboxvideo
170The X.org driver for video in VirtualBox guests
171
172%description -l ja -n xorg-x11-drv-vboxvideo
173VirtualBox のゲストシステム用の X.org ビデオドライバです。
174
175%endif
176
177%prep
178%setup -q -n %{distname}
179%patch2 -p1 -b .kernelrelease
180%patch4 -p1 -b .futex
181%patch5 -p1 -b .fix-timesync-req
182%patch6 -p1 -b .initscriptname
183%patch8 -p1 -b .versioncheck
184%patch10 -p1 -b .kernel-headers-2.6.29
185%patch11 -p1 -b .wined3d
186%patch12 -p1 -b .disable-update
187%patch100 -p1 -b .buildfix
188
189# remove prebuilt binaries
190rm -rf kBuild tools
191
192cat << EOF > LocalConfig.kmk
193VBOX_PATH_APP_PRIVATE_ARCH:=%{vboxlibdir}
194VBOX_WITH_ORIGIN:=
195VBOX_WITH_RUNPATH:=%{vboxlibdir}
196VBOX_PATH_APP_PRIVATE:=%{vboxdatadir}
197VBOX_WITH_TESTCASE:=
198VBOX_WITH_TESTSUITE:=
199EOF
200
201%build
202./configure --disable-kmods --with-linux=$PWD/fake-linux
203
204%if !%{build_additions}
205sed -rie 's/(VBOX_WITH_LINUX_ADDITIONS\s+:=\s+).*/\1/' AutoConfig.kmk
206echo VBOX_WITHOUT_ADDITIONS=1 >> LocalConfig.kmk
207%endif
208
209. ./env.sh
210kmk KBUILD_VERBOSE=2 \
211    TOOL_YASM_AS=yasm \
212    VBOX_WITH_REGISTRATION_REQUEST= \
213    %{?_smp_mflags} all
214
215%install
216rm -rf %{buildroot}
217
218# install vbox components
219mkdir -p %{buildroot}%{vboxlibdir} %{buildroot}%{vboxdatadir}
220
221(cd out/%{vbox_platform}/release/bin && tar cf - --exclude=additions .) | \
222(cd %{buildroot}%{vboxlibdir} && tar xf -)
223
224# move noarch files to vboxdatadir
225mv %{buildroot}%{vboxlibdir}/{VBox*.sh,nls,*.desktop,*.png} %{buildroot}%{vboxdatadir}
226
227# install service
228mkdir -p %{buildroot}%{_initrddir}
229install -m755 %{SOURCE2} %{buildroot}%{_initrddir}/virtualbox
230
231# install wrappers
232mkdir -p %{buildroot}%{_sysconfdir}/vbox
233cat > %{buildroot}%{_sysconfdir}/vbox/vbox.cfg << EOF
234# VirtualBox installation directory
235INSTALL_DIR="%{vboxlibdir}"
236EOF
237mkdir -p %{buildroot}%{_bindir}
238ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/%{name}
239ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxManage
240ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxSDL
241ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxHeadless
242#ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/vboxwebsrv
243
244# provide network control tools in bindir
245ln -s %{vboxlibdir}/VBoxTunctl %{buildroot}%{_bindir}/VBoxTunctl
246ln -s %{vboxlibdir}/VBoxNetAdpCtl %{buildroot}%{_bindir}/VBoxNetAdpCtl
247ln -s %{vboxlibdir}/VBoxNetDHCP %{buildroot}%{_bindir}/VBoxNetDHCP
248
249install -d %{buildroot}/var/run/%{name}
250
251# install dkms sources
252mkdir -p %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
253cat > vboxbuild << EOF
254#!/bin/sh
255set -e
256make -C %{kname} KERN_DIR=\$1
257cp -f %{kname}/Module.symvers vboxnetflt
258cp -f %{kname}/Module.symvers vboxnetadp
259make -C vboxnetflt KERN_DIR=\$1
260make -C vboxnetadp KERN_DIR=\$1
261EOF
262install -m 0755 vboxbuild %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
263mv %{buildroot}%{vboxlibdir}/src/* %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
264cat > %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/dkms.conf << EOF
265MAKE[0]="./vboxbuild \$kernel_source_dir"
266PACKAGE_NAME=%{name}
267PACKAGE_VERSION=%{version}-%{release}
268DEST_MODULE_LOCATION[0]=/kernel/3rdparty/vbox
269BUILT_MODULE_LOCATION[0]=%{kname}/
270BUILT_MODULE_NAME[0]=%{kname}
271DEST_MODULE_LOCATION[1]=/kernel/3rdparty/vbox
272BUILT_MODULE_LOCATION[1]=vboxnetflt/
273BUILT_MODULE_NAME[1]=vboxnetflt
274DEST_MODULE_LOCATION[2]=/kernel/3rdparty/vbox
275BUILT_MODULE_LOCATION[2]=vboxnetadp/
276BUILT_MODULE_NAME[2]=vboxnetadp
277AUTOINSTALL=yes
278EOF
279
280# install udev rules
281mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d/
282cat > %{buildroot}%{_sysconfdir}/udev/rules.d/%{name}.rules << EOF
283KERNEL=="%{kname}", MODE="0666"
284EOF
285cat > %{buildroot}%{_sysconfdir}/udev/rules.d/vbox-additions.rules << EOF
286KERNEL=="vboxguest|vboxuser", ENV{ACL_MANAGE}="1"
287EOF
288
289# install additions
290%if %{build_additions}
291mkdir -p %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty
292install -m755 src/VBox/Additions/linux/installer/vboxadd-service.sh %{buildroot}%{_initrddir}/vboxadd-timesync
293install -m755 src/VBox/Additions/x11/Installer/VBoxRandR.sh %{buildroot}%{_bindir}/VBoxRandR
294install -m755 src/VBox/Additions/linux/installer/90-vboxguest.fdi %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
295
296install -d %{buildroot}%{_sysconfdir}/X11/xinit.d
297install -m755 src/VBox/Additions/x11/Installer/98vboxadd-xclient %{buildroot}%{_sysconfdir}/X11/xinit.d
298
299pushd out/%{vbox_platform}/release/bin/additions
300  install -d %{buildroot}/sbin %{buildroot}%{_sbindir} %{buildroot}/%{_libdir}/dri
301  install -m755 mount.vboxsf %{buildroot}/sbin/mount.vboxsf
302  install -m755 VBoxService %{buildroot}%{_sbindir}
303
304  install -d %{buildroot}%{_sysconfdir}/security/console.perms.d/
305  install -m644 %{SOURCE4} %{buildroot}%{_sysconfdir}/security/console.perms.d/
306
307  install -m755 VBoxClient %{buildroot}%{_bindir}
308  install -m755 VBoxControl %{buildroot}%{_bindir}
309
310  install -m755 VBoxOGL*.so %{buildroot}%{_libdir}
311  ln -s -f ../VBoxOGL.so %{buildroot}%{_libdir}/dri/vboxvideo_dri.so
312
313  install -d %{buildroot}%{_sysconfdir}/modprobe.preload.d
314  cat > %{buildroot}%{_sysconfdir}/modprobe.preload.d/vbox-guest-additions << EOF
315vboxadd
316vboxvfs
317EOF
318
319  install -d %{buildroot}%{_libdir}/xorg/modules/{input,drivers}
320  install vboxmouse_drv_17.so %{buildroot}%{_libdir}/xorg/modules/input/vboxmouse_drv.so
321  install vboxvideo_drv_17.so %{buildroot}%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
322
323  mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}
324  cat > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
325PACKAGE_NAME=vboxadditions
326PACKAGE_VERSION=%{version}-%{release}
327MAKE[0]="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxguest &&
328cp \$dkms_tree/\$module/\$module_version/build/vboxguest/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxvfs &&
329make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvfs &&
330cp \$dkms_tree/\$module/\$module_version/build/vboxvfs/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxvideo &&
331make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo"
332EOF
333
334  i=0
335  for kmod in vboxguest vboxvfs vboxvideo; do
336    mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod
337    cp -a src/$kmod/* %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod/
338    cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
339DEST_MODULE_LOCATION[$i]=/kernel/3rdparty/vbox
340BUILT_MODULE_LOCATION[$i]=$kmod/
341BUILT_MODULE_NAME[$i]=$kmod
342EOF
343    i=$((i+1))
344  done
345  cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
346CLEAN="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxguest clean &&
347make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvfs clean &&
348make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo clean "
349AUTOINSTALL=yes
350EOF
351popd
352  sed 's/^\(.package.*-kernel-\)\(.*-latest\)\(.*\)\\$/\1\2\3Obsoletes: vboxvfs-kernel-\2 vboxvideo-kernel-\2\\n\\/' /etc/dkms/template-dkms-mkrpm.spec > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/vboxadditions-dkms-mkrpm.spec
353%endif
354
355# install icons
356mkdir -p %{buildroot}%{_iconsdir}
357install -m644 %{SOURCE10} %{buildroot}%{_iconsdir}/
358
359# install menu entries
360
361mkdir -p %{buildroot}%{_datadir}/applications
362cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
363[Desktop Entry]
364Name=VirtualBox
365Comment=Full virtualizer for x86 hardware
366Comment[ja]=x86 ハードウエアの完全仮想化システム
367Exec=%{_bindir}/%{name}
368Icon=%{name}
369Type=Application
370Terminal=false
371Categories=System;Emulator;
372EOF
373
374# add missing makefile for kernel module
375install -m644 src/VBox/HostDrivers/Support/linux/Makefile %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
376
377# remove unpackaged files
378rm -rf %{buildroot}%{vboxlibdir}/{src,sdk,testcase}
379rm  -f %{buildroot}%{vboxlibdir}/tst*
380rm  -f %{buildroot}%{vboxlibdir}/vboxkeyboard.tar.gz
381rm  -f %{buildroot}%{vboxlibdir}/SUP*
382rm  -f %{buildroot}%{vboxlibdir}/xpidl
383
384%clean
385rm -rf %{buildroot}
386
387%post
388/sbin/chkconfig --add virtualbox
389
390%postun
391if [ "$1" -ge "1" ]; then
392  /sbin/service virtualbox condrestart > /dev/null 2>&1 || :
393fi
394
395%preun
396if [ $1 = 0 ]; then
397    service virtualbox stop > /dev/null 2>&1 ||:
398    /sbin/chkconfig --del virtualbox
399fi
400       
401
402%post -n dkms-%{name}
403set -x
404/usr/sbin/dkms --rpm_safe_upgrade add -m %{name} -v %{version}-%{release} ||:
405/usr/sbin/dkms --rpm_safe_upgrade build -m %{name} -v %{version}-%{release} ||:
406/usr/sbin/dkms --rpm_safe_upgrade install -m %{name} -v %{version}-%{release} --force ||:
407/sbin/modprobe %{kname} >/dev/null 2>&1 || :
408/sbin/modprobe vboxnetflt >/dev/null 2>&1 || :
409
410%preun -n dkms-%{name}
411# rmmod can fail
412/sbin/rmmod vboxnetflt >/dev/null 2>&1
413/sbin/rmmod %{kname} >/dev/null 2>&1
414set -x
415/usr/sbin/dkms --rpm_safe_upgrade remove -m %{name} -v %{version}-%{release} --all || :
416
417%if %{build_additions}
418%post guest-additions
419/sbin/chkconfig --add vboxadd-timesync
420
421%postun guest-additions
422if [ "$1" -ge "1" ]; then
423  /sbin/service vboxadd-timesync condrestart > /dev/null 2>&1 || :
424fi
425
426%preun guest-additions
427if [ $1 = 0 ]; then
428    service vboxadd-timesync stop > /dev/null 2>&1 ||:
429    /sbin/chkconfig --del vboxadd-timesync
430fi
431
432%post -n dkms-vboxadd
433set -x
434/usr/sbin/dkms --rpm_safe_upgrade add -m vboxadditions -v %{version}-%{release} ||:
435/usr/sbin/dkms --rpm_safe_upgrade build -m vboxadditions -v %{version}-%{release} ||:
436/usr/sbin/dkms --rpm_safe_upgrade install -m vboxadditions -v %{version}-%{release} ||:
437:
438
439%preun -n dkms-vboxadd
440set -x
441/usr/sbin/dkms --rpm_safe_upgrade remove -m vboxadditions -v %{version}-%{release} --all ||:
442:
443
444%endif
445
446%files
447%defattr(-,root,root)
448%config %{_sysconfdir}/vbox/vbox.cfg
449%{_bindir}/%{name}
450%{_bindir}/VBoxManage
451%{_bindir}/VBoxSDL
452%{_bindir}/VBoxHeadless
453%{_bindir}/VBoxTunctl
454%{_bindir}/VBoxNetAdpCtl
455%{_bindir}/VBoxNetDHCP
456#%{_bindir}/vboxwebsrv
457%{vboxlibdir}
458%attr(4711,root,root) %{vboxlibdir}/VBoxHeadless
459%attr(4711,root,root) %{vboxlibdir}/VBoxSDL
460%attr(4711,root,root) %{vboxlibdir}/%{name}
461%attr(4711,root,root) %{vboxlibdir}/VBoxNetAdpCtl
462%attr(4711,root,root) %{vboxlibdir}/VBoxNetDHCP
463%attr(644,root,root) %{vboxlibdir}/*.gc
464%attr(644,root,root) %{vboxlibdir}/*.r0
465%{vboxdatadir}
466# initscripts integration
467%{_initrddir}/virtualbox
468%config %{_sysconfdir}/udev/rules.d/%{name}.rules
469%dir /var/run/%{name}
470# desktop integration
471%{_iconsdir}/*.png
472%{_datadir}/applications/%{name}.desktop
473
474%files -n dkms-%{name}
475%defattr(-,root,root)
476%{_usr}/src/%{name}-%{version}-%{release}
477
478%if %{build_additions}
479%files guest-additions
480%defattr(-,root,root)
481/sbin/mount.vboxsf
482%{_initrddir}/vboxadd-timesync
483%{_sbindir}/VBoxService
484%{_bindir}/VBoxClient
485%{_bindir}/VBoxControl
486%{_bindir}/VBoxRandR
487%{_sysconfdir}/security/console.perms.d/60-vboxadd.perms
488%{_sysconfdir}/udev/rules.d/vbox-additions.rules
489%{_sysconfdir}/X11/xinit.d/98vboxadd-xclient
490%{_sysconfdir}/modprobe.preload.d/vbox-guest-additions
491
492%files -n xorg-x11-drv-vboxmouse
493%defattr(-,root,root)
494%{_libdir}/xorg/modules/input/vboxmouse_drv.so
495%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
496
497%files -n xorg-x11-drv-vboxvideo
498%defattr(-,root,root)
499%{_libdir}/VBoxOGL*
500%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
501%{_libdir}/dri/vboxvideo_dri.so
502
503%files -n dkms-vboxadd
504%defattr(-,root,root)
505%{_usr}/src/vbox*-%{version}-%{release}
506
507%endif
508
509
510%changelog
511* Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.6-1
512- new upstream release
513
514* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.10-1
515- new upstream release
516- add missing BR:
517
518* Mon Sep 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.6-1
519- new upstream release
520
521* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.4-1
522- new upstream release
523- add translated summaries and descriptions
524
525* Mon Jul 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-1
526- new upstream release
527
528* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
529- new upstream release
530
531* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-3
532- change Group: of dkms-VirtualBox to System Environment/Kernel
533
534* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-2
535- remove modprobe.d/vbox-guest-additions
536
537* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-1
538- update to 2.2.4
539
540* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-1
541- initial build for Vine Linux
542- update to 2.2.2
543
544* Wed Apr 22 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-4mdv2009.1
545+ Revision: 368679
546- Fix mkrpm template
547
548* Tue Apr 21 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-3mdv2009.1
549+ Revision: 368502
550- BuildRequires:dkms-minimal
551- Obsolete -latest dkms binary packages
552
553* Wed Apr 15 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-2mdv2009.1
554+ Revision: 367571
555- Patch15: kill vboxclient if leftover from previous X11 session
556- Patch14 (Sun): fix OpenGL support for Linux Guest additions
557- improve packaging to be more LSB compliant
558
559* Fri Apr 10 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-1mdv2009.1
560+ Revision: 365828
561- Release 2.2.0
562- enable OpenGL pass-through. Caveat : Linux guest support is not working when building guest additions with Open source edition (under investigation)
563- move location of fdi file (fix mouse integration support when using HAL)
564- merge all guest additions kernel module in one single DKMS (pterjan)
565- Enable webservice
566- Remove patch9, no longer needed (when using kernel 2.6.29.x, you MUST use kernel 2.6.29.1 or later)
567- Regenerate patches 8, 10
568- Patch11: add Wine Direct3D guest additions option (Debian)
569- Patch12: disable update notification (Debian)
570- Patch13: make network settings more intuitive (Debian)
571- Add missing dependencies in guest additions package
572- No longer use gcc 4.2, build fine with latest gcc 4.3
573- Replace source3 with upstream version
574- Update source4 to change permissions on both guest additions devices
575- Fix permissions on non .so files
576
577* Mon Mar 09 2009 Pascal Terjan <pterjan@mandriva.org> 2.1.4-5mdv2009.1
578+ Revision: 353280
579- vboxvfs needs vboxadd
580
581* Wed Mar 04 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.4-4mdv2009.1
582+ Revision: 348336
583- Force rebuild of dkms modules
584
585* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-3mdv2009.1
586+ Revision: 344966
587- Copy Module.symvers for vboxnetflt dkms build, needed with
588  CONFIG_MODVERSIONS enabled in latest cooker kernels.
589
590* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-2mdv2009.1
591+ Revision: 344896
592- Apply fix for VM load failure with kernels 2.6.29-rc5 or later
593  (#48096, http://www.virtualbox.org/ticket/3403).
594- Fix building with kernel-headers-2.6.29*
595
596* Tue Feb 17 2009 Frederik Himpe <fhimpe@mandriva.org> 2.1.4-1mdv2009.1
597+ Revision: 342236
598- Update to new version 2.1.4
599- Fix source URL
600
601* Thu Jan 22 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.2-2mdv2009.1
602+ Revision: 332593
603- Use xorg 1.6 drivers when building cooker guest addition packages
604
605* Thu Jan 22 2009 Funda Wang <fundawang@mandriva.org> 2.1.2-1mdv2009.1
606+ Revision: 332404
607- specify CC4.2
608- New version 2.1.2
609- rediff libpath patch
610
611* Sun Jan 04 2009 Colin Guthrie <cguthrie@mandriva.org> 2.1.0-5mdv2009.1
612+ Revision: 324525
613- Rebuild mouse and display drivers for xserver 1.6
614
615* Thu Dec 25 2008 Michael Scherer <misc@mandriva.org> 2.1.0-4mdv2009.1
616+ Revision: 318540
617- rebuild for new python
618
619* Fri Dec 19 2008 Frederic Crozat <fcrozat@mandriva.com> 2.1.0-3mdv2009.1
620+ Revision: 316288
621- Fix guest additions for cooker, we ship Xorg 1.5 now
622- Ship fdi file for vboxmouse
623
624* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-2mdv2009.1
625+ Revision: 316021
626- oops, finish fixing up initscript
627
628* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-1mdv2009.1
629+ Revision: 316019
630- adjust initscript and dkms.conf for the fact that there's now two necessary
631  kernel modules for the master: vboxdrv and vboxnetflt
632- drop mdvconfig.patch: this stub does nothing useful, and breaks the build
633  (see fcrozat's mail on Cooker)
634- VBoxAddIF and VBoxDeleteIF are now obsolete and not provided
635
636  + Frederic Crozat <fcrozat@mandriva.com>
637    - Release 2.1.0
638    - Regenerate patch1
639    - update buildrequires
640
641* Sun Nov 30 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.6-2mdv2009.1
642+ Revision: 308552
643- Rebuild mouse and display drivers for xserver 1.5
644
645* Wed Nov 26 2008 Funda Wang <fundawang@mandriva.org> 2.0.6-1mdv2009.1
646+ Revision: 306865
647- New version 2.0.6
648
649* Mon Nov 03 2008 Funda Wang <fundawang@mandriva.org> 2.0.4-1mdv2009.1
650+ Revision: 299348
651- New version 2.0.4
652
653* Mon Sep 15 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.2-2mdv2009.0
654+ Revision: 284854
655- Patch8: disable version check at startup
656
657* Sat Sep 13 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.2-1mdv2009.0
658+ Revision: 284544
659- Update to bugfix update 2.0.2
660
661* Tue Sep 09 2008 Olivier Blin <oblin@mandriva.com> 2.0.0-3mdv2009.0
662+ Revision: 283015
663- build guest additions on x86_64 too (#43593)
664
665  + Frederic Crozat <fcrozat@mandriva.com>
666    - Patch7: fix QT4 detection on x86-64 on Mandriva 2008.1
667
668* Thu Sep 04 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.0-1mdv2009.0
669+ Revision: 280850
670- Fix BuildRequires
671- Release 2.0.0
672- Remove patches 3, 7 (merged upstream)
673
674* Mon Sep 01 2008 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 1.6.4-4mdv2009.0
675+ Revision: 278071
676- Added patch to allow VirtualBox kernel module to build with
677  Linux 2.6.27
678
679  + Pixel <pixel@mandriva.com>
680    - increase release number
681    - use gcc4.2 to build the recompiler (not ported to gcc 4.3 yet)
682
683* Wed Aug 06 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-2mdv2009.0
684+ Revision: 264273
685- create /var/run/VirtualBox (#41963)
686- use tunctl from the tunctl package while VBoxTunctl does not build
687
688* Tue Aug 05 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-1mdv2009.0
689+ Revision: 264016
690- do not include VBoxTunctl for now (build is broken in upstream tarball)
691- rediff misc_register patch (the register part has been implemented upstream, I should submit the deregister hunks)
692- fix 1.6.4 build by not building tunctl (some Makefile.kmk are missing)
693- 1.6.4
694
695* Tue Jul 29 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.2-2mdv2009.0
696+ Revision: 252777
697- Don't use gcc 3.3 for build on 2008.1 or earlier
698
699* Wed Jul 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.2-1mdv2009.0
700+ Revision: 232889
701- set again linux sources path in configure
702- use gcc 3.3 to build the recompiler (not ported to gcc 4.3 yet)
703- use kernel-devel-latest instead of kernel-source-latest
704- use a prepared copy of the linux tree (for linux/bounds.h)
705
706  + Frederic Crozat <fcrozat@mandriva.com>
707    - Release 1.6.2
708    - Regenerate patch5
709    - Fix duplicated line in specfile
710
711  + Pixel <pixel@mandriva.com>
712    - rpm filetriggers deprecates update_menus/update_scrollkeeper/update_mime_database/update_icon_cache/update_desktop_database/post_install_gconf_schemas
713
714* Fri May 16 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-4mdv2009.0
715+ Revision: 208160
716- Fix seamless mode in guest additions subpackage
717
718* Thu May 15 2008 Anssi Hannula <anssi@mandriva.org> 1.6.0-3mdv2009.0
719+ Revision: 207692
720- rename VBoxAddIF.sh and VBoxDeleteIF.sh to VBoxAddIF and VBoxDeleteIF
721  to match original names and documentation
722
723* Wed May 14 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-2mdv2009.0
724+ Revision: 207235
725- Replace source1 with patch 6 (use up to date VBox.sh script)
726- Ensure VBoxAddIF/VBoxDeleteIF scripts are packaged, as well as VBoxTunctl (Mdv bug #40769)
727- package VBoxHeadless (Mdv bug #40771)
728
729* Fri May 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.0-1mdv2009.0
730+ Revision: 205313
731- try harder to disable additions on x86_64
732- buildrequire libxslt-devel
733- adapt to vboxadd-xclient being renamed as VBoxClient
734- rediff futex patch
735- rediff misc_register patch
736- 1.6.0
737- revert BUILT_MODULE_NAME addition, the bug is fixed in dkms
738
739  + Anssi Hannula <anssi@mandriva.org>
740    - add BUILT_MODULE_NAME to dkms.conf of vboxadd and vboxvfs (fixes DKMS
741      error)
742
743* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.6-1mdv2008.1
744+ Revision: 175619
745- 1.5.6
746- rediff KERNELRELEASE patch
747
748* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-5mdv2008.1
749+ Revision: 175610
750- try to start dkms instead of vboxadd in vboxadd-timesync service (since modules are loaded from modprobe.preload.d, #36728)
751
752* Fri Feb 08 2008 Thierry Vignaud <tvignaud@mandriva.com> 1.5.4-4mdv2008.1
753+ Revision: 163970
754- drop old menu
755
756  + Frederic Crozat <fcrozat@mandriva.com>
757    - Really disable pulseaudio support on 2008.0 or older
758
759* Thu Jan 10 2008 Frederic Crozat <fcrozat@mandriva.com> 1.5.4-3mdv2008.1
760+ Revision: 147602
761- Use correct version of x11 mouse and video additional driver when used on 2008.1 (xorg 1.4) and 2008.0
762- Only build pulseaudio support for 2008.1
763
764* Wed Jan 09 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-2mdv2008.1
765+ Revision: 147006
766- fix dkms build for kernels different from running kernel
767
768* Thu Jan 03 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-1mdv2008.1
769+ Revision: 142711
770- buildrequire pulseaudio-devel
771- rediff libpath patch
772- remove 2.6.24 build fix, fixed upstream
773- 1.5.4
774- restore BuildRoot
775
776  + Pascal Terjan <pterjan@mandriva.org>
777    - Switch to Debian patch for 2.6.24
778    - Re-create the 2.6.24 patch, some bits got lost
779
780  + Thierry Vignaud <tvignaud@mandriva.com>
781    - kill re-definition of %%buildroot on Pixel's request
782    - kill explicit icon extension
783
784  + Giuseppe Ghibò <ghibo@mandriva.com>
785    - Use kernel-source-latest in BuildRequires as conditional.
786    - Add conditional build flags for older release.
787    - Let Patch5 conditional.
788
789* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-3mdv2008.1
790+ Revision: 114076
791- Improve 2.6.24 patch so that it should still build with older kernels
792
793* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-2mdv2008.1
794+ Revision: 114047
795- Fix other parts to build with 2.6.24
796- Fix vboxdrv for 2.6.24
797
798* Tue Nov 13 2007 Olivier Blin <oblin@mandriva.com> 1.5.2-1mdv2008.1
799+ Revision: 108363
800- remove keyboards patch (was from upstream svn)
801- rediff kernelrelease patch
802- rediff libpath patch
803- 1.5.2
804
805* Thu Oct 04 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-6mdv2008.0
806+ Revision: 95447
807- really apply misc_register patch (so that vboxadd devices are automatically created)
808- add release in dkms PACKAGE_VERSION to ease upgrades
809
810* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-5mdv2008.0
811+ Revision: 93837
812- require kmod(vboxdrv) instead of dkms package
813- do not mark initscript as config file
814- move initscripts and udev rules out of dkms package (so that it works when using dkms prebuilt modules)
815
816* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-4mdv2008.0
817+ Revision: 93812
818- add vboxadd-timesync service
819- add pam_console perms file to assign vboxadd device to console user
820- use misc_register() to register vboxadd device so that /dev/vboxadd gets created automatically by udev
821
822* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-3mdv2008.0
823+ Revision: 93770
824- add vboxadd-xclient xinit.d script
825- release new additions, but we still need to fix mknod for vboxadd
826  (or use device_create() in kernel module), set console perms for
827  vboxadd in console.perms.d, and add timesync initscript
828- make guest additions package require X11 drivers
829- make x11 driver packages suggest virtualbox-guest-additions
830- add virtualbox-guest-additions package (with xclient, timesync, mount.vboxsf)
831- add dkms-vboxadd and dkms-vboxvfs packages
832
833* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-2mdv2008.0
834+ Revision: 93534
835- build additions on ix86 only
836- fix support for Brazilian, Belgian, US intl and US dvorak keyboards and add support for multimedia keys (from upstream SVN)
837- buildrequire libstdc++-static-devel
838- buildrequire libxt-devel
839- buildrequire kernel-source-latest, since iurt/urpmi don't install latest kernel-source automatically
840- buildrequire kernel-source
841- package mouse guest addition in x11-driver-input-vboxmouse
842- package video guest addition in x11-driver-video-vboxvideo
843- build VirtualBox additions
844
845* Mon Sep 03 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-1mdv2008.0
846+ Revision: 78607
847- drop libstdc++5 BuildRequires
848- drop unapplied x86_64 NMI watchdog disabling patch (merged upstream)
849- 1.5.0
850- rediff mdvconfig patch
851
852  + Thierry Vignaud <tvignaud@mandriva.com>
853    - kill desktop-file-validate's 'warning: key "Encoding" in group "Desktop Entry" is deprecated'
854
855* Fri Jun 08 2007 Per Øyvind Karlsen <peroyvind@mandriva.org> 1.4.0-1mdv2008.0
856+ Revision: 37085
857- from Jos?\195?\169 Melo <mmodem00@gmail.com>:
858        o 1.4.0
859        o update patch:2 since is needed to load (modprobe) vbox driver in kernel-2.6.17
860        o remove patch1 since is becomes obsolete with this new version,and continues installing and running stable no matter if is kernel-2.6.17 or greater
861        o add missing buildrequire hal-devel
862
863
864* Thu Mar 15 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.8-1mdv2007.1
865+ Revision: 144313
866- add should-start: dkms to initscript (#29523)
867- 1.3.8
868  * hard reset network device on reboot
869  * fix issues with IBM JVM 1.4.2 in Linux guests
870  * add support for X.org 7.2.x in Linux guest additions
871
872* Fri Mar 02 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.6-1mdv2007.1
873+ Revision: 131492
874- disable NMIs on Core 2 platforms too
875- 1.3.6
876  * fix some GUI issues
877  * fix OpenBSD 4.0 support
878  * fix CD/DVD-ROM detection in Windows Vista guests
879  * fix networking issues with Windows NT 4.0 guests
880  * fix some ALSA problems that could cause system reboots
881
882* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.4-1mdv2007.1
883+ Revision: 119895
884- 1.3.4
885
886* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070209-1mdv2007.1
887+ Revision: 119017
888- SVN updates (2007/02/09):
889  * additional 64-bit fixes
890  * asynchronous packets transmission in NIC code
891
892* Sat Feb 03 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070202-1mdv2007.1
893+ Revision: 116064
894- various 64-bit fixes
895- updates from SVN (2007/02/02):
896  * initial 64-bit host support
897  * fix IDE for Open Solaris 10
898  * add VDI compacting to the GUI
899
900* Sat Jan 27 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3-1mdv2007.1
901+ Revision: 114276
902- initial mandriva linux package
903
Note: See TracBrowser for help on using the repository browser.