source: projects/specs/trunk/V/VirtualBox/VirtualBox-vl.spec @ 521

Revision 521, 30.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define version 3.0.10
2%define release 1%{?_dist_release}
3
4%define kname   vboxdrv
5%define oname   VirtualBox
6%define srcname %{oname}-%{version}-OSE
7%define distname        %{oname}-%{version}_OSE
8%define dirname vbox-ose
9%define pkgver  %{version}
10
11%define vboxlibdir      %{_libdir}/%{name}
12%define vboxdatadir     %{_datadir}/%{name}
13
14%define build_additions 1
15
16%ifarch %{ix86}
17%define vbox_platform linux.x86
18%endif
19%ifarch x86_64
20%define vbox_platform linux.amd64
21%endif
22
23# nuke vbox-specific dependencies
24%define _provides_exceptions ^VBox
25%define _requires_exceptions ^VBox
26
27Summary:        A general-purpose full virtualizer for x86 hardware
28Summary(ja):    汎用の x86 ハードウエア完全仮想化ソフトウエア
29Name:           VirtualBox
30Version:        %{version}
31Release:        %{release}
32License:        GPL
33Group:          Development/Tools
34Url:            http://www.virtualbox.org/
35
36Source0:        http://download.virtualbox.org/virtualbox/%ver/%{srcname}.tar.bz2
37Source2:        virtualbox.init
38Source4:        60-vboxadd.perms
39Source10:       VirtualBox.png
40Patch2:         VirtualBox-1.5.6_OSE-kernelrelease.patch
41Patch4:         VirtualBox-1.6.0_OSE-futex.patch
42#Patch5:                VirtualBox-1.6.2_OSE-fix-timesync-req.patch
43# (fc) 1.6.0-2mdv fix initscript name in VBox.sh script
44Patch6:         VirtualBox-1.6.0_OSE-initscriptname.patch
45# (fc) 2.0.2-2mdv disable version check at startup
46Patch8:         VirtualBox-disableversioncheck.patch
47# (hk) fix build kernel-headers-2.6.29*
48Patch10:        VirtualBox-kernel-headers-2.6.29.patch
49# (fc) 2.2.0-1mdv add Wine Direct3D guest additions option (Debian)
50Patch11:        15-wined3d-guest-addition.patch
51# (fc) 2.2.0-1mdv disable update notification (Debian)
52Patch12:        16-no-update.patch
53# (fc) 2.2.0-3mdv kill vboxclient if leftover from previous X11 session
54Patch15:        VirtualBox-2.2.0-killvboxclient.patch
55# vine
56Patch100:       VirtualBox-2.2.2-buildfix.patch
57
58BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
59ExclusiveArch:  %{ix86} x86_64
60Requires:       dkms-%{name} = %{version}-%{release}
61BuildRequires:  dev86, iasl
62BuildRequires:  zlib-devel
63BuildRequires:  libXcursor-devel
64BuildRequires:  libXmu-devel
65BuildRequires:  SDL-devel
66BuildRequires:  qt4-devel
67BuildRequires:  libIDL-devel
68BuildRequires:  e2fsprogs-devel
69BuildRequires:  libxslt-devel
70BuildRequires:  xerces-c-devel, xalan-c-devel
71BuildRequires:  hal-devel
72BuildRequires:  libXt-devel
73BuildRequires:  libstdc++34-devel
74BuildRequires:  python-devel
75BuildRequires:  libcap-devel
76BuildRequires:  pulseaudio-libs-devel
77BuildRequires:  kernel-devel
78BuildRequires:  mesa-libGL-devel
79BuildRequires:  mesa-libGLU-devel
80BuildRequires:  gsoap-devel
81BuildRequires:  curl-devel
82BuildRequires:  alsa-lib-devel
83BuildRequires:  dkms
84BuildRequires:  kBuild
85BuildRequires:  yasm
86BuildRequires:  qt4-designer
87%ifarch x86_64
88BuildRequires:  compat32-glibc-devel
89%endif
90
91%description
92VirtualBox Open Source Edition (OSE) is a general-purpose full
93virtualizer for x86 hardware.
94
95%description -l ja
96VirtualBox Open Source Edition (OSE) は汎用の x86 ハードウエア
97完全仮想化ソフトウエアです。
98
99%package -n     dkms-%{name}
100Summary:        VirtualBox OSE kernel module
101Summary(ja):    VirtualBox OSE カーネルモジュール
102Group:          System Environment/Kernel
103Requires(post):   dkms
104Requires(preun):  dkms
105
106%description -n dkms-%{name}
107Kernel support for VirtualBox OSE.
108
109%description -l ja -n dkms-%{name}
110VirtualBox OSE のカーネルサポートパッケージです。
111
112%if %{build_additions}
113%package        guest-additions
114Summary:        Additions for VirtualBox OSE guest systems
115Summary(ja):    VirtualBox OSE ゲストシステム用の追加モジュール
116Group:          System Environment/Kernel
117Requires:       dkms-vboxadd = %{version}-%{release}
118Requires:       dkms-vboxvfs = %{version}-%{release}
119Requires:       dkms-vboxvideo = %{version}-%{release}
120Requires:       xorg-x11-drv-vboxmouse
121Requires:       xorg-x11-drv-vboxvideo
122Requires:       xorg-x11-server-utils
123
124%description    guest-additions
125This packages contains additions for VirtualBox OSE guest systems.
126It allows to share files with the host system, copy/paste between
127guest and host, and sync time with host.
128
129%description -l ja guest-additions
130このパッケージには VirtualBox OSE ゲストシステムのための追加モジュール
131が含まれています。これを利用することでホストシステムとファイルを共有し
132たり、ゲスト/ホスト間でカット&ペーストを行ったり、ホストと時刻同期をし
133たりすることができます。
134
135%package -n     dkms-vboxadd
136Summary:        Kernel module for VirtualBox OSE additions
137Summary(ja):    VirtualBox OSE additions のカーネルモジュール
138Group:          System Environment/Kernel
139Requires(post):   dkms
140Requires(preun):  dkms
141Provides:       dkms-vboxvfs = %{version}-%{release}
142Obsoletes:      dkms-vboxvfs < %{version}-%{release}
143Provides:       dkms-vboxvideo = %{version}-%{release}
144Obsoletes:      dkms-vboxvideo < %{version}-%{release}
145
146%description -n dkms-vboxadd
147Kernel module for VirtualBox OSE additions.
148
149%description -l ja -n dkms-vboxadd
150VirtualBox OSE 追加モジュールのためのカーネルモジュールです。
151
152%package -n     xorg-x11-drv-vboxmouse
153Summary:        X.org X11 input driver for VirtualBox mouse
154Summary:        X.org X11 VirtualBox マウス入力ドライバ
155Group:          User Interface/X Hardware Support
156Requires:       %{name}-guest-additions
157
158%description -n xorg-x11-drv-vboxmouse
159The X.org driver for mouse in VirtualBox guests
160
161%description -l ja -n xorg-x11-drv-vboxmouse
162VirtualBox のゲストシステム用の X.org マウスドライバです。
163
164%package -n     xorg-x11-drv-vboxvideo
165Summary:        X.org X11 video driver for VirtualBox guests
166Summary(ja):    X.org X11 VirtualBox ビデオドライバ
167Group:          User Interface/X Hardware Support
168Requires:       %{name}-guest-additions
169
170%description -n xorg-x11-drv-vboxvideo
171The X.org driver for video in VirtualBox guests
172
173%description -l ja -n xorg-x11-drv-vboxvideo
174VirtualBox のゲストシステム用の X.org ビデオドライバです。
175
176%endif
177
178%prep
179%setup -q -n %{distname}
180%patch2 -p1 -b .kernelrelease
181%patch4 -p1 -b .futex
182#%patch5 -p1 -b .fix-timesync-req
183%patch6 -p1 -b .initscriptname
184%patch8 -p1 -b .versioncheck
185%patch10 -p1 -b .kernel-headers-2.6.29
186%patch11 -p1 -b .wined3d
187%patch12 -p1 -b .disable-update
188%patch15 -p1 -b .killvboxclient
189%patch100 -p1 -b .buildfix
190
191# remove prebuilt binaries
192rm -rf kBuild tools
193
194cat << EOF > LocalConfig.kmk
195VBOX_PATH_APP_PRIVATE_ARCH:=%{vboxlibdir}
196VBOX_WITH_ORIGIN:=
197VBOX_WITH_RUNPATH:=%{vboxlibdir}
198VBOX_PATH_APP_PRIVATE:=%{vboxdatadir}
199VBOX_WITH_TESTCASE:=
200VBOX_WITH_TESTSUITE:=
201EOF
202
203%build
204./configure --disable-kmods
205
206%if !%{build_additions}
207sed -rie 's/(VBOX_WITH_LINUX_ADDITIONS\s+:=\s+).*/\1/' AutoConfig.kmk
208echo VBOX_WITHOUT_ADDITIONS=1 >> LocalConfig.kmk
209%endif
210
211. ./env.sh
212kmk KBUILD_VERBOSE=2 TOOL_YASM_AS=yasm \
213    VBOX_WITH_REGISTRATION_REQUEST= \
214    PATH_INS="$PWD/obj" \
215    KMK_REVISION=3000 KBUILD_KMK_REVISION=3000
216
217%install
218rm -rf %{buildroot}
219
220# install vbox components
221mkdir -p %{buildroot}%{vboxlibdir} %{buildroot}%{vboxdatadir}
222
223(cd obj/bin && tar cf - --exclude=additions .) | \
224(cd %{buildroot}%{vboxlibdir} && tar xf -)
225
226# move noarch files to vboxdatadir
227mv %{buildroot}%{vboxlibdir}/{VBox*.sh,nls,*.desktop,*.png} %{buildroot}%{vboxdatadir}
228
229# install service
230mkdir -p %{buildroot}%{_initrddir}
231install -m755 %{SOURCE2} %{buildroot}%{_initrddir}/virtualbox
232
233# install wrappers
234mkdir -p %{buildroot}%{_sysconfdir}/vbox
235cat > %{buildroot}%{_sysconfdir}/vbox/vbox.cfg << EOF
236# VirtualBox installation directory
237INSTALL_DIR="%{vboxlibdir}"
238EOF
239mkdir -p %{buildroot}%{_bindir}
240ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/%{name}
241ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxManage
242ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxSDL
243ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxHeadless
244
245# move VBoxTunctl to bindir
246mv %{buildroot}%{vboxlibdir}/VBoxTunctl %{buildroot}%{_bindir}/
247
248install -d %{buildroot}/var/run/%{name}
249
250# install dkms sources
251mkdir -p %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
252cat > vboxbuild << EOF
253#!/bin/sh
254set -e
255droot=\$(pwd)
256cd \$droot/%{kname}
257make KERN_DIR=\$1
258cp -f \$droot/%{kname}/Module.symvers \$droot/vboxnetflt
259cd \$droot/vboxnetflt
260make KERN_DIR=\$1
261EOF
262install -m 0755 vboxbuild %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
263mv %{buildroot}%{vboxlibdir}/src/* %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
264cat > %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/dkms.conf << EOF
265MAKE[0]="./vboxbuild \$kernel_source_dir"
266PACKAGE_NAME=%{name}
267PACKAGE_VERSION=%{version}-%{release}
268DEST_MODULE_LOCATION[0]=/kernel/3rdparty/vbox
269BUILT_MODULE_LOCATION[0]=%{kname}/
270BUILT_MODULE_NAME[0]=%{kname}
271DEST_MODULE_LOCATION[1]=/kernel/3rdparty/vbox
272BUILT_MODULE_LOCATION[1]=vboxnetflt/
273BUILT_MODULE_NAME[1]=vboxnetflt
274AUTOINSTALL=yes
275EOF
276
277# install udev rules
278mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d/
279cat > %{buildroot}%{_sysconfdir}/udev/rules.d/%{name}.rules << EOF
280KERNEL=="%{kname}", MODE="0666"
281EOF
282
283# install additions
284%if %{build_additions}
285mkdir -p %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty
286#install -m755 src/VBox/Additions/linux/installer/vboxadd-timesync.sh %{buildroot}%{_initrddir}/vboxadd-timesync
287install -m755 src/VBox/Additions/x11/Installer/VBoxRandR.sh %{buildroot}%{_bindir}/VBoxRandR
288install -m755 src/VBox/Additions/linux/installer/90-vboxguest.fdi %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
289
290install -d %{buildroot}%{_sysconfdir}/X11/xinit.d
291install -m755 src/VBox/Additions/x11/Installer/98vboxadd-xclient %{buildroot}%{_sysconfdir}/X11/xinit.d
292
293pushd obj/bin/additions
294  install -d %{buildroot}/sbin %{buildroot}%{_sbindir} %{buildroot}/%{_libdir}/dri
295  install -m755 mountvboxsf %{buildroot}/sbin/mount.vboxsf
296#  install -m755 vboxadd-timesync %{buildroot}%{_sbindir}
297
298  install -d %{buildroot}%{_sysconfdir}/security/console.perms.d/
299  install -m644 %{SOURCE4} %{buildroot}%{_sysconfdir}/security/console.perms.d/
300
301  install -m755 VBoxClient %{buildroot}%{_bindir}
302  install -m755 VBoxControl %{buildroot}%{_bindir}
303
304  install -m755 VBoxOGL*.so %{buildroot}%{_libdir}
305  ln -s -f ../VBoxOGL.so %{buildroot}%{_libdir}/dri/vboxvideo_dri.so
306
307  install -d %{buildroot}%{_libdir}/xorg/modules/{input,drivers}
308  install vboxmouse_drv_16.so %{buildroot}%{_libdir}/xorg/modules/input/vboxmouse_drv.so
309  install vboxvideo_drv_16.so %{buildroot}%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
310  mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}
311  cat > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
312PACKAGE_NAME=vboxadditions
313PACKAGE_VERSION=%{version}-%{release}
314MAKE[0]="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxadd &&
315cp \$dkms_tree/\$module/\$module_version/build/vboxadd/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxvfs &&
316make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvfs &&
317cp \$dkms_tree/\$module/\$module_version/build/vboxvfs/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxvideo &&
318make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo"
319EOF
320  i=0
321  cp -arf src/vboxvideo_drm src/vboxvideo
322  for kmod in vboxadd vboxvfs vboxvideo; do
323    mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod
324    cp -a src/$kmod/* %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod/
325    cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
326DEST_MODULE_LOCATION[$i]=/kernel/3rdparty/vbox
327BUILT_MODULE_LOCATION[$i]=$kmod/
328BUILT_MODULE_NAME[$i]=$kmod
329EOF
330    i=$((i+1))
331  done
332  cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
333CLEAN="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxadd clean &&
334make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvfs clean &&
335make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo clean "
336AUTOINSTALL=yes
337EOF
338popd
339  sed 's/^\(.package.*-kernel-\)\(.*-latest\)\(.*\)\\$/\1\2\3Obsoletes: vboxvfs-kernel-\2 vboxvideo-kernel-\2\\n\\/' /etc/dkms/template-dkms-mkrpm.spec > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/vboxadditions-dkms-mkrpm.spec
340%endif
341
342# install icons
343mkdir -p %{buildroot}%{_iconsdir}
344install -m644 %{SOURCE10} %{buildroot}%{_iconsdir}/
345
346# install menu entries
347
348mkdir -p %{buildroot}%{_datadir}/applications
349cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
350[Desktop Entry]
351Name=VirtualBox
352Comment=Full virtualizer for x86 hardware
353Comment[ja]=x86 ハードウエアの完全仮想化システム
354Exec=%{_bindir}/%{name}
355Icon=%{name}
356Type=Application
357Terminal=false
358Categories=System;Emulator;
359EOF
360
361# add missing makefile for kernel module
362install -m644 src/VBox/HostDrivers/Support/linux/Makefile %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
363
364# remove unpackaged files
365rm -rf %{buildroot}%{vboxlibdir}/{src,sdk,testcase}
366rm  -f %{buildroot}%{vboxlibdir}/tst*
367rm  -f %{buildroot}%{vboxlibdir}/vboxkeyboard.tar.gz
368rm  -f %{buildroot}%{vboxlibdir}/SUP*
369rm  -f %{buildroot}%{vboxlibdir}/xpidl
370
371%clean
372rm -rf %{buildroot}
373
374%post
375/sbin/chkconfig --add virtualbox
376
377%postun
378if [ "$1" -ge "1" ]; then
379  /sbin/service virtualbox condrestart > /dev/null 2>&1 || :
380fi
381
382%preun
383if [ $1 = 0 ]; then
384    service virtualbox stop > /dev/null 2>&1 ||:
385    /sbin/chkconfig --del virtualbox
386fi
387       
388
389%post -n dkms-%{name}
390set -x
391/usr/sbin/dkms --rpm_safe_upgrade add -m %{name} -v %{version}-%{release} ||:
392/usr/sbin/dkms --rpm_safe_upgrade build -m %{name} -v %{version}-%{release} ||:
393/usr/sbin/dkms --rpm_safe_upgrade install -m %{name} -v %{version}-%{release} --force ||:
394/sbin/modprobe %{kname} >/dev/null 2>&1 || :
395/sbin/modprobe vboxnetflt >/dev/null 2>&1 || :
396
397%preun -n dkms-%{name}
398# rmmod can fail
399/sbin/rmmod vboxnetflt >/dev/null 2>&1
400/sbin/rmmod %{kname} >/dev/null 2>&1
401set -x
402/usr/sbin/dkms --rpm_safe_upgrade remove -m %{name} -v %{version}-%{release} --all || :
403
404%if %{build_additions}
405%preun guest-additions
406if [ $1 = 0 ]; then
407    service guest-additions stop > /dev/null 2>&1 ||:
408    /sbin/chkconfig --del guest-additions
409fi
410
411%post -n dkms-vboxadd
412set -x
413/usr/sbin/dkms --rpm_safe_upgrade add -m vboxadditions -v %{version}-%{release} ||:
414/usr/sbin/dkms --rpm_safe_upgrade build -m vboxadditions -v %{version}-%{release} ||:
415/usr/sbin/dkms --rpm_safe_upgrade install -m vboxadditions -v %{version}-%{release} ||:
416:
417
418%preun -n dkms-vboxadd
419set -x
420/usr/sbin/dkms --rpm_safe_upgrade remove -m vboxadditions -v %{version}-%{release} --all ||:
421:
422
423%endif
424
425%files
426%defattr(-,root,root)
427%config %{_sysconfdir}/vbox/vbox.cfg
428%{_bindir}/%{name}
429%{_bindir}/VBoxManage
430%{_bindir}/VBoxSDL
431%{_bindir}/VBoxHeadless
432%{_bindir}/VBoxTunctl
433%{vboxlibdir}
434%attr(4711,root,root) %{vboxlibdir}/VBoxHeadless
435%attr(4711,root,root) %{vboxlibdir}/VBoxSDL
436%attr(4711,root,root) %{vboxlibdir}/%{name}
437%attr(4711,root,root) %{vboxlibdir}/VBoxNetAdpCtl
438%attr(4711,root,root) %{vboxlibdir}/VBoxNetDHCP
439%attr(644,root,root) %{vboxlibdir}/*.gc
440%attr(644,root,root) %{vboxlibdir}/*.r0
441%{vboxdatadir}
442# initscripts integration
443%{_initrddir}/virtualbox
444%config %{_sysconfdir}/udev/rules.d/%{name}.rules
445%dir /var/run/%{name}
446# desktop integration
447%{_iconsdir}/*.png
448%{_datadir}/applications/%{name}.desktop
449
450%files -n dkms-%{name}
451%defattr(-,root,root)
452%{_usr}/src/%{name}-%{version}-%{release}
453
454%if %{build_additions}
455%files guest-additions
456%defattr(-,root,root)
457/sbin/mount.vboxsf
458#%{_initrddir}/vboxadd-timesync
459#%{_sbindir}/vboxadd-timesync
460%{_bindir}/VBoxClient
461%{_bindir}/VBoxControl
462%{_bindir}/VBoxRandR
463%{_sysconfdir}/security/console.perms.d/60-vboxadd.perms
464%{_sysconfdir}/X11/xinit.d/98vboxadd-xclient
465
466%files -n xorg-x11-drv-vboxmouse
467%defattr(-,root,root)
468%{_libdir}/xorg/modules/input/vboxmouse_drv.so
469%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
470
471%files -n xorg-x11-drv-vboxvideo
472%defattr(-,root,root)
473%{_libdir}/VBoxOGL*
474%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
475%{_libdir}/dri/vboxvideo_dri.so
476
477%files -n dkms-vboxadd
478%defattr(-,root,root)
479%{_usr}/src/vbox*-%{version}-%{release}
480
481%endif
482
483
484%changelog
485* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.10-1
486- new upstream release
487- add missing BR:
488
489* Mon Sep 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.6-1
490- new upstream release
491
492* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.4-1
493- new upstream release
494- add translated summaries and descriptions
495
496* Mon Jul 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-1
497- new upstream release
498
499* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
500- new upstream release
501
502* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-3
503- change Group: of dkms-VirtualBox to System Environment/Kernel
504
505* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-2
506- remove modprobe.d/vbox-guest-additions
507
508* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-1
509- update to 2.2.4
510
511* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-1
512- initial build for Vine Linux
513- update to 2.2.2
514
515* Wed Apr 22 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-4mdv2009.1
516+ Revision: 368679
517- Fix mkrpm template
518
519* Tue Apr 21 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-3mdv2009.1
520+ Revision: 368502
521- BuildRequires:dkms-minimal
522- Obsolete -latest dkms binary packages
523
524* Wed Apr 15 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-2mdv2009.1
525+ Revision: 367571
526- Patch15: kill vboxclient if leftover from previous X11 session
527- Patch14 (Sun): fix OpenGL support for Linux Guest additions
528- improve packaging to be more LSB compliant
529
530* Fri Apr 10 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-1mdv2009.1
531+ Revision: 365828
532- Release 2.2.0
533- enable OpenGL pass-through. Caveat : Linux guest support is not working when building guest additions with Open source edition (under investigation)
534- move location of fdi file (fix mouse integration support when using HAL)
535- merge all guest additions kernel module in one single DKMS (pterjan)
536- Enable webservice
537- Remove patch9, no longer needed (when using kernel 2.6.29.x, you MUST use kernel 2.6.29.1 or later)
538- Regenerate patches 8, 10
539- Patch11: add Wine Direct3D guest additions option (Debian)
540- Patch12: disable update notification (Debian)
541- Patch13: make network settings more intuitive (Debian)
542- Add missing dependencies in guest additions package
543- No longer use gcc 4.2, build fine with latest gcc 4.3
544- Replace source3 with upstream version
545- Update source4 to change permissions on both guest additions devices
546- Fix permissions on non .so files
547
548* Mon Mar 09 2009 Pascal Terjan <pterjan@mandriva.org> 2.1.4-5mdv2009.1
549+ Revision: 353280
550- vboxvfs needs vboxadd
551
552* Wed Mar 04 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.4-4mdv2009.1
553+ Revision: 348336
554- Force rebuild of dkms modules
555
556* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-3mdv2009.1
557+ Revision: 344966
558- Copy Module.symvers for vboxnetflt dkms build, needed with
559  CONFIG_MODVERSIONS enabled in latest cooker kernels.
560
561* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-2mdv2009.1
562+ Revision: 344896
563- Apply fix for VM load failure with kernels 2.6.29-rc5 or later
564  (#48096, http://www.virtualbox.org/ticket/3403).
565- Fix building with kernel-headers-2.6.29*
566
567* Tue Feb 17 2009 Frederik Himpe <fhimpe@mandriva.org> 2.1.4-1mdv2009.1
568+ Revision: 342236
569- Update to new version 2.1.4
570- Fix source URL
571
572* Thu Jan 22 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.2-2mdv2009.1
573+ Revision: 332593
574- Use xorg 1.6 drivers when building cooker guest addition packages
575
576* Thu Jan 22 2009 Funda Wang <fundawang@mandriva.org> 2.1.2-1mdv2009.1
577+ Revision: 332404
578- specify CC4.2
579- New version 2.1.2
580- rediff libpath patch
581
582* Sun Jan 04 2009 Colin Guthrie <cguthrie@mandriva.org> 2.1.0-5mdv2009.1
583+ Revision: 324525
584- Rebuild mouse and display drivers for xserver 1.6
585
586* Thu Dec 25 2008 Michael Scherer <misc@mandriva.org> 2.1.0-4mdv2009.1
587+ Revision: 318540
588- rebuild for new python
589
590* Fri Dec 19 2008 Frederic Crozat <fcrozat@mandriva.com> 2.1.0-3mdv2009.1
591+ Revision: 316288
592- Fix guest additions for cooker, we ship Xorg 1.5 now
593- Ship fdi file for vboxmouse
594
595* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-2mdv2009.1
596+ Revision: 316021
597- oops, finish fixing up initscript
598
599* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-1mdv2009.1
600+ Revision: 316019
601- adjust initscript and dkms.conf for the fact that there's now two necessary
602  kernel modules for the master: vboxdrv and vboxnetflt
603- drop mdvconfig.patch: this stub does nothing useful, and breaks the build
604  (see fcrozat's mail on Cooker)
605- VBoxAddIF and VBoxDeleteIF are now obsolete and not provided
606
607  + Frederic Crozat <fcrozat@mandriva.com>
608    - Release 2.1.0
609    - Regenerate patch1
610    - update buildrequires
611
612* Sun Nov 30 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.6-2mdv2009.1
613+ Revision: 308552
614- Rebuild mouse and display drivers for xserver 1.5
615
616* Wed Nov 26 2008 Funda Wang <fundawang@mandriva.org> 2.0.6-1mdv2009.1
617+ Revision: 306865
618- New version 2.0.6
619
620* Mon Nov 03 2008 Funda Wang <fundawang@mandriva.org> 2.0.4-1mdv2009.1
621+ Revision: 299348
622- New version 2.0.4
623
624* Mon Sep 15 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.2-2mdv2009.0
625+ Revision: 284854
626- Patch8: disable version check at startup
627
628* Sat Sep 13 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.2-1mdv2009.0
629+ Revision: 284544
630- Update to bugfix update 2.0.2
631
632* Tue Sep 09 2008 Olivier Blin <oblin@mandriva.com> 2.0.0-3mdv2009.0
633+ Revision: 283015
634- build guest additions on x86_64 too (#43593)
635
636  + Frederic Crozat <fcrozat@mandriva.com>
637    - Patch7: fix QT4 detection on x86-64 on Mandriva 2008.1
638
639* Thu Sep 04 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.0-1mdv2009.0
640+ Revision: 280850
641- Fix BuildRequires
642- Release 2.0.0
643- Remove patches 3, 7 (merged upstream)
644
645* Mon Sep 01 2008 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 1.6.4-4mdv2009.0
646+ Revision: 278071
647- Added patch to allow VirtualBox kernel module to build with
648  Linux 2.6.27
649
650  + Pixel <pixel@mandriva.com>
651    - increase release number
652    - use gcc4.2 to build the recompiler (not ported to gcc 4.3 yet)
653
654* Wed Aug 06 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-2mdv2009.0
655+ Revision: 264273
656- create /var/run/VirtualBox (#41963)
657- use tunctl from the tunctl package while VBoxTunctl does not build
658
659* Tue Aug 05 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-1mdv2009.0
660+ Revision: 264016
661- do not include VBoxTunctl for now (build is broken in upstream tarball)
662- rediff misc_register patch (the register part has been implemented upstream, I should submit the deregister hunks)
663- fix 1.6.4 build by not building tunctl (some Makefile.kmk are missing)
664- 1.6.4
665
666* Tue Jul 29 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.2-2mdv2009.0
667+ Revision: 252777
668- Don't use gcc 3.3 for build on 2008.1 or earlier
669
670* Wed Jul 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.2-1mdv2009.0
671+ Revision: 232889
672- set again linux sources path in configure
673- use gcc 3.3 to build the recompiler (not ported to gcc 4.3 yet)
674- use kernel-devel-latest instead of kernel-source-latest
675- use a prepared copy of the linux tree (for linux/bounds.h)
676
677  + Frederic Crozat <fcrozat@mandriva.com>
678    - Release 1.6.2
679    - Regenerate patch5
680    - Fix duplicated line in specfile
681
682  + Pixel <pixel@mandriva.com>
683    - rpm filetriggers deprecates update_menus/update_scrollkeeper/update_mime_database/update_icon_cache/update_desktop_database/post_install_gconf_schemas
684
685* Fri May 16 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-4mdv2009.0
686+ Revision: 208160
687- Fix seamless mode in guest additions subpackage
688
689* Thu May 15 2008 Anssi Hannula <anssi@mandriva.org> 1.6.0-3mdv2009.0
690+ Revision: 207692
691- rename VBoxAddIF.sh and VBoxDeleteIF.sh to VBoxAddIF and VBoxDeleteIF
692  to match original names and documentation
693
694* Wed May 14 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-2mdv2009.0
695+ Revision: 207235
696- Replace source1 with patch 6 (use up to date VBox.sh script)
697- Ensure VBoxAddIF/VBoxDeleteIF scripts are packaged, as well as VBoxTunctl (Mdv bug #40769)
698- package VBoxHeadless (Mdv bug #40771)
699
700* Fri May 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.0-1mdv2009.0
701+ Revision: 205313
702- try harder to disable additions on x86_64
703- buildrequire libxslt-devel
704- adapt to vboxadd-xclient being renamed as VBoxClient
705- rediff futex patch
706- rediff misc_register patch
707- 1.6.0
708- revert BUILT_MODULE_NAME addition, the bug is fixed in dkms
709
710  + Anssi Hannula <anssi@mandriva.org>
711    - add BUILT_MODULE_NAME to dkms.conf of vboxadd and vboxvfs (fixes DKMS
712      error)
713
714* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.6-1mdv2008.1
715+ Revision: 175619
716- 1.5.6
717- rediff KERNELRELEASE patch
718
719* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-5mdv2008.1
720+ Revision: 175610
721- try to start dkms instead of vboxadd in vboxadd-timesync service (since modules are loaded from modprobe.preload.d, #36728)
722
723* Fri Feb 08 2008 Thierry Vignaud <tvignaud@mandriva.com> 1.5.4-4mdv2008.1
724+ Revision: 163970
725- drop old menu
726
727  + Frederic Crozat <fcrozat@mandriva.com>
728    - Really disable pulseaudio support on 2008.0 or older
729
730* Thu Jan 10 2008 Frederic Crozat <fcrozat@mandriva.com> 1.5.4-3mdv2008.1
731+ Revision: 147602
732- Use correct version of x11 mouse and video additional driver when used on 2008.1 (xorg 1.4) and 2008.0
733- Only build pulseaudio support for 2008.1
734
735* Wed Jan 09 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-2mdv2008.1
736+ Revision: 147006
737- fix dkms build for kernels different from running kernel
738
739* Thu Jan 03 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-1mdv2008.1
740+ Revision: 142711
741- buildrequire pulseaudio-devel
742- rediff libpath patch
743- remove 2.6.24 build fix, fixed upstream
744- 1.5.4
745- restore BuildRoot
746
747  + Pascal Terjan <pterjan@mandriva.org>
748    - Switch to Debian patch for 2.6.24
749    - Re-create the 2.6.24 patch, some bits got lost
750
751  + Thierry Vignaud <tvignaud@mandriva.com>
752    - kill re-definition of %%buildroot on Pixel's request
753    - kill explicit icon extension
754
755  + Giuseppe Ghibò <ghibo@mandriva.com>
756    - Use kernel-source-latest in BuildRequires as conditional.
757    - Add conditional build flags for older release.
758    - Let Patch5 conditional.
759
760* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-3mdv2008.1
761+ Revision: 114076
762- Improve 2.6.24 patch so that it should still build with older kernels
763
764* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-2mdv2008.1
765+ Revision: 114047
766- Fix other parts to build with 2.6.24
767- Fix vboxdrv for 2.6.24
768
769* Tue Nov 13 2007 Olivier Blin <oblin@mandriva.com> 1.5.2-1mdv2008.1
770+ Revision: 108363
771- remove keyboards patch (was from upstream svn)
772- rediff kernelrelease patch
773- rediff libpath patch
774- 1.5.2
775
776* Thu Oct 04 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-6mdv2008.0
777+ Revision: 95447
778- really apply misc_register patch (so that vboxadd devices are automatically created)
779- add release in dkms PACKAGE_VERSION to ease upgrades
780
781* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-5mdv2008.0
782+ Revision: 93837
783- require kmod(vboxdrv) instead of dkms package
784- do not mark initscript as config file
785- move initscripts and udev rules out of dkms package (so that it works when using dkms prebuilt modules)
786
787* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-4mdv2008.0
788+ Revision: 93812
789- add vboxadd-timesync service
790- add pam_console perms file to assign vboxadd device to console user
791- use misc_register() to register vboxadd device so that /dev/vboxadd gets created automatically by udev
792
793* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-3mdv2008.0
794+ Revision: 93770
795- add vboxadd-xclient xinit.d script
796- release new additions, but we still need to fix mknod for vboxadd
797  (or use device_create() in kernel module), set console perms for
798  vboxadd in console.perms.d, and add timesync initscript
799- make guest additions package require X11 drivers
800- make x11 driver packages suggest virtualbox-guest-additions
801- add virtualbox-guest-additions package (with xclient, timesync, mount.vboxsf)
802- add dkms-vboxadd and dkms-vboxvfs packages
803
804* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-2mdv2008.0
805+ Revision: 93534
806- build additions on ix86 only
807- fix support for Brazilian, Belgian, US intl and US dvorak keyboards and add support for multimedia keys (from upstream SVN)
808- buildrequire libstdc++-static-devel
809- buildrequire libxt-devel
810- buildrequire kernel-source-latest, since iurt/urpmi don't install latest kernel-source automatically
811- buildrequire kernel-source
812- package mouse guest addition in x11-driver-input-vboxmouse
813- package video guest addition in x11-driver-video-vboxvideo
814- build VirtualBox additions
815
816* Mon Sep 03 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-1mdv2008.0
817+ Revision: 78607
818- drop libstdc++5 BuildRequires
819- drop unapplied x86_64 NMI watchdog disabling patch (merged upstream)
820- 1.5.0
821- rediff mdvconfig patch
822
823  + Thierry Vignaud <tvignaud@mandriva.com>
824    - kill desktop-file-validate's 'warning: key "Encoding" in group "Desktop Entry" is deprecated'
825
826* Fri Jun 08 2007 Per Øyvind Karlsen <peroyvind@mandriva.org> 1.4.0-1mdv2008.0
827+ Revision: 37085
828- from Jos?\195?\169 Melo <mmodem00@gmail.com>:
829        o 1.4.0
830        o update patch:2 since is needed to load (modprobe) vbox driver in kernel-2.6.17
831        o remove patch1 since is becomes obsolete with this new version,and continues installing and running stable no matter if is kernel-2.6.17 or greater
832        o add missing buildrequire hal-devel
833
834
835* Thu Mar 15 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.8-1mdv2007.1
836+ Revision: 144313
837- add should-start: dkms to initscript (#29523)
838- 1.3.8
839  * hard reset network device on reboot
840  * fix issues with IBM JVM 1.4.2 in Linux guests
841  * add support for X.org 7.2.x in Linux guest additions
842
843* Fri Mar 02 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.6-1mdv2007.1
844+ Revision: 131492
845- disable NMIs on Core 2 platforms too
846- 1.3.6
847  * fix some GUI issues
848  * fix OpenBSD 4.0 support
849  * fix CD/DVD-ROM detection in Windows Vista guests
850  * fix networking issues with Windows NT 4.0 guests
851  * fix some ALSA problems that could cause system reboots
852
853* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.4-1mdv2007.1
854+ Revision: 119895
855- 1.3.4
856
857* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070209-1mdv2007.1
858+ Revision: 119017
859- SVN updates (2007/02/09):
860  * additional 64-bit fixes
861  * asynchronous packets transmission in NIC code
862
863* Sat Feb 03 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070202-1mdv2007.1
864+ Revision: 116064
865- various 64-bit fixes
866- updates from SVN (2007/02/02):
867  * initial 64-bit host support
868  * fix IDE for Open Solaris 10
869  * add VDI compacting to the GUI
870
871* Sat Jan 27 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3-1mdv2007.1
872+ Revision: 114276
873- initial mandriva linux package
874
Note: See TracBrowser for help on using the repository browser.