source: projects/specs/trunk/V/VirtualBox/VirtualBox-vl.spec @ 2500

Revision 2500, 32.5 KB checked in by owa, 13 years ago (diff)

rebuilt with openssl-1.0.0c

Line 
1%define version 3.2.12
2%define release 3%{?_dist_release}
3
4%define kname   vboxdrv
5%define oname   VirtualBox
6%define srcname %{oname}-%{version}-OSE
7%define distname        %{oname}-%{version}_OSE
8%define dirname vbox-ose
9%define pkgver  %{version}
10
11%define vboxlibdir      %{_libdir}/%{name}
12%define vboxdatadir     %{_datadir}/%{name}
13
14%define build_additions 1
15
16%ifarch %{ix86}
17%define vbox_platform linux.x86
18%endif
19%ifarch x86_64
20%define vbox_platform linux.amd64
21%endif
22
23# nuke vbox-specific dependencies
24%define _provides_exceptions ^VBox
25%define _requires_exceptions ^VBox
26
27Summary:        A general-purpose full virtualizer for x86 hardware
28Summary(ja):    汎用の x86 ハードウエア完全仮想化ソフトウエア
29Name:           VirtualBox
30Version:        %{version}
31Release:        %{release}
32License:        GPL
33Group:          Development/Tools
34Url:            http://www.virtualbox.org/
35
36Source0:        http://download.virtualbox.org/virtualbox/%ver/%{srcname}.tar.bz2
37Source2:        virtualbox.init.vine
38Source3:        vboxadd-timesync.vine
39Source4:        60-vboxadd.perms
40Source10:       VirtualBox.png
41Patch2:         VirtualBox-1.5.6_OSE-kernelrelease.patch
42Patch4:         VirtualBox-1.6.0_OSE-futex.patch
43Patch5:         virtualbox-fix-vboxadd-req.patch
44# (fc) 1.6.0-2mdv fix initscript name in VBox.sh script
45Patch6:         VirtualBox-1.6.0_OSE-initscriptname.patch
46# (hk) fix build kernel-headers-2.6.29*
47Patch10:        VirtualBox-kernel-headers-2.6.29.patch
48# (fc) 2.2.0-1mdv disable update notification (Debian)
49Patch12:        16-no-update.patch
50
51# vine
52Patch100:       VirtualBox-2.2.2-buildfix.patch
53Patch110:       VirtualBox-3.2.4-vine.patch
54
55BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
56ExclusiveArch:  %{ix86} x86_64
57Requires:       dkms-%{name} = %{version}-%{release}
58BuildRequires:  dev86, iasl
59BuildRequires:  zlib-devel
60BuildRequires:  libXcursor-devel
61BuildRequires:  libXmu-devel
62BuildRequires:  SDL-devel
63BuildRequires:  qt4-devel
64BuildRequires:  libIDL-devel
65BuildRequires:  e2fsprogs-devel
66BuildRequires:  libxslt-devel
67BuildRequires:  xerces-c-devel, xalan-c-devel
68BuildRequires:  hal-devel
69BuildRequires:  libXt-devel
70BuildRequires:  libstdc++34-devel
71BuildRequires:  python-devel
72BuildRequires:  libcap-devel
73BuildRequires:  pulseaudio-libs-devel
74BuildRequires:  kernel-devel
75BuildRequires:  mesa-libGL-devel
76BuildRequires:  mesa-libGLU-devel
77BuildRequires:  gsoap-devel
78BuildRequires:  curl-devel
79BuildRequires:  alsa-lib-devel
80BuildRequires:  dkms
81BuildRequires:  kBuild >= 0.1.5p2
82BuildRequires:  yasm
83BuildRequires:  qt4-designer
84BuildRequires:  pam-devel
85%ifarch x86_64
86BuildRequires:  compat32-glibc-devel
87%endif
88
89%description
90VirtualBox Open Source Edition (OSE) is a general-purpose full
91virtualizer for x86 hardware.
92
93%description -l ja
94VirtualBox Open Source Edition (OSE) は汎用の x86 ハードウエア
95完全仮想化ソフトウエアです。
96
97%package -n     dkms-%{name}
98Summary:        VirtualBox OSE kernel module
99Summary(ja):    VirtualBox OSE カーネルモジュール
100Group:          System Environment/Kernel
101Requires(post):   dkms
102Requires(preun):  dkms
103
104%description -n dkms-%{name}
105Kernel support for VirtualBox OSE.
106
107%description -l ja -n dkms-%{name}
108VirtualBox OSE のカーネルサポートパッケージです。
109
110%if %{build_additions}
111%package        guest-additions
112Summary:        Additions for VirtualBox OSE guest systems
113Summary(ja):    VirtualBox OSE ゲストシステム用の追加モジュール
114Group:          System Environment/Kernel
115Requires:       dkms-vboxadd = %{version}-%{release}
116Requires:       dkms-vboxvfs = %{version}-%{release}
117Requires:       dkms-vboxvideo = %{version}-%{release}
118Requires:       xorg-x11-drv-vboxmouse
119Requires:       xorg-x11-drv-vboxvideo
120Requires:       xorg-x11-server-utils
121
122%description    guest-additions
123This packages contains additions for VirtualBox OSE guest systems.
124It allows to share files with the host system, copy/paste between
125guest and host, and sync time with host.
126
127%description -l ja guest-additions
128このパッケージには VirtualBox OSE ゲストシステムのための追加モジュール
129が含まれています。これを利用することでホストシステムとファイルを共有し
130たり、ゲスト/ホスト間でカット&ペーストを行ったり、ホストと時刻同期をし
131たりすることができます。
132
133%package -n     dkms-vboxadd
134Summary:        Kernel module for VirtualBox OSE additions
135Summary(ja):    VirtualBox OSE additions のカーネルモジュール
136Group:          System Environment/Kernel
137Requires(post):   dkms
138Requires(preun):  dkms
139Provides:       dkms-vboxvfs = %{version}-%{release}
140Obsoletes:      dkms-vboxvfs < %{version}-%{release}
141Provides:       dkms-vboxsf = %{version}-%{release}
142Obsoletes:      dkms-vboxsf < %{version}-%{release}
143Provides:       dkms-vboxvideo = %{version}-%{release}
144Obsoletes:      dkms-vboxvideo < %{version}-%{release}
145
146%description -n dkms-vboxadd
147Kernel module for VirtualBox OSE additions.
148
149%description -l ja -n dkms-vboxadd
150VirtualBox OSE 追加モジュールのためのカーネルモジュールです。
151
152%package -n     xorg-x11-drv-vboxmouse
153Summary:        X.org X11 input driver for VirtualBox mouse
154Summary:        X.org X11 VirtualBox マウス入力ドライバ
155Group:          User Interface/X Hardware Support
156Requires:       %{name}-guest-additions
157
158%description -n xorg-x11-drv-vboxmouse
159The X.org driver for mouse in VirtualBox guests
160
161%description -l ja -n xorg-x11-drv-vboxmouse
162VirtualBox のゲストシステム用の X.org マウスドライバです。
163
164%package -n     xorg-x11-drv-vboxvideo
165Summary:        X.org X11 video driver for VirtualBox guests
166Summary(ja):    X.org X11 VirtualBox ビデオドライバ
167Group:          User Interface/X Hardware Support
168Requires:       %{name}-guest-additions
169
170%description -n xorg-x11-drv-vboxvideo
171The X.org driver for video in VirtualBox guests
172
173%description -l ja -n xorg-x11-drv-vboxvideo
174VirtualBox のゲストシステム用の X.org ビデオドライバです。
175
176%endif
177
178%prep
179%setup -q -n %{distname}
180%patch2 -p1 -b .kernelrelease
181%patch4 -p1 -b .futex
182%patch5 -p1 -b .fix-timesync-req
183%patch6 -p1 -b .initscriptname
184%patch10 -p1 -b .kernel-headers-2.6.29
185%patch12 -p1 -b .disable-update
186%patch100 -p1 -b .buildfix
187%patch110 -p1 -b .vine
188
189# remove prebuilt binaries
190rm -rf kBuild tools
191
192cat << EOF > LocalConfig.kmk
193VBOX_PATH_APP_PRIVATE_ARCH:=%{vboxlibdir}
194VBOX_WITH_ORIGIN:=
195VBOX_WITH_RUNPATH:=%{vboxlibdir}
196VBOX_PATH_APP_PRIVATE:=%{vboxdatadir}
197VBOX_WITH_TESTCASES:=
198VBOX_WITH_TESTSUITE:=
199EOF
200
201%build
202./configure --disable-kmods --with-linux=$PWD/fake-linux
203
204%if !%{build_additions}
205sed -rie 's/(VBOX_WITH_LINUX_ADDITIONS\s+:=\s+).*/\1/' AutoConfig.kmk
206echo VBOX_WITHOUT_ADDITIONS=1 >> LocalConfig.kmk
207%endif
208
209. ./env.sh
210kmk KBUILD_VERBOSE=2 \
211    TOOL_YASM_AS=yasm \
212    VBOX_WITH_REGISTRATION_REQUEST= \
213    %{?_smp_mflags} all
214
215%install
216rm -rf %{buildroot}
217
218# install vbox components
219mkdir -p %{buildroot}%{vboxlibdir} %{buildroot}%{vboxdatadir}
220
221(cd out/%{vbox_platform}/release/bin && tar cf - --exclude=additions .) | \
222(cd %{buildroot}%{vboxlibdir} && tar xf -)
223
224# move noarch files to vboxdatadir
225mv %{buildroot}%{vboxlibdir}/{VBox*.sh,nls,*.desktop,*.png} %{buildroot}%{vboxdatadir}
226
227# install service
228mkdir -p %{buildroot}%{_initrddir}
229install -m755 %{SOURCE2} %{buildroot}%{_initrddir}/virtualbox
230
231# install wrappers
232mkdir -p %{buildroot}%{_sysconfdir}/vbox
233cat > %{buildroot}%{_sysconfdir}/vbox/vbox.cfg << EOF
234# VirtualBox installation directory
235INSTALL_DIR="%{vboxlibdir}"
236EOF
237mkdir -p %{buildroot}%{_bindir}
238ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/%{name}
239ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxManage
240ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxSDL
241ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxHeadless
242#ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/vboxwebsrv
243
244# provide network control tools in bindir
245ln -s %{vboxlibdir}/VBoxTunctl %{buildroot}%{_bindir}/VBoxTunctl
246ln -s %{vboxlibdir}/VBoxNetAdpCtl %{buildroot}%{_bindir}/VBoxNetAdpCtl
247ln -s %{vboxlibdir}/VBoxNetDHCP %{buildroot}%{_bindir}/VBoxNetDHCP
248
249install -d %{buildroot}/var/run/%{name}
250
251# install dkms sources
252mkdir -p %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
253cat > vboxbuild << EOF
254#!/bin/sh
255set -e
256make -C %{kname} KERN_DIR=\$1
257cp -f %{kname}/Module.symvers vboxnetflt
258cp -f %{kname}/Module.symvers vboxnetadp
259make -C vboxnetflt KERN_DIR=\$1
260make -C vboxnetadp KERN_DIR=\$1
261EOF
262install -m 0755 vboxbuild %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
263mv %{buildroot}%{vboxlibdir}/src/* %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
264cat > %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/dkms.conf << EOF
265MAKE[0]="./vboxbuild \$kernel_source_dir"
266PACKAGE_NAME=%{name}
267PACKAGE_VERSION=%{version}-%{release}
268DEST_MODULE_LOCATION[0]=/kernel/3rdparty/vbox
269BUILT_MODULE_LOCATION[0]=%{kname}/
270BUILT_MODULE_NAME[0]=%{kname}
271DEST_MODULE_LOCATION[1]=/kernel/3rdparty/vbox
272BUILT_MODULE_LOCATION[1]=vboxnetflt/
273BUILT_MODULE_NAME[1]=vboxnetflt
274DEST_MODULE_LOCATION[2]=/kernel/3rdparty/vbox
275BUILT_MODULE_LOCATION[2]=vboxnetadp/
276BUILT_MODULE_NAME[2]=vboxnetadp
277AUTOINSTALL=yes
278EOF
279
280# install udev rules
281mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d/
282cat > %{buildroot}%{_sysconfdir}/udev/rules.d/%{name}.rules << EOF
283KERNEL=="%{kname}", MODE="0666"
284EOF
285cat > %{buildroot}%{_sysconfdir}/udev/rules.d/vbox-additions.rules << EOF
286KERNEL=="vboxguest|vboxuser", ENV{ACL_MANAGE}="1"
287EOF
288
289# install additions
290%if %{build_additions}
291mkdir -p %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty
292#install -m755 src/VBox/Additions/linux/installer/vboxadd-service.sh %{buildroot}%{_initrddir}/vboxadd-timesync
293install -m755 %SOURCE3 %{buildroot}%{_initrddir}/vboxadd-timesync
294#install -m755 src/VBox/Additions/x11/Installer/VBoxRandR.sh %{buildroot}%{_bindir}/VBoxRandR
295install -m755 src/VBox/Additions/linux/installer/90-vboxguest.fdi %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
296mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d/
297install -m755 src/VBox/Additions/linux/installer/70-xorg-vboxmouse.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
298mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
299install -m755 src/VBox/Additions/x11/Installer/50-vboxmouse.conf %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
300
301install -d %{buildroot}%{_sysconfdir}/X11/xinit.d
302install -m755 src/VBox/Additions/x11/Installer/98vboxadd-xclient %{buildroot}%{_sysconfdir}/X11/xinit.d
303
304pushd out/%{vbox_platform}/release/bin/additions
305  install -d %{buildroot}/sbin %{buildroot}%{_sbindir} %{buildroot}/%{_libdir}/dri
306  install -m755 mount.vboxsf %{buildroot}/sbin/mount.vboxsf
307  install -m755 VBoxService %{buildroot}%{_sbindir}
308
309  install -d %{buildroot}%{_sysconfdir}/security/console.perms.d/
310  install -m644 %{SOURCE4} %{buildroot}%{_sysconfdir}/security/console.perms.d/
311
312  install -m755 VBoxClient %{buildroot}%{_bindir}
313  install -m755 VBoxControl %{buildroot}%{_bindir}
314
315  install -m755 VBoxOGL*.so %{buildroot}%{_libdir}
316  ln -s -f ../VBoxOGL.so %{buildroot}%{_libdir}/dri/vboxvideo_dri.so
317
318  install -d %{buildroot}%{_sysconfdir}/modprobe.preload.d
319  cat > %{buildroot}%{_sysconfdir}/modprobe.preload.d/vbox-guest-additions << EOF
320vboxadd
321EOF
322
323  install -d %{buildroot}%{_libdir}/xorg/modules/{input,drivers}
324  install vboxmouse_drv_17.so %{buildroot}%{_libdir}/xorg/modules/input/vboxmouse_drv.so
325  install vboxvideo_drv_17.so %{buildroot}%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
326
327  mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}
328  cat > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
329PACKAGE_NAME=vboxadditions
330PACKAGE_VERSION=%{version}-%{release}
331MAKE[0]="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxguest &&
332cp
333\$dkms_tree/\$module/\$module_version/build/vboxguest/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxsf &&
334make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxsf &&
335cp \$dkms_tree/\$module/\$module_version/build/vboxsf/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxvideo &&
336make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo"
337EOF
338
339  i=0
340  for kmod in vboxguest vboxsf vboxvideo; do
341    mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod
342    cp -a src/$kmod/* %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod/
343    cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
344DEST_MODULE_LOCATION[$i]=/kernel/3rdparty/vbox
345BUILT_MODULE_LOCATION[$i]=$kmod/
346BUILT_MODULE_NAME[$i]=$kmod
347EOF
348    i=$((i+1))
349  done
350  cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
351CLEAN="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxguest clean &&
352make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxsf clean &&
353make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo clean "
354AUTOINSTALL=yes
355EOF
356popd
357  sed 's/^\(.package.*-kernel-\)\(.*-latest\)\(.*\)\\$/\1\2\3Obsoletes: vboxsf-kernel-\2 vboxvideo-kernel-\2\\n\\/' /etc/dkms/template-dkms-mkrpm.spec > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/vboxadditions-dkms-mkrpm.spec
358%endif
359
360# install icons
361mkdir -p %{buildroot}%{_iconsdir}
362install -m644 %{SOURCE10} %{buildroot}%{_iconsdir}/
363
364# install menu entries
365
366mkdir -p %{buildroot}%{_datadir}/applications
367cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
368[Desktop Entry]
369Name=VirtualBox
370Comment=Full virtualizer for x86 hardware
371Comment[ja]=x86 ハードウエアの完全仮想化システム
372Exec=%{_bindir}/%{name}
373Icon=%{name}
374Type=Application
375Terminal=false
376Categories=System;Emulator;
377EOF
378
379# add missing makefile for kernel module
380install -m644 src/VBox/HostDrivers/Support/linux/Makefile %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
381
382# remove unpackaged files
383rm -rf %{buildroot}%{vboxlibdir}/{src,sdk,testcase}
384rm  -f %{buildroot}%{vboxlibdir}/tst*
385rm  -f %{buildroot}%{vboxlibdir}/vboxkeyboard.tar.gz
386rm  -f %{buildroot}%{vboxlibdir}/SUP*
387rm  -f %{buildroot}%{vboxlibdir}/xpidl
388
389%clean
390rm -rf %{buildroot}
391
392%post
393/sbin/chkconfig --add virtualbox
394
395%postun
396if [ "$1" -ge "1" ]; then
397  /sbin/service virtualbox condrestart > /dev/null 2>&1 || :
398fi
399
400%preun
401if [ $1 = 0 ]; then
402    service virtualbox stop > /dev/null 2>&1 ||:
403    /sbin/chkconfig --del virtualbox
404fi
405       
406
407%post -n dkms-%{name}
408set -x
409/usr/sbin/dkms --rpm_safe_upgrade add -m %{name} -v %{version}-%{release} ||:
410/usr/sbin/dkms --rpm_safe_upgrade build -m %{name} -v %{version}-%{release} ||:
411/usr/sbin/dkms --rpm_safe_upgrade install -m %{name} -v %{version}-%{release} --force ||:
412/sbin/modprobe %{kname} >/dev/null 2>&1 || :
413/sbin/modprobe vboxnetflt >/dev/null 2>&1 || :
414
415%preun -n dkms-%{name}
416# rmmod can fail
417/sbin/rmmod vboxnetflt >/dev/null 2>&1
418/sbin/rmmod %{kname} >/dev/null 2>&1
419set -x
420/usr/sbin/dkms --rpm_safe_upgrade remove -m %{name} -v %{version}-%{release} --all || :
421
422%if %{build_additions}
423%post guest-additions
424/sbin/chkconfig --add vboxadd-timesync
425
426%postun guest-additions
427if [ "$1" -ge "1" ]; then
428  /sbin/service vboxadd-timesync condrestart > /dev/null 2>&1 || :
429fi
430
431%preun guest-additions
432if [ $1 = 0 ]; then
433    service vboxadd-timesync stop > /dev/null 2>&1 ||:
434    /sbin/chkconfig --del vboxadd-timesync
435fi
436
437%post -n dkms-vboxadd
438set -x
439/usr/sbin/dkms --rpm_safe_upgrade add -m vboxadditions -v %{version}-%{release} ||:
440/usr/sbin/dkms --rpm_safe_upgrade build -m vboxadditions -v %{version}-%{release} ||:
441/usr/sbin/dkms --rpm_safe_upgrade install -m vboxadditions -v %{version}-%{release} ||:
442:
443
444%preun -n dkms-vboxadd
445set -x
446/usr/sbin/dkms --rpm_safe_upgrade remove -m vboxadditions -v %{version}-%{release} --all ||:
447:
448
449%endif
450
451%files
452%defattr(-,root,root)
453%config %{_sysconfdir}/vbox/vbox.cfg
454%{_bindir}/%{name}
455%{_bindir}/VBoxManage
456%{_bindir}/VBoxSDL
457%{_bindir}/VBoxHeadless
458%{_bindir}/VBoxTunctl
459%{_bindir}/VBoxNetAdpCtl
460%{_bindir}/VBoxNetDHCP
461#%{_bindir}/vboxwebsrv
462%{vboxlibdir}
463%attr(4711,root,root) %{vboxlibdir}/VBoxHeadless
464%attr(4711,root,root) %{vboxlibdir}/VBoxSDL
465%attr(4711,root,root) %{vboxlibdir}/%{name}
466%attr(4711,root,root) %{vboxlibdir}/VBoxNetAdpCtl
467%attr(4711,root,root) %{vboxlibdir}/VBoxNetDHCP
468%attr(644,root,root) %{vboxlibdir}/*.gc
469%attr(644,root,root) %{vboxlibdir}/*.r0
470%{vboxdatadir}
471# initscripts integration
472%{_initrddir}/virtualbox
473%config %{_sysconfdir}/udev/rules.d/%{name}.rules
474%dir /var/run/%{name}
475# desktop integration
476%{_iconsdir}/*.png
477%{_datadir}/applications/%{name}.desktop
478
479%files -n dkms-%{name}
480%defattr(-,root,root)
481%{_usr}/src/%{name}-%{version}-%{release}
482
483%if %{build_additions}
484%files guest-additions
485%defattr(-,root,root)
486/sbin/mount.vboxsf
487%{_initrddir}/vboxadd-timesync
488%{_sbindir}/VBoxService
489%{_bindir}/VBoxClient
490%{_bindir}/VBoxControl
491%{_sysconfdir}/security/console.perms.d/60-vboxadd.perms
492%{_sysconfdir}/udev/rules.d/vbox-additions.rules
493%{_sysconfdir}/X11/xinit.d/98vboxadd-xclient
494%{_sysconfdir}/modprobe.preload.d/vbox-guest-additions
495
496%files -n xorg-x11-drv-vboxmouse
497%defattr(-,root,root)
498%{_libdir}/xorg/modules/input/vboxmouse_drv.so
499%{_sysconfdir}/X11/xorg.conf.d/*.conf
500%{_sysconfdir}/udev/rules.d/*.rules
501%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
502
503%files -n xorg-x11-drv-vboxvideo
504%defattr(-,root,root)
505%{_libdir}/VBoxOGL*
506%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
507%{_libdir}/dri/vboxvideo_dri.so
508
509%files -n dkms-vboxadd
510%defattr(-,root,root)
511%{_usr}/src/vbox*-%{version}-%{release}
512
513%endif
514
515
516%changelog
517* Fri Jan 14 2011 Shu KONNO <owa@bg.wakwak.com> 3.2.12-3
518- rebuilt with openssl-1.0.0c
519- added vboxadd-timesync.vine instead of vboxadd-service.sh
520
521* Sat Dec 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-2
522- add BR: pam-devel
523- rebuild with python-2.6
524
525* Fri Dec 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.12-1
526- updated VirtualBox to 3.2.12-OSE
527
528* Mon Aug 23 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.8-1
529- new upstream release
530
531* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-2
532- add patch110 to fix vboxadd-timesync script
533
534* Thu Jun 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
535- new upstream release
536
537* Sat May 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.0-1
538- new upstream release
539- drop wined3d patch as the Windows guest additions provide
540  Direct3D acceleration.
541- add xorg.conf snippet for new xserver
542- vboxvfs renamed to vboxsf
543
544* Mon Apr 19 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.6-2
545- fix initscript
546
547* Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.6-1
548- new upstream release
549
550* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.10-1
551- new upstream release
552- add missing BR:
553
554* Mon Sep 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.6-1
555- new upstream release
556
557* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.4-1
558- new upstream release
559- add translated summaries and descriptions
560
561* Mon Jul 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-1
562- new upstream release
563
564* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
565- new upstream release
566
567* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-3
568- change Group: of dkms-VirtualBox to System Environment/Kernel
569
570* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-2
571- remove modprobe.d/vbox-guest-additions
572
573* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-1
574- update to 2.2.4
575
576* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-1
577- initial build for Vine Linux
578- update to 2.2.2
579
580* Wed Apr 22 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-4mdv2009.1
581+ Revision: 368679
582- Fix mkrpm template
583
584* Tue Apr 21 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-3mdv2009.1
585+ Revision: 368502
586- BuildRequires:dkms-minimal
587- Obsolete -latest dkms binary packages
588
589* Wed Apr 15 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-2mdv2009.1
590+ Revision: 367571
591- Patch15: kill vboxclient if leftover from previous X11 session
592- Patch14 (Sun): fix OpenGL support for Linux Guest additions
593- improve packaging to be more LSB compliant
594
595* Fri Apr 10 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-1mdv2009.1
596+ Revision: 365828
597- Release 2.2.0
598- enable OpenGL pass-through. Caveat : Linux guest support is not working when building guest additions with Open source edition (under investigation)
599- move location of fdi file (fix mouse integration support when using HAL)
600- merge all guest additions kernel module in one single DKMS (pterjan)
601- Enable webservice
602- Remove patch9, no longer needed (when using kernel 2.6.29.x, you MUST use kernel 2.6.29.1 or later)
603- Regenerate patches 8, 10
604- Patch11: add Wine Direct3D guest additions option (Debian)
605- Patch12: disable update notification (Debian)
606- Patch13: make network settings more intuitive (Debian)
607- Add missing dependencies in guest additions package
608- No longer use gcc 4.2, build fine with latest gcc 4.3
609- Replace source3 with upstream version
610- Update source4 to change permissions on both guest additions devices
611- Fix permissions on non .so files
612
613* Mon Mar 09 2009 Pascal Terjan <pterjan@mandriva.org> 2.1.4-5mdv2009.1
614+ Revision: 353280
615- vboxvfs needs vboxadd
616
617* Wed Mar 04 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.4-4mdv2009.1
618+ Revision: 348336
619- Force rebuild of dkms modules
620
621* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-3mdv2009.1
622+ Revision: 344966
623- Copy Module.symvers for vboxnetflt dkms build, needed with
624  CONFIG_MODVERSIONS enabled in latest cooker kernels.
625
626* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-2mdv2009.1
627+ Revision: 344896
628- Apply fix for VM load failure with kernels 2.6.29-rc5 or later
629  (#48096, http://www.virtualbox.org/ticket/3403).
630- Fix building with kernel-headers-2.6.29*
631
632* Tue Feb 17 2009 Frederik Himpe <fhimpe@mandriva.org> 2.1.4-1mdv2009.1
633+ Revision: 342236
634- Update to new version 2.1.4
635- Fix source URL
636
637* Thu Jan 22 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.2-2mdv2009.1
638+ Revision: 332593
639- Use xorg 1.6 drivers when building cooker guest addition packages
640
641* Thu Jan 22 2009 Funda Wang <fundawang@mandriva.org> 2.1.2-1mdv2009.1
642+ Revision: 332404
643- specify CC4.2
644- New version 2.1.2
645- rediff libpath patch
646
647* Sun Jan 04 2009 Colin Guthrie <cguthrie@mandriva.org> 2.1.0-5mdv2009.1
648+ Revision: 324525
649- Rebuild mouse and display drivers for xserver 1.6
650
651* Thu Dec 25 2008 Michael Scherer <misc@mandriva.org> 2.1.0-4mdv2009.1
652+ Revision: 318540
653- rebuild for new python
654
655* Fri Dec 19 2008 Frederic Crozat <fcrozat@mandriva.com> 2.1.0-3mdv2009.1
656+ Revision: 316288
657- Fix guest additions for cooker, we ship Xorg 1.5 now
658- Ship fdi file for vboxmouse
659
660* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-2mdv2009.1
661+ Revision: 316021
662- oops, finish fixing up initscript
663
664* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-1mdv2009.1
665+ Revision: 316019
666- adjust initscript and dkms.conf for the fact that there's now two necessary
667  kernel modules for the master: vboxdrv and vboxnetflt
668- drop mdvconfig.patch: this stub does nothing useful, and breaks the build
669  (see fcrozat's mail on Cooker)
670- VBoxAddIF and VBoxDeleteIF are now obsolete and not provided
671
672  + Frederic Crozat <fcrozat@mandriva.com>
673    - Release 2.1.0
674    - Regenerate patch1
675    - update buildrequires
676
677* Sun Nov 30 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.6-2mdv2009.1
678+ Revision: 308552
679- Rebuild mouse and display drivers for xserver 1.5
680
681* Wed Nov 26 2008 Funda Wang <fundawang@mandriva.org> 2.0.6-1mdv2009.1
682+ Revision: 306865
683- New version 2.0.6
684
685* Mon Nov 03 2008 Funda Wang <fundawang@mandriva.org> 2.0.4-1mdv2009.1
686+ Revision: 299348
687- New version 2.0.4
688
689* Mon Sep 15 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.2-2mdv2009.0
690+ Revision: 284854
691- Patch8: disable version check at startup
692
693* Sat Sep 13 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.2-1mdv2009.0
694+ Revision: 284544
695- Update to bugfix update 2.0.2
696
697* Tue Sep 09 2008 Olivier Blin <oblin@mandriva.com> 2.0.0-3mdv2009.0
698+ Revision: 283015
699- build guest additions on x86_64 too (#43593)
700
701  + Frederic Crozat <fcrozat@mandriva.com>
702    - Patch7: fix QT4 detection on x86-64 on Mandriva 2008.1
703
704* Thu Sep 04 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.0-1mdv2009.0
705+ Revision: 280850
706- Fix BuildRequires
707- Release 2.0.0
708- Remove patches 3, 7 (merged upstream)
709
710* Mon Sep 01 2008 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 1.6.4-4mdv2009.0
711+ Revision: 278071
712- Added patch to allow VirtualBox kernel module to build with
713  Linux 2.6.27
714
715  + Pixel <pixel@mandriva.com>
716    - increase release number
717    - use gcc4.2 to build the recompiler (not ported to gcc 4.3 yet)
718
719* Wed Aug 06 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-2mdv2009.0
720+ Revision: 264273
721- create /var/run/VirtualBox (#41963)
722- use tunctl from the tunctl package while VBoxTunctl does not build
723
724* Tue Aug 05 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-1mdv2009.0
725+ Revision: 264016
726- do not include VBoxTunctl for now (build is broken in upstream tarball)
727- rediff misc_register patch (the register part has been implemented upstream, I should submit the deregister hunks)
728- fix 1.6.4 build by not building tunctl (some Makefile.kmk are missing)
729- 1.6.4
730
731* Tue Jul 29 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.2-2mdv2009.0
732+ Revision: 252777
733- Don't use gcc 3.3 for build on 2008.1 or earlier
734
735* Wed Jul 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.2-1mdv2009.0
736+ Revision: 232889
737- set again linux sources path in configure
738- use gcc 3.3 to build the recompiler (not ported to gcc 4.3 yet)
739- use kernel-devel-latest instead of kernel-source-latest
740- use a prepared copy of the linux tree (for linux/bounds.h)
741
742  + Frederic Crozat <fcrozat@mandriva.com>
743    - Release 1.6.2
744    - Regenerate patch5
745    - Fix duplicated line in specfile
746
747  + Pixel <pixel@mandriva.com>
748    - rpm filetriggers deprecates update_menus/update_scrollkeeper/update_mime_database/update_icon_cache/update_desktop_database/post_install_gconf_schemas
749
750* Fri May 16 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-4mdv2009.0
751+ Revision: 208160
752- Fix seamless mode in guest additions subpackage
753
754* Thu May 15 2008 Anssi Hannula <anssi@mandriva.org> 1.6.0-3mdv2009.0
755+ Revision: 207692
756- rename VBoxAddIF.sh and VBoxDeleteIF.sh to VBoxAddIF and VBoxDeleteIF
757  to match original names and documentation
758
759* Wed May 14 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-2mdv2009.0
760+ Revision: 207235
761- Replace source1 with patch 6 (use up to date VBox.sh script)
762- Ensure VBoxAddIF/VBoxDeleteIF scripts are packaged, as well as VBoxTunctl (Mdv bug #40769)
763- package VBoxHeadless (Mdv bug #40771)
764
765* Fri May 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.0-1mdv2009.0
766+ Revision: 205313
767- try harder to disable additions on x86_64
768- buildrequire libxslt-devel
769- adapt to vboxadd-xclient being renamed as VBoxClient
770- rediff futex patch
771- rediff misc_register patch
772- 1.6.0
773- revert BUILT_MODULE_NAME addition, the bug is fixed in dkms
774
775  + Anssi Hannula <anssi@mandriva.org>
776    - add BUILT_MODULE_NAME to dkms.conf of vboxadd and vboxvfs (fixes DKMS
777      error)
778
779* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.6-1mdv2008.1
780+ Revision: 175619
781- 1.5.6
782- rediff KERNELRELEASE patch
783
784* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-5mdv2008.1
785+ Revision: 175610
786- try to start dkms instead of vboxadd in vboxadd-timesync service (since modules are loaded from modprobe.preload.d, #36728)
787
788* Fri Feb 08 2008 Thierry Vignaud <tvignaud@mandriva.com> 1.5.4-4mdv2008.1
789+ Revision: 163970
790- drop old menu
791
792  + Frederic Crozat <fcrozat@mandriva.com>
793    - Really disable pulseaudio support on 2008.0 or older
794
795* Thu Jan 10 2008 Frederic Crozat <fcrozat@mandriva.com> 1.5.4-3mdv2008.1
796+ Revision: 147602
797- Use correct version of x11 mouse and video additional driver when used on 2008.1 (xorg 1.4) and 2008.0
798- Only build pulseaudio support for 2008.1
799
800* Wed Jan 09 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-2mdv2008.1
801+ Revision: 147006
802- fix dkms build for kernels different from running kernel
803
804* Thu Jan 03 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-1mdv2008.1
805+ Revision: 142711
806- buildrequire pulseaudio-devel
807- rediff libpath patch
808- remove 2.6.24 build fix, fixed upstream
809- 1.5.4
810- restore BuildRoot
811
812  + Pascal Terjan <pterjan@mandriva.org>
813    - Switch to Debian patch for 2.6.24
814    - Re-create the 2.6.24 patch, some bits got lost
815
816  + Thierry Vignaud <tvignaud@mandriva.com>
817    - kill re-definition of %%buildroot on Pixel's request
818    - kill explicit icon extension
819
820  + Giuseppe Ghibò <ghibo@mandriva.com>
821    - Use kernel-source-latest in BuildRequires as conditional.
822    - Add conditional build flags for older release.
823    - Let Patch5 conditional.
824
825* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-3mdv2008.1
826+ Revision: 114076
827- Improve 2.6.24 patch so that it should still build with older kernels
828
829* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-2mdv2008.1
830+ Revision: 114047
831- Fix other parts to build with 2.6.24
832- Fix vboxdrv for 2.6.24
833
834* Tue Nov 13 2007 Olivier Blin <oblin@mandriva.com> 1.5.2-1mdv2008.1
835+ Revision: 108363
836- remove keyboards patch (was from upstream svn)
837- rediff kernelrelease patch
838- rediff libpath patch
839- 1.5.2
840
841* Thu Oct 04 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-6mdv2008.0
842+ Revision: 95447
843- really apply misc_register patch (so that vboxadd devices are automatically created)
844- add release in dkms PACKAGE_VERSION to ease upgrades
845
846* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-5mdv2008.0
847+ Revision: 93837
848- require kmod(vboxdrv) instead of dkms package
849- do not mark initscript as config file
850- move initscripts and udev rules out of dkms package (so that it works when using dkms prebuilt modules)
851
852* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-4mdv2008.0
853+ Revision: 93812
854- add vboxadd-timesync service
855- add pam_console perms file to assign vboxadd device to console user
856- use misc_register() to register vboxadd device so that /dev/vboxadd gets created automatically by udev
857
858* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-3mdv2008.0
859+ Revision: 93770
860- add vboxadd-xclient xinit.d script
861- release new additions, but we still need to fix mknod for vboxadd
862  (or use device_create() in kernel module), set console perms for
863  vboxadd in console.perms.d, and add timesync initscript
864- make guest additions package require X11 drivers
865- make x11 driver packages suggest virtualbox-guest-additions
866- add virtualbox-guest-additions package (with xclient, timesync, mount.vboxsf)
867- add dkms-vboxadd and dkms-vboxvfs packages
868
869* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-2mdv2008.0
870+ Revision: 93534
871- build additions on ix86 only
872- fix support for Brazilian, Belgian, US intl and US dvorak keyboards and add support for multimedia keys (from upstream SVN)
873- buildrequire libstdc++-static-devel
874- buildrequire libxt-devel
875- buildrequire kernel-source-latest, since iurt/urpmi don't install latest kernel-source automatically
876- buildrequire kernel-source
877- package mouse guest addition in x11-driver-input-vboxmouse
878- package video guest addition in x11-driver-video-vboxvideo
879- build VirtualBox additions
880
881* Mon Sep 03 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-1mdv2008.0
882+ Revision: 78607
883- drop libstdc++5 BuildRequires
884- drop unapplied x86_64 NMI watchdog disabling patch (merged upstream)
885- 1.5.0
886- rediff mdvconfig patch
887
888  + Thierry Vignaud <tvignaud@mandriva.com>
889    - kill desktop-file-validate's 'warning: key "Encoding" in group "Desktop Entry" is deprecated'
890
891* Fri Jun 08 2007 Per Øyvind Karlsen <peroyvind@mandriva.org> 1.4.0-1mdv2008.0
892+ Revision: 37085
893- from Jos?\195?\169 Melo <mmodem00@gmail.com>:
894        o 1.4.0
895        o update patch:2 since is needed to load (modprobe) vbox driver in kernel-2.6.17
896        o remove patch1 since is becomes obsolete with this new version,and continues installing and running stable no matter if is kernel-2.6.17 or greater
897        o add missing buildrequire hal-devel
898
899
900* Thu Mar 15 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.8-1mdv2007.1
901+ Revision: 144313
902- add should-start: dkms to initscript (#29523)
903- 1.3.8
904  * hard reset network device on reboot
905  * fix issues with IBM JVM 1.4.2 in Linux guests
906  * add support for X.org 7.2.x in Linux guest additions
907
908* Fri Mar 02 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.6-1mdv2007.1
909+ Revision: 131492
910- disable NMIs on Core 2 platforms too
911- 1.3.6
912  * fix some GUI issues
913  * fix OpenBSD 4.0 support
914  * fix CD/DVD-ROM detection in Windows Vista guests
915  * fix networking issues with Windows NT 4.0 guests
916  * fix some ALSA problems that could cause system reboots
917
918* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.4-1mdv2007.1
919+ Revision: 119895
920- 1.3.4
921
922* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070209-1mdv2007.1
923+ Revision: 119017
924- SVN updates (2007/02/09):
925  * additional 64-bit fixes
926  * asynchronous packets transmission in NIC code
927
928* Sat Feb 03 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070202-1mdv2007.1
929+ Revision: 116064
930- various 64-bit fixes
931- updates from SVN (2007/02/02):
932  * initial 64-bit host support
933  * fix IDE for Open Solaris 10
934  * add VDI compacting to the GUI
935
936* Sat Jan 27 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3-1mdv2007.1
937+ Revision: 114276
938- initial mandriva linux package
939
Note: See TracBrowser for help on using the repository browser.