source: projects/specs/trunk/V/VirtualBox/VirtualBox-vl.spec @ 2276

Revision 2276, 32.2 KB checked in by daisuke, 14 years ago (diff)

VirtualBox?: add BR: pam-devel, build with python-2.6

Line 
1%define version 3.2.12
2%define release 2%{?_dist_release}
3
4%define kname   vboxdrv
5%define oname   VirtualBox
6%define srcname %{oname}-%{version}-OSE
7%define distname        %{oname}-%{version}_OSE
8%define dirname vbox-ose
9%define pkgver  %{version}
10
11%define vboxlibdir      %{_libdir}/%{name}
12%define vboxdatadir     %{_datadir}/%{name}
13
14%define build_additions 1
15
16%ifarch %{ix86}
17%define vbox_platform linux.x86
18%endif
19%ifarch x86_64
20%define vbox_platform linux.amd64
21%endif
22
23# nuke vbox-specific dependencies
24%define _provides_exceptions ^VBox
25%define _requires_exceptions ^VBox
26
27Summary:        A general-purpose full virtualizer for x86 hardware
28Summary(ja):    汎用の x86 ハードウエア完全仮想化ソフトウエア
29Name:           VirtualBox
30Version:        %{version}
31Release:        %{release}
32License:        GPL
33Group:          Development/Tools
34Url:            http://www.virtualbox.org/
35
36Source0:        http://download.virtualbox.org/virtualbox/%ver/%{srcname}.tar.bz2
37Source2:        virtualbox.init.vine
38Source4:        60-vboxadd.perms
39Source10:       VirtualBox.png
40Patch2:         VirtualBox-1.5.6_OSE-kernelrelease.patch
41Patch4:         VirtualBox-1.6.0_OSE-futex.patch
42Patch5:         virtualbox-fix-vboxadd-req.patch
43# (fc) 1.6.0-2mdv fix initscript name in VBox.sh script
44Patch6:         VirtualBox-1.6.0_OSE-initscriptname.patch
45# (hk) fix build kernel-headers-2.6.29*
46Patch10:        VirtualBox-kernel-headers-2.6.29.patch
47# (fc) 2.2.0-1mdv disable update notification (Debian)
48Patch12:        16-no-update.patch
49
50# vine
51Patch100:       VirtualBox-2.2.2-buildfix.patch
52Patch110:       VirtualBox-3.2.4-vine.patch
53
54BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
55ExclusiveArch:  %{ix86} x86_64
56Requires:       dkms-%{name} = %{version}-%{release}
57BuildRequires:  dev86, iasl
58BuildRequires:  zlib-devel
59BuildRequires:  libXcursor-devel
60BuildRequires:  libXmu-devel
61BuildRequires:  SDL-devel
62BuildRequires:  qt4-devel
63BuildRequires:  libIDL-devel
64BuildRequires:  e2fsprogs-devel
65BuildRequires:  libxslt-devel
66BuildRequires:  xerces-c-devel, xalan-c-devel
67BuildRequires:  hal-devel
68BuildRequires:  libXt-devel
69BuildRequires:  libstdc++34-devel
70BuildRequires:  python-devel
71BuildRequires:  libcap-devel
72BuildRequires:  pulseaudio-libs-devel
73BuildRequires:  kernel-devel
74BuildRequires:  mesa-libGL-devel
75BuildRequires:  mesa-libGLU-devel
76BuildRequires:  gsoap-devel
77BuildRequires:  curl-devel
78BuildRequires:  alsa-lib-devel
79BuildRequires:  dkms
80BuildRequires:  kBuild >= 0.1.5p2
81BuildRequires:  yasm
82BuildRequires:  qt4-designer
83BuildRequires:  pam-devel
84%ifarch x86_64
85BuildRequires:  compat32-glibc-devel
86%endif
87
88%description
89VirtualBox Open Source Edition (OSE) is a general-purpose full
90virtualizer for x86 hardware.
91
92%description -l ja
93VirtualBox Open Source Edition (OSE) は汎用の x86 ハードウエア
94完全仮想化ソフトウエアです。
95
96%package -n     dkms-%{name}
97Summary:        VirtualBox OSE kernel module
98Summary(ja):    VirtualBox OSE カーネルモジュール
99Group:          System Environment/Kernel
100Requires(post):   dkms
101Requires(preun):  dkms
102
103%description -n dkms-%{name}
104Kernel support for VirtualBox OSE.
105
106%description -l ja -n dkms-%{name}
107VirtualBox OSE のカーネルサポートパッケージです。
108
109%if %{build_additions}
110%package        guest-additions
111Summary:        Additions for VirtualBox OSE guest systems
112Summary(ja):    VirtualBox OSE ゲストシステム用の追加モジュール
113Group:          System Environment/Kernel
114Requires:       dkms-vboxadd = %{version}-%{release}
115Requires:       dkms-vboxvfs = %{version}-%{release}
116Requires:       dkms-vboxvideo = %{version}-%{release}
117Requires:       xorg-x11-drv-vboxmouse
118Requires:       xorg-x11-drv-vboxvideo
119Requires:       xorg-x11-server-utils
120
121%description    guest-additions
122This packages contains additions for VirtualBox OSE guest systems.
123It allows to share files with the host system, copy/paste between
124guest and host, and sync time with host.
125
126%description -l ja guest-additions
127このパッケージには VirtualBox OSE ゲストシステムのための追加モジュール
128が含まれています。これを利用することでホストシステムとファイルを共有し
129たり、ゲスト/ホスト間でカット&ペーストを行ったり、ホストと時刻同期をし
130たりすることができます。
131
132%package -n     dkms-vboxadd
133Summary:        Kernel module for VirtualBox OSE additions
134Summary(ja):    VirtualBox OSE additions のカーネルモジュール
135Group:          System Environment/Kernel
136Requires(post):   dkms
137Requires(preun):  dkms
138Provides:       dkms-vboxvfs = %{version}-%{release}
139Obsoletes:      dkms-vboxvfs < %{version}-%{release}
140Provides:       dkms-vboxsf = %{version}-%{release}
141Obsoletes:      dkms-vboxsf < %{version}-%{release}
142Provides:       dkms-vboxvideo = %{version}-%{release}
143Obsoletes:      dkms-vboxvideo < %{version}-%{release}
144
145%description -n dkms-vboxadd
146Kernel module for VirtualBox OSE additions.
147
148%description -l ja -n dkms-vboxadd
149VirtualBox OSE 追加モジュールのためのカーネルモジュールです。
150
151%package -n     xorg-x11-drv-vboxmouse
152Summary:        X.org X11 input driver for VirtualBox mouse
153Summary:        X.org X11 VirtualBox マウス入力ドライバ
154Group:          User Interface/X Hardware Support
155Requires:       %{name}-guest-additions
156
157%description -n xorg-x11-drv-vboxmouse
158The X.org driver for mouse in VirtualBox guests
159
160%description -l ja -n xorg-x11-drv-vboxmouse
161VirtualBox のゲストシステム用の X.org マウスドライバです。
162
163%package -n     xorg-x11-drv-vboxvideo
164Summary:        X.org X11 video driver for VirtualBox guests
165Summary(ja):    X.org X11 VirtualBox ビデオドライバ
166Group:          User Interface/X Hardware Support
167Requires:       %{name}-guest-additions
168
169%description -n xorg-x11-drv-vboxvideo
170The X.org driver for video in VirtualBox guests
171
172%description -l ja -n xorg-x11-drv-vboxvideo
173VirtualBox のゲストシステム用の X.org ビデオドライバです。
174
175%endif
176
177%prep
178%setup -q -n %{distname}
179%patch2 -p1 -b .kernelrelease
180%patch4 -p1 -b .futex
181%patch5 -p1 -b .fix-timesync-req
182%patch6 -p1 -b .initscriptname
183%patch10 -p1 -b .kernel-headers-2.6.29
184%patch12 -p1 -b .disable-update
185%patch100 -p1 -b .buildfix
186%patch110 -p1 -b .vine
187
188# remove prebuilt binaries
189rm -rf kBuild tools
190
191cat << EOF > LocalConfig.kmk
192VBOX_PATH_APP_PRIVATE_ARCH:=%{vboxlibdir}
193VBOX_WITH_ORIGIN:=
194VBOX_WITH_RUNPATH:=%{vboxlibdir}
195VBOX_PATH_APP_PRIVATE:=%{vboxdatadir}
196VBOX_WITH_TESTCASES:=
197VBOX_WITH_TESTSUITE:=
198EOF
199
200%build
201./configure --disable-kmods --with-linux=$PWD/fake-linux
202
203%if !%{build_additions}
204sed -rie 's/(VBOX_WITH_LINUX_ADDITIONS\s+:=\s+).*/\1/' AutoConfig.kmk
205echo VBOX_WITHOUT_ADDITIONS=1 >> LocalConfig.kmk
206%endif
207
208. ./env.sh
209kmk KBUILD_VERBOSE=2 \
210    TOOL_YASM_AS=yasm \
211    VBOX_WITH_REGISTRATION_REQUEST= \
212    %{?_smp_mflags} all
213
214%install
215rm -rf %{buildroot}
216
217# install vbox components
218mkdir -p %{buildroot}%{vboxlibdir} %{buildroot}%{vboxdatadir}
219
220(cd out/%{vbox_platform}/release/bin && tar cf - --exclude=additions .) | \
221(cd %{buildroot}%{vboxlibdir} && tar xf -)
222
223# move noarch files to vboxdatadir
224mv %{buildroot}%{vboxlibdir}/{VBox*.sh,nls,*.desktop,*.png} %{buildroot}%{vboxdatadir}
225
226# install service
227mkdir -p %{buildroot}%{_initrddir}
228install -m755 %{SOURCE2} %{buildroot}%{_initrddir}/virtualbox
229
230# install wrappers
231mkdir -p %{buildroot}%{_sysconfdir}/vbox
232cat > %{buildroot}%{_sysconfdir}/vbox/vbox.cfg << EOF
233# VirtualBox installation directory
234INSTALL_DIR="%{vboxlibdir}"
235EOF
236mkdir -p %{buildroot}%{_bindir}
237ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/%{name}
238ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxManage
239ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxSDL
240ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxHeadless
241#ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/vboxwebsrv
242
243# provide network control tools in bindir
244ln -s %{vboxlibdir}/VBoxTunctl %{buildroot}%{_bindir}/VBoxTunctl
245ln -s %{vboxlibdir}/VBoxNetAdpCtl %{buildroot}%{_bindir}/VBoxNetAdpCtl
246ln -s %{vboxlibdir}/VBoxNetDHCP %{buildroot}%{_bindir}/VBoxNetDHCP
247
248install -d %{buildroot}/var/run/%{name}
249
250# install dkms sources
251mkdir -p %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
252cat > vboxbuild << EOF
253#!/bin/sh
254set -e
255make -C %{kname} KERN_DIR=\$1
256cp -f %{kname}/Module.symvers vboxnetflt
257cp -f %{kname}/Module.symvers vboxnetadp
258make -C vboxnetflt KERN_DIR=\$1
259make -C vboxnetadp KERN_DIR=\$1
260EOF
261install -m 0755 vboxbuild %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
262mv %{buildroot}%{vboxlibdir}/src/* %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
263cat > %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/dkms.conf << EOF
264MAKE[0]="./vboxbuild \$kernel_source_dir"
265PACKAGE_NAME=%{name}
266PACKAGE_VERSION=%{version}-%{release}
267DEST_MODULE_LOCATION[0]=/kernel/3rdparty/vbox
268BUILT_MODULE_LOCATION[0]=%{kname}/
269BUILT_MODULE_NAME[0]=%{kname}
270DEST_MODULE_LOCATION[1]=/kernel/3rdparty/vbox
271BUILT_MODULE_LOCATION[1]=vboxnetflt/
272BUILT_MODULE_NAME[1]=vboxnetflt
273DEST_MODULE_LOCATION[2]=/kernel/3rdparty/vbox
274BUILT_MODULE_LOCATION[2]=vboxnetadp/
275BUILT_MODULE_NAME[2]=vboxnetadp
276AUTOINSTALL=yes
277EOF
278
279# install udev rules
280mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d/
281cat > %{buildroot}%{_sysconfdir}/udev/rules.d/%{name}.rules << EOF
282KERNEL=="%{kname}", MODE="0666"
283EOF
284cat > %{buildroot}%{_sysconfdir}/udev/rules.d/vbox-additions.rules << EOF
285KERNEL=="vboxguest|vboxuser", ENV{ACL_MANAGE}="1"
286EOF
287
288# install additions
289%if %{build_additions}
290mkdir -p %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty
291install -m755 src/VBox/Additions/linux/installer/vboxadd-service.sh %{buildroot}%{_initrddir}/vboxadd-timesync
292#install -m755 src/VBox/Additions/x11/Installer/VBoxRandR.sh %{buildroot}%{_bindir}/VBoxRandR
293install -m755 src/VBox/Additions/linux/installer/90-vboxguest.fdi %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
294mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d/
295install -m755 src/VBox/Additions/linux/installer/70-xorg-vboxmouse.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
296mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
297install -m755 src/VBox/Additions/x11/Installer/50-vboxmouse.conf %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
298
299install -d %{buildroot}%{_sysconfdir}/X11/xinit.d
300install -m755 src/VBox/Additions/x11/Installer/98vboxadd-xclient %{buildroot}%{_sysconfdir}/X11/xinit.d
301
302pushd out/%{vbox_platform}/release/bin/additions
303  install -d %{buildroot}/sbin %{buildroot}%{_sbindir} %{buildroot}/%{_libdir}/dri
304  install -m755 mount.vboxsf %{buildroot}/sbin/mount.vboxsf
305  install -m755 VBoxService %{buildroot}%{_sbindir}
306
307  install -d %{buildroot}%{_sysconfdir}/security/console.perms.d/
308  install -m644 %{SOURCE4} %{buildroot}%{_sysconfdir}/security/console.perms.d/
309
310  install -m755 VBoxClient %{buildroot}%{_bindir}
311  install -m755 VBoxControl %{buildroot}%{_bindir}
312
313  install -m755 VBoxOGL*.so %{buildroot}%{_libdir}
314  ln -s -f ../VBoxOGL.so %{buildroot}%{_libdir}/dri/vboxvideo_dri.so
315
316  install -d %{buildroot}%{_sysconfdir}/modprobe.preload.d
317  cat > %{buildroot}%{_sysconfdir}/modprobe.preload.d/vbox-guest-additions << EOF
318vboxadd
319EOF
320
321  install -d %{buildroot}%{_libdir}/xorg/modules/{input,drivers}
322  install vboxmouse_drv_17.so %{buildroot}%{_libdir}/xorg/modules/input/vboxmouse_drv.so
323  install vboxvideo_drv_17.so %{buildroot}%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
324
325  mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}
326  cat > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
327PACKAGE_NAME=vboxadditions
328PACKAGE_VERSION=%{version}-%{release}
329MAKE[0]="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxguest &&
330cp
331\$dkms_tree/\$module/\$module_version/build/vboxguest/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxsf &&
332make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxsf &&
333cp \$dkms_tree/\$module/\$module_version/build/vboxsf/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxvideo &&
334make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo"
335EOF
336
337  i=0
338  for kmod in vboxguest vboxsf vboxvideo; do
339    mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod
340    cp -a src/$kmod/* %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod/
341    cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
342DEST_MODULE_LOCATION[$i]=/kernel/3rdparty/vbox
343BUILT_MODULE_LOCATION[$i]=$kmod/
344BUILT_MODULE_NAME[$i]=$kmod
345EOF
346    i=$((i+1))
347  done
348  cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
349CLEAN="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxguest clean &&
350make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxsf clean &&
351make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo clean "
352AUTOINSTALL=yes
353EOF
354popd
355  sed 's/^\(.package.*-kernel-\)\(.*-latest\)\(.*\)\\$/\1\2\3Obsoletes: vboxsf-kernel-\2 vboxvideo-kernel-\2\\n\\/' /etc/dkms/template-dkms-mkrpm.spec > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/vboxadditions-dkms-mkrpm.spec
356%endif
357
358# install icons
359mkdir -p %{buildroot}%{_iconsdir}
360install -m644 %{SOURCE10} %{buildroot}%{_iconsdir}/
361
362# install menu entries
363
364mkdir -p %{buildroot}%{_datadir}/applications
365cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
366[Desktop Entry]
367Name=VirtualBox
368Comment=Full virtualizer for x86 hardware
369Comment[ja]=x86 ハードウエアの完全仮想化システム
370Exec=%{_bindir}/%{name}
371Icon=%{name}
372Type=Application
373Terminal=false
374Categories=System;Emulator;
375EOF
376
377# add missing makefile for kernel module
378install -m644 src/VBox/HostDrivers/Support/linux/Makefile %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
379
380# remove unpackaged files
381rm -rf %{buildroot}%{vboxlibdir}/{src,sdk,testcase}
382rm  -f %{buildroot}%{vboxlibdir}/tst*
383rm  -f %{buildroot}%{vboxlibdir}/vboxkeyboard.tar.gz
384rm  -f %{buildroot}%{vboxlibdir}/SUP*
385rm  -f %{buildroot}%{vboxlibdir}/xpidl
386
387%clean
388rm -rf %{buildroot}
389
390%post
391/sbin/chkconfig --add virtualbox
392
393%postun
394if [ "$1" -ge "1" ]; then
395  /sbin/service virtualbox condrestart > /dev/null 2>&1 || :
396fi
397
398%preun
399if [ $1 = 0 ]; then
400    service virtualbox stop > /dev/null 2>&1 ||:
401    /sbin/chkconfig --del virtualbox
402fi
403       
404
405%post -n dkms-%{name}
406set -x
407/usr/sbin/dkms --rpm_safe_upgrade add -m %{name} -v %{version}-%{release} ||:
408/usr/sbin/dkms --rpm_safe_upgrade build -m %{name} -v %{version}-%{release} ||:
409/usr/sbin/dkms --rpm_safe_upgrade install -m %{name} -v %{version}-%{release} --force ||:
410/sbin/modprobe %{kname} >/dev/null 2>&1 || :
411/sbin/modprobe vboxnetflt >/dev/null 2>&1 || :
412
413%preun -n dkms-%{name}
414# rmmod can fail
415/sbin/rmmod vboxnetflt >/dev/null 2>&1
416/sbin/rmmod %{kname} >/dev/null 2>&1
417set -x
418/usr/sbin/dkms --rpm_safe_upgrade remove -m %{name} -v %{version}-%{release} --all || :
419
420%if %{build_additions}
421%post guest-additions
422/sbin/chkconfig --add vboxadd-timesync
423
424%postun guest-additions
425if [ "$1" -ge "1" ]; then
426  /sbin/service vboxadd-timesync condrestart > /dev/null 2>&1 || :
427fi
428
429%preun guest-additions
430if [ $1 = 0 ]; then
431    service vboxadd-timesync stop > /dev/null 2>&1 ||:
432    /sbin/chkconfig --del vboxadd-timesync
433fi
434
435%post -n dkms-vboxadd
436set -x
437/usr/sbin/dkms --rpm_safe_upgrade add -m vboxadditions -v %{version}-%{release} ||:
438/usr/sbin/dkms --rpm_safe_upgrade build -m vboxadditions -v %{version}-%{release} ||:
439/usr/sbin/dkms --rpm_safe_upgrade install -m vboxadditions -v %{version}-%{release} ||:
440:
441
442%preun -n dkms-vboxadd
443set -x
444/usr/sbin/dkms --rpm_safe_upgrade remove -m vboxadditions -v %{version}-%{release} --all ||:
445:
446
447%endif
448
449%files
450%defattr(-,root,root)
451%config %{_sysconfdir}/vbox/vbox.cfg
452%{_bindir}/%{name}
453%{_bindir}/VBoxManage
454%{_bindir}/VBoxSDL
455%{_bindir}/VBoxHeadless
456%{_bindir}/VBoxTunctl
457%{_bindir}/VBoxNetAdpCtl
458%{_bindir}/VBoxNetDHCP
459#%{_bindir}/vboxwebsrv
460%{vboxlibdir}
461%attr(4711,root,root) %{vboxlibdir}/VBoxHeadless
462%attr(4711,root,root) %{vboxlibdir}/VBoxSDL
463%attr(4711,root,root) %{vboxlibdir}/%{name}
464%attr(4711,root,root) %{vboxlibdir}/VBoxNetAdpCtl
465%attr(4711,root,root) %{vboxlibdir}/VBoxNetDHCP
466%attr(644,root,root) %{vboxlibdir}/*.gc
467%attr(644,root,root) %{vboxlibdir}/*.r0
468%{vboxdatadir}
469# initscripts integration
470%{_initrddir}/virtualbox
471%config %{_sysconfdir}/udev/rules.d/%{name}.rules
472%dir /var/run/%{name}
473# desktop integration
474%{_iconsdir}/*.png
475%{_datadir}/applications/%{name}.desktop
476
477%files -n dkms-%{name}
478%defattr(-,root,root)
479%{_usr}/src/%{name}-%{version}-%{release}
480
481%if %{build_additions}
482%files guest-additions
483%defattr(-,root,root)
484/sbin/mount.vboxsf
485%{_initrddir}/vboxadd-timesync
486%{_sbindir}/VBoxService
487%{_bindir}/VBoxClient
488%{_bindir}/VBoxControl
489%{_sysconfdir}/security/console.perms.d/60-vboxadd.perms
490%{_sysconfdir}/udev/rules.d/vbox-additions.rules
491%{_sysconfdir}/X11/xinit.d/98vboxadd-xclient
492%{_sysconfdir}/modprobe.preload.d/vbox-guest-additions
493
494%files -n xorg-x11-drv-vboxmouse
495%defattr(-,root,root)
496%{_libdir}/xorg/modules/input/vboxmouse_drv.so
497%{_sysconfdir}/X11/xorg.conf.d/*.conf
498%{_sysconfdir}/udev/rules.d/*.rules
499%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
500
501%files -n xorg-x11-drv-vboxvideo
502%defattr(-,root,root)
503%{_libdir}/VBoxOGL*
504%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
505%{_libdir}/dri/vboxvideo_dri.so
506
507%files -n dkms-vboxadd
508%defattr(-,root,root)
509%{_usr}/src/vbox*-%{version}-%{release}
510
511%endif
512
513
514%changelog
515* Sat Dec 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-2
516- add BR: pam-devel
517- rebuild with python-2.6
518
519* Fri Dec 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.12-1
520- updated VirtualBox to 3.2.12-OSE
521
522* Mon Aug 23 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.8-1
523- new upstream release
524
525* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-2
526- add patch110 to fix vboxadd-timesync script
527
528* Thu Jun 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
529- new upstream release
530
531* Sat May 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.0-1
532- new upstream release
533- drop wined3d patch as the Windows guest additions provide
534  Direct3D acceleration.
535- add xorg.conf snippet for new xserver
536- vboxvfs renamed to vboxsf
537
538* Mon Apr 19 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.6-2
539- fix initscript
540
541* Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.6-1
542- new upstream release
543
544* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.10-1
545- new upstream release
546- add missing BR:
547
548* Mon Sep 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.6-1
549- new upstream release
550
551* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.4-1
552- new upstream release
553- add translated summaries and descriptions
554
555* Mon Jul 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-1
556- new upstream release
557
558* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
559- new upstream release
560
561* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-3
562- change Group: of dkms-VirtualBox to System Environment/Kernel
563
564* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-2
565- remove modprobe.d/vbox-guest-additions
566
567* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-1
568- update to 2.2.4
569
570* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-1
571- initial build for Vine Linux
572- update to 2.2.2
573
574* Wed Apr 22 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-4mdv2009.1
575+ Revision: 368679
576- Fix mkrpm template
577
578* Tue Apr 21 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-3mdv2009.1
579+ Revision: 368502
580- BuildRequires:dkms-minimal
581- Obsolete -latest dkms binary packages
582
583* Wed Apr 15 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-2mdv2009.1
584+ Revision: 367571
585- Patch15: kill vboxclient if leftover from previous X11 session
586- Patch14 (Sun): fix OpenGL support for Linux Guest additions
587- improve packaging to be more LSB compliant
588
589* Fri Apr 10 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-1mdv2009.1
590+ Revision: 365828
591- Release 2.2.0
592- enable OpenGL pass-through. Caveat : Linux guest support is not working when building guest additions with Open source edition (under investigation)
593- move location of fdi file (fix mouse integration support when using HAL)
594- merge all guest additions kernel module in one single DKMS (pterjan)
595- Enable webservice
596- Remove patch9, no longer needed (when using kernel 2.6.29.x, you MUST use kernel 2.6.29.1 or later)
597- Regenerate patches 8, 10
598- Patch11: add Wine Direct3D guest additions option (Debian)
599- Patch12: disable update notification (Debian)
600- Patch13: make network settings more intuitive (Debian)
601- Add missing dependencies in guest additions package
602- No longer use gcc 4.2, build fine with latest gcc 4.3
603- Replace source3 with upstream version
604- Update source4 to change permissions on both guest additions devices
605- Fix permissions on non .so files
606
607* Mon Mar 09 2009 Pascal Terjan <pterjan@mandriva.org> 2.1.4-5mdv2009.1
608+ Revision: 353280
609- vboxvfs needs vboxadd
610
611* Wed Mar 04 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.4-4mdv2009.1
612+ Revision: 348336
613- Force rebuild of dkms modules
614
615* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-3mdv2009.1
616+ Revision: 344966
617- Copy Module.symvers for vboxnetflt dkms build, needed with
618  CONFIG_MODVERSIONS enabled in latest cooker kernels.
619
620* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-2mdv2009.1
621+ Revision: 344896
622- Apply fix for VM load failure with kernels 2.6.29-rc5 or later
623  (#48096, http://www.virtualbox.org/ticket/3403).
624- Fix building with kernel-headers-2.6.29*
625
626* Tue Feb 17 2009 Frederik Himpe <fhimpe@mandriva.org> 2.1.4-1mdv2009.1
627+ Revision: 342236
628- Update to new version 2.1.4
629- Fix source URL
630
631* Thu Jan 22 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.2-2mdv2009.1
632+ Revision: 332593
633- Use xorg 1.6 drivers when building cooker guest addition packages
634
635* Thu Jan 22 2009 Funda Wang <fundawang@mandriva.org> 2.1.2-1mdv2009.1
636+ Revision: 332404
637- specify CC4.2
638- New version 2.1.2
639- rediff libpath patch
640
641* Sun Jan 04 2009 Colin Guthrie <cguthrie@mandriva.org> 2.1.0-5mdv2009.1
642+ Revision: 324525
643- Rebuild mouse and display drivers for xserver 1.6
644
645* Thu Dec 25 2008 Michael Scherer <misc@mandriva.org> 2.1.0-4mdv2009.1
646+ Revision: 318540
647- rebuild for new python
648
649* Fri Dec 19 2008 Frederic Crozat <fcrozat@mandriva.com> 2.1.0-3mdv2009.1
650+ Revision: 316288
651- Fix guest additions for cooker, we ship Xorg 1.5 now
652- Ship fdi file for vboxmouse
653
654* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-2mdv2009.1
655+ Revision: 316021
656- oops, finish fixing up initscript
657
658* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-1mdv2009.1
659+ Revision: 316019
660- adjust initscript and dkms.conf for the fact that there's now two necessary
661  kernel modules for the master: vboxdrv and vboxnetflt
662- drop mdvconfig.patch: this stub does nothing useful, and breaks the build
663  (see fcrozat's mail on Cooker)
664- VBoxAddIF and VBoxDeleteIF are now obsolete and not provided
665
666  + Frederic Crozat <fcrozat@mandriva.com>
667    - Release 2.1.0
668    - Regenerate patch1
669    - update buildrequires
670
671* Sun Nov 30 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.6-2mdv2009.1
672+ Revision: 308552
673- Rebuild mouse and display drivers for xserver 1.5
674
675* Wed Nov 26 2008 Funda Wang <fundawang@mandriva.org> 2.0.6-1mdv2009.1
676+ Revision: 306865
677- New version 2.0.6
678
679* Mon Nov 03 2008 Funda Wang <fundawang@mandriva.org> 2.0.4-1mdv2009.1
680+ Revision: 299348
681- New version 2.0.4
682
683* Mon Sep 15 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.2-2mdv2009.0
684+ Revision: 284854
685- Patch8: disable version check at startup
686
687* Sat Sep 13 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.2-1mdv2009.0
688+ Revision: 284544
689- Update to bugfix update 2.0.2
690
691* Tue Sep 09 2008 Olivier Blin <oblin@mandriva.com> 2.0.0-3mdv2009.0
692+ Revision: 283015
693- build guest additions on x86_64 too (#43593)
694
695  + Frederic Crozat <fcrozat@mandriva.com>
696    - Patch7: fix QT4 detection on x86-64 on Mandriva 2008.1
697
698* Thu Sep 04 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.0-1mdv2009.0
699+ Revision: 280850
700- Fix BuildRequires
701- Release 2.0.0
702- Remove patches 3, 7 (merged upstream)
703
704* Mon Sep 01 2008 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 1.6.4-4mdv2009.0
705+ Revision: 278071
706- Added patch to allow VirtualBox kernel module to build with
707  Linux 2.6.27
708
709  + Pixel <pixel@mandriva.com>
710    - increase release number
711    - use gcc4.2 to build the recompiler (not ported to gcc 4.3 yet)
712
713* Wed Aug 06 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-2mdv2009.0
714+ Revision: 264273
715- create /var/run/VirtualBox (#41963)
716- use tunctl from the tunctl package while VBoxTunctl does not build
717
718* Tue Aug 05 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-1mdv2009.0
719+ Revision: 264016
720- do not include VBoxTunctl for now (build is broken in upstream tarball)
721- rediff misc_register patch (the register part has been implemented upstream, I should submit the deregister hunks)
722- fix 1.6.4 build by not building tunctl (some Makefile.kmk are missing)
723- 1.6.4
724
725* Tue Jul 29 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.2-2mdv2009.0
726+ Revision: 252777
727- Don't use gcc 3.3 for build on 2008.1 or earlier
728
729* Wed Jul 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.2-1mdv2009.0
730+ Revision: 232889
731- set again linux sources path in configure
732- use gcc 3.3 to build the recompiler (not ported to gcc 4.3 yet)
733- use kernel-devel-latest instead of kernel-source-latest
734- use a prepared copy of the linux tree (for linux/bounds.h)
735
736  + Frederic Crozat <fcrozat@mandriva.com>
737    - Release 1.6.2
738    - Regenerate patch5
739    - Fix duplicated line in specfile
740
741  + Pixel <pixel@mandriva.com>
742    - rpm filetriggers deprecates update_menus/update_scrollkeeper/update_mime_database/update_icon_cache/update_desktop_database/post_install_gconf_schemas
743
744* Fri May 16 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-4mdv2009.0
745+ Revision: 208160
746- Fix seamless mode in guest additions subpackage
747
748* Thu May 15 2008 Anssi Hannula <anssi@mandriva.org> 1.6.0-3mdv2009.0
749+ Revision: 207692
750- rename VBoxAddIF.sh and VBoxDeleteIF.sh to VBoxAddIF and VBoxDeleteIF
751  to match original names and documentation
752
753* Wed May 14 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-2mdv2009.0
754+ Revision: 207235
755- Replace source1 with patch 6 (use up to date VBox.sh script)
756- Ensure VBoxAddIF/VBoxDeleteIF scripts are packaged, as well as VBoxTunctl (Mdv bug #40769)
757- package VBoxHeadless (Mdv bug #40771)
758
759* Fri May 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.0-1mdv2009.0
760+ Revision: 205313
761- try harder to disable additions on x86_64
762- buildrequire libxslt-devel
763- adapt to vboxadd-xclient being renamed as VBoxClient
764- rediff futex patch
765- rediff misc_register patch
766- 1.6.0
767- revert BUILT_MODULE_NAME addition, the bug is fixed in dkms
768
769  + Anssi Hannula <anssi@mandriva.org>
770    - add BUILT_MODULE_NAME to dkms.conf of vboxadd and vboxvfs (fixes DKMS
771      error)
772
773* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.6-1mdv2008.1
774+ Revision: 175619
775- 1.5.6
776- rediff KERNELRELEASE patch
777
778* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-5mdv2008.1
779+ Revision: 175610
780- try to start dkms instead of vboxadd in vboxadd-timesync service (since modules are loaded from modprobe.preload.d, #36728)
781
782* Fri Feb 08 2008 Thierry Vignaud <tvignaud@mandriva.com> 1.5.4-4mdv2008.1
783+ Revision: 163970
784- drop old menu
785
786  + Frederic Crozat <fcrozat@mandriva.com>
787    - Really disable pulseaudio support on 2008.0 or older
788
789* Thu Jan 10 2008 Frederic Crozat <fcrozat@mandriva.com> 1.5.4-3mdv2008.1
790+ Revision: 147602
791- Use correct version of x11 mouse and video additional driver when used on 2008.1 (xorg 1.4) and 2008.0
792- Only build pulseaudio support for 2008.1
793
794* Wed Jan 09 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-2mdv2008.1
795+ Revision: 147006
796- fix dkms build for kernels different from running kernel
797
798* Thu Jan 03 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-1mdv2008.1
799+ Revision: 142711
800- buildrequire pulseaudio-devel
801- rediff libpath patch
802- remove 2.6.24 build fix, fixed upstream
803- 1.5.4
804- restore BuildRoot
805
806  + Pascal Terjan <pterjan@mandriva.org>
807    - Switch to Debian patch for 2.6.24
808    - Re-create the 2.6.24 patch, some bits got lost
809
810  + Thierry Vignaud <tvignaud@mandriva.com>
811    - kill re-definition of %%buildroot on Pixel's request
812    - kill explicit icon extension
813
814  + Giuseppe Ghibò <ghibo@mandriva.com>
815    - Use kernel-source-latest in BuildRequires as conditional.
816    - Add conditional build flags for older release.
817    - Let Patch5 conditional.
818
819* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-3mdv2008.1
820+ Revision: 114076
821- Improve 2.6.24 patch so that it should still build with older kernels
822
823* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-2mdv2008.1
824+ Revision: 114047
825- Fix other parts to build with 2.6.24
826- Fix vboxdrv for 2.6.24
827
828* Tue Nov 13 2007 Olivier Blin <oblin@mandriva.com> 1.5.2-1mdv2008.1
829+ Revision: 108363
830- remove keyboards patch (was from upstream svn)
831- rediff kernelrelease patch
832- rediff libpath patch
833- 1.5.2
834
835* Thu Oct 04 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-6mdv2008.0
836+ Revision: 95447
837- really apply misc_register patch (so that vboxadd devices are automatically created)
838- add release in dkms PACKAGE_VERSION to ease upgrades
839
840* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-5mdv2008.0
841+ Revision: 93837
842- require kmod(vboxdrv) instead of dkms package
843- do not mark initscript as config file
844- move initscripts and udev rules out of dkms package (so that it works when using dkms prebuilt modules)
845
846* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-4mdv2008.0
847+ Revision: 93812
848- add vboxadd-timesync service
849- add pam_console perms file to assign vboxadd device to console user
850- use misc_register() to register vboxadd device so that /dev/vboxadd gets created automatically by udev
851
852* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-3mdv2008.0
853+ Revision: 93770
854- add vboxadd-xclient xinit.d script
855- release new additions, but we still need to fix mknod for vboxadd
856  (or use device_create() in kernel module), set console perms for
857  vboxadd in console.perms.d, and add timesync initscript
858- make guest additions package require X11 drivers
859- make x11 driver packages suggest virtualbox-guest-additions
860- add virtualbox-guest-additions package (with xclient, timesync, mount.vboxsf)
861- add dkms-vboxadd and dkms-vboxvfs packages
862
863* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-2mdv2008.0
864+ Revision: 93534
865- build additions on ix86 only
866- fix support for Brazilian, Belgian, US intl and US dvorak keyboards and add support for multimedia keys (from upstream SVN)
867- buildrequire libstdc++-static-devel
868- buildrequire libxt-devel
869- buildrequire kernel-source-latest, since iurt/urpmi don't install latest kernel-source automatically
870- buildrequire kernel-source
871- package mouse guest addition in x11-driver-input-vboxmouse
872- package video guest addition in x11-driver-video-vboxvideo
873- build VirtualBox additions
874
875* Mon Sep 03 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-1mdv2008.0
876+ Revision: 78607
877- drop libstdc++5 BuildRequires
878- drop unapplied x86_64 NMI watchdog disabling patch (merged upstream)
879- 1.5.0
880- rediff mdvconfig patch
881
882  + Thierry Vignaud <tvignaud@mandriva.com>
883    - kill desktop-file-validate's 'warning: key "Encoding" in group "Desktop Entry" is deprecated'
884
885* Fri Jun 08 2007 Per Øyvind Karlsen <peroyvind@mandriva.org> 1.4.0-1mdv2008.0
886+ Revision: 37085
887- from Jos?\195?\169 Melo <mmodem00@gmail.com>:
888        o 1.4.0
889        o update patch:2 since is needed to load (modprobe) vbox driver in kernel-2.6.17
890        o remove patch1 since is becomes obsolete with this new version,and continues installing and running stable no matter if is kernel-2.6.17 or greater
891        o add missing buildrequire hal-devel
892
893
894* Thu Mar 15 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.8-1mdv2007.1
895+ Revision: 144313
896- add should-start: dkms to initscript (#29523)
897- 1.3.8
898  * hard reset network device on reboot
899  * fix issues with IBM JVM 1.4.2 in Linux guests
900  * add support for X.org 7.2.x in Linux guest additions
901
902* Fri Mar 02 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.6-1mdv2007.1
903+ Revision: 131492
904- disable NMIs on Core 2 platforms too
905- 1.3.6
906  * fix some GUI issues
907  * fix OpenBSD 4.0 support
908  * fix CD/DVD-ROM detection in Windows Vista guests
909  * fix networking issues with Windows NT 4.0 guests
910  * fix some ALSA problems that could cause system reboots
911
912* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.4-1mdv2007.1
913+ Revision: 119895
914- 1.3.4
915
916* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070209-1mdv2007.1
917+ Revision: 119017
918- SVN updates (2007/02/09):
919  * additional 64-bit fixes
920  * asynchronous packets transmission in NIC code
921
922* Sat Feb 03 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070202-1mdv2007.1
923+ Revision: 116064
924- various 64-bit fixes
925- updates from SVN (2007/02/02):
926  * initial 64-bit host support
927  * fix IDE for Open Solaris 10
928  * add VDI compacting to the GUI
929
930* Sat Jan 27 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3-1mdv2007.1
931+ Revision: 114276
932- initial mandriva linux package
933
Note: See TracBrowser for help on using the repository browser.