source: projects/specs/trunk/V/VirtualBox/VirtualBox-vl.spec @ 1190

Revision 1190, 31.9 KB checked in by daisuke, 14 years ago (diff)

VirtualBox?: fix vboxadd-timesync script to support vine-release

Line 
1%define version 3.2.4
2%define release 2%{?_dist_release}
3
4%define kname   vboxdrv
5%define oname   VirtualBox
6%define srcname %{oname}-%{version}-OSE
7%define distname        %{oname}-%{version}_OSE
8%define dirname vbox-ose
9%define pkgver  %{version}
10
11%define vboxlibdir      %{_libdir}/%{name}
12%define vboxdatadir     %{_datadir}/%{name}
13
14%define build_additions 1
15
16%ifarch %{ix86}
17%define vbox_platform linux.x86
18%endif
19%ifarch x86_64
20%define vbox_platform linux.amd64
21%endif
22
23# nuke vbox-specific dependencies
24%define _provides_exceptions ^VBox
25%define _requires_exceptions ^VBox
26
27Summary:        A general-purpose full virtualizer for x86 hardware
28Summary(ja):    汎用の x86 ハードウエア完全仮想化ソフトウエア
29Name:           VirtualBox
30Version:        %{version}
31Release:        %{release}
32License:        GPL
33Group:          Development/Tools
34Url:            http://www.virtualbox.org/
35
36Source0:        http://download.virtualbox.org/virtualbox/%ver/%{srcname}.tar.bz2
37Source2:        virtualbox.init.vine
38Source4:        60-vboxadd.perms
39Source10:       VirtualBox.png
40Patch2:         VirtualBox-1.5.6_OSE-kernelrelease.patch
41Patch4:         VirtualBox-1.6.0_OSE-futex.patch
42Patch5:         virtualbox-fix-vboxadd-req.patch
43# (fc) 1.6.0-2mdv fix initscript name in VBox.sh script
44Patch6:         VirtualBox-1.6.0_OSE-initscriptname.patch
45# (hk) fix build kernel-headers-2.6.29*
46Patch10:        VirtualBox-kernel-headers-2.6.29.patch
47# (fc) 2.2.0-1mdv disable update notification (Debian)
48Patch12:        16-no-update.patch
49
50# vine
51Patch100:       VirtualBox-2.2.2-buildfix.patch
52Patch110:       VirtualBox-3.2.4-vine.patch
53
54BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
55ExclusiveArch:  %{ix86} x86_64
56Requires:       dkms-%{name} = %{version}-%{release}
57BuildRequires:  dev86, iasl
58BuildRequires:  zlib-devel
59BuildRequires:  libXcursor-devel
60BuildRequires:  libXmu-devel
61BuildRequires:  SDL-devel
62BuildRequires:  qt4-devel
63BuildRequires:  libIDL-devel
64BuildRequires:  e2fsprogs-devel
65BuildRequires:  libxslt-devel
66BuildRequires:  xerces-c-devel, xalan-c-devel
67BuildRequires:  hal-devel
68BuildRequires:  libXt-devel
69BuildRequires:  libstdc++34-devel
70BuildRequires:  python-devel
71BuildRequires:  libcap-devel
72BuildRequires:  pulseaudio-libs-devel
73BuildRequires:  kernel-devel
74BuildRequires:  mesa-libGL-devel
75BuildRequires:  mesa-libGLU-devel
76BuildRequires:  gsoap-devel
77BuildRequires:  curl-devel
78BuildRequires:  alsa-lib-devel
79BuildRequires:  dkms
80BuildRequires:  kBuild >= 0.1.5p2
81BuildRequires:  yasm
82BuildRequires:  qt4-designer
83%ifarch x86_64
84BuildRequires:  compat32-glibc-devel
85%endif
86
87%description
88VirtualBox Open Source Edition (OSE) is a general-purpose full
89virtualizer for x86 hardware.
90
91%description -l ja
92VirtualBox Open Source Edition (OSE) は汎用の x86 ハードウエア
93完全仮想化ソフトウエアです。
94
95%package -n     dkms-%{name}
96Summary:        VirtualBox OSE kernel module
97Summary(ja):    VirtualBox OSE カーネルモジュール
98Group:          System Environment/Kernel
99Requires(post):   dkms
100Requires(preun):  dkms
101
102%description -n dkms-%{name}
103Kernel support for VirtualBox OSE.
104
105%description -l ja -n dkms-%{name}
106VirtualBox OSE のカーネルサポートパッケージです。
107
108%if %{build_additions}
109%package        guest-additions
110Summary:        Additions for VirtualBox OSE guest systems
111Summary(ja):    VirtualBox OSE ゲストシステム用の追加モジュール
112Group:          System Environment/Kernel
113Requires:       dkms-vboxadd = %{version}-%{release}
114Requires:       dkms-vboxvfs = %{version}-%{release}
115Requires:       dkms-vboxvideo = %{version}-%{release}
116Requires:       xorg-x11-drv-vboxmouse
117Requires:       xorg-x11-drv-vboxvideo
118Requires:       xorg-x11-server-utils
119
120%description    guest-additions
121This packages contains additions for VirtualBox OSE guest systems.
122It allows to share files with the host system, copy/paste between
123guest and host, and sync time with host.
124
125%description -l ja guest-additions
126このパッケージには VirtualBox OSE ゲストシステムのための追加モジュール
127が含まれています。これを利用することでホストシステムとファイルを共有し
128たり、ゲスト/ホスト間でカット&ペーストを行ったり、ホストと時刻同期をし
129たりすることができます。
130
131%package -n     dkms-vboxadd
132Summary:        Kernel module for VirtualBox OSE additions
133Summary(ja):    VirtualBox OSE additions のカーネルモジュール
134Group:          System Environment/Kernel
135Requires(post):   dkms
136Requires(preun):  dkms
137Provides:       dkms-vboxvfs = %{version}-%{release}
138Obsoletes:      dkms-vboxvfs < %{version}-%{release}
139Provides:       dkms-vboxsf = %{version}-%{release}
140Obsoletes:      dkms-vboxsf < %{version}-%{release}
141Provides:       dkms-vboxvideo = %{version}-%{release}
142Obsoletes:      dkms-vboxvideo < %{version}-%{release}
143
144%description -n dkms-vboxadd
145Kernel module for VirtualBox OSE additions.
146
147%description -l ja -n dkms-vboxadd
148VirtualBox OSE 追加モジュールのためのカーネルモジュールです。
149
150%package -n     xorg-x11-drv-vboxmouse
151Summary:        X.org X11 input driver for VirtualBox mouse
152Summary:        X.org X11 VirtualBox マウス入力ドライバ
153Group:          User Interface/X Hardware Support
154Requires:       %{name}-guest-additions
155
156%description -n xorg-x11-drv-vboxmouse
157The X.org driver for mouse in VirtualBox guests
158
159%description -l ja -n xorg-x11-drv-vboxmouse
160VirtualBox のゲストシステム用の X.org マウスドライバです。
161
162%package -n     xorg-x11-drv-vboxvideo
163Summary:        X.org X11 video driver for VirtualBox guests
164Summary(ja):    X.org X11 VirtualBox ビデオドライバ
165Group:          User Interface/X Hardware Support
166Requires:       %{name}-guest-additions
167
168%description -n xorg-x11-drv-vboxvideo
169The X.org driver for video in VirtualBox guests
170
171%description -l ja -n xorg-x11-drv-vboxvideo
172VirtualBox のゲストシステム用の X.org ビデオドライバです。
173
174%endif
175
176%prep
177%setup -q -n %{distname}
178%patch2 -p1 -b .kernelrelease
179%patch4 -p1 -b .futex
180%patch5 -p1 -b .fix-timesync-req
181%patch6 -p1 -b .initscriptname
182%patch10 -p1 -b .kernel-headers-2.6.29
183%patch12 -p1 -b .disable-update
184%patch100 -p1 -b .buildfix
185%patch110 -p1 -b .vine
186
187# remove prebuilt binaries
188rm -rf kBuild tools
189
190cat << EOF > LocalConfig.kmk
191VBOX_PATH_APP_PRIVATE_ARCH:=%{vboxlibdir}
192VBOX_WITH_ORIGIN:=
193VBOX_WITH_RUNPATH:=%{vboxlibdir}
194VBOX_PATH_APP_PRIVATE:=%{vboxdatadir}
195VBOX_WITH_TESTCASES:=
196VBOX_WITH_TESTSUITE:=
197EOF
198
199%build
200./configure --disable-kmods --with-linux=$PWD/fake-linux
201
202%if !%{build_additions}
203sed -rie 's/(VBOX_WITH_LINUX_ADDITIONS\s+:=\s+).*/\1/' AutoConfig.kmk
204echo VBOX_WITHOUT_ADDITIONS=1 >> LocalConfig.kmk
205%endif
206
207. ./env.sh
208kmk KBUILD_VERBOSE=2 \
209    TOOL_YASM_AS=yasm \
210    VBOX_WITH_REGISTRATION_REQUEST= \
211    %{?_smp_mflags} all
212
213%install
214rm -rf %{buildroot}
215
216# install vbox components
217mkdir -p %{buildroot}%{vboxlibdir} %{buildroot}%{vboxdatadir}
218
219(cd out/%{vbox_platform}/release/bin && tar cf - --exclude=additions .) | \
220(cd %{buildroot}%{vboxlibdir} && tar xf -)
221
222# move noarch files to vboxdatadir
223mv %{buildroot}%{vboxlibdir}/{VBox*.sh,nls,*.desktop,*.png} %{buildroot}%{vboxdatadir}
224
225# install service
226mkdir -p %{buildroot}%{_initrddir}
227install -m755 %{SOURCE2} %{buildroot}%{_initrddir}/virtualbox
228
229# install wrappers
230mkdir -p %{buildroot}%{_sysconfdir}/vbox
231cat > %{buildroot}%{_sysconfdir}/vbox/vbox.cfg << EOF
232# VirtualBox installation directory
233INSTALL_DIR="%{vboxlibdir}"
234EOF
235mkdir -p %{buildroot}%{_bindir}
236ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/%{name}
237ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxManage
238ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxSDL
239ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxHeadless
240#ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/vboxwebsrv
241
242# provide network control tools in bindir
243ln -s %{vboxlibdir}/VBoxTunctl %{buildroot}%{_bindir}/VBoxTunctl
244ln -s %{vboxlibdir}/VBoxNetAdpCtl %{buildroot}%{_bindir}/VBoxNetAdpCtl
245ln -s %{vboxlibdir}/VBoxNetDHCP %{buildroot}%{_bindir}/VBoxNetDHCP
246
247install -d %{buildroot}/var/run/%{name}
248
249# install dkms sources
250mkdir -p %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
251cat > vboxbuild << EOF
252#!/bin/sh
253set -e
254make -C %{kname} KERN_DIR=\$1
255cp -f %{kname}/Module.symvers vboxnetflt
256cp -f %{kname}/Module.symvers vboxnetadp
257make -C vboxnetflt KERN_DIR=\$1
258make -C vboxnetadp KERN_DIR=\$1
259EOF
260install -m 0755 vboxbuild %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
261mv %{buildroot}%{vboxlibdir}/src/* %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
262cat > %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/dkms.conf << EOF
263MAKE[0]="./vboxbuild \$kernel_source_dir"
264PACKAGE_NAME=%{name}
265PACKAGE_VERSION=%{version}-%{release}
266DEST_MODULE_LOCATION[0]=/kernel/3rdparty/vbox
267BUILT_MODULE_LOCATION[0]=%{kname}/
268BUILT_MODULE_NAME[0]=%{kname}
269DEST_MODULE_LOCATION[1]=/kernel/3rdparty/vbox
270BUILT_MODULE_LOCATION[1]=vboxnetflt/
271BUILT_MODULE_NAME[1]=vboxnetflt
272DEST_MODULE_LOCATION[2]=/kernel/3rdparty/vbox
273BUILT_MODULE_LOCATION[2]=vboxnetadp/
274BUILT_MODULE_NAME[2]=vboxnetadp
275AUTOINSTALL=yes
276EOF
277
278# install udev rules
279mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d/
280cat > %{buildroot}%{_sysconfdir}/udev/rules.d/%{name}.rules << EOF
281KERNEL=="%{kname}", MODE="0666"
282EOF
283cat > %{buildroot}%{_sysconfdir}/udev/rules.d/vbox-additions.rules << EOF
284KERNEL=="vboxguest|vboxuser", ENV{ACL_MANAGE}="1"
285EOF
286
287# install additions
288%if %{build_additions}
289mkdir -p %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty
290install -m755 src/VBox/Additions/linux/installer/vboxadd-service.sh %{buildroot}%{_initrddir}/vboxadd-timesync
291#install -m755 src/VBox/Additions/x11/Installer/VBoxRandR.sh %{buildroot}%{_bindir}/VBoxRandR
292install -m755 src/VBox/Additions/linux/installer/90-vboxguest.fdi %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
293mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d/
294install -m755 src/VBox/Additions/linux/installer/70-xorg-vboxmouse.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
295mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
296install -m755 src/VBox/Additions/x11/Installer/50-vboxmouse.conf %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
297
298install -d %{buildroot}%{_sysconfdir}/X11/xinit.d
299install -m755 src/VBox/Additions/x11/Installer/98vboxadd-xclient %{buildroot}%{_sysconfdir}/X11/xinit.d
300
301pushd out/%{vbox_platform}/release/bin/additions
302  install -d %{buildroot}/sbin %{buildroot}%{_sbindir} %{buildroot}/%{_libdir}/dri
303  install -m755 mount.vboxsf %{buildroot}/sbin/mount.vboxsf
304  install -m755 VBoxService %{buildroot}%{_sbindir}
305
306  install -d %{buildroot}%{_sysconfdir}/security/console.perms.d/
307  install -m644 %{SOURCE4} %{buildroot}%{_sysconfdir}/security/console.perms.d/
308
309  install -m755 VBoxClient %{buildroot}%{_bindir}
310  install -m755 VBoxControl %{buildroot}%{_bindir}
311
312  install -m755 VBoxOGL*.so %{buildroot}%{_libdir}
313  ln -s -f ../VBoxOGL.so %{buildroot}%{_libdir}/dri/vboxvideo_dri.so
314
315  install -d %{buildroot}%{_sysconfdir}/modprobe.preload.d
316  cat > %{buildroot}%{_sysconfdir}/modprobe.preload.d/vbox-guest-additions << EOF
317vboxadd
318EOF
319
320  install -d %{buildroot}%{_libdir}/xorg/modules/{input,drivers}
321  install vboxmouse_drv_17.so %{buildroot}%{_libdir}/xorg/modules/input/vboxmouse_drv.so
322  install vboxvideo_drv_17.so %{buildroot}%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
323
324  mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}
325  cat > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
326PACKAGE_NAME=vboxadditions
327PACKAGE_VERSION=%{version}-%{release}
328MAKE[0]="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxguest &&
329cp
330\$dkms_tree/\$module/\$module_version/build/vboxguest/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxsf &&
331make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxsf &&
332cp \$dkms_tree/\$module/\$module_version/build/vboxsf/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxvideo &&
333make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo"
334EOF
335
336  i=0
337  for kmod in vboxguest vboxsf vboxvideo; do
338    mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod
339    cp -a src/$kmod/* %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod/
340    cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
341DEST_MODULE_LOCATION[$i]=/kernel/3rdparty/vbox
342BUILT_MODULE_LOCATION[$i]=$kmod/
343BUILT_MODULE_NAME[$i]=$kmod
344EOF
345    i=$((i+1))
346  done
347  cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
348CLEAN="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxguest clean &&
349make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxsf clean &&
350make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo clean "
351AUTOINSTALL=yes
352EOF
353popd
354  sed 's/^\(.package.*-kernel-\)\(.*-latest\)\(.*\)\\$/\1\2\3Obsoletes: vboxsf-kernel-\2 vboxvideo-kernel-\2\\n\\/' /etc/dkms/template-dkms-mkrpm.spec > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/vboxadditions-dkms-mkrpm.spec
355%endif
356
357# install icons
358mkdir -p %{buildroot}%{_iconsdir}
359install -m644 %{SOURCE10} %{buildroot}%{_iconsdir}/
360
361# install menu entries
362
363mkdir -p %{buildroot}%{_datadir}/applications
364cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
365[Desktop Entry]
366Name=VirtualBox
367Comment=Full virtualizer for x86 hardware
368Comment[ja]=x86 ハードウエアの完全仮想化システム
369Exec=%{_bindir}/%{name}
370Icon=%{name}
371Type=Application
372Terminal=false
373Categories=System;Emulator;
374EOF
375
376# add missing makefile for kernel module
377install -m644 src/VBox/HostDrivers/Support/linux/Makefile %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
378
379# remove unpackaged files
380rm -rf %{buildroot}%{vboxlibdir}/{src,sdk,testcase}
381rm  -f %{buildroot}%{vboxlibdir}/tst*
382rm  -f %{buildroot}%{vboxlibdir}/vboxkeyboard.tar.gz
383rm  -f %{buildroot}%{vboxlibdir}/SUP*
384rm  -f %{buildroot}%{vboxlibdir}/xpidl
385
386%clean
387rm -rf %{buildroot}
388
389%post
390/sbin/chkconfig --add virtualbox
391
392%postun
393if [ "$1" -ge "1" ]; then
394  /sbin/service virtualbox condrestart > /dev/null 2>&1 || :
395fi
396
397%preun
398if [ $1 = 0 ]; then
399    service virtualbox stop > /dev/null 2>&1 ||:
400    /sbin/chkconfig --del virtualbox
401fi
402       
403
404%post -n dkms-%{name}
405set -x
406/usr/sbin/dkms --rpm_safe_upgrade add -m %{name} -v %{version}-%{release} ||:
407/usr/sbin/dkms --rpm_safe_upgrade build -m %{name} -v %{version}-%{release} ||:
408/usr/sbin/dkms --rpm_safe_upgrade install -m %{name} -v %{version}-%{release} --force ||:
409/sbin/modprobe %{kname} >/dev/null 2>&1 || :
410/sbin/modprobe vboxnetflt >/dev/null 2>&1 || :
411
412%preun -n dkms-%{name}
413# rmmod can fail
414/sbin/rmmod vboxnetflt >/dev/null 2>&1
415/sbin/rmmod %{kname} >/dev/null 2>&1
416set -x
417/usr/sbin/dkms --rpm_safe_upgrade remove -m %{name} -v %{version}-%{release} --all || :
418
419%if %{build_additions}
420%post guest-additions
421/sbin/chkconfig --add vboxadd-timesync
422
423%postun guest-additions
424if [ "$1" -ge "1" ]; then
425  /sbin/service vboxadd-timesync condrestart > /dev/null 2>&1 || :
426fi
427
428%preun guest-additions
429if [ $1 = 0 ]; then
430    service vboxadd-timesync stop > /dev/null 2>&1 ||:
431    /sbin/chkconfig --del vboxadd-timesync
432fi
433
434%post -n dkms-vboxadd
435set -x
436/usr/sbin/dkms --rpm_safe_upgrade add -m vboxadditions -v %{version}-%{release} ||:
437/usr/sbin/dkms --rpm_safe_upgrade build -m vboxadditions -v %{version}-%{release} ||:
438/usr/sbin/dkms --rpm_safe_upgrade install -m vboxadditions -v %{version}-%{release} ||:
439:
440
441%preun -n dkms-vboxadd
442set -x
443/usr/sbin/dkms --rpm_safe_upgrade remove -m vboxadditions -v %{version}-%{release} --all ||:
444:
445
446%endif
447
448%files
449%defattr(-,root,root)
450%config %{_sysconfdir}/vbox/vbox.cfg
451%{_bindir}/%{name}
452%{_bindir}/VBoxManage
453%{_bindir}/VBoxSDL
454%{_bindir}/VBoxHeadless
455%{_bindir}/VBoxTunctl
456%{_bindir}/VBoxNetAdpCtl
457%{_bindir}/VBoxNetDHCP
458#%{_bindir}/vboxwebsrv
459%{vboxlibdir}
460%attr(4711,root,root) %{vboxlibdir}/VBoxHeadless
461%attr(4711,root,root) %{vboxlibdir}/VBoxSDL
462%attr(4711,root,root) %{vboxlibdir}/%{name}
463%attr(4711,root,root) %{vboxlibdir}/VBoxNetAdpCtl
464%attr(4711,root,root) %{vboxlibdir}/VBoxNetDHCP
465%attr(644,root,root) %{vboxlibdir}/*.gc
466%attr(644,root,root) %{vboxlibdir}/*.r0
467%{vboxdatadir}
468# initscripts integration
469%{_initrddir}/virtualbox
470%config %{_sysconfdir}/udev/rules.d/%{name}.rules
471%dir /var/run/%{name}
472# desktop integration
473%{_iconsdir}/*.png
474%{_datadir}/applications/%{name}.desktop
475
476%files -n dkms-%{name}
477%defattr(-,root,root)
478%{_usr}/src/%{name}-%{version}-%{release}
479
480%if %{build_additions}
481%files guest-additions
482%defattr(-,root,root)
483/sbin/mount.vboxsf
484%{_initrddir}/vboxadd-timesync
485%{_sbindir}/VBoxService
486%{_bindir}/VBoxClient
487%{_bindir}/VBoxControl
488%{_sysconfdir}/security/console.perms.d/60-vboxadd.perms
489%{_sysconfdir}/udev/rules.d/vbox-additions.rules
490%{_sysconfdir}/X11/xinit.d/98vboxadd-xclient
491%{_sysconfdir}/modprobe.preload.d/vbox-guest-additions
492
493%files -n xorg-x11-drv-vboxmouse
494%defattr(-,root,root)
495%{_libdir}/xorg/modules/input/vboxmouse_drv.so
496%{_sysconfdir}/X11/xorg.conf.d/*.conf
497%{_sysconfdir}/udev/rules.d/*.rules
498%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
499
500%files -n xorg-x11-drv-vboxvideo
501%defattr(-,root,root)
502%{_libdir}/VBoxOGL*
503%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
504%{_libdir}/dri/vboxvideo_dri.so
505
506%files -n dkms-vboxadd
507%defattr(-,root,root)
508%{_usr}/src/vbox*-%{version}-%{release}
509
510%endif
511
512
513%changelog
514* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-2
515- add patch110 to fix vboxadd-timesync script
516
517* Thu Jun 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
518- new upstream release
519
520* Sat May 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.0-1
521- new upstream release
522- drop wined3d patch as the Windows guest additions provide
523  Direct3D acceleration.
524- add xorg.conf snippet for new xserver
525- vboxvfs renamed to vboxsf
526
527* Mon Apr 19 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.6-2
528- fix initscript
529
530* Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.6-1
531- new upstream release
532
533* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.10-1
534- new upstream release
535- add missing BR:
536
537* Mon Sep 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.6-1
538- new upstream release
539
540* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.4-1
541- new upstream release
542- add translated summaries and descriptions
543
544* Mon Jul 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-1
545- new upstream release
546
547* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
548- new upstream release
549
550* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-3
551- change Group: of dkms-VirtualBox to System Environment/Kernel
552
553* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-2
554- remove modprobe.d/vbox-guest-additions
555
556* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-1
557- update to 2.2.4
558
559* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-1
560- initial build for Vine Linux
561- update to 2.2.2
562
563* Wed Apr 22 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-4mdv2009.1
564+ Revision: 368679
565- Fix mkrpm template
566
567* Tue Apr 21 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-3mdv2009.1
568+ Revision: 368502
569- BuildRequires:dkms-minimal
570- Obsolete -latest dkms binary packages
571
572* Wed Apr 15 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-2mdv2009.1
573+ Revision: 367571
574- Patch15: kill vboxclient if leftover from previous X11 session
575- Patch14 (Sun): fix OpenGL support for Linux Guest additions
576- improve packaging to be more LSB compliant
577
578* Fri Apr 10 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-1mdv2009.1
579+ Revision: 365828
580- Release 2.2.0
581- enable OpenGL pass-through. Caveat : Linux guest support is not working when building guest additions with Open source edition (under investigation)
582- move location of fdi file (fix mouse integration support when using HAL)
583- merge all guest additions kernel module in one single DKMS (pterjan)
584- Enable webservice
585- Remove patch9, no longer needed (when using kernel 2.6.29.x, you MUST use kernel 2.6.29.1 or later)
586- Regenerate patches 8, 10
587- Patch11: add Wine Direct3D guest additions option (Debian)
588- Patch12: disable update notification (Debian)
589- Patch13: make network settings more intuitive (Debian)
590- Add missing dependencies in guest additions package
591- No longer use gcc 4.2, build fine with latest gcc 4.3
592- Replace source3 with upstream version
593- Update source4 to change permissions on both guest additions devices
594- Fix permissions on non .so files
595
596* Mon Mar 09 2009 Pascal Terjan <pterjan@mandriva.org> 2.1.4-5mdv2009.1
597+ Revision: 353280
598- vboxvfs needs vboxadd
599
600* Wed Mar 04 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.4-4mdv2009.1
601+ Revision: 348336
602- Force rebuild of dkms modules
603
604* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-3mdv2009.1
605+ Revision: 344966
606- Copy Module.symvers for vboxnetflt dkms build, needed with
607  CONFIG_MODVERSIONS enabled in latest cooker kernels.
608
609* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-2mdv2009.1
610+ Revision: 344896
611- Apply fix for VM load failure with kernels 2.6.29-rc5 or later
612  (#48096, http://www.virtualbox.org/ticket/3403).
613- Fix building with kernel-headers-2.6.29*
614
615* Tue Feb 17 2009 Frederik Himpe <fhimpe@mandriva.org> 2.1.4-1mdv2009.1
616+ Revision: 342236
617- Update to new version 2.1.4
618- Fix source URL
619
620* Thu Jan 22 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.2-2mdv2009.1
621+ Revision: 332593
622- Use xorg 1.6 drivers when building cooker guest addition packages
623
624* Thu Jan 22 2009 Funda Wang <fundawang@mandriva.org> 2.1.2-1mdv2009.1
625+ Revision: 332404
626- specify CC4.2
627- New version 2.1.2
628- rediff libpath patch
629
630* Sun Jan 04 2009 Colin Guthrie <cguthrie@mandriva.org> 2.1.0-5mdv2009.1
631+ Revision: 324525
632- Rebuild mouse and display drivers for xserver 1.6
633
634* Thu Dec 25 2008 Michael Scherer <misc@mandriva.org> 2.1.0-4mdv2009.1
635+ Revision: 318540
636- rebuild for new python
637
638* Fri Dec 19 2008 Frederic Crozat <fcrozat@mandriva.com> 2.1.0-3mdv2009.1
639+ Revision: 316288
640- Fix guest additions for cooker, we ship Xorg 1.5 now
641- Ship fdi file for vboxmouse
642
643* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-2mdv2009.1
644+ Revision: 316021
645- oops, finish fixing up initscript
646
647* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-1mdv2009.1
648+ Revision: 316019
649- adjust initscript and dkms.conf for the fact that there's now two necessary
650  kernel modules for the master: vboxdrv and vboxnetflt
651- drop mdvconfig.patch: this stub does nothing useful, and breaks the build
652  (see fcrozat's mail on Cooker)
653- VBoxAddIF and VBoxDeleteIF are now obsolete and not provided
654
655  + Frederic Crozat <fcrozat@mandriva.com>
656    - Release 2.1.0
657    - Regenerate patch1
658    - update buildrequires
659
660* Sun Nov 30 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.6-2mdv2009.1
661+ Revision: 308552
662- Rebuild mouse and display drivers for xserver 1.5
663
664* Wed Nov 26 2008 Funda Wang <fundawang@mandriva.org> 2.0.6-1mdv2009.1
665+ Revision: 306865
666- New version 2.0.6
667
668* Mon Nov 03 2008 Funda Wang <fundawang@mandriva.org> 2.0.4-1mdv2009.1
669+ Revision: 299348
670- New version 2.0.4
671
672* Mon Sep 15 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.2-2mdv2009.0
673+ Revision: 284854
674- Patch8: disable version check at startup
675
676* Sat Sep 13 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.2-1mdv2009.0
677+ Revision: 284544
678- Update to bugfix update 2.0.2
679
680* Tue Sep 09 2008 Olivier Blin <oblin@mandriva.com> 2.0.0-3mdv2009.0
681+ Revision: 283015
682- build guest additions on x86_64 too (#43593)
683
684  + Frederic Crozat <fcrozat@mandriva.com>
685    - Patch7: fix QT4 detection on x86-64 on Mandriva 2008.1
686
687* Thu Sep 04 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.0-1mdv2009.0
688+ Revision: 280850
689- Fix BuildRequires
690- Release 2.0.0
691- Remove patches 3, 7 (merged upstream)
692
693* Mon Sep 01 2008 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 1.6.4-4mdv2009.0
694+ Revision: 278071
695- Added patch to allow VirtualBox kernel module to build with
696  Linux 2.6.27
697
698  + Pixel <pixel@mandriva.com>
699    - increase release number
700    - use gcc4.2 to build the recompiler (not ported to gcc 4.3 yet)
701
702* Wed Aug 06 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-2mdv2009.0
703+ Revision: 264273
704- create /var/run/VirtualBox (#41963)
705- use tunctl from the tunctl package while VBoxTunctl does not build
706
707* Tue Aug 05 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-1mdv2009.0
708+ Revision: 264016
709- do not include VBoxTunctl for now (build is broken in upstream tarball)
710- rediff misc_register patch (the register part has been implemented upstream, I should submit the deregister hunks)
711- fix 1.6.4 build by not building tunctl (some Makefile.kmk are missing)
712- 1.6.4
713
714* Tue Jul 29 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.2-2mdv2009.0
715+ Revision: 252777
716- Don't use gcc 3.3 for build on 2008.1 or earlier
717
718* Wed Jul 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.2-1mdv2009.0
719+ Revision: 232889
720- set again linux sources path in configure
721- use gcc 3.3 to build the recompiler (not ported to gcc 4.3 yet)
722- use kernel-devel-latest instead of kernel-source-latest
723- use a prepared copy of the linux tree (for linux/bounds.h)
724
725  + Frederic Crozat <fcrozat@mandriva.com>
726    - Release 1.6.2
727    - Regenerate patch5
728    - Fix duplicated line in specfile
729
730  + Pixel <pixel@mandriva.com>
731    - rpm filetriggers deprecates update_menus/update_scrollkeeper/update_mime_database/update_icon_cache/update_desktop_database/post_install_gconf_schemas
732
733* Fri May 16 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-4mdv2009.0
734+ Revision: 208160
735- Fix seamless mode in guest additions subpackage
736
737* Thu May 15 2008 Anssi Hannula <anssi@mandriva.org> 1.6.0-3mdv2009.0
738+ Revision: 207692
739- rename VBoxAddIF.sh and VBoxDeleteIF.sh to VBoxAddIF and VBoxDeleteIF
740  to match original names and documentation
741
742* Wed May 14 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-2mdv2009.0
743+ Revision: 207235
744- Replace source1 with patch 6 (use up to date VBox.sh script)
745- Ensure VBoxAddIF/VBoxDeleteIF scripts are packaged, as well as VBoxTunctl (Mdv bug #40769)
746- package VBoxHeadless (Mdv bug #40771)
747
748* Fri May 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.0-1mdv2009.0
749+ Revision: 205313
750- try harder to disable additions on x86_64
751- buildrequire libxslt-devel
752- adapt to vboxadd-xclient being renamed as VBoxClient
753- rediff futex patch
754- rediff misc_register patch
755- 1.6.0
756- revert BUILT_MODULE_NAME addition, the bug is fixed in dkms
757
758  + Anssi Hannula <anssi@mandriva.org>
759    - add BUILT_MODULE_NAME to dkms.conf of vboxadd and vboxvfs (fixes DKMS
760      error)
761
762* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.6-1mdv2008.1
763+ Revision: 175619
764- 1.5.6
765- rediff KERNELRELEASE patch
766
767* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-5mdv2008.1
768+ Revision: 175610
769- try to start dkms instead of vboxadd in vboxadd-timesync service (since modules are loaded from modprobe.preload.d, #36728)
770
771* Fri Feb 08 2008 Thierry Vignaud <tvignaud@mandriva.com> 1.5.4-4mdv2008.1
772+ Revision: 163970
773- drop old menu
774
775  + Frederic Crozat <fcrozat@mandriva.com>
776    - Really disable pulseaudio support on 2008.0 or older
777
778* Thu Jan 10 2008 Frederic Crozat <fcrozat@mandriva.com> 1.5.4-3mdv2008.1
779+ Revision: 147602
780- Use correct version of x11 mouse and video additional driver when used on 2008.1 (xorg 1.4) and 2008.0
781- Only build pulseaudio support for 2008.1
782
783* Wed Jan 09 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-2mdv2008.1
784+ Revision: 147006
785- fix dkms build for kernels different from running kernel
786
787* Thu Jan 03 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-1mdv2008.1
788+ Revision: 142711
789- buildrequire pulseaudio-devel
790- rediff libpath patch
791- remove 2.6.24 build fix, fixed upstream
792- 1.5.4
793- restore BuildRoot
794
795  + Pascal Terjan <pterjan@mandriva.org>
796    - Switch to Debian patch for 2.6.24
797    - Re-create the 2.6.24 patch, some bits got lost
798
799  + Thierry Vignaud <tvignaud@mandriva.com>
800    - kill re-definition of %%buildroot on Pixel's request
801    - kill explicit icon extension
802
803  + Giuseppe Ghibò <ghibo@mandriva.com>
804    - Use kernel-source-latest in BuildRequires as conditional.
805    - Add conditional build flags for older release.
806    - Let Patch5 conditional.
807
808* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-3mdv2008.1
809+ Revision: 114076
810- Improve 2.6.24 patch so that it should still build with older kernels
811
812* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-2mdv2008.1
813+ Revision: 114047
814- Fix other parts to build with 2.6.24
815- Fix vboxdrv for 2.6.24
816
817* Tue Nov 13 2007 Olivier Blin <oblin@mandriva.com> 1.5.2-1mdv2008.1
818+ Revision: 108363
819- remove keyboards patch (was from upstream svn)
820- rediff kernelrelease patch
821- rediff libpath patch
822- 1.5.2
823
824* Thu Oct 04 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-6mdv2008.0
825+ Revision: 95447
826- really apply misc_register patch (so that vboxadd devices are automatically created)
827- add release in dkms PACKAGE_VERSION to ease upgrades
828
829* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-5mdv2008.0
830+ Revision: 93837
831- require kmod(vboxdrv) instead of dkms package
832- do not mark initscript as config file
833- move initscripts and udev rules out of dkms package (so that it works when using dkms prebuilt modules)
834
835* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-4mdv2008.0
836+ Revision: 93812
837- add vboxadd-timesync service
838- add pam_console perms file to assign vboxadd device to console user
839- use misc_register() to register vboxadd device so that /dev/vboxadd gets created automatically by udev
840
841* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-3mdv2008.0
842+ Revision: 93770
843- add vboxadd-xclient xinit.d script
844- release new additions, but we still need to fix mknod for vboxadd
845  (or use device_create() in kernel module), set console perms for
846  vboxadd in console.perms.d, and add timesync initscript
847- make guest additions package require X11 drivers
848- make x11 driver packages suggest virtualbox-guest-additions
849- add virtualbox-guest-additions package (with xclient, timesync, mount.vboxsf)
850- add dkms-vboxadd and dkms-vboxvfs packages
851
852* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-2mdv2008.0
853+ Revision: 93534
854- build additions on ix86 only
855- fix support for Brazilian, Belgian, US intl and US dvorak keyboards and add support for multimedia keys (from upstream SVN)
856- buildrequire libstdc++-static-devel
857- buildrequire libxt-devel
858- buildrequire kernel-source-latest, since iurt/urpmi don't install latest kernel-source automatically
859- buildrequire kernel-source
860- package mouse guest addition in x11-driver-input-vboxmouse
861- package video guest addition in x11-driver-video-vboxvideo
862- build VirtualBox additions
863
864* Mon Sep 03 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-1mdv2008.0
865+ Revision: 78607
866- drop libstdc++5 BuildRequires
867- drop unapplied x86_64 NMI watchdog disabling patch (merged upstream)
868- 1.5.0
869- rediff mdvconfig patch
870
871  + Thierry Vignaud <tvignaud@mandriva.com>
872    - kill desktop-file-validate's 'warning: key "Encoding" in group "Desktop Entry" is deprecated'
873
874* Fri Jun 08 2007 Per Øyvind Karlsen <peroyvind@mandriva.org> 1.4.0-1mdv2008.0
875+ Revision: 37085
876- from Jos?\195?\169 Melo <mmodem00@gmail.com>:
877        o 1.4.0
878        o update patch:2 since is needed to load (modprobe) vbox driver in kernel-2.6.17
879        o remove patch1 since is becomes obsolete with this new version,and continues installing and running stable no matter if is kernel-2.6.17 or greater
880        o add missing buildrequire hal-devel
881
882
883* Thu Mar 15 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.8-1mdv2007.1
884+ Revision: 144313
885- add should-start: dkms to initscript (#29523)
886- 1.3.8
887  * hard reset network device on reboot
888  * fix issues with IBM JVM 1.4.2 in Linux guests
889  * add support for X.org 7.2.x in Linux guest additions
890
891* Fri Mar 02 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.6-1mdv2007.1
892+ Revision: 131492
893- disable NMIs on Core 2 platforms too
894- 1.3.6
895  * fix some GUI issues
896  * fix OpenBSD 4.0 support
897  * fix CD/DVD-ROM detection in Windows Vista guests
898  * fix networking issues with Windows NT 4.0 guests
899  * fix some ALSA problems that could cause system reboots
900
901* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.4-1mdv2007.1
902+ Revision: 119895
903- 1.3.4
904
905* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070209-1mdv2007.1
906+ Revision: 119017
907- SVN updates (2007/02/09):
908  * additional 64-bit fixes
909  * asynchronous packets transmission in NIC code
910
911* Sat Feb 03 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070202-1mdv2007.1
912+ Revision: 116064
913- various 64-bit fixes
914- updates from SVN (2007/02/02):
915  * initial 64-bit host support
916  * fix IDE for Open Solaris 10
917  * add VDI compacting to the GUI
918
919* Sat Jan 27 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3-1mdv2007.1
920+ Revision: 114276
921- initial mandriva linux package
922
Note: See TracBrowser for help on using the repository browser.