source: projects/specs/trunk/V/VirtualBox/VirtualBox-vl.spec @ 1181

Revision 1181, 31.7 KB checked in by daisuke, 14 years ago (diff)

VirtualBox?: update to 3.2.4

Line 
1%define version 3.2.4
2%define release 1%{?_dist_release}
3
4%define kname   vboxdrv
5%define oname   VirtualBox
6%define srcname %{oname}-%{version}-OSE
7%define distname        %{oname}-%{version}_OSE
8%define dirname vbox-ose
9%define pkgver  %{version}
10
11%define vboxlibdir      %{_libdir}/%{name}
12%define vboxdatadir     %{_datadir}/%{name}
13
14%define build_additions 1
15
16%ifarch %{ix86}
17%define vbox_platform linux.x86
18%endif
19%ifarch x86_64
20%define vbox_platform linux.amd64
21%endif
22
23# nuke vbox-specific dependencies
24%define _provides_exceptions ^VBox
25%define _requires_exceptions ^VBox
26
27Summary:        A general-purpose full virtualizer for x86 hardware
28Summary(ja):    汎用の x86 ハードウエア完全仮想化ソフトウエア
29Name:           VirtualBox
30Version:        %{version}
31Release:        %{release}
32License:        GPL
33Group:          Development/Tools
34Url:            http://www.virtualbox.org/
35
36Source0:        http://download.virtualbox.org/virtualbox/%ver/%{srcname}.tar.bz2
37Source2:        virtualbox.init.vine
38Source4:        60-vboxadd.perms
39Source10:       VirtualBox.png
40Patch2:         VirtualBox-1.5.6_OSE-kernelrelease.patch
41Patch4:         VirtualBox-1.6.0_OSE-futex.patch
42Patch5:         virtualbox-fix-vboxadd-req.patch
43# (fc) 1.6.0-2mdv fix initscript name in VBox.sh script
44Patch6:         VirtualBox-1.6.0_OSE-initscriptname.patch
45# (hk) fix build kernel-headers-2.6.29*
46Patch10:        VirtualBox-kernel-headers-2.6.29.patch
47# (fc) 2.2.0-1mdv disable update notification (Debian)
48Patch12:        16-no-update.patch
49
50# vine
51Patch100:       VirtualBox-2.2.2-buildfix.patch
52
53BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
54ExclusiveArch:  %{ix86} x86_64
55Requires:       dkms-%{name} = %{version}-%{release}
56BuildRequires:  dev86, iasl
57BuildRequires:  zlib-devel
58BuildRequires:  libXcursor-devel
59BuildRequires:  libXmu-devel
60BuildRequires:  SDL-devel
61BuildRequires:  qt4-devel
62BuildRequires:  libIDL-devel
63BuildRequires:  e2fsprogs-devel
64BuildRequires:  libxslt-devel
65BuildRequires:  xerces-c-devel, xalan-c-devel
66BuildRequires:  hal-devel
67BuildRequires:  libXt-devel
68BuildRequires:  libstdc++34-devel
69BuildRequires:  python-devel
70BuildRequires:  libcap-devel
71BuildRequires:  pulseaudio-libs-devel
72BuildRequires:  kernel-devel
73BuildRequires:  mesa-libGL-devel
74BuildRequires:  mesa-libGLU-devel
75BuildRequires:  gsoap-devel
76BuildRequires:  curl-devel
77BuildRequires:  alsa-lib-devel
78BuildRequires:  dkms
79BuildRequires:  kBuild >= 0.1.5p2
80BuildRequires:  yasm
81BuildRequires:  qt4-designer
82%ifarch x86_64
83BuildRequires:  compat32-glibc-devel
84%endif
85
86%description
87VirtualBox Open Source Edition (OSE) is a general-purpose full
88virtualizer for x86 hardware.
89
90%description -l ja
91VirtualBox Open Source Edition (OSE) は汎用の x86 ハードウエア
92完全仮想化ソフトウエアです。
93
94%package -n     dkms-%{name}
95Summary:        VirtualBox OSE kernel module
96Summary(ja):    VirtualBox OSE カーネルモジュール
97Group:          System Environment/Kernel
98Requires(post):   dkms
99Requires(preun):  dkms
100
101%description -n dkms-%{name}
102Kernel support for VirtualBox OSE.
103
104%description -l ja -n dkms-%{name}
105VirtualBox OSE のカーネルサポートパッケージです。
106
107%if %{build_additions}
108%package        guest-additions
109Summary:        Additions for VirtualBox OSE guest systems
110Summary(ja):    VirtualBox OSE ゲストシステム用の追加モジュール
111Group:          System Environment/Kernel
112Requires:       dkms-vboxadd = %{version}-%{release}
113Requires:       dkms-vboxvfs = %{version}-%{release}
114Requires:       dkms-vboxvideo = %{version}-%{release}
115Requires:       xorg-x11-drv-vboxmouse
116Requires:       xorg-x11-drv-vboxvideo
117Requires:       xorg-x11-server-utils
118
119%description    guest-additions
120This packages contains additions for VirtualBox OSE guest systems.
121It allows to share files with the host system, copy/paste between
122guest and host, and sync time with host.
123
124%description -l ja guest-additions
125このパッケージには VirtualBox OSE ゲストシステムのための追加モジュール
126が含まれています。これを利用することでホストシステムとファイルを共有し
127たり、ゲスト/ホスト間でカット&ペーストを行ったり、ホストと時刻同期をし
128たりすることができます。
129
130%package -n     dkms-vboxadd
131Summary:        Kernel module for VirtualBox OSE additions
132Summary(ja):    VirtualBox OSE additions のカーネルモジュール
133Group:          System Environment/Kernel
134Requires(post):   dkms
135Requires(preun):  dkms
136Provides:       dkms-vboxvfs = %{version}-%{release}
137Obsoletes:      dkms-vboxvfs < %{version}-%{release}
138Provides:       dkms-vboxsf = %{version}-%{release}
139Obsoletes:      dkms-vboxsf < %{version}-%{release}
140Provides:       dkms-vboxvideo = %{version}-%{release}
141Obsoletes:      dkms-vboxvideo < %{version}-%{release}
142
143%description -n dkms-vboxadd
144Kernel module for VirtualBox OSE additions.
145
146%description -l ja -n dkms-vboxadd
147VirtualBox OSE 追加モジュールのためのカーネルモジュールです。
148
149%package -n     xorg-x11-drv-vboxmouse
150Summary:        X.org X11 input driver for VirtualBox mouse
151Summary:        X.org X11 VirtualBox マウス入力ドライバ
152Group:          User Interface/X Hardware Support
153Requires:       %{name}-guest-additions
154
155%description -n xorg-x11-drv-vboxmouse
156The X.org driver for mouse in VirtualBox guests
157
158%description -l ja -n xorg-x11-drv-vboxmouse
159VirtualBox のゲストシステム用の X.org マウスドライバです。
160
161%package -n     xorg-x11-drv-vboxvideo
162Summary:        X.org X11 video driver for VirtualBox guests
163Summary(ja):    X.org X11 VirtualBox ビデオドライバ
164Group:          User Interface/X Hardware Support
165Requires:       %{name}-guest-additions
166
167%description -n xorg-x11-drv-vboxvideo
168The X.org driver for video in VirtualBox guests
169
170%description -l ja -n xorg-x11-drv-vboxvideo
171VirtualBox のゲストシステム用の X.org ビデオドライバです。
172
173%endif
174
175%prep
176%setup -q -n %{distname}
177%patch2 -p1 -b .kernelrelease
178%patch4 -p1 -b .futex
179%patch5 -p1 -b .fix-timesync-req
180%patch6 -p1 -b .initscriptname
181%patch10 -p1 -b .kernel-headers-2.6.29
182%patch12 -p1 -b .disable-update
183%patch100 -p1 -b .buildfix
184
185# remove prebuilt binaries
186rm -rf kBuild tools
187
188cat << EOF > LocalConfig.kmk
189VBOX_PATH_APP_PRIVATE_ARCH:=%{vboxlibdir}
190VBOX_WITH_ORIGIN:=
191VBOX_WITH_RUNPATH:=%{vboxlibdir}
192VBOX_PATH_APP_PRIVATE:=%{vboxdatadir}
193VBOX_WITH_TESTCASES:=
194VBOX_WITH_TESTSUITE:=
195EOF
196
197%build
198./configure --disable-kmods --with-linux=$PWD/fake-linux
199
200%if !%{build_additions}
201sed -rie 's/(VBOX_WITH_LINUX_ADDITIONS\s+:=\s+).*/\1/' AutoConfig.kmk
202echo VBOX_WITHOUT_ADDITIONS=1 >> LocalConfig.kmk
203%endif
204
205. ./env.sh
206kmk KBUILD_VERBOSE=2 \
207    TOOL_YASM_AS=yasm \
208    VBOX_WITH_REGISTRATION_REQUEST= \
209    %{?_smp_mflags} all
210
211%install
212rm -rf %{buildroot}
213
214# install vbox components
215mkdir -p %{buildroot}%{vboxlibdir} %{buildroot}%{vboxdatadir}
216
217(cd out/%{vbox_platform}/release/bin && tar cf - --exclude=additions .) | \
218(cd %{buildroot}%{vboxlibdir} && tar xf -)
219
220# move noarch files to vboxdatadir
221mv %{buildroot}%{vboxlibdir}/{VBox*.sh,nls,*.desktop,*.png} %{buildroot}%{vboxdatadir}
222
223# install service
224mkdir -p %{buildroot}%{_initrddir}
225install -m755 %{SOURCE2} %{buildroot}%{_initrddir}/virtualbox
226
227# install wrappers
228mkdir -p %{buildroot}%{_sysconfdir}/vbox
229cat > %{buildroot}%{_sysconfdir}/vbox/vbox.cfg << EOF
230# VirtualBox installation directory
231INSTALL_DIR="%{vboxlibdir}"
232EOF
233mkdir -p %{buildroot}%{_bindir}
234ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/%{name}
235ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxManage
236ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxSDL
237ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/VBoxHeadless
238#ln -s %{vboxdatadir}/VBox.sh %{buildroot}%{_bindir}/vboxwebsrv
239
240# provide network control tools in bindir
241ln -s %{vboxlibdir}/VBoxTunctl %{buildroot}%{_bindir}/VBoxTunctl
242ln -s %{vboxlibdir}/VBoxNetAdpCtl %{buildroot}%{_bindir}/VBoxNetAdpCtl
243ln -s %{vboxlibdir}/VBoxNetDHCP %{buildroot}%{_bindir}/VBoxNetDHCP
244
245install -d %{buildroot}/var/run/%{name}
246
247# install dkms sources
248mkdir -p %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
249cat > vboxbuild << EOF
250#!/bin/sh
251set -e
252make -C %{kname} KERN_DIR=\$1
253cp -f %{kname}/Module.symvers vboxnetflt
254cp -f %{kname}/Module.symvers vboxnetadp
255make -C vboxnetflt KERN_DIR=\$1
256make -C vboxnetadp KERN_DIR=\$1
257EOF
258install -m 0755 vboxbuild %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}
259mv %{buildroot}%{vboxlibdir}/src/* %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
260cat > %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/dkms.conf << EOF
261MAKE[0]="./vboxbuild \$kernel_source_dir"
262PACKAGE_NAME=%{name}
263PACKAGE_VERSION=%{version}-%{release}
264DEST_MODULE_LOCATION[0]=/kernel/3rdparty/vbox
265BUILT_MODULE_LOCATION[0]=%{kname}/
266BUILT_MODULE_NAME[0]=%{kname}
267DEST_MODULE_LOCATION[1]=/kernel/3rdparty/vbox
268BUILT_MODULE_LOCATION[1]=vboxnetflt/
269BUILT_MODULE_NAME[1]=vboxnetflt
270DEST_MODULE_LOCATION[2]=/kernel/3rdparty/vbox
271BUILT_MODULE_LOCATION[2]=vboxnetadp/
272BUILT_MODULE_NAME[2]=vboxnetadp
273AUTOINSTALL=yes
274EOF
275
276# install udev rules
277mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d/
278cat > %{buildroot}%{_sysconfdir}/udev/rules.d/%{name}.rules << EOF
279KERNEL=="%{kname}", MODE="0666"
280EOF
281cat > %{buildroot}%{_sysconfdir}/udev/rules.d/vbox-additions.rules << EOF
282KERNEL=="vboxguest|vboxuser", ENV{ACL_MANAGE}="1"
283EOF
284
285# install additions
286%if %{build_additions}
287mkdir -p %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty
288install -m755 src/VBox/Additions/linux/installer/vboxadd-service.sh %{buildroot}%{_initrddir}/vboxadd-timesync
289#install -m755 src/VBox/Additions/x11/Installer/VBoxRandR.sh %{buildroot}%{_bindir}/VBoxRandR
290install -m755 src/VBox/Additions/linux/installer/90-vboxguest.fdi %{buildroot}%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
291mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d/
292install -m755 src/VBox/Additions/linux/installer/70-xorg-vboxmouse.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
293mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
294install -m755 src/VBox/Additions/x11/Installer/50-vboxmouse.conf %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
295
296install -d %{buildroot}%{_sysconfdir}/X11/xinit.d
297install -m755 src/VBox/Additions/x11/Installer/98vboxadd-xclient %{buildroot}%{_sysconfdir}/X11/xinit.d
298
299pushd out/%{vbox_platform}/release/bin/additions
300  install -d %{buildroot}/sbin %{buildroot}%{_sbindir} %{buildroot}/%{_libdir}/dri
301  install -m755 mount.vboxsf %{buildroot}/sbin/mount.vboxsf
302  install -m755 VBoxService %{buildroot}%{_sbindir}
303
304  install -d %{buildroot}%{_sysconfdir}/security/console.perms.d/
305  install -m644 %{SOURCE4} %{buildroot}%{_sysconfdir}/security/console.perms.d/
306
307  install -m755 VBoxClient %{buildroot}%{_bindir}
308  install -m755 VBoxControl %{buildroot}%{_bindir}
309
310  install -m755 VBoxOGL*.so %{buildroot}%{_libdir}
311  ln -s -f ../VBoxOGL.so %{buildroot}%{_libdir}/dri/vboxvideo_dri.so
312
313  install -d %{buildroot}%{_sysconfdir}/modprobe.preload.d
314  cat > %{buildroot}%{_sysconfdir}/modprobe.preload.d/vbox-guest-additions << EOF
315vboxadd
316EOF
317
318  install -d %{buildroot}%{_libdir}/xorg/modules/{input,drivers}
319  install vboxmouse_drv_17.so %{buildroot}%{_libdir}/xorg/modules/input/vboxmouse_drv.so
320  install vboxvideo_drv_17.so %{buildroot}%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
321
322  mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}
323  cat > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
324PACKAGE_NAME=vboxadditions
325PACKAGE_VERSION=%{version}-%{release}
326MAKE[0]="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxguest &&
327cp
328\$dkms_tree/\$module/\$module_version/build/vboxguest/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxsf &&
329make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxsf &&
330cp \$dkms_tree/\$module/\$module_version/build/vboxsf/Module.symvers \$dkms_tree/\$module/\$module_version/build/vboxvideo &&
331make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo"
332EOF
333
334  i=0
335  for kmod in vboxguest vboxsf vboxvideo; do
336    mkdir -p %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod
337    cp -a src/$kmod/* %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/$kmod/
338    cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
339DEST_MODULE_LOCATION[$i]=/kernel/3rdparty/vbox
340BUILT_MODULE_LOCATION[$i]=$kmod/
341BUILT_MODULE_NAME[$i]=$kmod
342EOF
343    i=$((i+1))
344  done
345  cat >> %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/dkms.conf << EOF
346CLEAN="make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxguest clean &&
347make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxsf clean &&
348make -C \$kernel_source_dir M=\$dkms_tree/\$module/\$module_version/build/vboxvideo clean "
349AUTOINSTALL=yes
350EOF
351popd
352  sed 's/^\(.package.*-kernel-\)\(.*-latest\)\(.*\)\\$/\1\2\3Obsoletes: vboxsf-kernel-\2 vboxvideo-kernel-\2\\n\\/' /etc/dkms/template-dkms-mkrpm.spec > %{buildroot}%{_usr}/src/vboxadditions-%{version}-%{release}/vboxadditions-dkms-mkrpm.spec
353%endif
354
355# install icons
356mkdir -p %{buildroot}%{_iconsdir}
357install -m644 %{SOURCE10} %{buildroot}%{_iconsdir}/
358
359# install menu entries
360
361mkdir -p %{buildroot}%{_datadir}/applications
362cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
363[Desktop Entry]
364Name=VirtualBox
365Comment=Full virtualizer for x86 hardware
366Comment[ja]=x86 ハードウエアの完全仮想化システム
367Exec=%{_bindir}/%{name}
368Icon=%{name}
369Type=Application
370Terminal=false
371Categories=System;Emulator;
372EOF
373
374# add missing makefile for kernel module
375install -m644 src/VBox/HostDrivers/Support/linux/Makefile %{buildroot}%{_usr}/src/%{name}-%{version}-%{release}/
376
377# remove unpackaged files
378rm -rf %{buildroot}%{vboxlibdir}/{src,sdk,testcase}
379rm  -f %{buildroot}%{vboxlibdir}/tst*
380rm  -f %{buildroot}%{vboxlibdir}/vboxkeyboard.tar.gz
381rm  -f %{buildroot}%{vboxlibdir}/SUP*
382rm  -f %{buildroot}%{vboxlibdir}/xpidl
383
384%clean
385rm -rf %{buildroot}
386
387%post
388/sbin/chkconfig --add virtualbox
389
390%postun
391if [ "$1" -ge "1" ]; then
392  /sbin/service virtualbox condrestart > /dev/null 2>&1 || :
393fi
394
395%preun
396if [ $1 = 0 ]; then
397    service virtualbox stop > /dev/null 2>&1 ||:
398    /sbin/chkconfig --del virtualbox
399fi
400       
401
402%post -n dkms-%{name}
403set -x
404/usr/sbin/dkms --rpm_safe_upgrade add -m %{name} -v %{version}-%{release} ||:
405/usr/sbin/dkms --rpm_safe_upgrade build -m %{name} -v %{version}-%{release} ||:
406/usr/sbin/dkms --rpm_safe_upgrade install -m %{name} -v %{version}-%{release} --force ||:
407/sbin/modprobe %{kname} >/dev/null 2>&1 || :
408/sbin/modprobe vboxnetflt >/dev/null 2>&1 || :
409
410%preun -n dkms-%{name}
411# rmmod can fail
412/sbin/rmmod vboxnetflt >/dev/null 2>&1
413/sbin/rmmod %{kname} >/dev/null 2>&1
414set -x
415/usr/sbin/dkms --rpm_safe_upgrade remove -m %{name} -v %{version}-%{release} --all || :
416
417%if %{build_additions}
418%post guest-additions
419/sbin/chkconfig --add vboxadd-timesync
420
421%postun guest-additions
422if [ "$1" -ge "1" ]; then
423  /sbin/service vboxadd-timesync condrestart > /dev/null 2>&1 || :
424fi
425
426%preun guest-additions
427if [ $1 = 0 ]; then
428    service vboxadd-timesync stop > /dev/null 2>&1 ||:
429    /sbin/chkconfig --del vboxadd-timesync
430fi
431
432%post -n dkms-vboxadd
433set -x
434/usr/sbin/dkms --rpm_safe_upgrade add -m vboxadditions -v %{version}-%{release} ||:
435/usr/sbin/dkms --rpm_safe_upgrade build -m vboxadditions -v %{version}-%{release} ||:
436/usr/sbin/dkms --rpm_safe_upgrade install -m vboxadditions -v %{version}-%{release} ||:
437:
438
439%preun -n dkms-vboxadd
440set -x
441/usr/sbin/dkms --rpm_safe_upgrade remove -m vboxadditions -v %{version}-%{release} --all ||:
442:
443
444%endif
445
446%files
447%defattr(-,root,root)
448%config %{_sysconfdir}/vbox/vbox.cfg
449%{_bindir}/%{name}
450%{_bindir}/VBoxManage
451%{_bindir}/VBoxSDL
452%{_bindir}/VBoxHeadless
453%{_bindir}/VBoxTunctl
454%{_bindir}/VBoxNetAdpCtl
455%{_bindir}/VBoxNetDHCP
456#%{_bindir}/vboxwebsrv
457%{vboxlibdir}
458%attr(4711,root,root) %{vboxlibdir}/VBoxHeadless
459%attr(4711,root,root) %{vboxlibdir}/VBoxSDL
460%attr(4711,root,root) %{vboxlibdir}/%{name}
461%attr(4711,root,root) %{vboxlibdir}/VBoxNetAdpCtl
462%attr(4711,root,root) %{vboxlibdir}/VBoxNetDHCP
463%attr(644,root,root) %{vboxlibdir}/*.gc
464%attr(644,root,root) %{vboxlibdir}/*.r0
465%{vboxdatadir}
466# initscripts integration
467%{_initrddir}/virtualbox
468%config %{_sysconfdir}/udev/rules.d/%{name}.rules
469%dir /var/run/%{name}
470# desktop integration
471%{_iconsdir}/*.png
472%{_datadir}/applications/%{name}.desktop
473
474%files -n dkms-%{name}
475%defattr(-,root,root)
476%{_usr}/src/%{name}-%{version}-%{release}
477
478%if %{build_additions}
479%files guest-additions
480%defattr(-,root,root)
481/sbin/mount.vboxsf
482%{_initrddir}/vboxadd-timesync
483%{_sbindir}/VBoxService
484%{_bindir}/VBoxClient
485%{_bindir}/VBoxControl
486%{_sysconfdir}/security/console.perms.d/60-vboxadd.perms
487%{_sysconfdir}/udev/rules.d/vbox-additions.rules
488%{_sysconfdir}/X11/xinit.d/98vboxadd-xclient
489%{_sysconfdir}/modprobe.preload.d/vbox-guest-additions
490
491%files -n xorg-x11-drv-vboxmouse
492%defattr(-,root,root)
493%{_libdir}/xorg/modules/input/vboxmouse_drv.so
494%{_sysconfdir}/X11/xorg.conf.d/*.conf
495%{_sysconfdir}/udev/rules.d/*.rules
496%{_datadir}/hal/fdi/policy/20thirdparty/90-vboxguest.fdi
497
498%files -n xorg-x11-drv-vboxvideo
499%defattr(-,root,root)
500%{_libdir}/VBoxOGL*
501%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
502%{_libdir}/dri/vboxvideo_dri.so
503
504%files -n dkms-vboxadd
505%defattr(-,root,root)
506%{_usr}/src/vbox*-%{version}-%{release}
507
508%endif
509
510
511%changelog
512* Thu Jun 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
513- new upstream release
514
515* Sat May 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.0-1
516- new upstream release
517- drop wined3d patch as the Windows guest additions provide
518  Direct3D acceleration.
519- add xorg.conf snippet for new xserver
520- vboxvfs renamed to vboxsf
521
522* Mon Apr 19 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.6-2
523- fix initscript
524
525* Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.6-1
526- new upstream release
527
528* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.10-1
529- new upstream release
530- add missing BR:
531
532* Mon Sep 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.6-1
533- new upstream release
534
535* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.4-1
536- new upstream release
537- add translated summaries and descriptions
538
539* Mon Jul 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-1
540- new upstream release
541
542* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
543- new upstream release
544
545* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-3
546- change Group: of dkms-VirtualBox to System Environment/Kernel
547
548* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-2
549- remove modprobe.d/vbox-guest-additions
550
551* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-1
552- update to 2.2.4
553
554* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-1
555- initial build for Vine Linux
556- update to 2.2.2
557
558* Wed Apr 22 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-4mdv2009.1
559+ Revision: 368679
560- Fix mkrpm template
561
562* Tue Apr 21 2009 Pascal Terjan <pterjan@mandriva.org> 2.2.0-3mdv2009.1
563+ Revision: 368502
564- BuildRequires:dkms-minimal
565- Obsolete -latest dkms binary packages
566
567* Wed Apr 15 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-2mdv2009.1
568+ Revision: 367571
569- Patch15: kill vboxclient if leftover from previous X11 session
570- Patch14 (Sun): fix OpenGL support for Linux Guest additions
571- improve packaging to be more LSB compliant
572
573* Fri Apr 10 2009 Frederic Crozat <fcrozat@mandriva.com> 2.2.0-1mdv2009.1
574+ Revision: 365828
575- Release 2.2.0
576- enable OpenGL pass-through. Caveat : Linux guest support is not working when building guest additions with Open source edition (under investigation)
577- move location of fdi file (fix mouse integration support when using HAL)
578- merge all guest additions kernel module in one single DKMS (pterjan)
579- Enable webservice
580- Remove patch9, no longer needed (when using kernel 2.6.29.x, you MUST use kernel 2.6.29.1 or later)
581- Regenerate patches 8, 10
582- Patch11: add Wine Direct3D guest additions option (Debian)
583- Patch12: disable update notification (Debian)
584- Patch13: make network settings more intuitive (Debian)
585- Add missing dependencies in guest additions package
586- No longer use gcc 4.2, build fine with latest gcc 4.3
587- Replace source3 with upstream version
588- Update source4 to change permissions on both guest additions devices
589- Fix permissions on non .so files
590
591* Mon Mar 09 2009 Pascal Terjan <pterjan@mandriva.org> 2.1.4-5mdv2009.1
592+ Revision: 353280
593- vboxvfs needs vboxadd
594
595* Wed Mar 04 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.4-4mdv2009.1
596+ Revision: 348336
597- Force rebuild of dkms modules
598
599* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-3mdv2009.1
600+ Revision: 344966
601- Copy Module.symvers for vboxnetflt dkms build, needed with
602  CONFIG_MODVERSIONS enabled in latest cooker kernels.
603
604* Wed Feb 25 2009 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 2.1.4-2mdv2009.1
605+ Revision: 344896
606- Apply fix for VM load failure with kernels 2.6.29-rc5 or later
607  (#48096, http://www.virtualbox.org/ticket/3403).
608- Fix building with kernel-headers-2.6.29*
609
610* Tue Feb 17 2009 Frederik Himpe <fhimpe@mandriva.org> 2.1.4-1mdv2009.1
611+ Revision: 342236
612- Update to new version 2.1.4
613- Fix source URL
614
615* Thu Jan 22 2009 Frederic Crozat <fcrozat@mandriva.com> 2.1.2-2mdv2009.1
616+ Revision: 332593
617- Use xorg 1.6 drivers when building cooker guest addition packages
618
619* Thu Jan 22 2009 Funda Wang <fundawang@mandriva.org> 2.1.2-1mdv2009.1
620+ Revision: 332404
621- specify CC4.2
622- New version 2.1.2
623- rediff libpath patch
624
625* Sun Jan 04 2009 Colin Guthrie <cguthrie@mandriva.org> 2.1.0-5mdv2009.1
626+ Revision: 324525
627- Rebuild mouse and display drivers for xserver 1.6
628
629* Thu Dec 25 2008 Michael Scherer <misc@mandriva.org> 2.1.0-4mdv2009.1
630+ Revision: 318540
631- rebuild for new python
632
633* Fri Dec 19 2008 Frederic Crozat <fcrozat@mandriva.com> 2.1.0-3mdv2009.1
634+ Revision: 316288
635- Fix guest additions for cooker, we ship Xorg 1.5 now
636- Ship fdi file for vboxmouse
637
638* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-2mdv2009.1
639+ Revision: 316021
640- oops, finish fixing up initscript
641
642* Fri Dec 19 2008 Adam Williamson <awilliamson@mandriva.org> 2.1.0-1mdv2009.1
643+ Revision: 316019
644- adjust initscript and dkms.conf for the fact that there's now two necessary
645  kernel modules for the master: vboxdrv and vboxnetflt
646- drop mdvconfig.patch: this stub does nothing useful, and breaks the build
647  (see fcrozat's mail on Cooker)
648- VBoxAddIF and VBoxDeleteIF are now obsolete and not provided
649
650  + Frederic Crozat <fcrozat@mandriva.com>
651    - Release 2.1.0
652    - Regenerate patch1
653    - update buildrequires
654
655* Sun Nov 30 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.6-2mdv2009.1
656+ Revision: 308552
657- Rebuild mouse and display drivers for xserver 1.5
658
659* Wed Nov 26 2008 Funda Wang <fundawang@mandriva.org> 2.0.6-1mdv2009.1
660+ Revision: 306865
661- New version 2.0.6
662
663* Mon Nov 03 2008 Funda Wang <fundawang@mandriva.org> 2.0.4-1mdv2009.1
664+ Revision: 299348
665- New version 2.0.4
666
667* Mon Sep 15 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.2-2mdv2009.0
668+ Revision: 284854
669- Patch8: disable version check at startup
670
671* Sat Sep 13 2008 Frederik Himpe <fhimpe@mandriva.org> 2.0.2-1mdv2009.0
672+ Revision: 284544
673- Update to bugfix update 2.0.2
674
675* Tue Sep 09 2008 Olivier Blin <oblin@mandriva.com> 2.0.0-3mdv2009.0
676+ Revision: 283015
677- build guest additions on x86_64 too (#43593)
678
679  + Frederic Crozat <fcrozat@mandriva.com>
680    - Patch7: fix QT4 detection on x86-64 on Mandriva 2008.1
681
682* Thu Sep 04 2008 Frederic Crozat <fcrozat@mandriva.com> 2.0.0-1mdv2009.0
683+ Revision: 280850
684- Fix BuildRequires
685- Release 2.0.0
686- Remove patches 3, 7 (merged upstream)
687
688* Mon Sep 01 2008 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 1.6.4-4mdv2009.0
689+ Revision: 278071
690- Added patch to allow VirtualBox kernel module to build with
691  Linux 2.6.27
692
693  + Pixel <pixel@mandriva.com>
694    - increase release number
695    - use gcc4.2 to build the recompiler (not ported to gcc 4.3 yet)
696
697* Wed Aug 06 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-2mdv2009.0
698+ Revision: 264273
699- create /var/run/VirtualBox (#41963)
700- use tunctl from the tunctl package while VBoxTunctl does not build
701
702* Tue Aug 05 2008 Olivier Blin <oblin@mandriva.com> 1.6.4-1mdv2009.0
703+ Revision: 264016
704- do not include VBoxTunctl for now (build is broken in upstream tarball)
705- rediff misc_register patch (the register part has been implemented upstream, I should submit the deregister hunks)
706- fix 1.6.4 build by not building tunctl (some Makefile.kmk are missing)
707- 1.6.4
708
709* Tue Jul 29 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.2-2mdv2009.0
710+ Revision: 252777
711- Don't use gcc 3.3 for build on 2008.1 or earlier
712
713* Wed Jul 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.2-1mdv2009.0
714+ Revision: 232889
715- set again linux sources path in configure
716- use gcc 3.3 to build the recompiler (not ported to gcc 4.3 yet)
717- use kernel-devel-latest instead of kernel-source-latest
718- use a prepared copy of the linux tree (for linux/bounds.h)
719
720  + Frederic Crozat <fcrozat@mandriva.com>
721    - Release 1.6.2
722    - Regenerate patch5
723    - Fix duplicated line in specfile
724
725  + Pixel <pixel@mandriva.com>
726    - rpm filetriggers deprecates update_menus/update_scrollkeeper/update_mime_database/update_icon_cache/update_desktop_database/post_install_gconf_schemas
727
728* Fri May 16 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-4mdv2009.0
729+ Revision: 208160
730- Fix seamless mode in guest additions subpackage
731
732* Thu May 15 2008 Anssi Hannula <anssi@mandriva.org> 1.6.0-3mdv2009.0
733+ Revision: 207692
734- rename VBoxAddIF.sh and VBoxDeleteIF.sh to VBoxAddIF and VBoxDeleteIF
735  to match original names and documentation
736
737* Wed May 14 2008 Frederic Crozat <fcrozat@mandriva.com> 1.6.0-2mdv2009.0
738+ Revision: 207235
739- Replace source1 with patch 6 (use up to date VBox.sh script)
740- Ensure VBoxAddIF/VBoxDeleteIF scripts are packaged, as well as VBoxTunctl (Mdv bug #40769)
741- package VBoxHeadless (Mdv bug #40771)
742
743* Fri May 09 2008 Olivier Blin <oblin@mandriva.com> 1.6.0-1mdv2009.0
744+ Revision: 205313
745- try harder to disable additions on x86_64
746- buildrequire libxslt-devel
747- adapt to vboxadd-xclient being renamed as VBoxClient
748- rediff futex patch
749- rediff misc_register patch
750- 1.6.0
751- revert BUILT_MODULE_NAME addition, the bug is fixed in dkms
752
753  + Anssi Hannula <anssi@mandriva.org>
754    - add BUILT_MODULE_NAME to dkms.conf of vboxadd and vboxvfs (fixes DKMS
755      error)
756
757* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.6-1mdv2008.1
758+ Revision: 175619
759- 1.5.6
760- rediff KERNELRELEASE patch
761
762* Tue Feb 26 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-5mdv2008.1
763+ Revision: 175610
764- try to start dkms instead of vboxadd in vboxadd-timesync service (since modules are loaded from modprobe.preload.d, #36728)
765
766* Fri Feb 08 2008 Thierry Vignaud <tvignaud@mandriva.com> 1.5.4-4mdv2008.1
767+ Revision: 163970
768- drop old menu
769
770  + Frederic Crozat <fcrozat@mandriva.com>
771    - Really disable pulseaudio support on 2008.0 or older
772
773* Thu Jan 10 2008 Frederic Crozat <fcrozat@mandriva.com> 1.5.4-3mdv2008.1
774+ Revision: 147602
775- Use correct version of x11 mouse and video additional driver when used on 2008.1 (xorg 1.4) and 2008.0
776- Only build pulseaudio support for 2008.1
777
778* Wed Jan 09 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-2mdv2008.1
779+ Revision: 147006
780- fix dkms build for kernels different from running kernel
781
782* Thu Jan 03 2008 Olivier Blin <oblin@mandriva.com> 1.5.4-1mdv2008.1
783+ Revision: 142711
784- buildrequire pulseaudio-devel
785- rediff libpath patch
786- remove 2.6.24 build fix, fixed upstream
787- 1.5.4
788- restore BuildRoot
789
790  + Pascal Terjan <pterjan@mandriva.org>
791    - Switch to Debian patch for 2.6.24
792    - Re-create the 2.6.24 patch, some bits got lost
793
794  + Thierry Vignaud <tvignaud@mandriva.com>
795    - kill re-definition of %%buildroot on Pixel's request
796    - kill explicit icon extension
797
798  + Giuseppe Ghibò <ghibo@mandriva.com>
799    - Use kernel-source-latest in BuildRequires as conditional.
800    - Add conditional build flags for older release.
801    - Let Patch5 conditional.
802
803* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-3mdv2008.1
804+ Revision: 114076
805- Improve 2.6.24 patch so that it should still build with older kernels
806
807* Fri Nov 30 2007 Pascal Terjan <pterjan@mandriva.org> 1.5.2-2mdv2008.1
808+ Revision: 114047
809- Fix other parts to build with 2.6.24
810- Fix vboxdrv for 2.6.24
811
812* Tue Nov 13 2007 Olivier Blin <oblin@mandriva.com> 1.5.2-1mdv2008.1
813+ Revision: 108363
814- remove keyboards patch (was from upstream svn)
815- rediff kernelrelease patch
816- rediff libpath patch
817- 1.5.2
818
819* Thu Oct 04 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-6mdv2008.0
820+ Revision: 95447
821- really apply misc_register patch (so that vboxadd devices are automatically created)
822- add release in dkms PACKAGE_VERSION to ease upgrades
823
824* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-5mdv2008.0
825+ Revision: 93837
826- require kmod(vboxdrv) instead of dkms package
827- do not mark initscript as config file
828- move initscripts and udev rules out of dkms package (so that it works when using dkms prebuilt modules)
829
830* Sat Sep 29 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-4mdv2008.0
831+ Revision: 93812
832- add vboxadd-timesync service
833- add pam_console perms file to assign vboxadd device to console user
834- use misc_register() to register vboxadd device so that /dev/vboxadd gets created automatically by udev
835
836* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-3mdv2008.0
837+ Revision: 93770
838- add vboxadd-xclient xinit.d script
839- release new additions, but we still need to fix mknod for vboxadd
840  (or use device_create() in kernel module), set console perms for
841  vboxadd in console.perms.d, and add timesync initscript
842- make guest additions package require X11 drivers
843- make x11 driver packages suggest virtualbox-guest-additions
844- add virtualbox-guest-additions package (with xclient, timesync, mount.vboxsf)
845- add dkms-vboxadd and dkms-vboxvfs packages
846
847* Fri Sep 28 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-2mdv2008.0
848+ Revision: 93534
849- build additions on ix86 only
850- fix support for Brazilian, Belgian, US intl and US dvorak keyboards and add support for multimedia keys (from upstream SVN)
851- buildrequire libstdc++-static-devel
852- buildrequire libxt-devel
853- buildrequire kernel-source-latest, since iurt/urpmi don't install latest kernel-source automatically
854- buildrequire kernel-source
855- package mouse guest addition in x11-driver-input-vboxmouse
856- package video guest addition in x11-driver-video-vboxvideo
857- build VirtualBox additions
858
859* Mon Sep 03 2007 Olivier Blin <oblin@mandriva.com> 1.5.0-1mdv2008.0
860+ Revision: 78607
861- drop libstdc++5 BuildRequires
862- drop unapplied x86_64 NMI watchdog disabling patch (merged upstream)
863- 1.5.0
864- rediff mdvconfig patch
865
866  + Thierry Vignaud <tvignaud@mandriva.com>
867    - kill desktop-file-validate's 'warning: key "Encoding" in group "Desktop Entry" is deprecated'
868
869* Fri Jun 08 2007 Per Øyvind Karlsen <peroyvind@mandriva.org> 1.4.0-1mdv2008.0
870+ Revision: 37085
871- from Jos?\195?\169 Melo <mmodem00@gmail.com>:
872        o 1.4.0
873        o update patch:2 since is needed to load (modprobe) vbox driver in kernel-2.6.17
874        o remove patch1 since is becomes obsolete with this new version,and continues installing and running stable no matter if is kernel-2.6.17 or greater
875        o add missing buildrequire hal-devel
876
877
878* Thu Mar 15 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.8-1mdv2007.1
879+ Revision: 144313
880- add should-start: dkms to initscript (#29523)
881- 1.3.8
882  * hard reset network device on reboot
883  * fix issues with IBM JVM 1.4.2 in Linux guests
884  * add support for X.org 7.2.x in Linux guest additions
885
886* Fri Mar 02 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.6-1mdv2007.1
887+ Revision: 131492
888- disable NMIs on Core 2 platforms too
889- 1.3.6
890  * fix some GUI issues
891  * fix OpenBSD 4.0 support
892  * fix CD/DVD-ROM detection in Windows Vista guests
893  * fix networking issues with Windows NT 4.0 guests
894  * fix some ALSA problems that could cause system reboots
895
896* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.4-1mdv2007.1
897+ Revision: 119895
898- 1.3.4
899
900* Mon Feb 12 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070209-1mdv2007.1
901+ Revision: 119017
902- SVN updates (2007/02/09):
903  * additional 64-bit fixes
904  * asynchronous packets transmission in NIC code
905
906* Sat Feb 03 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3.20070202-1mdv2007.1
907+ Revision: 116064
908- various 64-bit fixes
909- updates from SVN (2007/02/02):
910  * initial 64-bit host support
911  * fix IDE for Open Solaris 10
912  * add VDI compacting to the GUI
913
914* Sat Jan 27 2007 Gwenole Beauchesne <gbeauchesne@mandriva.com> 1.3.3-1mdv2007.1
915+ Revision: 114276
916- initial mandriva linux package
917
Note: See TracBrowser for help on using the repository browser.