source: projects/specs/trunk/T/TrueType-liberation/TrueType-liberation-vl.spec @ 521

Revision 521, 7.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define fontname liberation
2%define archivename %{name}-%{version}
3%define common_desc \
4The Liberation Fonts are intended to be replacements for the three most \
5commonly used fonts on Microsoft systems: Times New Roman, Arial, and Courier \
6New.
7
8%define _fontdir %{_datadir}/fonts/TrueType-%{fontname}
9
10Name:             TrueType-%{fontname}
11Summary:          Fonts to replace commonly used Microsoft Windows fonts
12Summary(ja):      一般に使用されている Microsoft Windows のフォントを置換するためのフォント
13Version:          1.05.2.20091227
14Release:          1%{?_dist_release}
15# The license of the Liberation Fonts is a EULA that contains GPLv2 and two
16# exceptions:
17# The first exception is the standard FSF font exception.
18# The second exception is an anti-lockdown clause somewhat like the one in
19# GPLv3. This license is Free, but GPLv2 and GPLv3 incompatible.
20License:          Liberation
21Group:            User Interface/X
22URL:              https://www.redhat.com/promo/fonts/
23Source0:          %{fontname}-fonts-ttf-%{version}.tar.gz
24
25Requires:         TrueType-%{fontname}-sans >= %{version}
26Requires:         TrueType-%{fontname}-serif >= %{version}
27Requires:         TrueType-%{fontname}-mono >= %{version}
28BuildRoot:        %{_tmppath}/%{name}-%{version}-root
29BuildArch:        noarch
30
31%description
32%common_desc
33
34Meta-package of Liberation fonts which installs Sans, Serif, and Monospace
35families.
36
37%description -l ja
38liberation fonts はマイクロソフトのシステムでよく使用される3つのフォント、
39Times New Roman・Arial・Courier New を置換することが意図されている
40フォントです。
41
42このパッケージは Liberation フォントのメタパッケージです。
43Sans・Serif・Monospace の3書体をインストールします。
44
45%package sans
46Summary: liberation sans TrueType Fonts
47Summary(ja): liberation sans True Type フォント
48Group: User Interface/X
49Requires: TrueType-liberation-doc
50
51%description sans
52This package includes liberation sans TrueType fonts.
53
54%description -l ja sans
55このパッケージには liberation sans フォントが含まれています。
56
57
58%package serif
59Summary: liberation serif TrueType Fonts
60Summary(ja): liberation serif True Type フォント
61Group: User Interface/X
62Requires: TrueType-liberation-doc
63
64%description serif
65This package includes liberation serif TrueType fonts.
66
67%description -l ja serif
68このパッケージには liberation serif フォントが含まれています。
69
70
71%package mono
72Summary: liberation mono TrueType Fonts
73Summary(ja): liberation mono True Type フォント
74Group: User Interface/X
75Requires: TrueType-liberation-doc
76
77%description mono
78This package includes liberation mono TrueType fonts.
79
80%description -l ja mono
81このパッケージには liberation mono フォントが含まれています。
82
83
84%package doc
85Summary: liberation Font Documents
86Summary(ja): liberation フォントドキュメント
87Group: User Interface/X
88
89%description doc
90This package includes important documents for liberation fonts includes enduser
91license.
92
93%description -l ja doc
94このパッケージには liberation フォントのライセンスを含むドキュメント類が含まれています。
95
96
97%prep
98%setup -q -c %{name}-%{version}
99mv ttf/*.ttf .
100
101%clean
102if test -n "${RPM_BUILD_ROOT}" && test "/" != "${RPM_BUILD_ROOT}"; then
103    rm -rf ${RPM_BUILD_ROOT}
104fi
105
106%build
107
108%install
109rm -rf %{buildroot}
110
111mkdir -p $RPM_BUILD_ROOT%{_fontdir}
112cp -a *.ttf $RPM_BUILD_ROOT%{_fontdir}
113
114# generate fonts.dir and fonts.scale
115#mkfontdir %{buildroot}%{_fontdir}
116#mkfontscale %{buildroot}%{_fontdir}
117
118%post sans
119%__font_install_post %{_fontdir}
120
121%post serif
122%__font_install_post %{_fontdir}
123
124%post mono
125%__font_install_post %{_fontdir}
126
127
128%postun sans
129%__font_install_postun %{_fontdir}
130
131%postun serif
132%__font_install_postun %{_fontdir}
133
134%postun mono
135%__font_install_postun %{_fontdir}
136
137%files
138
139%files sans
140%{_fontdir}/LiberationSans-*.ttf
141
142%files serif
143%{_fontdir}/LiberationSerif-*.ttf
144
145%files mono
146%{_fontdir}/LiberationMono-*.ttf
147
148%files doc
149%doc AUTHORS COPYING ChangeLog License.txt README
150
151%changelog
152* Sun Dec 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.2.20091227-1
153- new upstream release
154
155* Wed Jul 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.1.20090721-1
156- new upstream release
157
158* Fri Jul 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.1.20090706-1
159- new upstream release
160
161* Tue Apr 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.04.93-1
162- initial build for VineSeed
163
164* Fri Jan 09 2009 Caius Chance <cchance@redhat.com> - 1.04.93-3.fc11
165- Resolves: rhbz#477410 (Convert to new font packaging guidelines.)
166
167* Tue Dec 09 2008 Caius Chance <cchance@redhat.com> - 1.04.93-2.fc11
168- Resolves: rhbz#474522 (Cent sign is not coressed in Sans & Mono.)
169
170* Wed Dec 03 2008 Caius Chance <cchance@redhat.com> - 1.04.93-1.fc11
171- Resolves: rhbz#473481
172  (Blurriness of Greek letter m (U+03BC) in Liberation Sans Regular.)
173
174* Thu Jul 17 2008 Caius Chance <cchance@redhat.com> - 1.04.90-1.fc10
175- Resolves: rhbz#258592
176  (Incorrect glyph points and missing hinting instructions for U+0079, U+03BC,
177   U+0431, U+2010..2012.)
178
179* Thu Jul 17 2008 Caius Chance <cchance@redhat.com> - 1.04-1.fc10
180- Resolves: rhbz#455717 (Update sources to version 1.04.)
181- Improved .spec file.
182
183* Thu Jun 12 2008 Caius Chance <cchance@redhat.com> - 1.04-0.1.beta2.fc10
184- Updated source version to 1.04.beta2.
185- Removed License.txt and COPYING as already included in sources.
186
187* Thu Apr 10 2008 Caius Chance <cchance@redhat.com> - 1.03-1.fc9
188- Resolves: rhbz#251890 (Exchanged and incomplete glyphs.)
189- Repack source tarball and re-align source version number.
190
191* Mon Mar 31 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.02-2
192- correct license tag, license explanation added
193
194* Tue Mar 25 2008 Caius Chance <cchance@redhat.com> - 1.02-1.fc9
195- Resolves: rhbz#240525 (Alignment mismatch of dot accents.)
196
197* Wed Jan 16 2008 Caius Chance <cchance@redhat.com> - 1.01-1.fc9
198- Moved source tarball from cvs to separated storage.
199
200* Mon Jan 14 2008 Caius Chance <cchance@redhat.com> - 1.0-1.fc9
201- Resolves: rhbz#428596 (Liberation fonts need to be updated to latest font.)
202
203* Wed Nov 28 2007 Caius Chance <cchance@redhat.com> - 0.2-4.fc9
204- Resolves: rhbz#367791 (remove 59-liberation-fonts.conf)
205
206* Wed Sep 12 2007 Jens Petersen <petersen@redhat.com> - 0.2-3.fc8
207- add fontdir macro
208- create fonts.dir and fonts.scale (reported by Mark Alford, #245961)
209- add catalogue symlink
210
211* Wed Sep 12 2007 Jens Petersen <petersen@redhat.com> - 0.2-2.fc8
212- update license field to GPLv2
213
214* Thu Jun 14 2007 Caius Chance <cchance@redhat.com> 0.2-1.fc8
215- Updated new source tarball from upstream: '-3' (version 0.2).
216
217* Tue May 15 2007 Matthias Clasen <mclasen@redhat.com> 0.1-9
218- Bump revision
219
220* Tue May 15 2007 Matthias Clasen <mclasen@redhat.com> 0.1-8
221- Change the license tag to "GPL + font exception"
222
223* Mon May 14 2007 Matthias Clasen <mclasen@redhat.com> 0.1-7
224- Correct the source url
225
226* Mon May 14 2007 Matthias Clasen <mclasen@redhat.com> 0.1-6
227- Incorporate package review feedback
228
229* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> 0.1-5
230- Bring the package in sync with Fedora packaging standards
231
232* Wed Apr 25 2007 Meethune Bhowmick <bhowmick@redhat.com> 0.1-4
233- Require fontconfig package for post and postun
234
235* Tue Apr 24 2007 Meethune Bhowmick <bhowmick@redhat.com> 0.1-3
236- Bump version to fix issue in RHEL4 RHN
237
238* Thu Mar 29 2007 Richard Monk <rmonk@redhat.com> 0.1-2rhis
239- New license file
240
241* Thu Mar 29 2007 Richard Monk <rmonk@redhat.com> 0.1-1rhis
242- Inital packaging
Note: See TracBrowser for help on using the repository browser.