source: projects/specs/trunk/T/TrueType-liberation/TrueType-liberation-vl.spec @ 11962

Revision 11962, 8.3 KB checked in by iwaim, 5 years ago (diff)

TrueType?-liberation 2.00.4-1

Line 
1%define fontname liberation
2%define archivename %{name}-%{version}
3%define common_desc \
4The Liberation Fonts are intended to be replacements for the three most \
5commonly used fonts on Microsoft systems: Times New Roman, Arial, and Courier \
6New.
7
8%define _fontdir %{_datadir}/fonts/TrueType-%{fontname}
9
10Name:             TrueType-%{fontname}
11Summary:          Fonts to replace commonly used Microsoft Windows fonts
12Summary(ja):      一般に使用されている Microsoft Windows のフォントを置換するためのフォント
13Version:          2.00.4
14Release:          1%{?_dist_release}
15License:          OFL
16Group:            User Interface/X
17URL:              https://www.redhat.com/promo/fonts/
18# https://fedorahosted.org/liberation-fonts/
19Source0:          %{fontname}-fonts-ttf-%{version}.tar.gz
20
21Requires:         TrueType-%{fontname}-sans >= %{version}
22Requires:         TrueType-%{fontname}-serif >= %{version}
23Requires:         TrueType-%{fontname}-mono >= %{version}
24Requires:         TrueType-%{fontname}-doc = %{version}
25BuildRoot:        %{_tmppath}/%{name}-%{version}-root
26BuildArch:        noarch
27
28# for google-chrome-stable rpm package
29Provides:         liberation-fonts
30
31%description
32%common_desc
33
34Meta-package of Liberation fonts which installs Sans, Serif, and Monospace
35families.
36
37%description -l ja
38liberation fonts はマイクロソフトのシステムでよく使用される3つのフォント、
39Times New Roman・Arial・Courier New を置換することが意図されている
40フォントです。
41
42このパッケージは Liberation フォントのメタパッケージです。
43Sans・Serif・Monospace の3書体をインストールします。
44
45%package sans
46Summary: liberation sans TrueType Fonts
47Summary(ja): liberation sans True Type フォント
48Group: User Interface/X
49Requires: TrueType-liberation-doc
50
51%description sans
52This package includes liberation sans TrueType fonts.
53
54%description -l ja sans
55このパッケージには liberation sans フォントが含まれています。
56
57
58%package serif
59Summary: liberation serif TrueType Fonts
60Summary(ja): liberation serif True Type フォント
61Group: User Interface/X
62Requires: TrueType-liberation-doc
63
64%description serif
65This package includes liberation serif TrueType fonts.
66
67%description -l ja serif
68このパッケージには liberation serif フォントが含まれています。
69
70
71%package mono
72Summary: liberation mono TrueType Fonts
73Summary(ja): liberation mono True Type フォント
74Group: User Interface/X
75Requires: TrueType-liberation-doc
76
77%description mono
78This package includes liberation mono TrueType fonts.
79
80%description -l ja mono
81このパッケージには liberation mono フォントが含まれています。
82
83
84%package doc
85Summary: liberation Font Documents
86Summary(ja): liberation フォントドキュメント
87Group: User Interface/X
88
89%description doc
90This package includes important documents for liberation fonts
91includes enduser license.
92
93%description -l ja doc
94このパッケージには liberation フォントのライセンスを含むドキュメント類が含まれています。
95
96
97%prep
98%setup -q -n %{fontname}-fonts-ttf-%{version}
99
100%clean
101if test -n "${RPM_BUILD_ROOT}" && test "/" != "${RPM_BUILD_ROOT}"; then
102    rm -rf ${RPM_BUILD_ROOT}
103fi
104
105%build
106
107%install
108rm -rf %{buildroot}
109
110mkdir -p $RPM_BUILD_ROOT%{_fontdir}
111cp -a *.ttf $RPM_BUILD_ROOT%{_fontdir}
112
113%post sans
114%__font_install_post %{_fontdir}
115
116%post serif
117%__font_install_post %{_fontdir}
118
119%post mono
120%__font_install_post %{_fontdir}
121
122
123%postun sans
124%__font_install_postun %{_fontdir}
125
126%postun serif
127%__font_install_postun %{_fontdir}
128
129%postun mono
130%__font_install_postun %{_fontdir}
131
132%files
133
134%files sans
135%{_fontdir}/LiberationSans*.ttf
136
137%files serif
138%{_fontdir}/LiberationSerif-*.ttf
139
140%files mono
141%{_fontdir}/LiberationMono-*.ttf
142
143%files doc
144%doc AUTHORS ChangeLog LICENSE README TODO
145
146%changelog
147* Fri Nov 30 2018 IWAI, Masaharu <iwaim@aquarius.beering.jp> 2.00.4-1
148- update to 2.00.4
149- Provides: liberation-fonts
150
151* Mon Jan 13 2014 TANAKA hiroaki <mosaicist@jcom.home.ne.jp> 2.00.1-2
152- built with gcc-4.8
153
154* Fri Nov 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.00.1-1
155- new upstream release
156
157* Mon Jul 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.00.0-1
158- new upstream release
159- changed License: OFL
160  - because based on croscore fonts version 1.21.0 (original license is OFL)
161
162* Wed Mar 07 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.07.2-1
163- new upstream release
164
165* Wed Sep 21 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.07.1-1
166- new upstream release
167
168* Wed Jun 01 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.07.0-1
169- new upstream release
170
171* Thu Jul 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.06.0.20100721-1
172- new upstream release
173- added TODO in %%doc
174
175* Wed Jun 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.3.20100621-1
176- new upstream release
177
178* Mon May 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.3.20100510-1
179- new upstream release
180- added Requires:  TrueType-%{fontname}-doc = %{version}
181
182* Sun Dec 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.2.20091227-1
183- new upstream release
184
185* Wed Jul 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.1.20090721-1
186- new upstream release
187
188* Fri Jul 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.1.20090706-1
189- new upstream release
190
191* Tue Apr 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.04.93-1
192- initial build for VineSeed
193
194* Fri Jan 09 2009 Caius Chance <cchance@redhat.com> - 1.04.93-3.fc11
195- Resolves: rhbz#477410 (Convert to new font packaging guidelines.)
196
197* Tue Dec 09 2008 Caius Chance <cchance@redhat.com> - 1.04.93-2.fc11
198- Resolves: rhbz#474522 (Cent sign is not coressed in Sans & Mono.)
199
200* Wed Dec 03 2008 Caius Chance <cchance@redhat.com> - 1.04.93-1.fc11
201- Resolves: rhbz#473481
202  (Blurriness of Greek letter m (U+03BC) in Liberation Sans Regular.)
203
204* Thu Jul 17 2008 Caius Chance <cchance@redhat.com> - 1.04.90-1.fc10
205- Resolves: rhbz#258592
206  (Incorrect glyph points and missing hinting instructions for U+0079, U+03BC,
207   U+0431, U+2010..2012.)
208
209* Thu Jul 17 2008 Caius Chance <cchance@redhat.com> - 1.04-1.fc10
210- Resolves: rhbz#455717 (Update sources to version 1.04.)
211- Improved .spec file.
212
213* Thu Jun 12 2008 Caius Chance <cchance@redhat.com> - 1.04-0.1.beta2.fc10
214- Updated source version to 1.04.beta2.
215- Removed License.txt and COPYING as already included in sources.
216
217* Thu Apr 10 2008 Caius Chance <cchance@redhat.com> - 1.03-1.fc9
218- Resolves: rhbz#251890 (Exchanged and incomplete glyphs.)
219- Repack source tarball and re-align source version number.
220
221* Mon Mar 31 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.02-2
222- correct license tag, license explanation added
223
224* Tue Mar 25 2008 Caius Chance <cchance@redhat.com> - 1.02-1.fc9
225- Resolves: rhbz#240525 (Alignment mismatch of dot accents.)
226
227* Wed Jan 16 2008 Caius Chance <cchance@redhat.com> - 1.01-1.fc9
228- Moved source tarball from cvs to separated storage.
229
230* Mon Jan 14 2008 Caius Chance <cchance@redhat.com> - 1.0-1.fc9
231- Resolves: rhbz#428596 (Liberation fonts need to be updated to latest font.)
232
233* Wed Nov 28 2007 Caius Chance <cchance@redhat.com> - 0.2-4.fc9
234- Resolves: rhbz#367791 (remove 59-liberation-fonts.conf)
235
236* Wed Sep 12 2007 Jens Petersen <petersen@redhat.com> - 0.2-3.fc8
237- add fontdir macro
238- create fonts.dir and fonts.scale (reported by Mark Alford, #245961)
239- add catalogue symlink
240
241* Wed Sep 12 2007 Jens Petersen <petersen@redhat.com> - 0.2-2.fc8
242- update license field to GPLv2
243
244* Thu Jun 14 2007 Caius Chance <cchance@redhat.com> 0.2-1.fc8
245- Updated new source tarball from upstream: '-3' (version 0.2).
246
247* Tue May 15 2007 Matthias Clasen <mclasen@redhat.com> 0.1-9
248- Bump revision
249
250* Tue May 15 2007 Matthias Clasen <mclasen@redhat.com> 0.1-8
251- Change the license tag to "GPL + font exception"
252
253* Mon May 14 2007 Matthias Clasen <mclasen@redhat.com> 0.1-7
254- Correct the source url
255
256* Mon May 14 2007 Matthias Clasen <mclasen@redhat.com> 0.1-6
257- Incorporate package review feedback
258
259* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> 0.1-5
260- Bring the package in sync with Fedora packaging standards
261
262* Wed Apr 25 2007 Meethune Bhowmick <bhowmick@redhat.com> 0.1-4
263- Require fontconfig package for post and postun
264
265* Tue Apr 24 2007 Meethune Bhowmick <bhowmick@redhat.com> 0.1-3
266- Bump version to fix issue in RHEL4 RHN
267
268* Thu Mar 29 2007 Richard Monk <rmonk@redhat.com> 0.1-2rhis
269- New license file
270
271* Thu Mar 29 2007 Richard Monk <rmonk@redhat.com> 0.1-1rhis
272- Inital packaging
Note: See TracBrowser for help on using the repository browser.