source: projects/specs/trunk/T/TrueType-liberation/TrueType-liberation-vl.spec @ 1266

Revision 1266, 7.8 KB checked in by kudoh, 14 years ago (diff)
Line 
1%define fontname liberation
2%define archivename %{name}-%{version}
3%define common_desc \
4The Liberation Fonts are intended to be replacements for the three most \
5commonly used fonts on Microsoft systems: Times New Roman, Arial, and Courier \
6New.
7
8%define _fontdir %{_datadir}/fonts/TrueType-%{fontname}
9
10Name:             TrueType-%{fontname}
11Summary:          Fonts to replace commonly used Microsoft Windows fonts
12Summary(ja):      一般に使用されている Microsoft Windows のフォントを置換するためのフォント
13Version:          1.05.3.20100621
14Release:          1%{?_dist_release}
15# The license of the Liberation Fonts is a EULA that contains GPLv2 and two
16# exceptions:
17# The first exception is the standard FSF font exception.
18# The second exception is an anti-lockdown clause somewhat like the one in
19# GPLv3. This license is Free, but GPLv2 and GPLv3 incompatible.
20License:          Liberation
21Group:            User Interface/X
22URL:              https://www.redhat.com/promo/fonts/
23Source0:          %{fontname}-fonts-ttf-%{version}.tar.gz
24
25Requires:         TrueType-%{fontname}-sans >= %{version}
26Requires:         TrueType-%{fontname}-serif >= %{version}
27Requires:         TrueType-%{fontname}-mono >= %{version}
28Requires:         TrueType-%{fontname}-doc = %{version}
29BuildRoot:        %{_tmppath}/%{name}-%{version}-root
30BuildArch:        noarch
31
32%description
33%common_desc
34
35Meta-package of Liberation fonts which installs Sans, Serif, and Monospace
36families.
37
38%description -l ja
39liberation fonts はマイクロソフトのシステムでよく使用される3つのフォント、
40Times New Roman・Arial・Courier New を置換することが意図されている
41フォントです。
42
43このパッケージは Liberation フォントのメタパッケージです。
44Sans・Serif・Monospace の3書体をインストールします。
45
46%package sans
47Summary: liberation sans TrueType Fonts
48Summary(ja): liberation sans True Type フォント
49Group: User Interface/X
50Requires: TrueType-liberation-doc
51
52%description sans
53This package includes liberation sans TrueType fonts.
54
55%description -l ja sans
56このパッケージには liberation sans フォントが含まれています。
57
58
59%package serif
60Summary: liberation serif TrueType Fonts
61Summary(ja): liberation serif True Type フォント
62Group: User Interface/X
63Requires: TrueType-liberation-doc
64
65%description serif
66This package includes liberation serif TrueType fonts.
67
68%description -l ja serif
69このパッケージには liberation serif フォントが含まれています。
70
71
72%package mono
73Summary: liberation mono TrueType Fonts
74Summary(ja): liberation mono True Type フォント
75Group: User Interface/X
76Requires: TrueType-liberation-doc
77
78%description mono
79This package includes liberation mono TrueType fonts.
80
81%description -l ja mono
82このパッケージには liberation mono フォントが含まれています。
83
84
85%package doc
86Summary: liberation Font Documents
87Summary(ja): liberation フォントドキュメント
88Group: User Interface/X
89
90%description doc
91This package includes important documents for liberation fonts includes enduser
92license.
93
94%description -l ja doc
95このパッケージには liberation フォントのライセンスを含むドキュメント類が含まれています。
96
97
98%prep
99%setup -q -c %{fontname}-fonts-%{version}
100mv ttf/*.ttf .
101
102%clean
103if test -n "${RPM_BUILD_ROOT}" && test "/" != "${RPM_BUILD_ROOT}"; then
104    rm -rf ${RPM_BUILD_ROOT}
105fi
106
107%build
108
109%install
110rm -rf %{buildroot}
111
112mkdir -p $RPM_BUILD_ROOT%{_fontdir}
113cp -a *.ttf $RPM_BUILD_ROOT%{_fontdir}
114
115# generate fonts.dir and fonts.scale
116#mkfontdir %{buildroot}%{_fontdir}
117#mkfontscale %{buildroot}%{_fontdir}
118
119%post sans
120%__font_install_post %{_fontdir}
121
122%post serif
123%__font_install_post %{_fontdir}
124
125%post mono
126%__font_install_post %{_fontdir}
127
128
129%postun sans
130%__font_install_postun %{_fontdir}
131
132%postun serif
133%__font_install_postun %{_fontdir}
134
135%postun mono
136%__font_install_postun %{_fontdir}
137
138%files
139
140%files sans
141%{_fontdir}/LiberationSans*.ttf
142
143%files serif
144%{_fontdir}/LiberationSerif-*.ttf
145
146%files mono
147%{_fontdir}/LiberationMono-*.ttf
148
149%files doc
150%doc AUTHORS COPYING ChangeLog License.txt README
151
152%changelog
153* Wed Jun 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.3.20100621-1
154- new upstream release
155
156* Mon May 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.3.20100510-1
157- new upstream release
158- added Requires:  TrueType-%{fontname}-doc = %{version}
159
160* Sun Dec 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.2.20091227-1
161- new upstream release
162
163* Wed Jul 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.1.20090721-1
164- new upstream release
165
166* Fri Jul 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.1.20090706-1
167- new upstream release
168
169* Tue Apr 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.04.93-1
170- initial build for VineSeed
171
172* Fri Jan 09 2009 Caius Chance <cchance@redhat.com> - 1.04.93-3.fc11
173- Resolves: rhbz#477410 (Convert to new font packaging guidelines.)
174
175* Tue Dec 09 2008 Caius Chance <cchance@redhat.com> - 1.04.93-2.fc11
176- Resolves: rhbz#474522 (Cent sign is not coressed in Sans & Mono.)
177
178* Wed Dec 03 2008 Caius Chance <cchance@redhat.com> - 1.04.93-1.fc11
179- Resolves: rhbz#473481
180  (Blurriness of Greek letter m (U+03BC) in Liberation Sans Regular.)
181
182* Thu Jul 17 2008 Caius Chance <cchance@redhat.com> - 1.04.90-1.fc10
183- Resolves: rhbz#258592
184  (Incorrect glyph points and missing hinting instructions for U+0079, U+03BC,
185   U+0431, U+2010..2012.)
186
187* Thu Jul 17 2008 Caius Chance <cchance@redhat.com> - 1.04-1.fc10
188- Resolves: rhbz#455717 (Update sources to version 1.04.)
189- Improved .spec file.
190
191* Thu Jun 12 2008 Caius Chance <cchance@redhat.com> - 1.04-0.1.beta2.fc10
192- Updated source version to 1.04.beta2.
193- Removed License.txt and COPYING as already included in sources.
194
195* Thu Apr 10 2008 Caius Chance <cchance@redhat.com> - 1.03-1.fc9
196- Resolves: rhbz#251890 (Exchanged and incomplete glyphs.)
197- Repack source tarball and re-align source version number.
198
199* Mon Mar 31 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.02-2
200- correct license tag, license explanation added
201
202* Tue Mar 25 2008 Caius Chance <cchance@redhat.com> - 1.02-1.fc9
203- Resolves: rhbz#240525 (Alignment mismatch of dot accents.)
204
205* Wed Jan 16 2008 Caius Chance <cchance@redhat.com> - 1.01-1.fc9
206- Moved source tarball from cvs to separated storage.
207
208* Mon Jan 14 2008 Caius Chance <cchance@redhat.com> - 1.0-1.fc9
209- Resolves: rhbz#428596 (Liberation fonts need to be updated to latest font.)
210
211* Wed Nov 28 2007 Caius Chance <cchance@redhat.com> - 0.2-4.fc9
212- Resolves: rhbz#367791 (remove 59-liberation-fonts.conf)
213
214* Wed Sep 12 2007 Jens Petersen <petersen@redhat.com> - 0.2-3.fc8
215- add fontdir macro
216- create fonts.dir and fonts.scale (reported by Mark Alford, #245961)
217- add catalogue symlink
218
219* Wed Sep 12 2007 Jens Petersen <petersen@redhat.com> - 0.2-2.fc8
220- update license field to GPLv2
221
222* Thu Jun 14 2007 Caius Chance <cchance@redhat.com> 0.2-1.fc8
223- Updated new source tarball from upstream: '-3' (version 0.2).
224
225* Tue May 15 2007 Matthias Clasen <mclasen@redhat.com> 0.1-9
226- Bump revision
227
228* Tue May 15 2007 Matthias Clasen <mclasen@redhat.com> 0.1-8
229- Change the license tag to "GPL + font exception"
230
231* Mon May 14 2007 Matthias Clasen <mclasen@redhat.com> 0.1-7
232- Correct the source url
233
234* Mon May 14 2007 Matthias Clasen <mclasen@redhat.com> 0.1-6
235- Incorporate package review feedback
236
237* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> 0.1-5
238- Bring the package in sync with Fedora packaging standards
239
240* Wed Apr 25 2007 Meethune Bhowmick <bhowmick@redhat.com> 0.1-4
241- Require fontconfig package for post and postun
242
243* Tue Apr 24 2007 Meethune Bhowmick <bhowmick@redhat.com> 0.1-3
244- Bump version to fix issue in RHEL4 RHN
245
246* Thu Mar 29 2007 Richard Monk <rmonk@redhat.com> 0.1-2rhis
247- New license file
248
249* Thu Mar 29 2007 Richard Monk <rmonk@redhat.com> 0.1-1rhis
250- Inital packaging
Note: See TracBrowser for help on using the repository browser.