source: projects/specs/trunk/R/R/R-vl.spec @ 7300

Revision 7300, 14.1 KB checked in by iwaim, 11 years ago (diff)

R 2.15.2-1

Line 
1%define pkg_version 2.15.2
2%define pkg_release 1%{?_dist_release}
3
4Summary:          A language for data analysis and graphics
5Summary(ja):      データ解析・グラフィック化の言語
6Name:             R
7Version:          %{pkg_version}
8Release:          %{pkg_release}
9
10License:          GPLv2+
11Group:            Applications/Edutainment
12URL:              http://www.r-project.org
13
14Source0:          ftp://cran.r-project.org/pub/R/src/base/R-2/%{name}-%{version}.tar.gz
15Source1:          R.desktop
16#Patch0:           R-release.diff.gz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gcc-c++
20BuildRequires: gcc-gfortran libgfortran
21BuildRequires: texlive
22BuildRequires: texlive-common
23BuildRequires: texlive-collection-basic
24BuildRequires: texlive-collection-texinfo
25BuildRequires: texlive-collection-fontsextra
26BuildRequires: texinfo tcl tk
27BuildRequires: libpng-devel libjpeg-devel libtiff-devel
28BuildRequires: readline-devel libtermcap-devel
29BuildRequires: zlib-devel bzip2-devel
30BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
31BuildRequires: cairo-devel pango-devel
32BuildRequires: libicu-devel
33Requires: libgfortran
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: Toshiaki Ara <ara_t@384.jp>
38
39%description
40'GNU S' - A language and environment for statistical computing and
41graphics. R is similar to the award-winning S system, which was
42developed at Bell Laboratories by John Chambers et al. It provides
43a wide variety of statistical and graphical techniques (linear and
44nonlinear modelling, statistical tests, time series analysis,
45classification, clustering, ...).
46
47R is designed as a true computer language with control-flow
48constructions for iteration and alternation, and it allows users to
49add additional functionality by defining new functions.
50For computationally intensive tasks, C, C++ and Fortran code
51can be linked and called at run time.
52
53%description -l ja
54'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
55Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
56線形・非線型モデル、統計検定、時系列分析、クラスター分析など
57幅広い統計解析・視覚化手法を提供する。
58Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
59として設計されており、ユーザが新たに関数を組み込むことが可能である。
60また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
61使用することができる。
62
63%package devel
64Summary:          files for development of R packages.
65Summary(ja):      Rパッケージ開発用ファイル
66Group:            Development/Libraries
67Requires:         R = %{version}-%{release}
68
69%description devel
70Install R-devel if you are going to develop or compile R packages.
71
72This is just a stub package containing the documentation on
73"Writing R Extensions".  However, installing it will ensure that
74the build environment for R packages is correct.
75
76%description -l ja devel
77Rパッケージを開発したりコンパイルする場合には、このR-develを
78インストールします。R-exts.pdf ("Writing R Extensions": 英文)
79が含まれているだけのサブパッケージですが、正しくRパッケージを
80開発するための助けになるでしょう。
81
82%package -n libRmath
83Summary:          standalone math library from the R project
84Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
85Group:            System Environment/Libraries
86
87%description -n libRmath
88A standalone library of mathematical and statistical functions derived
89from the R project.  This packages provides the shared libRmath library.
90
91%description -l ja -n libRmath
92単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
93共有ライブラリを提供する。
94
95%package -n libRmath-devel
96Summary:          standalone math library from the R project
97Summary(ja):      libRmathの開発ライブラリ
98Group:            Development/Libraries
99Requires:         libRmath = %{version}-%{release}
100
101%description -n libRmath-devel
102A standalone library of mathematical and statistical functions derived
103from the R project.  This packages provides the header files.
104
105%description -l ja -n libRmath-devel
106libRmathのヘッダファイル(Rmath.h)
107
108%package -n libRmath-static
109Summary: Static R Standalone math library
110Summary(ja): libRmath の静的ライブラリ
111Group: Development/Libraries
112Requires: libRmath-devel = %{version}-%{release}
113
114%description -n libRmath-static
115A standalone library of mathematical and statistical functions derived
116from the R project.  This package provides the static libRmath library.
117
118
119%prep
120%{__rm} -rf ${RPM_BUILD_ROOT}
121%setup -q
122#%patch0 -p1
123
124%build
125export R_PDFVIEWER="%{_bindir}/xdg-open"
126export R_PRINTCMD="lpr"
127export R_BROWSER="%{_bindir}/xdg-open"
128
129%configure --enable-R-shlib
130
131%{__make} %{?_smp_mflags}
132(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
133LANG=C make check-all
134%{__make} pdf
135#We can only "make info" if we have an up to date version of texinfo
136%{?INFO: %{__make} info}
137
138
139%install
140%{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
141%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
142%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
143
144#Install libRmath files
145(cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
146
147mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
148echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
149
150#Fix lication of R_HOME_DIR in shell wrapper
151sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
152  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
153chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
154sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
155  > ${RPM_BUILD_ROOT}%{_bindir}/R
156chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
157
158# add R into menu
159mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
160mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/icons
161
162cp -a %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/
163cp -a doc/html/logosm.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
164
165
166%clean
167%{__rm} -rf ${RPM_BUILD_ROOT}
168
169
170%post
171%if 0%{?INFO}
172   # Create directory entries for info files
173   # (optional doc files, so we must check that they are installed)
174   for doc in admin data exts FAQ intro lang; do
175      file=%{_infodir}/R-${doc}.info.gz
176      if [ -e $file ]; then
177         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
178      fi
179   done
180%endif
181%{_syssbindir}/ldconfig
182
183
184%preun
185%if 0%{?INFO}
186   if [ $1 = 0 ]; then
187      # Delete directory entries for info files (if they were installed)
188      for doc in admin data exts FAQ intro lang; do
189         file=%{_infodir}/R-${doc}.info.gz
190         if [ -e ${file} ]; then
191            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
192         fi
193      done
194   fi
195%endif
196
197%postun -p %{_syssbindir}/ldconfig
198
199%post -n libRmath -p %{_syssbindir}/ldconfig
200
201%postun -n libRmath -p %{_syssbindir}/ldconfig
202
203
204%files
205%defattr(-, root, root)
206%{_bindir}/R
207%{_bindir}/Rscript
208%{_libdir}/R
209%{_datadir}/applications/*
210%{_datadir}/icons/*
211%{?INFO:%{_infodir}/R-*.info*}
212%{_mandir}/man1/*
213/etc/ld.so.conf.d/*
214
215%files devel
216%defattr(-, root, root)
217%doc doc/manual/R-exts.pdf
218
219%files -n libRmath
220%defattr(-, root, root)
221%{_libdir}/libRmath.so
222
223%files -n libRmath-devel
224%defattr(-, root, root)
225%{_libdir}/pkgconfig/*.pc
226%{_includedir}/Rmath.h
227
228%files -n libRmath-static
229%defattr(-, root, root)
230%{_libdir}/libRmath.a
231
232
233%changelog
234* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
235- Updated to 2.15.2
236
237* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
238- changed group to Applications/Edutainment
239- added R to menu
240
241* Sat Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
242- Updated to 2.15.1
243
244* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
245- Updated to 2.15.0
246
247* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
248- Updated to 2.14.2
249
250* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
251- Updated to 2.14.1
252
253* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
254- Updated to 2.14.0
255- add BuildRequires: texlive-collection-fontsextra
256
257* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
258- Updated to 2.13.2
259- add BuildRequires: texlive-common
260- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
261- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
262
263* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
264- synchronized to VinePlus/5 package
265  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
266  - Updated to 2.13.1
267  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
268  - Updated to 2.13.0
269  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
270  - Updated to 2.12.2
271
272* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
273- add BuildRequires: libicu-devel
274
275* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
276- synchronized to VinePlus/5 package
277  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
278  - Updated to 2.12.1
279- added --enable-R-shlib option to %%configure
280- added static subpackage
281- use BR: texlive instead of tetex on VineSeed
282
283* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
284- rebuilt with rpm-4.8.1 for pkg-config
285
286* Thu Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
287- recompiled because tcl/tk were not linked
288
289* Thu Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
290- Updated to 2.11.0
291- added Requires: libgfortran
292
293* Thu Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
294- Updated to 2.10.1
295
296* Thu Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
297- patched to 2.10.0
298
299* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
300- spec in UTF-8
301
302* Thu Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
303- Updated to 2.10.0
304
305* Thu Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
306- Updated to 2.9.2
307- deleted BuildRequires: lapack-devel blas-devel
308- rewrote SPEC file
309
310* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
311- Updated to 2.5.1
312- added BuildRequires: gcc-gfortran for VineSeed
313- added BuildRequires: lapack-devel blas-devel
314- fixed %preun script
315
316* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
317- Updated to 2.4.1
318- Added INFO option
319- Exclude Japanese Rprofile.site
320
321* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
322- Updated to 2.4.0
323
324* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
325- Added optimization flags
326
327* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
328- Packaged for VineLinux3.2
329
330* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
331- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
332
333* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
334- Packaged for VineLinux3.2
335- Slipped texinfo
336- Fixed preun error
337- Preset Japanese fonts
338
339* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
340- Packaged for VineLinux3.2
341
342* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
343- Restored CAPABILITIES file lost in 2.2.1beta
344
345* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
346- Configure uses --without-blas by default.
347- Install pdf manuals.
348- All toplevel documentation files are installed into _libdir/R
349  as they may be required by R (qv note on AUTHORS and THANKS below).
350- Legacy scripts for rebuilding package indices removed.
351
352* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
353- R now compiles with gcc 4.0.1 and default rpm optimization flags.
354
355* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
356- The files AUTHORS and THANKS need to be installed into _libdir/R
357  as they are required by the function contributors().  Previously
358  they were installed only as documentation files.
359
360* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
361- Corrected date error in SPEC file.
362
363* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
364- Dropped support for Red Hat boxed set.
365- Synchronized with Fedora Extras 4 RPM by Tom Calloway
366  including support for shared R library.
367- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
368  with the default optimization flags, so there is a temporary work-around.
369
370* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
371- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
372
373* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
374- Install R-data.info file as well.
375- Make info processing conditional on texinfo version, not platform release,
376  so that if a new enough version is installed, we will build and install info.
377
378* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
379- Built R 2.1.0.  R now supports internationalization, so the patch
380  to set the locale to "C" is now dropped.
381- install.packages() exits gracefully with a helpful message if
382  the file INSTALL is not present, so this is now included in the
383  R-devel package.
384
385* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
386- Added support for Scientific Linux (http://www.scientificlinux.org)
387  A distribution based on RHEL. Thanks to Jon Peatfield.
388
389* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
390- Fixed file ownership in R-devel and libRmath packages
391
392* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
393- R-devel package is now a stub package with no files, except a documentation
394  file (RPM won't accept sub-packages with no files). R now conflicts
395  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
396- Created libRmath subpackage with shared library.
397
398* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
399- Created R-devel and libRmath-devel subpackages
400
401* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
402- Built R 2.0.1
403
404* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
405- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
406  gives "lpr".
407- Define macro fcx for all Fedora distributions. This replaces Rinfo
408
409* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
410- Info support is now conditional on the macro Rinfo, which is only
411  defined for Fedora 1 and 2.
412
413* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
414- Built R 2.0.0
415- There is no longer a BUGS file, so this is not installed as a
416  documentation file.
Note: See TracBrowser for help on using the repository browser.