source: projects/specs/trunk/R/R/R-vl.spec @ 1919

Revision 1919, 11.3 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define pkg_version 2.11.0
2%define pkg_release 3%{?_dist_release}
3
4Summary:          A language for data analysis and graphics
5Summary(ja):      データ解析・グラフィック化の言語
6Name:             R
7Version:          %{pkg_version}
8Release:          %{pkg_release}
9Source0:          ftp://cran.r-project.org/pub/R/src/base/R-2/%{name}-%{version}.tar.gz
10#Patch0:           R-release.diff.gz
11License:          GPL2
12Group:            Applications/Engineering
13URL:              http://www.r-project.org
14
15Requires: libgfortran
16
17BuildRequires: gcc-c++
18BuildRequires: gcc-gfortran libgfortran
19#BuildRequires: tetex texinfo tcl tk
20BuildRequires: texlive texinfo tcl tk
21BuildRequires: libpng-devel libjpeg-devel
22BuildRequires: readline-devel libtermcap-devel
23BuildRequires: zlib-devel bzip2-devel XOrg-devel
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: Toshiaki Ara <ara_t@384.jp>
29
30%description
31'GNU S' - A language and environment for statistical computing and
32graphics. R is similar to the award-winning S system, which was
33developed at Bell Laboratories by John Chambers et al. It provides
34a wide variety of statistical and graphical techniques (linear and
35nonlinear modelling, statistical tests, time series analysis,
36classification, clustering, ...).
37
38R is designed as a true computer language with control-flow
39constructions for iteration and alternation, and it allows users to
40add additional functionality by defining new functions.
41For computationally intensive tasks, C, C++ and Fortran code
42can be linked and called at run time.
43
44%description -l ja
45'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
46Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
47線形・非線型モデル、統計検定、時系列分析、クラスター分析など
48幅広い統計解析・視覚化手法を提供する。
49Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
50として設計されており、ユーザが新たに関数を組み込むことが可能である。
51また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
52使用することができる。
53
54%package devel
55Summary:          files for development of R packages.
56Summary(ja):      Rパッケージ開発用ファイル
57Group:            Development/Libraries
58Requires:         R = %{version}-%{release}
59
60%description devel
61Install R-devel if you are going to develop or compile R packages.
62
63This is just a stub package containing the documentation on "Writing R
64Extensions".  However, installing it will ensure that the build
65environment for R packages is correct.
66
67%description -l ja devel
68Rパッケージを開発したりコンパイルする場合には、このR-develを
69インストールします。R-exts.pdf ("Writing R Extensions": 英文)
70が含まれているだけのサブパッケージですが、正しくRパッケージを
71開発するための助けになるでしょう。
72
73%package -n libRmath
74Summary:          standalone math library from the R project
75Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
76Group:            System Environment/Libraries
77
78%description -n libRmath
79A standalone library of mathematical and statistical functions derived
80from the R project.  This packages provides the shared libRmath library.
81
82%description -l ja -n libRmath
83単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
84共有ライブラリを提供する。
85
86%package -n libRmath-devel
87Summary:          standalone math library from the R project
88Summary(ja):      libRmathの開発ライブラリ
89Group:            Development/Libraries
90Requires:         libRmath = %{version}-%{release}
91
92%description -n libRmath-devel
93A standalone library of mathematical and statistical functions derived
94from the R project.  This packages provides the header files.
95
96%description -l ja -n libRmath-devel
97libRmathのヘッダファイル(Rmath.h)
98
99%prep
100%{__rm} -rf ${RPM_BUILD_ROOT}
101%setup -q
102#%patch0 -p1
103
104%build
105export R_BROWSER="%{_bindir}/firefox"
106%configure
107%{__make} %{?_smp_mflags}
108(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
109LANG=C make check-all
110%{__make} pdf
111#We can only "make info" if we have an up to date version of texinfo
112%{?INFO: %{__make} info}
113
114
115%install
116%{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
117%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
118%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
119
120#Install libRmath files
121(cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
122
123mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
124echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
125
126#Fix lication of R_HOME_DIR in shell wrapper
127sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
128  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
129chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
130sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
131  > ${RPM_BUILD_ROOT}%{_bindir}/R
132chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
133
134
135%files
136%defattr(-, root, root)
137%{_bindir}/R
138%{_bindir}/Rscript
139%{_libdir}/R
140%{?INFO:%{_infodir}/R-*.info*}
141%{_mandir}/man1/*
142/etc/ld.so.conf.d/*
143
144%files devel
145%defattr(-, root, root)
146%doc doc/manual/R-exts.pdf
147
148%files -n libRmath
149%defattr(-, root, root)
150%{_libdir}/libRmath.so
151
152%files -n libRmath-devel
153%defattr(-, root, root)
154%{_libdir}/pkgconfig/*.pc
155%{_includedir}/Rmath.h
156
157%clean
158%{__rm} -rf ${RPM_BUILD_ROOT}
159
160
161%post
162%if 0%{?INFO}
163   # Create directory entries for info files
164   # (optional doc files, so we must check that they are installed)
165   for doc in admin data exts FAQ intro lang; do
166      file=%{_infodir}/R-${doc}.info.gz
167      if [ -e $file ]; then
168         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
169      fi
170   done
171%endif
172%{_syssbindir}/ldconfig
173
174%preun
175%if 0%{?INFO}
176   if [ $1 = 0 ]; then
177      # Delete directory entries for info files (if they were installed)
178      for doc in admin data exts FAQ intro lang; do
179         file=%{_infodir}/R-${doc}.info.gz
180         if [ -e ${file} ]; then
181            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
182         fi
183      done
184   fi
185%endif
186
187%postun -p %{_syssbindir}/ldconfig
188
189%post -n libRmath -p %{_syssbindir}/ldconfig
190
191%postun -n libRmath -p %{_syssbindir}/ldconfig
192
193
194%changelog
195* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
196- rebuilt with rpm-4.8.1 for pkg-config
197
198* Thu Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
199- recompiled because tcl/tk were not linked
200
201* Thu Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
202- Updated to 2.11.0
203- added Requires: libgfortran
204
205* Thu Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
206- Updated to 2.10.1
207
208* Thu Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
209- patched to 2.10.0
210
211* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
212- spec in UTF-8
213
214* Thu Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
215- Updated to 2.10.0
216
217* Thu Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
218- Updated to 2.9.2
219- deleted BuildRequires: lapack-devel blas-devel
220- rewrote SPEC file
221
222* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
223- Updated to 2.5.1
224- added BuildRequires: gcc-gfortran for VineSeed
225- added BuildRequires: lapack-devel blas-devel
226- fixed %preun script
227
228* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
229- Updated to 2.4.1
230- Added INFO option
231- Exclude Japanese Rprofile.site
232
233* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
234- Updated to 2.4.0
235
236* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
237- Added optimization flags
238
239* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
240- Packaged for VineLinux3.2
241
242* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
243- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
244
245* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
246- Packaged for VineLinux3.2
247- Slipped texinfo
248- Fixed preun error
249- Preset Japanese fonts
250
251* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
252- Packaged for VineLinux3.2
253
254* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
255- Restored CAPABILITIES file lost in 2.2.1beta
256
257* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
258- Configure uses --without-blas by default.
259- Install pdf manuals.
260- All toplevel documentation files are installed into _libdir/R
261  as they may be required by R (qv note on AUTHORS and THANKS below).
262- Legacy scripts for rebuilding package indices removed.
263
264* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
265- R now compiles with gcc 4.0.1 and default rpm optimization flags.
266
267* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
268- The files AUTHORS and THANKS need to be installed into _libdir/R
269  as they are required by the function contributors().  Previously
270  they were installed only as documentation files.
271
272* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
273- Corrected date error in SPEC file.
274
275* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
276- Dropped support for Red Hat boxed set.
277- Synchronized with Fedora Extras 4 RPM by Tom Calloway
278  including support for shared R library.
279- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
280  with the default optimization flags, so there is a temporary work-around.
281
282* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
283- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
284
285* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
286- Install R-data.info file as well.
287- Make info processing conditional on texinfo version, not platform release,
288  so that if a new enough version is installed, we will build and install info.
289
290* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
291- Built R 2.1.0.  R now supports internationalization, so the patch
292  to set the locale to "C" is now dropped.
293- install.packages() exits gracefully with a helpful message if
294  the file INSTALL is not present, so this is now included in the
295  R-devel package.
296
297* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
298- Added support for Scientific Linux (http://www.scientificlinux.org)
299  A distribution based on RHEL. Thanks to Jon Peatfield.
300
301* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
302- Fixed file ownership in R-devel and libRmath packages
303
304* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
305- R-devel package is now a stub package with no files, except a documentation
306  file (RPM won't accept sub-packages with no files). R now conflicts
307  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
308- Created libRmath subpackage with shared library.
309
310* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
311- Created R-devel and libRmath-devel subpackages
312
313* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
314- Built R 2.0.1
315
316* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
317- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
318  gives "lpr".
319- Define macro fcx for all Fedora distributions. This replaces Rinfo
320
321* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
322- Info support is now conditional on the macro Rinfo, which is only
323  defined for Fedora 1 and 2.
324
325* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
326- Built R 2.0.0
327- There is no longer a BUGS file, so this is not installed as a
328  documentation file.
Note: See TracBrowser for help on using the repository browser.