source: projects/specs/trunk/R/R/R-vl.spec @ 12049

Revision 12049, 19.3 KB checked in by ara_t, 5 years ago (diff)

R: update to 3.5.3

Line 
1%define pkg_name    R
2%define pkg_version 3.5.3
3%define pkg_release 1%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
16# Patch0:      R-release.diff.gz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gcc-c++
20BuildRequires: gcc-gfortran libgfortran
21BuildRequires: texinfo
22
23%if %{?_dist_release} == "vl6"
24BuildRequires: R-pcre-devel
25BuildRequires: tcl85-devel tk85-devel
26%endif
27%if %{?_dist_release} >= "vl7"
28BuildRequires: pcre2-devel
29BuildRequires: tcl-devel tk-devel
30%endif
31BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
32BuildRequires: readline-devel ncurses-devel
33BuildRequires: zlib-devel bzip2-devel xz-devel
34BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
35BuildRequires: cairo-devel pango-devel
36BuildRequires: libicu-devel
37BuildRequires: curl-devel
38BuildRequires: blas-devel
39
40BuildRequires: texlive-common
41BuildRequires: texlive-collection-basic
42BuildRequires: texlive-collection-latexextra
43BuildRequires: texlive-collection-fontsextra
44%if %{?_dist_release} == "vl6"
45BuildRequires: texlive-collection-texinfo
46%endif
47%if %{?_dist_release} >= "vl7"
48BuildRequires: texlive-collection-plaingeneric
49BuildRequires: texlive-collection-fontsrecommended
50%endif
51BuildRequires: java-devel
52
53Requires: gcc-gfortran
54Requires: libgfortran
55Requires: libicu
56%if %{?_dist_release} == "vl6"
57Requires: tcl85 tk85
58Requires: R-pcre
59%endif
60%if %{?_dist_release} >= "vl7"
61Requires: tcl tk
62Requires: pcre2
63Obsoletes: tcl85 tk85
64Obsoletes: R-pcre
65%endif
66
67Requires: blas
68Requires: openblas-Rblas
69
70Obsoletes: R-devel < %{version}-%{release}
71
72Vendor: Project Vine
73Distribution: Vine Linux
74Packager: ara_t
75
76
77%description
78'GNU S' - A language and environment for statistical computing and
79graphics. R is similar to the award-winning S system, which was
80developed at Bell Laboratories by John Chambers et al. It provides
81a wide variety of statistical and graphical techniques (linear and
82nonlinear modelling, statistical tests, time series analysis,
83classification, clustering, ...).
84
85R is designed as a true computer language with control-flow
86constructions for iteration and alternation, and it allows users to
87add additional functionality by defining new functions.
88For computationally intensive tasks, C, C++ and Fortran code
89can be linked and called at run time.
90
91%description -l ja
92'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
93Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
94線形・非線型モデル、統計検定、時系列分析、クラスター分析など
95幅広い統計解析・視覚化手法を提供する。
96Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
97として設計されており、ユーザが新たに関数を組み込むことが可能である。
98また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
99使用することができる。
100
101%package -n libRmath
102Summary:     standalone math library from the R project
103Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
104Group:       System Environment/Libraries
105
106%description -n libRmath
107A standalone library of mathematical and statistical functions derived
108from the R project.  This packages provides the shared libRmath library.
109
110%description -l ja -n libRmath
111単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
112共有ライブラリを提供する。
113
114%package -n libRmath-devel
115Summary:     standalone math library from the R project
116Summary(ja): libRmathの開発ライブラリ
117Group:       Development/Libraries
118Requires:    libRmath = %{version}-%{release}
119
120%description -n libRmath-devel
121A standalone library of mathematical and statistical functions derived
122from the R project.  This packages provides the header files.
123
124%description -l ja -n libRmath-devel
125libRmathのヘッダファイル(Rmath.h)
126
127%package -n libRmath-static
128Summary: Static R Standalone math library
129Summary(ja): libRmath の静的ライブラリ
130Group: Development/Libraries
131Requires: libRmath-devel = %{version}-%{release}
132
133%description -n libRmath-static
134A standalone library of mathematical and statistical functions derived
135from the R project.  This package provides the static libRmath library.
136
137
138%prep
139%{__rm} -rf ${RPM_BUILD_ROOT}
140%setup -q
141# %patch0 -p1
142
143cat > R.desktop <<EOF
144[Desktop Entry]
145Name=GNU R
146Comment=A language for data analysis and graphics
147TryExec=/usr/bin/R
148Exec=/usr/bin/R
149Icon=/usr/share/icons/logo.jpg
150Terminal=true
151Type=Application
152Categories=Education;Science;
153StartupNotify=false
154EOF
155
156%build
157export R_PDFVIEWER="%{_bindir}/xdg-open"
158export R_PRINTCMD="lpr"
159export R_BROWSER="%{_bindir}/xdg-open"
160%if %{?_dist_release} == "vl6"
161export LD_LIBRARY_PATH=%{_libdir}/R/lib
162%endif
163
164%{configure} --enable-R-shlib --with-tcltk \
165 --with-blas="-lblas" \
166%if %{?_dist_release} == "vl6"
167 --with-tcl-config=%{_libdir}/tclConfig85.sh \
168 --with-tk-config=%{_libdir}/tkConfig85.sh \
169 CPPFLAGS="-I%{_libdir}/R/include" \
170 LDFLAGS="-L%{_libdir}/R/lib"
171%endif
172
173%{__make} %{?_smp_mflags}
174pushd src/nmath/standalone
175%{__make} %{?_smp_mflags}
176popd
177%{__make} pdf
178
179%install
180%{make_install}
181%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
182%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
183%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
184
185# Remove libRblas.so
186%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/R/lib/libRblas.so
187
188# Install libRmath files
189pushd src/nmath/standalone
190%{make_install}
191popd
192
193%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
194echo "%{_libdir}/R/lib" > \
195     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
196
197# Fix lication of R_HOME_DIR in shell wrapper
198%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
199  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
200%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
201%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
202  > ${RPM_BUILD_ROOT}%{_bindir}/R
203%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
204
205# add R into menu
206%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
207%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
208%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
209%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
210
211# move manuals
212%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
213%{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
214 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
215
216# make symlink for libblas.so.3 (No need to use blas-devel)
217pushd ${RPM_BUILD_ROOT}%{_libdir}/R/lib
218%{__ln_s} %{_libdir}/libblas.so.3 libblas.so
219popd
220
221
222%check
223%{__make} check
224
225%clean
226%{__rm} -rf ${RPM_BUILD_ROOT}
227
228
229%post -p %{_syssbindir}/ldconfig
230
231%preun
232if [ "$1" = "0" ]
233then
234    %{__rm} -f %{_libdir}/R/lib/libblas*.so.*
235    %{__rm} -f %{_libdir}/R/lib/libopenblas*.so.*
236fi
237
238%postun -p %{_syssbindir}/ldconfig
239
240%post -n libRmath -p %{_syssbindir}/ldconfig
241
242%postun -n libRmath -p %{_syssbindir}/ldconfig
243
244
245%files
246%defattr(-, root, root)
247%{_bindir}/R
248%{_bindir}/Rscript
249%{_libdir}/R
250%{_datadir}/applications/*
251%{_datadir}/icons/*
252%{_mandir}/man1/*
253%{_docdir}/%{name}-%{version}
254%{_sysconfdir}/ld.so.conf.d/*
255
256%files -n libRmath
257%defattr(-, root, root)
258%{_libdir}/libRmath.so
259
260%files -n libRmath-devel
261%defattr(-, root, root)
262%{_libdir}/pkgconfig/*.pc
263%{_includedir}/Rmath.h
264
265%files -n libRmath-static
266%defattr(-, root, root)
267%{_libdir}/libRmath.a
268
269
270%changelog
271* Mon Mar 11 2019 Toshiaki Ara <ara_t@384.jp> 3.5.3-1
272- update to 3.5.3
273
274* Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
275- rebuild with gfortran-8.2.0
276
277* Thu Dec 20 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-1
278- update to 3.5.2
279
280* Mon Jul 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.1-1
281- update to 3.5.1
282
283* Fri Jun 29 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-2
284- add Requires: openblas-Rblas
285- change using system blas
286
287* Mon Apr 23 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-1
288- update to 3.5.0
289- drop Patch 1 and 2
290
291* Thu Mar 15 2018 Toshiaki Ara <ara_t@384.jp> 3.4.4-1
292- updated to 3.4.4
293- add Obsoletes: tcl85 tk85 R-pcre for VineSeed
294
295* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 3.4.3-2
296- rebuild under icu-60.2
297
298* Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
299- Updated to 3.4.3
300
301* Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
302- Updated to 3.4.2
303- change download URL
304
305* Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
306- left %%{_libdir}/R/doc
307
308* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
309- Updated to 3.4.1
310- rebuild under R-pcre (pcre-8.39) for Vine6
311- add Requires: gcc-gfortran
312- change to BuildRequires: texlive-collection-plaingeneric
313- delete unnecessary descriptions
314
315* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
316- Updated to 3.4.0
317- add Patch1 and Patch2 to avoid 'make check' error
318- add export TZ="Asia/Tokyo" to avoid 'make check' error
319- delete descrption about info
320
321* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
322- Updated to 3.3.3
323
324* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
325- use tcl-8.5/tk-8.5 for Vine6.5
326  - BuildRequires to tcl85-devel/tk85-devel
327  - Requires to tcl85/tk85
328
329* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
330- merge SPEC file for Vine6
331- drop devel package
332- move PDF manuals to /usr/share/doc/R-%%{version}
333- revert logo of menu item to logo.jpg
334
335* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
336- Updated to 3.3.2
337
338* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
339- Updated to 3.3.1
340- delete BuildRequires: texlive-collection-lang*
341
342* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
343- add BuildRequires: texlive-collection-lang*
344
345* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
346- Updated to 3.3.0
347- add BuildRequires: pcre-devel xz-devel
348- change logo of menu item to Rlogo.svg
349
350* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
351- correct SPEC file
352
353* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
354- Updated to 3.2.4-revised
355
356* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
357- Updated to 3.2.4
358- fixed build error in src/extra/xz
359
360* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
361- add BuildRequires: curl-devel
362- add BuildRequires: libgomp
363
364* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
365- Updated to 3.2.3
366
367* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
368- rebuild with icu-56.1
369
370* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
371- Updated to 3.2.2
372
373* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
374- add configure options: --with-tcltk
375- add BuildRequires: tcl-devel tk-devel
376- add Requires: tcl tk
377
378* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
379- Updated to 3.2.1
380
381* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
382- add "LIBS=-lbz2" to configure option
383
384* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
385- Updated to 3.2.0
386
387* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
388- Updated to 3.1.3
389- added BuildRequires: texlive-collection-fontsextra for Vine6
390- changed option "make check-all" to "make check"
391-   to avoid error in checking of mgcv package
392- changed orders of BuildRequires
393
394* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
395- rebuild with icu-54.1
396
397* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
398- Updated to 3.1.2
399
400* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
401- Updated to 3.1.1
402- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
403
404* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
405- add patch (2014-04-26)
406
407* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
408- Updated to 3.1.0
409
410* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
411- Updated to 3.0.3
412
413* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
414- rebuild current VineSeed
415- add patch (2014-01-06)
416
417* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
418- add Requires: libicu
419
420* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
421- combine spec files Vine6 and VineSeed
422- correct the days of the week in changelog
423
424* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
425- delete BuildRequires: texlive-collection-texinfo
426- add BuildRequires: texlive-collection-plainextra
427- add BuildRequires: texlive-collection-latexextra
428- add BuildRequires: texlive-collection-fontsrecommended
429-   for VineSeed
430
431* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
432- Updated to 3.0.2
433
434* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
435- Updated to 3.0.1
436- add BuildRequires: java-1.6.0-openjdk-devel
437
438* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
439- Updated to 3.0.0
440
441* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
442- Updated to 2.15.3
443- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
444- use BuildRequires ncurses-devel instead of libtermcap-devel
445
446* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
447- Updated to 2.15.2
448
449* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
450- changed group to Applications/Edutainment
451- added R to menu
452
453* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
454- Updated to 2.15.1
455
456* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
457- Updated to 2.15.0
458
459* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
460- Updated to 2.14.2
461
462* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
463- Updated to 2.14.1
464
465* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
466- Updated to 2.14.0
467- add BuildRequires: texlive-collection-fontsextra
468
469* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
470- Updated to 2.13.2
471- add BuildRequires: texlive-common
472- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
473- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
474
475* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
476- synchronized to VinePlus/5 package
477  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
478  - Updated to 2.13.1
479  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
480  - Updated to 2.13.0
481  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
482  - Updated to 2.12.2
483
484* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
485- add BuildRequires: libicu-devel
486
487* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
488- synchronized to VinePlus/5 package
489  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
490  - Updated to 2.12.1
491- added --enable-R-shlib option to %%configure
492- added static subpackage
493- use BR: texlive instead of tetex on VineSeed
494
495* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
496- rebuilt with rpm-4.8.1 for pkg-config
497
498* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
499- recompiled because tcl/tk were not linked
500
501* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
502- Updated to 2.11.0
503- added Requires: libgfortran
504
505* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
506- Updated to 2.10.1
507
508* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
509- patched to 2.10.0
510
511* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
512- spec in UTF-8
513
514* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
515- Updated to 2.10.0
516
517* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
518- Updated to 2.9.2
519- deleted BuildRequires: lapack-devel blas-devel
520- rewrote SPEC file
521
522* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
523- Updated to 2.5.1
524- added BuildRequires: gcc-gfortran for VineSeed
525- added BuildRequires: lapack-devel blas-devel
526- fixed %preun script
527
528* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
529- Updated to 2.4.1
530- Added INFO option
531- Exclude Japanese Rprofile.site
532
533* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
534- Updated to 2.4.0
535
536* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
537- Added optimization flags
538
539* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
540- Packaged for VineLinux3.2
541
542* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
543- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
544
545* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
546- Packaged for VineLinux3.2
547- Slipped texinfo
548- Fixed preun error
549- Preset Japanese fonts
550
551* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
552- Packaged for VineLinux3.2
553
554* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
555- Restored CAPABILITIES file lost in 2.2.1beta
556
557* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
558- Configure uses --without-blas by default.
559- Install pdf manuals.
560- All toplevel documentation files are installed into _libdir/R
561  as they may be required by R (qv note on AUTHORS and THANKS below).
562- Legacy scripts for rebuilding package indices removed.
563
564* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
565- R now compiles with gcc 4.0.1 and default rpm optimization flags.
566
567* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
568- The files AUTHORS and THANKS need to be installed into _libdir/R
569  as they are required by the function contributors().  Previously
570  they were installed only as documentation files.
571
572* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
573- Corrected date error in SPEC file.
574
575* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
576- Dropped support for Red Hat boxed set.
577- Synchronized with Fedora Extras 4 RPM by Tom Calloway
578  including support for shared R library.
579- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
580  with the default optimization flags, so there is a temporary work-around.
581
582* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
583- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
584
585* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
586- Install R-data.info file as well.
587- Make info processing conditional on texinfo version, not platform release,
588  so that if a new enough version is installed, we will build and install info.
589
590* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
591- Built R 2.1.0.  R now supports internationalization, so the patch
592  to set the locale to "C" is now dropped.
593- install.packages() exits gracefully with a helpful message if
594  the file INSTALL is not present, so this is now included in the
595  R-devel package.
596
597* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
598- Added support for Scientific Linux (http://www.scientificlinux.org)
599  A distribution based on RHEL. Thanks to Jon Peatfield.
600
601* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
602- Fixed file ownership in R-devel and libRmath packages
603
604* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
605- R-devel package is now a stub package with no files, except a documentation
606  file (RPM won't accept sub-packages with no files). R now conflicts
607  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
608- Created libRmath subpackage with shared library.
609
610* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
611- Created R-devel and libRmath-devel subpackages
612
613* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
614- Built R 2.0.1
615
616* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
617- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
618  gives "lpr".
619- Define macro fcx for all Fedora distributions. This replaces Rinfo
620
621* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
622- Info support is now conditional on the macro Rinfo, which is only
623  defined for Fedora 1 and 2.
624
625* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
626- Built R 2.0.0
627- There is no longer a BUGS file, so this is not installed as a
628  documentation file.
Note: See TracBrowser for help on using the repository browser.