source: projects/specs/trunk/R/R/R-vl.spec @ 12029

Revision 12029, 19.2 KB checked in by ara_t, 5 years ago (diff)

R: rebuild with gfortran-8.2.0

Line 
1%define pkg_name    R
2%define pkg_version 3.5.2
3%define pkg_release 2%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
16# Patch0:      R-release.diff.gz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gcc-c++
20BuildRequires: gcc-gfortran libgfortran
21BuildRequires: texinfo
22
23%if %{?_dist_release} == "vl6"
24BuildRequires: R-pcre-devel
25BuildRequires: tcl85-devel tk85-devel
26%endif
27%if %{?_dist_release} >= "vl7"
28BuildRequires: pcre2-devel
29BuildRequires: tcl-devel tk-devel
30%endif
31BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
32BuildRequires: readline-devel ncurses-devel
33BuildRequires: zlib-devel bzip2-devel xz-devel
34BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
35BuildRequires: cairo-devel pango-devel
36BuildRequires: libicu-devel
37BuildRequires: curl-devel
38BuildRequires: blas-devel
39
40BuildRequires: texlive-common
41BuildRequires: texlive-collection-basic
42BuildRequires: texlive-collection-latexextra
43BuildRequires: texlive-collection-fontsextra
44%if %{?_dist_release} == "vl6"
45BuildRequires: texlive-collection-texinfo
46%endif
47%if %{?_dist_release} >= "vl7"
48BuildRequires: texlive-collection-plaingeneric
49BuildRequires: texlive-collection-fontsrecommended
50%endif
51BuildRequires: java-devel
52
53Requires: gcc-gfortran
54Requires: libgfortran
55Requires: libicu
56%if %{?_dist_release} == "vl6"
57Requires: tcl85 tk85
58Requires: R-pcre
59%endif
60%if %{?_dist_release} >= "vl7"
61Requires: tcl tk
62Requires: pcre2
63Obsoletes: tcl85 tk85
64Obsoletes: R-pcre
65%endif
66
67Requires: blas
68Requires: openblas-Rblas
69
70Obsoletes: R-devel < %{version}-%{release}
71
72Vendor: Project Vine
73Distribution: Vine Linux
74Packager: ara_t
75
76
77%description
78'GNU S' - A language and environment for statistical computing and
79graphics. R is similar to the award-winning S system, which was
80developed at Bell Laboratories by John Chambers et al. It provides
81a wide variety of statistical and graphical techniques (linear and
82nonlinear modelling, statistical tests, time series analysis,
83classification, clustering, ...).
84
85R is designed as a true computer language with control-flow
86constructions for iteration and alternation, and it allows users to
87add additional functionality by defining new functions.
88For computationally intensive tasks, C, C++ and Fortran code
89can be linked and called at run time.
90
91%description -l ja
92'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
93Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
94線形・非線型モデル、統計検定、時系列分析、クラスター分析など
95幅広い統計解析・視覚化手法を提供する。
96Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
97として設計されており、ユーザが新たに関数を組み込むことが可能である。
98また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
99使用することができる。
100
101%package -n libRmath
102Summary:     standalone math library from the R project
103Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
104Group:       System Environment/Libraries
105
106%description -n libRmath
107A standalone library of mathematical and statistical functions derived
108from the R project.  This packages provides the shared libRmath library.
109
110%description -l ja -n libRmath
111単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
112共有ライブラリを提供する。
113
114%package -n libRmath-devel
115Summary:     standalone math library from the R project
116Summary(ja): libRmathの開発ライブラリ
117Group:       Development/Libraries
118Requires:    libRmath = %{version}-%{release}
119
120%description -n libRmath-devel
121A standalone library of mathematical and statistical functions derived
122from the R project.  This packages provides the header files.
123
124%description -l ja -n libRmath-devel
125libRmathのヘッダファイル(Rmath.h)
126
127%package -n libRmath-static
128Summary: Static R Standalone math library
129Summary(ja): libRmath の静的ライブラリ
130Group: Development/Libraries
131Requires: libRmath-devel = %{version}-%{release}
132
133%description -n libRmath-static
134A standalone library of mathematical and statistical functions derived
135from the R project.  This package provides the static libRmath library.
136
137
138%prep
139%{__rm} -rf ${RPM_BUILD_ROOT}
140%setup -q
141# %patch0 -p1
142
143cat > R.desktop <<EOF
144[Desktop Entry]
145Name=GNU R
146Comment=A language for data analysis and graphics
147TryExec=/usr/bin/R
148Exec=/usr/bin/R
149Icon=/usr/share/icons/logo.jpg
150Terminal=true
151Type=Application
152Categories=Education;Science;
153StartupNotify=false
154EOF
155
156%build
157export R_PDFVIEWER="%{_bindir}/xdg-open"
158export R_PRINTCMD="lpr"
159export R_BROWSER="%{_bindir}/xdg-open"
160%if %{?_dist_release} == "vl6"
161export LD_LIBRARY_PATH=%{_libdir}/R/lib
162%endif
163
164%{configure} --enable-R-shlib --with-tcltk \
165 --with-blas="-lblas" \
166%if %{?_dist_release} == "vl6"
167 --with-tcl-config=%{_libdir}/tclConfig85.sh \
168 --with-tk-config=%{_libdir}/tkConfig85.sh \
169 CPPFLAGS="-I%{_libdir}/R/include" \
170 LDFLAGS="-L%{_libdir}/R/lib"
171%endif
172
173%{__make} %{?_smp_mflags}
174pushd src/nmath/standalone
175%{__make} %{?_smp_mflags}
176popd
177%{__make} pdf
178
179%install
180%{make_install}
181%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
182%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
183%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
184
185# Remove libRblas.so
186%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/R/lib/libRblas.so
187
188# Install libRmath files
189pushd src/nmath/standalone
190%{make_install}
191popd
192
193%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
194echo "%{_libdir}/R/lib" > \
195     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
196
197# Fix lication of R_HOME_DIR in shell wrapper
198%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
199  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
200%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
201%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
202  > ${RPM_BUILD_ROOT}%{_bindir}/R
203%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
204
205# add R into menu
206%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
207%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
208%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
209%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
210
211# move manuals
212%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
213%{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
214 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
215
216# make symlink for libblas.so.3 (No need to use blas-devel)
217pushd ${RPM_BUILD_ROOT}%{_libdir}/R/lib
218%{__ln_s} %{_libdir}/libblas.so.3 libblas.so
219popd
220
221
222%check
223%{__make} check
224
225%clean
226%{__rm} -rf ${RPM_BUILD_ROOT}
227
228
229%post -p %{_syssbindir}/ldconfig
230
231%preun
232if [ "$1" = "0" ]
233then
234    %{__rm} -f %{_libdir}/R/lib/libblas*.so.*
235    %{__rm} -f %{_libdir}/R/lib/libopenblas*.so.*
236fi
237
238%postun -p %{_syssbindir}/ldconfig
239
240%post -n libRmath -p %{_syssbindir}/ldconfig
241
242%postun -n libRmath -p %{_syssbindir}/ldconfig
243
244
245%files
246%defattr(-, root, root)
247%{_bindir}/R
248%{_bindir}/Rscript
249%{_libdir}/R
250%{_datadir}/applications/*
251%{_datadir}/icons/*
252%{_mandir}/man1/*
253%{_docdir}/%{name}-%{version}
254%{_sysconfdir}/ld.so.conf.d/*
255
256%files -n libRmath
257%defattr(-, root, root)
258%{_libdir}/libRmath.so
259
260%files -n libRmath-devel
261%defattr(-, root, root)
262%{_libdir}/pkgconfig/*.pc
263%{_includedir}/Rmath.h
264
265%files -n libRmath-static
266%defattr(-, root, root)
267%{_libdir}/libRmath.a
268
269
270%changelog
271* Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
272- rebuild with gfortran-8.2.0
273
274* Thu Dec 20 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-1
275- update to 3.5.2
276
277* Mon Jul 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.1-1
278- update to 3.5.1
279
280* Fri Jun 29 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-2
281- add Requires: openblas-Rblas
282- change using system blas
283
284* Mon Apr 23 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-1
285- update to 3.5.0
286- drop Patch 1 and 2
287
288* Thu Mar 15 2018 Toshiaki Ara <ara_t@384.jp> 3.4.4-1
289- updated to 3.4.4
290- add Obsoletes: tcl85 tk85 R-pcre for VineSeed
291
292* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 3.4.3-2
293- rebuild under icu-60.2
294
295* Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
296- Updated to 3.4.3
297
298* Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
299- Updated to 3.4.2
300- change download URL
301
302* Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
303- left %%{_libdir}/R/doc
304
305* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
306- Updated to 3.4.1
307- rebuild under R-pcre (pcre-8.39) for Vine6
308- add Requires: gcc-gfortran
309- change to BuildRequires: texlive-collection-plaingeneric
310- delete unnecessary descriptions
311
312* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
313- Updated to 3.4.0
314- add Patch1 and Patch2 to avoid 'make check' error
315- add export TZ="Asia/Tokyo" to avoid 'make check' error
316- delete descrption about info
317
318* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
319- Updated to 3.3.3
320
321* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
322- use tcl-8.5/tk-8.5 for Vine6.5
323  - BuildRequires to tcl85-devel/tk85-devel
324  - Requires to tcl85/tk85
325
326* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
327- merge SPEC file for Vine6
328- drop devel package
329- move PDF manuals to /usr/share/doc/R-%%{version}
330- revert logo of menu item to logo.jpg
331
332* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
333- Updated to 3.3.2
334
335* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
336- Updated to 3.3.1
337- delete BuildRequires: texlive-collection-lang*
338
339* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
340- add BuildRequires: texlive-collection-lang*
341
342* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
343- Updated to 3.3.0
344- add BuildRequires: pcre-devel xz-devel
345- change logo of menu item to Rlogo.svg
346
347* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
348- correct SPEC file
349
350* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
351- Updated to 3.2.4-revised
352
353* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
354- Updated to 3.2.4
355- fixed build error in src/extra/xz
356
357* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
358- add BuildRequires: curl-devel
359- add BuildRequires: libgomp
360
361* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
362- Updated to 3.2.3
363
364* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
365- rebuild with icu-56.1
366
367* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
368- Updated to 3.2.2
369
370* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
371- add configure options: --with-tcltk
372- add BuildRequires: tcl-devel tk-devel
373- add Requires: tcl tk
374
375* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
376- Updated to 3.2.1
377
378* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
379- add "LIBS=-lbz2" to configure option
380
381* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
382- Updated to 3.2.0
383
384* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
385- Updated to 3.1.3
386- added BuildRequires: texlive-collection-fontsextra for Vine6
387- changed option "make check-all" to "make check"
388-   to avoid error in checking of mgcv package
389- changed orders of BuildRequires
390
391* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
392- rebuild with icu-54.1
393
394* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
395- Updated to 3.1.2
396
397* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
398- Updated to 3.1.1
399- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
400
401* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
402- add patch (2014-04-26)
403
404* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
405- Updated to 3.1.0
406
407* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
408- Updated to 3.0.3
409
410* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
411- rebuild current VineSeed
412- add patch (2014-01-06)
413
414* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
415- add Requires: libicu
416
417* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
418- combine spec files Vine6 and VineSeed
419- correct the days of the week in changelog
420
421* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
422- delete BuildRequires: texlive-collection-texinfo
423- add BuildRequires: texlive-collection-plainextra
424- add BuildRequires: texlive-collection-latexextra
425- add BuildRequires: texlive-collection-fontsrecommended
426-   for VineSeed
427
428* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
429- Updated to 3.0.2
430
431* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
432- Updated to 3.0.1
433- add BuildRequires: java-1.6.0-openjdk-devel
434
435* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
436- Updated to 3.0.0
437
438* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
439- Updated to 2.15.3
440- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
441- use BuildRequires ncurses-devel instead of libtermcap-devel
442
443* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
444- Updated to 2.15.2
445
446* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
447- changed group to Applications/Edutainment
448- added R to menu
449
450* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
451- Updated to 2.15.1
452
453* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
454- Updated to 2.15.0
455
456* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
457- Updated to 2.14.2
458
459* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
460- Updated to 2.14.1
461
462* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
463- Updated to 2.14.0
464- add BuildRequires: texlive-collection-fontsextra
465
466* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
467- Updated to 2.13.2
468- add BuildRequires: texlive-common
469- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
470- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
471
472* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
473- synchronized to VinePlus/5 package
474  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
475  - Updated to 2.13.1
476  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
477  - Updated to 2.13.0
478  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
479  - Updated to 2.12.2
480
481* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
482- add BuildRequires: libicu-devel
483
484* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
485- synchronized to VinePlus/5 package
486  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
487  - Updated to 2.12.1
488- added --enable-R-shlib option to %%configure
489- added static subpackage
490- use BR: texlive instead of tetex on VineSeed
491
492* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
493- rebuilt with rpm-4.8.1 for pkg-config
494
495* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
496- recompiled because tcl/tk were not linked
497
498* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
499- Updated to 2.11.0
500- added Requires: libgfortran
501
502* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
503- Updated to 2.10.1
504
505* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
506- patched to 2.10.0
507
508* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
509- spec in UTF-8
510
511* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
512- Updated to 2.10.0
513
514* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
515- Updated to 2.9.2
516- deleted BuildRequires: lapack-devel blas-devel
517- rewrote SPEC file
518
519* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
520- Updated to 2.5.1
521- added BuildRequires: gcc-gfortran for VineSeed
522- added BuildRequires: lapack-devel blas-devel
523- fixed %preun script
524
525* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
526- Updated to 2.4.1
527- Added INFO option
528- Exclude Japanese Rprofile.site
529
530* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
531- Updated to 2.4.0
532
533* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
534- Added optimization flags
535
536* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
537- Packaged for VineLinux3.2
538
539* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
540- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
541
542* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
543- Packaged for VineLinux3.2
544- Slipped texinfo
545- Fixed preun error
546- Preset Japanese fonts
547
548* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
549- Packaged for VineLinux3.2
550
551* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
552- Restored CAPABILITIES file lost in 2.2.1beta
553
554* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
555- Configure uses --without-blas by default.
556- Install pdf manuals.
557- All toplevel documentation files are installed into _libdir/R
558  as they may be required by R (qv note on AUTHORS and THANKS below).
559- Legacy scripts for rebuilding package indices removed.
560
561* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
562- R now compiles with gcc 4.0.1 and default rpm optimization flags.
563
564* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
565- The files AUTHORS and THANKS need to be installed into _libdir/R
566  as they are required by the function contributors().  Previously
567  they were installed only as documentation files.
568
569* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
570- Corrected date error in SPEC file.
571
572* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
573- Dropped support for Red Hat boxed set.
574- Synchronized with Fedora Extras 4 RPM by Tom Calloway
575  including support for shared R library.
576- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
577  with the default optimization flags, so there is a temporary work-around.
578
579* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
580- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
581
582* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
583- Install R-data.info file as well.
584- Make info processing conditional on texinfo version, not platform release,
585  so that if a new enough version is installed, we will build and install info.
586
587* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
588- Built R 2.1.0.  R now supports internationalization, so the patch
589  to set the locale to "C" is now dropped.
590- install.packages() exits gracefully with a helpful message if
591  the file INSTALL is not present, so this is now included in the
592  R-devel package.
593
594* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
595- Added support for Scientific Linux (http://www.scientificlinux.org)
596  A distribution based on RHEL. Thanks to Jon Peatfield.
597
598* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
599- Fixed file ownership in R-devel and libRmath packages
600
601* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
602- R-devel package is now a stub package with no files, except a documentation
603  file (RPM won't accept sub-packages with no files). R now conflicts
604  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
605- Created libRmath subpackage with shared library.
606
607* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
608- Created R-devel and libRmath-devel subpackages
609
610* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
611- Built R 2.0.1
612
613* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
614- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
615  gives "lpr".
616- Define macro fcx for all Fedora distributions. This replaces Rinfo
617
618* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
619- Info support is now conditional on the macro Rinfo, which is only
620  defined for Fedora 1 and 2.
621
622* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
623- Built R 2.0.0
624- There is no longer a BUGS file, so this is not installed as a
625  documentation file.
Note: See TracBrowser for help on using the repository browser.