source: projects/specs/trunk/P/PyQt4/PyQt4-vl.spec @ 5383

Revision 5383, 9.9 KB checked in by inagaki, 12 years ago (diff)

update: akonadi, automoc4, herqq, ibus-qt, kdebase-runtime, libqzeitgeist, phonon, PyQt4, qca2, qca-ossl, qt4, qt-assistant-adp, qscintilla, qtsoap, uim

Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4
5%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.0)
6%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
7%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
8%define qt4qmake %{_qt4_prefix}/bin/qmake
9
10Name:    PyQt4
11Summary: Python bindings for Qt4
12Summary(ja): Qt4 の Python バインディング
13Version: 4.9
14Release: 1%{?_dist_release}
15
16# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
17License: GPLv3 or GPLv2 with exceptions
18Group:   Development/Languages
19URL:     http://www.riverbankcomputing.com/software/pyqt/
20
21Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
22Patch1:  PyQt-x11-gpl-4.8.4-64bit.patch
23# HACK! FIXME: ping upstream why this isn't working right. -- Rex
24Patch2:  PyQt-x11-gpl-4.5.2-QT_SHARED.patch
25Patch4:  PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
26
27# Vine Patch
28Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: dbus-devel dbus-python-devel
32BuildRequires: findutils
33BuildRequires: libXext-devel
34BuildRequires: phonon-devel
35BuildRequires: python-devel
36# beware of PyQt4/qscintilla bootstap issues
37#BuildRequires: qscintilla
38BuildRequires: qt4-devel >= 4.5.0
39BuildRequires: qt-assistant-adp-devel
40BuildRequires: sip-devel >= 4.13.1
41Requires: sip >= 4.13.1
42Requires: dbus-python
43Requires: qt4
44
45%description
46These are Python bindings for Qt4.
47
48%package devel
49Summary: Files needed to build other bindings based on Qt4
50Group:   Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: qt4-devel >= 4.5.0
53Requires: qt-assistant-adp-devel
54Requires: sip-devel >= 4.13.1
55
56%description devel
57Files needed to build other bindings for C++ classes that inherit from any
58of the Qt4 classes (e.g. KDE or your own).
59
60
61%prep
62%setup -q -n PyQt-x11-gpl-%{version}
63%ifarch x86_64
64%patch1 -p1 -b .64bit
65%endif
66%patch2 -p1 -b .QT_SHARED
67
68#patch100 -p1 -b .phononpath_vine
69
70## permissions
71# mark examples non-executable
72find examples/ -name "*.py" | xargs chmod a-x
73chmod a+rx pyuic/uic/pyuic.py
74
75%build
76CFLAGS="${CFLAGS:-%optflags}" \
77CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
78%{__python} configure.py \
79  --confirm-license \
80  --qmake=%{qt4qmake} \
81  --no-qsci-api \
82  --verbose
83
84make %{?_smp_mflags}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
90
91# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
92rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
93mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
94   $RPM_BUILD_ROOT%{_bindir}/pyuic4
95ln -s %{_bindir}/pyuic4 \
96      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%files
102%defattr(-,root,root,-)
103%doc NEWS README
104%doc OPENSOURCE-NOTICE.TXT
105%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
106%doc LICENSE.GPL3
107%{python_sitearch}/PyQt4/
108%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
109# fixme?  -> sitearch?  -- Rex
110%{python_sitelib}/dbus/mainloop/qt.so
111%{_qt4_plugindir}/designer/*
112
113%files devel
114%defattr(-,root,root,-)
115%doc doc/*
116%doc examples/
117%{_bindir}/pylupdate4
118%{_bindir}/pyrcc4
119%{_bindir}/pyuic4
120%{python_sitearch}/PyQt4/uic/pyuic.py*
121%{_datadir}/sip/PyQt4/
122#{_qt4_prefix}/qsci/api/python/PyQt4.api
123
124%changelog
125* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.0-1
126- new upstream release
127- aaded BR: qt-assistant-adp-devel
128
129* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.4-2
130- update Patch1 (PyQt-x11-gpl-4.8.4-64bit.patch) (x86_64 only)
131
132* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
133- new upstream release
134
135* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
136- re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
137- remove %%sip_ver
138
139* Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
140- rebuilt with qt4-4.7.2
141
142* Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
143- update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
144
145* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
146- new upstream release
147- built with sip-4.12.1 and qt4-4.7.1
148
149* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
150- rebuild with qt4-4.6.3
151- fix %qtver (from 4.6.1 to 4.6.3)
152
153* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
154- new upstream release
155- rebuilt with sip-4.10.5 and qt4-4.6.3
156
157* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
158- new upstream release
159- updated Patch100
160
161* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
162- updated Patch100 to build phonon module
163
164* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
165- new upstream release
166- rebuilt with python-2.6.4
167- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
168
169* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
170- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
171
172* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
173- new upstream release
174- added BR: libXext-devel
175
176* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
177- added Patch100 for building phonon modules
178
179* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
180- Initial build for Vine
181
182* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
183- PyQt4-4.5.4
184
185* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
186- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
187
188* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
189- PyQt4-4.5.2
190
191* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
192- fix build with qt-4.5.2
193- PyQt4-devel multilib conflict (#509415)
194
195* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
196- PyQt-4.5.1
197
198* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
199- PyQt-4.5
200
201* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
202- fix generation of sip_ver
203
204* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
205- PyQt-4.5-snapshot-20090520
206
207* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
208- rebuild for phonon bindings (#497680)
209
210* Wed Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
211- move designer plugins to main/runtime (#487622)
212
213* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
215
216* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
217- rebuild against qt-4.5rc1
218
219* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
220- Rebuild for Python 2.6
221
222* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
223- PyQt-4.4.4
224
225* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
226- PyQt-4.4.3
227
228* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
229- PyQt4 is built without QtWebKit support (#451490)
230
231* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
232- PyQt-4.4.2
233
234* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
235- PyQt-4.4
236- License: GPLv3 or GPLv2 with exceptions
237
238* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
239- respin (gcc43)
240
241* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
242- PyQt-4.3.3
243
244* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
245- dbus support (#395741)
246
247* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
248- PyQt-4.3.1
249
250* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
251- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
252
253* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
254- fix QtDesigner plugin install
255
256* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
257- 64bit QtDesigner patch
258
259* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
260- -devel: Requires: qt4-devel
261
262* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
263- use %%python_sitearch
264- License: GPLv2
265
266* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
267- fix python_sitelib typo (wrt chrpath call)
268- move %%_bindir stuff to -devel
269- mark %%doc examples non-executable
270- add shebang to %%_bindir/pyuic4
271
272* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
273- remove rpath from QtDesigner.so
274- BR: qt4-devel > 4.3.0-8
275
276* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
277- PyQt4-4.2
278
279* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
280- fix build against multilib'd qt4
281
282* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
283- PyQt4-4.1.1
284- BR: sip-devel >= 4.5.1
285
286* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
287- PyQt4-4.1
288
289* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
290- don't own %%_datadir/sip (bug #206633)
291
292* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
293- BR: qt4-devel < 4.2
294
295* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
296- fix reference(s) to qmake(4)
297
298* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
299- PyQt-4.0.1
300
301* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
302- PyQt-4.0(final)
303- BR: sip-devel >= 4.4.4 (see bug #199430)
304
305* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
306- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
307- drop usage of (undefined) %%sip_min
308
309* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
310- cleanup for Extras
311
312* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
313- 4.0beta1
314
315* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
316- respin for sip-4.4.3
317- use sip-abi, sip-abi-min
318
319* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
320- 20060421 snapshot
321
322* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
323- first try, using 20060417 snapshot
324
Note: See TracBrowser for help on using the repository browser.