source: projects/specs/trunk/P/PyQt4/PyQt4-vl.spec @ 4675

Revision 4675, 9.8 KB checked in by Takemikaduchi, 13 years ago (diff)

PyQt4: fix x86_64 patch, others: new upstream release

Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4
5%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
6%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
7%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
8%define qt4qmake %{_qt4_prefix}/bin/qmake
9
10Name:    PyQt4
11Summary: Python bindings for Qt4
12Summary(ja): Qt4 の Python バインディング
13Version: 4.8.4
14Release: 2%{?_dist_release}
15
16# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
17License: GPLv3 or GPLv2 with exceptions
18Group:   Development/Languages
19URL:     http://www.riverbankcomputing.com/software/pyqt/
20
21Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
22Patch1:  PyQt-x11-gpl-4.8.4-64bit.patch
23# HACK! FIXME: ping upstream why this isn't working right. -- Rex
24Patch2:  PyQt-x11-gpl-4.5.2-QT_SHARED.patch
25Patch4:  PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
26
27# Vine Patch
28Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31#BuildRequires: chrpath
32BuildRequires: dbus-devel dbus-python-devel
33BuildRequires: findutils
34BuildRequires: libXext-devel
35BuildRequires: phonon-devel
36BuildRequires: python-devel
37# beware of PyQt4/qscintilla bootstap issues
38#BuildRequires: qscintilla
39BuildRequires: qt4-devel >= 4.5.0
40BuildRequires: sip-devel >= 4.12.1
41Requires: sip >= 4.12.1
42Requires: dbus-python
43Requires: qt4
44
45%description
46These are Python bindings for Qt4.
47
48%package devel
49Summary: Files needed to build other bindings based on Qt4
50Group:   Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: sip-devel >= 4.12.1
53
54%description devel
55Files needed to build other bindings for C++ classes that inherit from any
56of the Qt4 classes (e.g. KDE or your own).
57
58
59%prep
60%setup -q -n PyQt-x11-gpl-%{version}
61%ifarch x86_64
62%patch1 -p1 -b .64bit
63%endif
64%patch2 -p1 -b .QT_SHARED
65#patch4 -p1
66
67%patch100 -p1 -b .phononpath_vine
68
69## permissions
70# mark examples non-executable
71find examples/ -name "*.py" | xargs chmod a-x
72chmod a+rx pyuic/uic/pyuic.py
73
74
75%build
76unset QTDIR || : ; . /etc/profile.d/qt4.sh
77CFLAGS="${CFLAGS:-%optflags}" \
78CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
79%{__python} configure.py \
80  --confirm-license \
81  --qmake=%{qt4qmake} \
82  --no-qsci-api \
83  --verbose
84
85make %{?_smp_mflags}
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
91
92# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
93rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
94mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
95   $RPM_BUILD_ROOT%{_bindir}/pyuic4
96ln -s %{_bindir}/pyuic4 \
97      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%files
103%defattr(-,root,root,-)
104%doc NEWS README
105%doc OPENSOURCE-NOTICE.TXT
106%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
107%doc LICENSE.GPL3
108%{python_sitearch}/PyQt4/
109%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
110# fixme?  -> sitearch?  -- Rex
111%{python_sitelib}/dbus/mainloop/qt.so
112%{_qt4_plugindir}/designer/*
113
114%files devel
115%defattr(-,root,root,-)
116%doc doc/*
117%doc examples/
118%{_bindir}/pylupdate4
119%{_bindir}/pyrcc4
120%{_bindir}/pyuic4
121%{python_sitearch}/PyQt4/uic/pyuic.py*
122%{_datadir}/sip/PyQt4/
123#{_qt4_prefix}/qsci/api/python/PyQt4.api
124
125%changelog
126* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.4-2
127- update Patch1 (PyQt-x11-gpl-4.8.4-64bit.patch) (x86_64 only)
128
129* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
130- new upstream release
131
132* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
133- re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
134- remove %%sip_ver
135
136* Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
137- rebuilt with qt4-4.7.2
138
139* Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
140- update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
141
142* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
143- new upstream release
144- built with sip-4.12.1 and qt4-4.7.1
145
146* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
147- rebuild with qt4-4.6.3
148- fix %qtver (from 4.6.1 to 4.6.3)
149
150* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
151- new upstream release
152- rebuilt with sip-4.10.5 and qt4-4.6.3
153
154* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
155- new upstream release
156- updated Patch100
157
158* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
159- updated Patch100 to build phonon module
160
161* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
162- new upstream release
163- rebuilt with python-2.6.4
164- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
165
166* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
167- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
168
169* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
170- new upstream release
171- added BR: libXext-devel
172
173* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
174- added Patch100 for building phonon modules
175
176* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
177- Initial build for Vine
178
179* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
180- PyQt4-4.5.4
181
182* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
183- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
184
185* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
186- PyQt4-4.5.2
187
188* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
189- fix build with qt-4.5.2
190- PyQt4-devel multilib conflict (#509415)
191
192* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
193- PyQt-4.5.1
194
195* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
196- PyQt-4.5
197
198* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
199- fix generation of sip_ver
200
201* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
202- PyQt-4.5-snapshot-20090520
203
204* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
205- rebuild for phonon bindings (#497680)
206
207* Wed Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
208- move designer plugins to main/runtime (#487622)
209
210* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
211- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
212
213* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
214- rebuild against qt-4.5rc1
215
216* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
217- Rebuild for Python 2.6
218
219* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
220- PyQt-4.4.4
221
222* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
223- PyQt-4.4.3
224
225* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
226- PyQt4 is built without QtWebKit support (#451490)
227
228* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
229- PyQt-4.4.2
230
231* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
232- PyQt-4.4
233- License: GPLv3 or GPLv2 with exceptions
234
235* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
236- respin (gcc43)
237
238* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
239- PyQt-4.3.3
240
241* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
242- dbus support (#395741)
243
244* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
245- PyQt-4.3.1
246
247* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
248- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
249
250* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
251- fix QtDesigner plugin install
252
253* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
254- 64bit QtDesigner patch
255
256* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
257- -devel: Requires: qt4-devel
258
259* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
260- use %%python_sitearch
261- License: GPLv2
262
263* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
264- fix python_sitelib typo (wrt chrpath call)
265- move %%_bindir stuff to -devel
266- mark %%doc examples non-executable
267- add shebang to %%_bindir/pyuic4
268
269* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
270- remove rpath from QtDesigner.so
271- BR: qt4-devel > 4.3.0-8
272
273* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
274- PyQt4-4.2
275
276* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
277- fix build against multilib'd qt4
278
279* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
280- PyQt4-4.1.1
281- BR: sip-devel >= 4.5.1
282
283* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
284- PyQt4-4.1
285
286* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
287- don't own %%_datadir/sip (bug #206633)
288
289* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
290- BR: qt4-devel < 4.2
291
292* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
293- fix reference(s) to qmake(4)
294
295* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
296- PyQt-4.0.1
297
298* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
299- PyQt-4.0(final)
300- BR: sip-devel >= 4.4.4 (see bug #199430)
301
302* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
303- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
304- drop usage of (undefined) %%sip_min
305
306* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
307- cleanup for Extras
308
309* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
310- 4.0beta1
311
312* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
313- respin for sip-4.4.3
314- use sip-abi, sip-abi-min
315
316* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
317- 20060421 snapshot
318
319* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
320- first try, using 20060417 snapshot
321
Note: See TracBrowser for help on using the repository browser.