source: projects/specs/trunk/P/PyQt4/PyQt4-vl.spec @ 9071

Revision 9071, 10.7 KB checked in by inagaki, 9 years ago (diff)

2014-11-08 Ryoichi INAGAKI <ryo1@…>

  • PyQt?: rebuilt
  • PyQt4, qscintilla, sip: updated


Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4
5%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
6%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
7%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
8%define qt4qmake %{_qt4_prefix}/bin/qmake
9
10Name:    PyQt4
11Summary: Python bindings for Qt4
12Summary(ja): Qt4 の Python バインディング
13Version: 4.11.2
14Release: 1%{?_dist_release}
15
16# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
17License: GPLv3 or GPLv2 with exceptions
18Group:   System Environment/Libraries
19URL:     http://www.riverbankcomputing.com/software/pyqt/
20
21Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
22
23## upstreamable patches
24# fix multilib conflict because of timestamp
25Patch50:  PyQt-x11-gpl-4.9.5-timestamp_multilib.patch
26Patch52:  PyQt-x11-gpl-4.10.4-pyuic_shbang.patch
27
28# Vine Patch
29Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: dbus-devel dbus-python-devel
33BuildRequires: findutils
34BuildRequires: libXext-devel
35BuildRequires: phonon-devel
36BuildRequires: python-devel
37# beware of PyQt4/qscintilla bootstap issues
38#BuildRequires: qscintilla
39BuildRequires: qt4-devel >= 4.5.0
40BuildRequires: qt-assistant-adp-devel
41BuildRequires: sip-devel >= 4.13.1
42Requires: sip >= 4.13.1
43Requires: dbus-python
44Requires: qt4
45
46%description
47These are Python bindings for Qt4.
48
49%package devel
50Summary: Files needed to build other bindings based on Qt4
51Group:   Development/Libraries
52Requires: %{name} = %{version}-%{release}
53Requires: qt4-devel >= 4.5.0
54Requires: qt-assistant-adp-devel
55Requires: sip-devel >= 4.13.1
56
57%description devel
58Files needed to build other bindings for C++ classes that inherit from any
59of the Qt4 classes (e.g. KDE or your own).
60
61
62%prep
63%setup -q -n PyQt-x11-gpl-%{version}
64%patch50 -p1 -b .timestamp
65# skip -b on this one, so the backup copy doesnt end up packaged too
66%patch52 -p1
67
68#patch100 -p1 -b .phononpath_vine
69
70# permissions, mark examples non-executable
71find examples/ -name "*.py" | xargs chmod a-x
72chmod a+rx pyuic/uic/pyuic.py
73
74%build
75QT4DIR=%{_qt4_prefix}
76PATH=%{_qt4_bindir}:$PATH ; export PATH
77%{__python} configure.py \
78  --assume-shared \
79  --confirm-license \
80  --no-timestamp \
81  --qmake=%{qt4qmake} \
82  --no-qsci-api \
83  --verbose
84
85make %{?_smp_mflags}
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
91
92# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
93rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
94mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
95   $RPM_BUILD_ROOT%{_bindir}/pyuic4
96ln -s %{_bindir}/pyuic4 \
97      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%files
103%defattr(-,root,root,-)
104%doc NEWS README
105%doc OPENSOURCE-NOTICE.TXT
106%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
107%doc LICENSE.GPL3
108%{python_sitearch}/PyQt4/
109%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
110# fixme?  -> sitearch?  -- Rex
111%{python_sitelib}/dbus/mainloop/qt.so
112%{_qt4_plugindir}/designer/*
113
114%files devel
115%defattr(-,root,root,-)
116%doc doc/*
117%doc examples/
118%{_bindir}/pylupdate4
119%{_bindir}/pyrcc4
120%{_bindir}/pyuic4
121%{python_sitearch}/PyQt4/uic/pyuic.py*
122%{_datadir}/sip/PyQt4/
123#{_qt4_prefix}/qsci/api/python/PyQt4.api
124
125%changelog
126* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.11.2-1
127- new upstream release
128- added Patch50 and 52
129- moved to System Environment/Libraries Group
130
131* Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.4-1
132- new upstream release
133- update Patch1 (PyQt-x11-gpl-4.10.4-64bit.patch)
134
135* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.3-1
136- new upstream release
137
138* Sat Sep 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.2-1
139- new upstream release
140
141* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.1-1
142- new upstream release
143
144* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.4-1
145- new upstream release
146- update Patch1 (PyQt-x11-gpl-4.9.4-64bit.patch)
147
148* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
149- rebuild with python-2.7.2
150
151* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.0-1
152- new upstream release
153- aaded BR: qt-assistant-adp-devel
154
155* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.4-2
156- update Patch1 (PyQt-x11-gpl-4.8.4-64bit.patch) (x86_64 only)
157
158* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
159- new upstream release
160
161* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
162- re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
163- remove %%sip_ver
164
165* Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
166- rebuilt with qt4-4.7.2
167
168* Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
169- update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
170
171* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
172- new upstream release
173- built with sip-4.12.1 and qt4-4.7.1
174
175* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
176- rebuild with qt4-4.6.3
177- fix %qtver (from 4.6.1 to 4.6.3)
178
179* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
180- new upstream release
181- rebuilt with sip-4.10.5 and qt4-4.6.3
182
183* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
184- new upstream release
185- updated Patch100
186
187* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
188- updated Patch100 to build phonon module
189
190* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
191- new upstream release
192- rebuilt with python-2.6.4
193- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
194
195* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
196- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
197
198* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
199- new upstream release
200- added BR: libXext-devel
201
202* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
203- added Patch100 for building phonon modules
204
205* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
206- Initial build for Vine
207
208* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
209- PyQt4-4.5.4
210
211* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
213
214* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
215- PyQt4-4.5.2
216
217* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
218- fix build with qt-4.5.2
219- PyQt4-devel multilib conflict (#509415)
220
221* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
222- PyQt-4.5.1
223
224* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
225- PyQt-4.5
226
227* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
228- fix generation of sip_ver
229
230* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
231- PyQt-4.5-snapshot-20090520
232
233* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
234- rebuild for phonon bindings (#497680)
235
236* Thu Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
237- move designer plugins to main/runtime (#487622)
238
239* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
240- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
241
242* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
243- rebuild against qt-4.5rc1
244
245* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
246- Rebuild for Python 2.6
247
248* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
249- PyQt-4.4.4
250
251* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
252- PyQt-4.4.3
253
254* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
255- PyQt4 is built without QtWebKit support (#451490)
256
257* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
258- PyQt-4.4.2
259
260* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
261- PyQt-4.4
262- License: GPLv3 or GPLv2 with exceptions
263
264* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
265- respin (gcc43)
266
267* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
268- PyQt-4.3.3
269
270* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
271- dbus support (#395741)
272
273* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
274- PyQt-4.3.1
275
276* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
277- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
278
279* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
280- fix QtDesigner plugin install
281
282* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
283- 64bit QtDesigner patch
284
285* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
286- -devel: Requires: qt4-devel
287
288* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
289- use %%python_sitearch
290- License: GPLv2
291
292* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
293- fix python_sitelib typo (wrt chrpath call)
294- move %%_bindir stuff to -devel
295- mark %%doc examples non-executable
296- add shebang to %%_bindir/pyuic4
297
298* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
299- remove rpath from QtDesigner.so
300- BR: qt4-devel > 4.3.0-8
301
302* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
303- PyQt4-4.2
304
305* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
306- fix build against multilib'd qt4
307
308* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
309- PyQt4-4.1.1
310- BR: sip-devel >= 4.5.1
311
312* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
313- PyQt4-4.1
314
315* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
316- don't own %%_datadir/sip (bug #206633)
317
318* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
319- BR: qt4-devel < 4.2
320
321* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
322- fix reference(s) to qmake(4)
323
324* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
325- PyQt-4.0.1
326
327* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
328- PyQt-4.0(final)
329- BR: sip-devel >= 4.4.4 (see bug #199430)
330
331* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
332- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
333- drop usage of (undefined) %%sip_min
334
335* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
336- cleanup for Extras
337
338* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
339- 4.0beta1
340
341* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
342- respin for sip-4.4.3
343- use sip-abi, sip-abi-min
344
345* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
346- 20060421 snapshot
347
348* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
349- first try, using 20060417 snapshot
350
Note: See TracBrowser for help on using the repository browser.