source: projects/specs/trunk/P/PyQt4/PyQt4-vl.spec @ 10460

Revision 10460, 10.8 KB checked in by Takemikaduchi, 8 years ago (diff)

firefox: new upstrream release
others: rebuild with gcc-5.4.0

Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4
5%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
6%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
7%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
8%define qt4qmake %{_qt4_prefix}/bin/qmake
9
10Name:    PyQt4
11Summary: Python bindings for Qt4
12Summary(ja): Qt4 の Python バインディング
13Version: 4.11.2
14Release: 2%{?_dist_release}
15
16# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
17License: GPLv3 or GPLv2 with exceptions
18Group:   System Environment/Libraries
19URL:     http://www.riverbankcomputing.com/software/pyqt/
20
21Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
22
23## upstreamable patches
24# fix multilib conflict because of timestamp
25Patch50:  PyQt-x11-gpl-4.9.5-timestamp_multilib.patch
26Patch52:  PyQt-x11-gpl-4.10.4-pyuic_shbang.patch
27
28# Vine Patch
29Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: dbus-devel dbus-python-devel
33BuildRequires: findutils
34BuildRequires: libXext-devel
35BuildRequires: phonon-devel
36BuildRequires: python-devel
37# beware of PyQt4/qscintilla bootstap issues
38#BuildRequires: qscintilla
39BuildRequires: qt4-devel >= 4.5.0
40BuildRequires: qt-assistant-adp-devel
41BuildRequires: sip-devel >= 4.13.1
42Requires: sip >= 4.13.1
43Requires: dbus-python
44Requires: qt4
45
46%description
47These are Python bindings for Qt4.
48
49%package devel
50Summary: Files needed to build other bindings based on Qt4
51Group:   Development/Libraries
52Requires: %{name} = %{version}-%{release}
53Requires: qt4-devel >= 4.5.0
54Requires: qt-assistant-adp-devel
55Requires: sip-devel >= 4.13.1
56
57%description devel
58Files needed to build other bindings for C++ classes that inherit from any
59of the Qt4 classes (e.g. KDE or your own).
60
61
62%prep
63%setup -q -n PyQt-x11-gpl-%{version}
64%patch50 -p1 -b .timestamp
65# skip -b on this one, so the backup copy doesnt end up packaged too
66%patch52 -p1
67
68#patch100 -p1 -b .phononpath_vine
69
70# permissions, mark examples non-executable
71find examples/ -name "*.py" | xargs chmod a-x
72chmod a+rx pyuic/uic/pyuic.py
73
74%build
75QT4DIR=%{_qt4_prefix}
76PATH=%{_qt4_bindir}:$PATH ; export PATH
77%{__python} configure.py \
78  --assume-shared \
79  --confirm-license \
80  --no-timestamp \
81  --qmake=%{qt4qmake} \
82  --no-qsci-api \
83  --verbose
84
85make %{?_smp_mflags}
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
91
92# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
93rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
94mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
95   $RPM_BUILD_ROOT%{_bindir}/pyuic4
96ln -s %{_bindir}/pyuic4 \
97      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%files
103%defattr(-,root,root,-)
104%doc NEWS README
105%doc OPENSOURCE-NOTICE.TXT
106%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
107%doc LICENSE.GPL3
108%{python_sitearch}/PyQt4/
109%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
110# fixme?  -> sitearch?  -- Rex
111%{python_sitelib}/dbus/mainloop/qt.so
112%{_qt4_plugindir}/designer/*
113
114%files devel
115%defattr(-,root,root,-)
116%doc doc/*
117%doc examples/
118%{_bindir}/pylupdate4
119%{_bindir}/pyrcc4
120%{_bindir}/pyuic4
121%{python_sitearch}/PyQt4/uic/pyuic.py*
122%{_datadir}/sip/PyQt4/
123#{_qt4_prefix}/qsci/api/python/PyQt4.api
124
125%changelog
126* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.2-2
127- rebuild with gcc-5.4.0
128
129* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.11.2-1
130- new upstream release
131- added Patch50 and 52
132- moved to System Environment/Libraries Group
133
134* Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.4-1
135- new upstream release
136- update Patch1 (PyQt-x11-gpl-4.10.4-64bit.patch)
137
138* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.3-1
139- new upstream release
140
141* Sat Sep 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.2-1
142- new upstream release
143
144* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.1-1
145- new upstream release
146
147* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.4-1
148- new upstream release
149- update Patch1 (PyQt-x11-gpl-4.9.4-64bit.patch)
150
151* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
152- rebuild with python-2.7.2
153
154* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.0-1
155- new upstream release
156- aaded BR: qt-assistant-adp-devel
157
158* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.4-2
159- update Patch1 (PyQt-x11-gpl-4.8.4-64bit.patch) (x86_64 only)
160
161* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
162- new upstream release
163
164* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
165- re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
166- remove %%sip_ver
167
168* Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
169- rebuilt with qt4-4.7.2
170
171* Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
172- update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
173
174* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
175- new upstream release
176- built with sip-4.12.1 and qt4-4.7.1
177
178* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
179- rebuild with qt4-4.6.3
180- fix %qtver (from 4.6.1 to 4.6.3)
181
182* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
183- new upstream release
184- rebuilt with sip-4.10.5 and qt4-4.6.3
185
186* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
187- new upstream release
188- updated Patch100
189
190* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
191- updated Patch100 to build phonon module
192
193* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
194- new upstream release
195- rebuilt with python-2.6.4
196- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
197
198* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
199- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
200
201* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
202- new upstream release
203- added BR: libXext-devel
204
205* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
206- added Patch100 for building phonon modules
207
208* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
209- Initial build for Vine
210
211* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
212- PyQt4-4.5.4
213
214* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
216
217* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
218- PyQt4-4.5.2
219
220* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
221- fix build with qt-4.5.2
222- PyQt4-devel multilib conflict (#509415)
223
224* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
225- PyQt-4.5.1
226
227* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
228- PyQt-4.5
229
230* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
231- fix generation of sip_ver
232
233* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
234- PyQt-4.5-snapshot-20090520
235
236* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
237- rebuild for phonon bindings (#497680)
238
239* Thu Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
240- move designer plugins to main/runtime (#487622)
241
242* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
243- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
244
245* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
246- rebuild against qt-4.5rc1
247
248* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
249- Rebuild for Python 2.6
250
251* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
252- PyQt-4.4.4
253
254* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
255- PyQt-4.4.3
256
257* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
258- PyQt4 is built without QtWebKit support (#451490)
259
260* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
261- PyQt-4.4.2
262
263* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
264- PyQt-4.4
265- License: GPLv3 or GPLv2 with exceptions
266
267* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
268- respin (gcc43)
269
270* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
271- PyQt-4.3.3
272
273* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
274- dbus support (#395741)
275
276* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
277- PyQt-4.3.1
278
279* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
280- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
281
282* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
283- fix QtDesigner plugin install
284
285* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
286- 64bit QtDesigner patch
287
288* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
289- -devel: Requires: qt4-devel
290
291* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
292- use %%python_sitearch
293- License: GPLv2
294
295* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
296- fix python_sitelib typo (wrt chrpath call)
297- move %%_bindir stuff to -devel
298- mark %%doc examples non-executable
299- add shebang to %%_bindir/pyuic4
300
301* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
302- remove rpath from QtDesigner.so
303- BR: qt4-devel > 4.3.0-8
304
305* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
306- PyQt4-4.2
307
308* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
309- fix build against multilib'd qt4
310
311* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
312- PyQt4-4.1.1
313- BR: sip-devel >= 4.5.1
314
315* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
316- PyQt4-4.1
317
318* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
319- don't own %%_datadir/sip (bug #206633)
320
321* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
322- BR: qt4-devel < 4.2
323
324* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
325- fix reference(s) to qmake(4)
326
327* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
328- PyQt-4.0.1
329
330* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
331- PyQt-4.0(final)
332- BR: sip-devel >= 4.4.4 (see bug #199430)
333
334* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
335- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
336- drop usage of (undefined) %%sip_min
337
338* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
339- cleanup for Extras
340
341* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
342- 4.0beta1
343
344* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
345- respin for sip-4.4.3
346- use sip-abi, sip-abi-min
347
348* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
349- 20060421 snapshot
350
351* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
352- first try, using 20060417 snapshot
353
Note: See TracBrowser for help on using the repository browser.