source: projects/specs/trunk/P/PyQt4/PyQt4-vl.spec @ 2623

Revision 2623, 9.3 KB checked in by Takemikaduchi, 13 years ago (diff)

fix Patch1

Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4%global sip_ver %(sip -V 2>/dev/null | cut -d' ' -f1 | cut -d- -f1)
5
6# Qt4 version auto-detection -- inagaki
7%define qtver %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.1)
8%define qt4qmake %{_libdir}/qt-%{qtver}/bin/qmake
9
10Name:    PyQt4
11Summary: Python bindings for Qt4
12Summary(ja): Qt4 の Python バインディング
13Version: 4.8.3
14Release: 2%{?_dist_release}
15
16# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
17License: GPLv3 or GPLv2 with exceptions
18Group:   Development/Languages
19URL:     http://www.riverbankcomputing.com/software/pyqt/
20Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
21Patch1:  PyQt-x11-gpl-4.8.3-64bit.patch
22# HACK! FIXME: ping upstream why this isn't working right. -- Rex
23Patch2:  PyQt-x11-gpl-4.5.2-QT_SHARED.patch
24Patch4:  PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
25
26# Vine Patch
27Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30#BuildRequires: chrpath
31BuildRequires: dbus-devel dbus-python-devel
32BuildRequires: findutils
33BuildRequires: phonon-devel
34# beware of PyQt4/qscintilla bootstap issues
35#BuildRequires: qscintilla
36BuildRequires: qt4-devel >= 4.5.0
37BuildRequires: python-devel
38BuildRequires: sip-devel >= 4.9
39BuildRequires: libXext-devel
40Requires: sip >= %{sip_ver}
41Requires: dbus-python
42Requires: qt4 >= %{qtver}
43
44
45%description
46These are Python bindings for Qt4.
47
48%package devel
49Summary: Files needed to build other bindings based on Qt4
50Group:   Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: qt4-devel >= %{qtver}
53Requires: sip-devel >= 4.9
54
55%description devel
56Files needed to build other bindings for C++ classes that inherit from any
57of the Qt4 classes (e.g. KDE or your own).
58
59
60%prep
61%setup -q -n PyQt-x11-gpl-%{version}
62%ifarch x86_64
63%patch1 -p1 -b .64bit
64%endif
65%patch2 -p1 -b .QT_SHARED
66#patch4 -p1
67
68%patch100 -p1 -b .phononpath_vine
69
70## permissions
71# mark examples non-executable
72find examples/ -name "*.py" | xargs chmod a-x
73chmod a+rx pyuic/uic/pyuic.py
74
75
76%build
77unset QTDIR || : ; . /etc/profile.d/qt4.sh
78CFLAGS="${CFLAGS:-%optflags}" \
79CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
80%{__python} configure.py \
81  --confirm-license \
82  --qmake=%{qt4qmake} \
83  --no-qsci-api \
84  --verbose
85
86make %{?_smp_mflags}
87
88%install
89rm -rf $RPM_BUILD_ROOT
90
91make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
92
93# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
94rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
95mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
96   $RPM_BUILD_ROOT%{_bindir}/pyuic4
97ln -s %{_bindir}/pyuic4 \
98      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%files
104%defattr(-,root,root,-)
105%doc NEWS README
106%doc OPENSOURCE-NOTICE.TXT
107%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
108%doc LICENSE.GPL3
109%{python_sitearch}/PyQt4/
110%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
111# fixme?  -> sitearch?  -- Rex
112%{python_sitelib}/dbus/mainloop/qt.so
113%{_libdir}/qt-%{qtver}/plugins/designer/*
114
115%files devel
116%defattr(-,root,root,-)
117%doc doc/*
118%doc examples/
119%{_bindir}/pylupdate4
120%{_bindir}/pyrcc4
121%{_bindir}/pyuic4
122%{python_sitearch}/PyQt4/uic/pyuic.py*
123%{_datadir}/sip/PyQt4/
124#{_qt4_prefix}/qsci/api/python/PyQt4.api
125
126
127%changelog
128* Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
129- update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
130
131* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
132- new upstream release
133- built with sip-4.12.1 and qt4-4.7.1
134
135* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
136- rebuild with qt4-4.6.3
137- fix %qtver (from 4.6.1 to 4.6.3)
138
139* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
140- new upstream release
141- rebuilt with sip-4.10.5 and qt4-4.6.3
142
143* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
144- new upstream release
145- updated Patch100
146
147* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
148- updated Patch100 to build phonon module
149
150* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
151- new upstream release
152- rebuilt with python-2.6.4
153- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
154
155* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
156- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
157
158* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
159- new upstream release
160- added BR: libXext-devel
161
162* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
163- added Patch100 for building phonon modules
164
165* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
166- Initial build for Vine
167
168* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
169- PyQt4-4.5.4
170
171* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
173
174* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
175- PyQt4-4.5.2
176
177* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
178- fix build with qt-4.5.2
179- PyQt4-devel multilib conflict (#509415)
180
181* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
182- PyQt-4.5.1
183
184* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
185- PyQt-4.5
186
187* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
188- fix generation of sip_ver
189
190* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
191- PyQt-4.5-snapshot-20090520
192
193* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
194- rebuild for phonon bindings (#497680)
195
196* Wed Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
197- move designer plugins to main/runtime (#487622)
198
199* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
200- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
201
202* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
203- rebuild against qt-4.5rc1
204
205* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
206- Rebuild for Python 2.6
207
208* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
209- PyQt-4.4.4
210
211* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
212- PyQt-4.4.3
213
214* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
215- PyQt4 is built without QtWebKit support (#451490)
216
217* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
218- PyQt-4.4.2
219
220* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
221- PyQt-4.4
222- License: GPLv3 or GPLv2 with exceptions
223
224* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
225- respin (gcc43)
226
227* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
228- PyQt-4.3.3
229
230* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
231- dbus support (#395741)
232
233* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
234- PyQt-4.3.1
235
236* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
237- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
238
239* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
240- fix QtDesigner plugin install
241
242* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
243- 64bit QtDesigner patch
244
245* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
246- -devel: Requires: qt4-devel
247
248* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
249- use %%python_sitearch
250- License: GPLv2
251
252* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
253- fix python_sitelib typo (wrt chrpath call)
254- move %%_bindir stuff to -devel
255- mark %%doc examples non-executable
256- add shebang to %%_bindir/pyuic4
257
258* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
259- remove rpath from QtDesigner.so
260- BR: qt4-devel > 4.3.0-8
261
262* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
263- PyQt4-4.2
264
265* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
266- fix build against multilib'd qt4
267
268* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
269- PyQt4-4.1.1
270- BR: sip-devel >= 4.5.1
271
272* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
273- PyQt4-4.1
274
275* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
276- don't own %%_datadir/sip (bug #206633)
277
278* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
279- BR: qt4-devel < 4.2
280
281* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
282- fix reference(s) to qmake(4)
283
284* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
285- PyQt-4.0.1
286
287* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
288- PyQt-4.0(final)
289- BR: sip-devel >= 4.4.4 (see bug #199430)
290
291* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
292- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
293- drop usage of (undefined) %%sip_min
294
295* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
296- cleanup for Extras
297
298* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
299- 4.0beta1
300
301* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
302- respin for sip-4.4.3
303- use sip-abi, sip-abi-min
304
305* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
306- 20060421 snapshot
307
308* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
309- first try, using 20060417 snapshot
310
Note: See TracBrowser for help on using the repository browser.