source: projects/specs/trunk/P/PyQt4/PyQt4-vl.spec @ 2981

Revision 2981, 9.5 KB checked in by inagaki, 13 years ago (diff)

updated: qt, qt4, PyQt4, avogadro, phonon, qca-ossl, qca2, qoauth, scim-bridge and uim

Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4%global sip_ver %(sip -V 2>/dev/null | cut -d' ' -f1 | cut -d- -f1)
5
6%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
7%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
8%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
9%define qt4qmake %{_qt4_prefix}/bin/qmake
10
11Name:    PyQt4
12Summary: Python bindings for Qt4
13Summary(ja): Qt4 の Python バインディング
14Version: 4.8.3
15Release: 3%{?_dist_release}
16
17# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
18License: GPLv3 or GPLv2 with exceptions
19Group:   Development/Languages
20URL:     http://www.riverbankcomputing.com/software/pyqt/
21Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
22Patch1:  PyQt-x11-gpl-4.4.4-64bit.patch
23# HACK! FIXME: ping upstream why this isn't working right. -- Rex
24Patch2:  PyQt-x11-gpl-4.5.2-QT_SHARED.patch
25Patch4:  PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
26
27# Vine Patch
28Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31#BuildRequires: chrpath
32BuildRequires: dbus-devel dbus-python-devel
33BuildRequires: findutils
34BuildRequires: libXext-devel
35BuildRequires: phonon-devel
36BuildRequires: python-devel
37# beware of PyQt4/qscintilla bootstap issues
38#BuildRequires: qscintilla
39BuildRequires: qt4-devel >= 4.5.0
40BuildRequires: sip-devel >= 4.9
41Requires: sip >= %{sip_ver}
42Requires: dbus-python
43Requires: qt4
44
45%description
46These are Python bindings for Qt4.
47
48%package devel
49Summary: Files needed to build other bindings based on Qt4
50Group:   Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: sip-devel >= 4.9
53
54%description devel
55Files needed to build other bindings for C++ classes that inherit from any
56of the Qt4 classes (e.g. KDE or your own).
57
58
59%prep
60%setup -q -n PyQt-x11-gpl-%{version}
61#patch1 -p1 -b .64bit
62%patch2 -p1 -b .QT_SHARED
63#patch4 -p1
64
65%patch100 -p1 -b .phononpath_vine
66
67## permissions
68# mark examples non-executable
69find examples/ -name "*.py" | xargs chmod a-x
70chmod a+rx pyuic/uic/pyuic.py
71
72
73%build
74unset QTDIR || : ; . /etc/profile.d/qt4.sh
75CFLAGS="${CFLAGS:-%optflags}" \
76CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
77%{__python} configure.py \
78  --confirm-license \
79  --qmake=%{qt4qmake} \
80  --no-qsci-api \
81  --verbose
82
83make %{?_smp_mflags}
84
85%install
86rm -rf $RPM_BUILD_ROOT
87
88make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
89
90# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
91rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
92mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
93   $RPM_BUILD_ROOT%{_bindir}/pyuic4
94ln -s %{_bindir}/pyuic4 \
95      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%files
101%defattr(-,root,root,-)
102%doc NEWS README
103%doc OPENSOURCE-NOTICE.TXT
104%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
105%doc LICENSE.GPL3
106%{python_sitearch}/PyQt4/
107%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
108# fixme?  -> sitearch?  -- Rex
109%{python_sitelib}/dbus/mainloop/qt.so
110%{_qt4_plugindir}/designer/*
111
112%files devel
113%defattr(-,root,root,-)
114%doc doc/*
115%doc examples/
116%{_bindir}/pylupdate4
117%{_bindir}/pyrcc4
118%{_bindir}/pyuic4
119%{python_sitearch}/PyQt4/uic/pyuic.py*
120%{_datadir}/sip/PyQt4/
121#{_qt4_prefix}/qsci/api/python/PyQt4.api
122
123%changelog
124* Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
125- rebuilt with qt4-4.7.2
126
127* Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
128- update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
129
130* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
131- new upstream release
132- built with sip-4.12.1 and qt4-4.7.1
133
134* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
135- rebuild with qt4-4.6.3
136- fix %qtver (from 4.6.1 to 4.6.3)
137
138* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
139- new upstream release
140- rebuilt with sip-4.10.5 and qt4-4.6.3
141
142* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
143- new upstream release
144- updated Patch100
145
146* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
147- updated Patch100 to build phonon module
148
149* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
150- new upstream release
151- rebuilt with python-2.6.4
152- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
153
154* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
155- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
156
157* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
158- new upstream release
159- added BR: libXext-devel
160
161* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
162- added Patch100 for building phonon modules
163
164* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
165- Initial build for Vine
166
167* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
168- PyQt4-4.5.4
169
170* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
172
173* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
174- PyQt4-4.5.2
175
176* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
177- fix build with qt-4.5.2
178- PyQt4-devel multilib conflict (#509415)
179
180* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
181- PyQt-4.5.1
182
183* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
184- PyQt-4.5
185
186* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
187- fix generation of sip_ver
188
189* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
190- PyQt-4.5-snapshot-20090520
191
192* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
193- rebuild for phonon bindings (#497680)
194
195* Wed Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
196- move designer plugins to main/runtime (#487622)
197
198* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
200
201* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
202- rebuild against qt-4.5rc1
203
204* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
205- Rebuild for Python 2.6
206
207* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
208- PyQt-4.4.4
209
210* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
211- PyQt-4.4.3
212
213* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
214- PyQt4 is built without QtWebKit support (#451490)
215
216* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
217- PyQt-4.4.2
218
219* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
220- PyQt-4.4
221- License: GPLv3 or GPLv2 with exceptions
222
223* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
224- respin (gcc43)
225
226* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
227- PyQt-4.3.3
228
229* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
230- dbus support (#395741)
231
232* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
233- PyQt-4.3.1
234
235* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
236- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
237
238* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
239- fix QtDesigner plugin install
240
241* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
242- 64bit QtDesigner patch
243
244* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
245- -devel: Requires: qt4-devel
246
247* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
248- use %%python_sitearch
249- License: GPLv2
250
251* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
252- fix python_sitelib typo (wrt chrpath call)
253- move %%_bindir stuff to -devel
254- mark %%doc examples non-executable
255- add shebang to %%_bindir/pyuic4
256
257* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
258- remove rpath from QtDesigner.so
259- BR: qt4-devel > 4.3.0-8
260
261* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
262- PyQt4-4.2
263
264* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
265- fix build against multilib'd qt4
266
267* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
268- PyQt4-4.1.1
269- BR: sip-devel >= 4.5.1
270
271* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
272- PyQt4-4.1
273
274* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
275- don't own %%_datadir/sip (bug #206633)
276
277* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
278- BR: qt4-devel < 4.2
279
280* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
281- fix reference(s) to qmake(4)
282
283* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
284- PyQt-4.0.1
285
286* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
287- PyQt-4.0(final)
288- BR: sip-devel >= 4.4.4 (see bug #199430)
289
290* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
291- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
292- drop usage of (undefined) %%sip_min
293
294* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
295- cleanup for Extras
296
297* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
298- 4.0beta1
299
300* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
301- respin for sip-4.4.3
302- use sip-abi, sip-abi-min
303
304* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
305- 20060421 snapshot
306
307* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
308- first try, using 20060417 snapshot
309
Note: See TracBrowser for help on using the repository browser.