source: projects/specs/trunk/P/PyQt/PyQt-vl.spec @ 521

Revision 521, 2.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pyexeclib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2%define name    PyQt
3%define version 3.18.1
4%define release 2%{?_dist_release}
5
6Summary:        Python bindings for Qt.
7Name:           %{name}
8Version:        %{version}
9Release:        %{release}
10License:        GPL
11Group:          Development/Languages
12Source:         http://www.riverbankcomputing.com/Downloads/PyQt3/GPL/%{name}-x11-gpl-%{version}.tar.gz
13URL:            http://www.riverbankcomputing.co.uk/pyqt
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  python-devel sip-devel qt-devel
16Requires:       python
17
18%description
19Python bindings for the Qt C++ class library.
20
21%package devel
22Summary:        Files needed to build other bindings based on Qt
23Group:          Development/Libraries
24Requires:       %{name} = %{version}
25Requires:       sip-devel qt-devel
26
27%description devel
28Files needed to build other bindings for C++ classes that inherit from any
29of the Qt classes (e.g. KDE or your own).
30
31%prep
32%setup -q -n %{name}-x11-gpl-%{version}
33
34%build
35mkdir -p $RPM_BUILD_ROOT%{pyexeclib}
36python configure.py -d %{pyexeclib} <<EOF
37    yes
38EOF
39# note that -j2 does not work
40make
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make DESTDIR=$RPM_BUILD_ROOT install
45mkdir -p $RPM_BUILD_ROOT%{_datadir}/sip/qt
46cp -r sip/* $RPM_BUILD_ROOT%{_datadir}/sip/qt/
47
48%clean
49rm -rf %{buildroot}
50
51%files
52%defattr(-, root, root, 755)
53%doc NEWS README ChangeLog THANKS
54%doc doc/PyQt.html
55%{_bindir}/*
56%{pyexeclib}/*
57
58%files devel
59%defattr(-,root,root)
60%doc examples*
61%{_datadir}/sip/*
62
63%changelog
64* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.18.1-2
65- rebuilt with python-2.6.4
66
67* Thu Nov 12 2009 Ryoichi INAGAKI <owa@bg.wakwak.com> 3.18.1-1
68- new upstream release
69- removed qscintilla dependency
70
71* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 3.17.3-1vl5
72- rebuilt with python-2.5.2
73- added pyexeclib macro
74- applied new versioning policy
75
76* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 3.17.3-0vl2
77- changed source url
78- fixed python site-packages path (for lib64)
79
80* Thu Sep 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.17.3-0vl1
81- updated to 3.16
82- rebuilt with new toolchain
83
84* Sun Jun 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.16-0vl1
85- updated to 3.16
86- changed Group to Development/Languages
87- rebuild with python-2.4.3, sip-4.4.5, qscinteilla-1.6
88
89* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 3.13-0vl2
90- rebuild with python-2.4.1
91
92* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 3.13-0vl1
93- initial release for VineLinux
94
Note: See TracBrowser for help on using the repository browser.