source: projects/specs/trunk/P/PyQt/PyQt-vl.spec @ 5701

Revision 5701, 2.5 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define pyexeclib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2%define name    PyQt
3%define version 3.18.1
4%define release 3%{?_dist_release}
5
6Summary:        Python bindings for Qt.
7Name:           %{name}
8Version:        %{version}
9Release:        %{release}
10License:        GPL
11Group:          Development/Languages
12Source:         http://www.riverbankcomputing.com/Downloads/PyQt3/GPL/%{name}-x11-gpl-%{version}.tar.gz
13URL:            http://www.riverbankcomputing.co.uk/pyqt
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  python-devel sip-devel qt-devel
16Requires:       python
17
18%description
19Python bindings for the Qt C++ class library.
20
21%package devel
22Summary:        Files needed to build other bindings based on Qt
23Group:          Development/Libraries
24Requires:       %{name} = %{version}
25Requires:       sip-devel qt-devel
26
27%description devel
28Files needed to build other bindings for C++ classes that inherit from any
29of the Qt classes (e.g. KDE or your own).
30
31%prep
32%setup -q -n %{name}-x11-gpl-%{version}
33
34%build
35mkdir -p $RPM_BUILD_ROOT%{pyexeclib}
36python configure.py -d %{pyexeclib} <<EOF
37    yes
38EOF
39# note that -j2 does not work
40make
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make DESTDIR=$RPM_BUILD_ROOT install
45mkdir -p $RPM_BUILD_ROOT%{_datadir}/sip/qt
46cp -r sip/* $RPM_BUILD_ROOT%{_datadir}/sip/qt/
47
48%clean
49rm -rf %{buildroot}
50
51%files
52%defattr(-, root, root, 755)
53%doc NEWS README ChangeLog THANKS
54%doc doc/PyQt.html
55%{_bindir}/*
56%{pyexeclib}/*
57
58%files devel
59%defattr(-,root,root)
60%doc examples*
61%{_datadir}/sip/*
62
63%changelog
64* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-3
65- rebuilt with python-2.7.2
66
67* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.18.1-2
68- rebuilt with python-2.6.4
69
70* Thu Nov 12 2009 Ryoichi INAGAKI <owa@bg.wakwak.com> 3.18.1-1
71- new upstream release
72- removed qscintilla dependency
73
74* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 3.17.3-1vl5
75- rebuilt with python-2.5.2
76- added pyexeclib macro
77- applied new versioning policy
78
79* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 3.17.3-0vl2
80- changed source url
81- fixed python site-packages path (for lib64)
82
83* Thu Sep 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.17.3-0vl1
84- updated to 3.16
85- rebuilt with new toolchain
86
87* Sun Jun 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.16-0vl1
88- updated to 3.16
89- changed Group to Development/Languages
90- rebuild with python-2.4.3, sip-4.4.5, qscinteilla-1.6
91
92* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 3.13-0vl2
93- rebuild with python-2.4.1
94
95* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 3.13-0vl1
96- initial release for VineLinux
97
Note: See TracBrowser for help on using the repository browser.